• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question Flash rom for XQ-BC72 (China)

Search This thread

Duy0107

New member
Aug 26, 2021
1
0
you can find the way to open cmd in the flasher and rom folder, try google how to add "open cmd in right menu click" or find the exe file like that, open cmd and type "newflasher set_active:a" enter then close the cmd, run newflasher as normal and everything ok
default it's using slot b to boot

i'm not sure, i don't unlock bootloader yet
Thank for guiding, i’ve flashed already.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    With 1ii, it's possible to flash HK, TW or EU ROMs but you will not get mobile signal. I tried all kind of ROMs but had to come back to stock Chinese ROM at the end.

    It's lucky that in chinese ROM we still have Google Service and all you need is install Play Store APK, unlike Huawei or some others. Bloatwares can also be uninstalled easily.

    I'm having 1iii XQ-BC72 now and pretty sure it will be the same. But need to wait for Xperifirm to release firmwares of other market first then I will try and come back here.
    2
    don't know why, but with my devices , i download TW rom with xperifirm then flash with newflasher_v48, cant remember that get corupted 3 or 4 times, but not like other, it's showed the android recovery and i can choose "power off" or "factory reset", it's can't go to system with "factory reset", so i tried to flash again sometimes, and in the last time, it's booted up and everything is ok.
    But today i just help other to flash thier devices, doing same thing, but never see the "android recovery" again and, always bootloop with sony logo, or corrupted device.
    and solution for it's is reflash with CN rom by newflasher -> still can't boot up, but after that you can use xperia companion to repair without "missing info" error.
    maybe need to more rom in different to check.

    ___________________________
    update: we can simply fix this problem with change active slot b to a in newflasher, everything working well.
    2
    how do you do this? i never saw options for doing it.
    you can find the way to open cmd in the flasher and rom folder, try google how to add "open cmd in right menu click" or find the exe file like that, open cmd and type "newflasher set_active:a" enter then close the cmd, run newflasher as normal and everything ok
    default it's using slot b to boot
    BL is factory locked ?
    i'm not sure, i don't unlock bootloader yet
    1
    I have successfully flashed TW ROM on XQ-BC72 CN version using newflasher. Everything works fine
    1
    So, somebody flashed TW FW ok, somebody failed, what is the reason ?
    Those who flased their device OK, PLEASE, tell us in detail how you did it ?