• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Flashed stock rom, motion sensors and position sensors not working.

Search This thread
Oct 13, 2021
7
0
Hey guys, had a little problem I was hoping you could help me with.

I have a moto 9 g plus, and I rooted it and flashed an android 10 stock rom. Everything seems to be working great except I noticed the moto actions/gestures stopped working for the camera and flashlight. A while later I realized the tilt screen function also wasn't working.

I downloaded Sensor Detector app and see that all of the position and motion sensors are no longer working. Only the proximity sensor works, and GPS works with map apps. I did not disable or uninstall moto, moto actions & gestures, moto app launcher, or moto display apps, and all have been updated.

Anyone have any idea how I can fix the sensors so that I can use tilt screen and moto actions?
 
Last edited:
Oct 13, 2021
7
0
My guess is that the mentioned "android 10 stock rom" you flashed isn't suitable to your phone.

I got it from there. There are 3 versions depending on region, I bought mine in Colombia so I assume the LATAM is the one.

I'm trying to flash the 3rd version listed on the page now.
 
Last edited:
Oct 13, 2021
7
0
My guess is that the mentioned "android 10 stock rom" you flashed isn't suitable to your phone.
I really didn't want to flash again because I was pretty sure it wouldn't make a difference since it is an official stock rom from motorola, for that make and model, but the region made the difference! I guessed it was the LATAM one, but there are not any extra numbers on the box that would indicate which one it would be. In any case, moto action gestures and tilt screen work normally again.

Thanks for helping out!