FLIRC + Fire TV

Search This thread

sjors86

Member
Sep 29, 2009
46
1
okay, I found (part of) the problem and also found a solution, but I still have to figure out how I can put this to practice. First I'll explain how I found the problem, I noticed when pointing the remote directly at the flirc (straight line) it worked perfectly, but when pointing besides it or to the wall, it would register one press as multiple (lots). I thought it had to do something with reflection, so I created a tunnel around the flirc, so it wouldn't recieve any reflection from the walls, but I still had the same problem.

I took an USB Extendension to see if another background would work, but it didn't. Then with the flirc still in the extension, i put it in my wrist and suddenly I noticed it worked. I eventually figured out that if I would touch the metalic part of the flirc (USB) it worked, no mather what i'm pointing at. I even noticed that when not touching the metal and sending a command it would go crazy again and I could stop that by just touching the metal with a finger. It seems as if my flirc module isn't grounded (no idea if this is the right word). Now I just have to figure out how I can do this, without it looking strange.

Any ideas allready tried it with a wire, but to what do I have to connect the wire (except my own body :p)?

Edit:
uc
 
Last edited:

Smokeysa

Member
Oct 10, 2014
8
0
Hi,

I just set up my Fire TV with Flirc and my Harmony oine. All is well except I can't seem to find a way to reboot the Fire TV with select and play. Is there something I can do or do I need the original remote for that?

Thanks in advance
 

wellersl

Senior Member
Feb 15, 2011
373
45
Tucson, AZ
I also have power off tied to a sleep button on my FLIRC.
Sorry if this is blatant necro-posting. I was spcifically looking for that so I believe my question belongs here to keep everything tied together.

Can you expand on how you did that, please? The power button on the K400R works exactly as I want, but I can't figure out what IR code to send that does the same thing.

EDIT: I *think* I found it. Can't test it yet. Will report back later. Big thanks to rbox for leaving a trail!

---------- Post added at 08:29 AM ---------- Previous post was at 08:07 AM ----------

Any ideas allready tried it with a wire, but to what do I have to connect the wire (except my own body :p)?
I have two stupid questions because I think I see two separate issues:

1) Have you tried testing the FLIRC without an extension? If all you're doing is touching the USB case ever so lightly - so lightly that it can't possibly make a difference in the mechanical connection - and it causes the FLIRC to work, that's called ghost-capacitance or hand-capacitance (Know what a Theremin is?) and is a separate issue from a poor ground. That would probably require a replacement. But if you're applying enough mechanical pressure to complete the electrical contact between the two shields, that can be addressed with a bit of gentle bending.

2) Have you tried testing the FLIRC in total darkness? What does your ambient lighting consist of? IR can be fickle and subject to all sorts of interferences. If it works more reliably in the dark, you should be able to isolate the offending source by trial and error. Keep in mind that IR is invisible to the human eye, so try not to overlook anything.
 
Last edited:

g35nightrider

Member
Sep 3, 2008
23
1
Any luck out there??

Hi there,
I'm having problems actually getting the flirc to work with my Amazon Fire TV. I insert the flirc usb into my computer, program the buttons successfully and then plug it into my Amazon Fire TV usb slot and then nothing works. Is there something I'm missing here?
 

Top Liked Posts