• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Full brick updating Fire TV 2 from 5.2.1.0 to 5.2.1.1 using TWRP Custom Recovery :(

Search This thread

red_indian

Member
Mar 10, 2011
6
0
I bricked my Fire TV 2 with fully unlocked bootloader and TWRP Custom Recovery menu. I thought this wasn't even possible?

After updating my 2nd Fire TV 2 (1st was successfully updated) TWRP got an error while writing the new pre-rooted image. The error was something like mounting /system and I think it said exit error/status 7. But looking up this error seems to be related to using invalid images, which I didn't because the 1st Fire TV 2 updated fine using the same image.

The only option was to reboot the device which I did and now it is stuck on the white Amazon logo and the LED keeps fading in and out. The TWRP menu is unreachable and using a keyboard to get into the recovery menu also doesn't work.

I've tried everything (from aftvnews how-to-unbrick-and-prevent-bricking-an-amazon-fire-tv) even fastboot using the USB A-to-A cable I originally rooted it with. No luck, nothing. Fast boot won't list any devices.

The only thing that seems to acknowledge any device begin present is to retry the rooting process. This will detect the handshake and tried to modify the bootloader. But off course this has changed after the last updates so I won't inject the code meant for 5.0.5.1.

I thought TWRP and a fully unlocked bootloader meant safe updating, so how could I brick it like this?

Any thoughts? I'm open to suggestions and would even be able to open it up and do a hardware flash if possible...
 
Last edited:

red_indian

Member
Mar 10, 2011
6
0

red_indian

Member
Mar 10, 2011
6
0
It worked! Thanks a lot rbox!

Used the unbrick.img with ramdisk.img on microSD. Was able to boot into the TWRP and flashed the pre-rooted 5.2.1.1 image. Then did a full cache wipe and rebooted... and she's back! Had some problems with the USB cable at first which I'll share in the unbrick thread.

Made another donation for your continuous hard work and support!
 

leo_bsb

Senior Member
May 8, 2010
145
13
Brasilia
My AFTV 1 is bricked. There is no led.
I had the boot menu and CW recovery. After applying the bueller-5.2.1.1-rooted_r1.zip the device is dead. :(
No led, no boot menu, nothing. I checked the power supply and it is OK. Any help?
 

leo_bsb

Senior Member
May 8, 2010
145
13
Brasilia
I connected the AFTV to my computer using the A-to-A cable.
The computer shows a storage device with some files and the device manager shows a Marshall London HS-USB Diagnostics 9006 port.
Any suggestions? ADB and fastboot do not work. There is no device connected
 

Top Liked Posts