Full guide to install Google services

Search This thread

kilrah

Senior Member
Sep 16, 2005
1,749
20
Cool, thanks for the feedback. Will probably go for it in a few days then. Hope it's as stable as the previous one - I actually have 2100h of uptime, zero reboot since last update and have been deferring this one for a couple of weeks in doubt.

Did the upgrade and can confirm everything works as it did before.
 

Wilson Rubio

New member
Sep 29, 2020
2
0
Link

hi, this happened to me yestd cos i stupidly upgraded the firmware, so installed hisense suite onto my pc and roll back the firmware. XDA doesnt allow me the attach the link to the guide but you can try googling it or pm me for it.

however, im currently still stuck at step 9, have been trying this method (dated aug 14) on youtube by Rui Tukayana which is the closest i got to success.

do let me know if you have better success at it, cheers!
Can you sent it to me ?

I just buy a new Mate Xs and I new to downgrade the version in order to be able to install GMS
 

Anndy

Member
Dec 27, 2005
47
2
Anyone has succeeded in donwgrading Mate XS's firmware.

I cannot find it anywhere.

Just received mine from RMA but they had upgraded my firmware and cannot install LZ Play suite anymore :(!

Thank you in advance,
 

kilrah

Senior Member
Sep 16, 2005
1,749
20
It's been mentioned that even old firmware doesn't help, Google having made it impossible to log in to your account with the method that was used.
Would look into micro G....
 

thklinge

Senior Member
Jul 7, 2008
140
22
Tromsø
Anyone has succeeded in donwgrading Mate XS's firmware.

I cannot find it anywhere.

Just received mine from RMA but they had upgraded my firmware and cannot install LZ Play suite anymore :(!

Thank you in advance,
Have you tried the Hisense desktop app?
It's been mentioned that even old firmware doesn't help, Google having made it impossible to log in to your account with the method that was used.
Would look into micro G....
It's old news, a new method with microG has been around for a few weeks and as far as I know it still works.
Got new update to 10.1.0.166, updated with no issues with GMS.
Yes, same here.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    This method was the only one that worked for me.

    https://youtu.be/HAxj0FYgwoY


    Had to start over and reset the phone 3 times but the result made this phone perfect.


    Sent from my iPad using Tapatalk
    1
    Mine still function bro lol, so many user confuse how to use but a lot also success.
    The Key Point is Never GIVEUP

    1
    So are there no steps to take with the LZPlay backup? Appreciate your help!

    if found this in googe search:
    LZPlay on mega
    1
    Has anyone had success with lzplay after the .151 firmware? New owner, but having an issue using LZPlay of course. Any options to revert or downgrade firmware? Thanks

    hi, this happened to me yestd cos i stupidly upgraded the firmware, so installed hisense suite onto my pc and roll back the firmware. XDA doesnt allow me the attach the link to the guide but you can try googling it or pm me for it.

    however, im currently still stuck at step 9, have been trying this method (dated aug 14) on youtube by Rui Tukayana which is the closest i got to success.

    do let me know if you have better success at it, cheers!
    1
    Same thing happened to me. LZplay won't run on .151, use HiSuite on pc to downgrade your Mate Xs to .146. Then follow the process to install the Google services. Once its all working, it will stay working even after the .151 update and the recent patch. If you're stuck on step 9, what worked for me was to keep uninstalling file 9/10 and install 7/8, uninstall 7/8, install 9/10... had to do it a few times before no errors and all working.