Full guide to install Google services

Search This thread

addx972

Senior Member
Mar 19, 2007
311
47
Huawei P40 Pro
Huawei Mate X2
has anyone tried to downgrade from 11 to 10 these days?
I have loaded several versions of HiSuite, and none provided me an option to choose another version, just states that my device is updated?
Is it possible now to downgrade, or we should seek for another solution?
it is no longer possible to downgrade or you do it officially but you have risks of blocking the phone
I'm still stuggling, and have given up on several occations. Can anyone point me to their package with files. I downgraded to 10.0.1.146 from HiSuite. Please help.

Edit: I finally did it, I had to do the last steps a few times, and the restart wasn't the thing that did it. But it looks like it works now, no errors.
(files in the description)

But I have some issues however with push notifications(that previously was installed just as a apk), I'm not getting any.. Will upgrading to 10.1 or 11 fix this issue?
the update for the notification push will not enable it
 

stefanw1337

Member
Jul 3, 2014
12
2
it is no longer possible to downgrade or you do it officially but you have risks of blocking the phone

the update for the notification push will not enable it
I don't get why the push notifications doesn't work with apps installed via their AppGallery. It's like I should contact their support or something, and ask them to help me resolve it. I'm talking for instance the eufy and Arlo apps' notifications especially.
 
Last edited:

stefanw1337

Member
Jul 3, 2014
12
2
If you want notifications either you freeze the framework or another solution that is paid
First of all, I tried using Ice Box and freeze. But made no difference(as I think that's for the apps installed with Google Play Store?), then I tried to update the Google Play services (and install the app via Google Play Store) as the guide I watched said I should. But that broke it again.

What paid solution? I paid for the phone, shouldn't it work out of the box with apps downloaded from the AppGallery? I think I might call'em for support on that.
 

addx972

Senior Member
Mar 19, 2007
311
47
Huawei P40 Pro
Huawei Mate X2
First of all, I tried using Ice Box and freeze. But made no difference(as I think that's for the apps installed with Google Play Store?), then I tried to update the Google Play services (and install the app via Google Play Store) as the guide I watched said I should. But that broke it again.

What paid solution? I paid for the phone, shouldn't it work out of the box with apps downloaded from the AppGallery? I think I might call'em for support on that.
Ok if you talk about appgallery applications it's not normal that you don't have a notification. Do you have to delete the cache and data of applications that do not work?
 

cemy90

New member
Jan 28, 2011
1
0
can you please renew GSM1&GSM2 Fixed file links?
This method will fix everything

*No more error message
*All apps can connect to google services
*Restart fix it





Note
Log in with all of your accounts before clear Google services data

*Full youtube instructions from zero By Gatal Gadged digital :



Steps


1 Unzip the GMS file & put the file in the Memory root (check video)

https://drive.google.com/file/d/1PB6...ew?usp=sharing


2 Go setting system & restor then back up and restor

3 Restore the back up from memory

4 Install all Google apps from Google folder (from zip file)

5 Open GMS app in Chinese langue then restart the device

6 Open play store then close it

7 Now you should get error message from google

------These steps not included on the YouTube video-----

8 Go to setting --- apps ---- Clear Google service data

9 Download and install GSM 1

10 Go to setting --- apps ---- Clear Google framework data

11 Check Google play store, restore device, check google app ,and check snapchat or all app need to use google services

12 Install GSM 2 ,then restart the phone





New GSM1&GSM2 Fixed file


https://drive.google.com/open?id=1mhS8tDhXf4AUtpfh9--8Dg8-MJgc_OKv



Easy way :


First check the new file i uploaded today

install gms with lz play restore back up method
sign into gms with account manager 4.0.3
Intall google frameworks
Check id gsf ''using device id app''
If have
uninstall google play services
Intall modgsm1.apk ''download from link''
check id gsf
close all apps
check id
close all
remove google framework
reinstall google framework
check id
close all
remove google play service
install gsm2
check id
reboot device

done


To sign in more than one account :

Use icebox
Freeze framework
Clear data Google accounts manager
Sign in 2,3,4,5,6,7,8,9,1000000 accounts
Unfreeze the framework
Abraka dabra everything work lile a charm


Youtube video to approve this method





I apologize for the delay, because Google has fixed the previous error in the file i sent





Enjoy guys.






contact info :
Instagram: mrhouny
Snapchat: mrhouny
facebook: mrhouny
xda dev: skyline_r


Special Thanks to @nhoccon
[/QUOTE]
can you please GSM1&GSM2 Fixed file links?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    hisuite is updated ?

    It was necessary to change the DNS to Chinese
  • 2
    This method was the only one that worked for me.

    https://youtu.be/HAxj0FYgwoY


    Had to start over and reset the phone 3 times but the result made this phone perfect.


    Sent from my iPad using Tapatalk
    1
    Mine still function bro lol, so many user confuse how to use but a lot also success.
    The Key Point is Never GIVEUP

    1
    So are there no steps to take with the LZPlay backup? Appreciate your help!

    if found this in googe search:
    LZPlay on mega
    1
    Has anyone had success with lzplay after the .151 firmware? New owner, but having an issue using LZPlay of course. Any options to revert or downgrade firmware? Thanks

    hi, this happened to me yestd cos i stupidly upgraded the firmware, so installed hisense suite onto my pc and roll back the firmware. XDA doesnt allow me the attach the link to the guide but you can try googling it or pm me for it.

    however, im currently still stuck at step 9, have been trying this method (dated aug 14) on youtube by Rui Tukayana which is the closest i got to success.

    do let me know if you have better success at it, cheers!
    1
    Same thing happened to me. LZplay won't run on .151, use HiSuite on pc to downgrade your Mate Xs to .146. Then follow the process to install the Google services. Once its all working, it will stay working even after the .151 update and the recent patch. If you're stuck on step 9, what worked for me was to keep uninstalling file 9/10 and install 7/8, uninstall 7/8, install 9/10... had to do it a few times before no errors and all working.