FydeOS with full Google sync and without using a FydeOs account

lucaoldb

Senior Member
Apr 20, 2012
619
307
83
MILAN
FydeOs is a good chromium fork and it supports android, but it lacks a full google sync and that’s not so good, since sync across multiple devices is the best thing ever and that’s where Google services do play their best. At least I think so.

Moreover, FydeOs by default sends the user’s data to their servers. They do such thing in an open way, through a FydeOs account, so they shouldn’t be blamed, but we are free to use the Os which is in our device without sharing our data with FydeOs so as some don’t like sharing their data with Google.

So, I have found a quite easy way to remove those limitations. The purpose is to use FydeOs without a FydeOs account, without sharing our data (passwords and so on) with them, while retaining a fully functional play store and a full google sync.

This is a simple how-to written in a few spare time. If I get more time, I will make it less rough.

First of all, press CTRL + ALT + T

then use this commands

shell
sudo su

and you’ll have got to insert the password chronos

then go on and mount the system to read and write

sudo mount -o remount,rw /

then remove a couple of files

cd /etc/chromium/policies/managed
sudo rm *.*

Then edit the conf file

cd /etc
sudo vim chrome_dev.conf

(disclaimer: please google for vim commands, it’s preinstalled in chrome os)

comment the lines referring to FydeOs account like that and add a line referring to google account (maybe useless)

#--fydeos-account-enabled
#--fydemina
--google-account-enabled

Close the tab and open a chromium tab in incognito mode, then type

chrome://flags

Look for the flag Support secondary accounts for Sync standalone transport

and switch it on.

Then reboot and you’ll be able to add a secondary account, then you'll be prompted to insert your google account.

Follow the usual steps to configure the device and your apps and settings will be restored (if you already have got another chromebook). The file manager now will show your google drive folder:)

To install the play store you have got to edit chrome_dev.conf, by uncommenting the lines which you had previously commented, and reboot...

Then you can use the app provided by FydeOs to install the Play store. This step will remove the google sync and you won’t see google drive inside the file manager.

Now you can comment those lines again and reboot and everything will be fine i.e. google sync will be back.

After rebooting, you can go to chromium extensions and remove the FydeOs extension (the one which sends your data to their servers) and you can go to the shelf and remove the installer with the chinese name, by simply clicking it.

Now you can use the secondary account, which is fully working and syncing to google servers (only) and forget about the other one (i.e. the FydeOs one).

I tested these steps once only and maybe not all of them were required, but my device has been working fine for 3 days straight without any issue.
 
Last edited:

coolloser

Senior Member
Sep 25, 2009
400
104
63
Calgary
FydeOs is a good chromium fork and it supports android, but it lacks a full google sync and that’s not so good, since sync across multiple devices is the best thing ever and that’s where Google services do play their best. At least I think so.

Moreover, FydeOs by default sends the user’s data to their servers. They do such thing in an open way, through a FydeOs account, so they shouldn’t be blamed, but we are free to use the Os which is in our device without sharing our data with FydeOs so as some don’t like sharing their data with Google.

So, I have found a quite easy way to remove those limitations. The purpose is to use FydeOs without a FydeOs account, without sharing our data (passwords and so on) with them, while retaining a fully functional play store and a full google sync.

This is a simple how-to written in a few spare time. If I get more time, I will make it less rough.

First of all, press CTRL + ALT + T

then use this commands

shell
sudo su

and you’ll have got to insert the password chronos

then go on and mount the system to read and write

sudo mount -o remount,rw /

then remove a couple of files

cd /etc/chromium/policies/managed
sudo rm *.*

Then edit the conf file

cd /etc
sudo vim chrome_dev.conf

(disclaimer: please google for vim commands, it’s preinstalled in chrome os)

comment the lines referring to FydeOs account like that and add a line referring to google account (maybe useless)

#--fydeos-account-enabled
#--fydemina
--google-account-enabled

Close the tab and open a chromium tab in incognito mode, then type

chrome://flags

Look for the flag Support secondary accounts for Sync standalone transport

and switch it on.

Then reboot and you’ll be prompted to insert your google account.

Follow the usual steps to configure the device and your apps and settings will be restored (if you already have got another chromebook). The file manager now will show your google drive folder:)
Thanks for the walkthrough! Thankfully I'm familiar with VIM so your instructions were easy peasy.

I did up until here on my flash drive with my main laptop but since it's AMD and won't run Android apps or Linux, I switched to my Intel. First boot let me log into Google right away and appeared to have Android enabled but kept erroring when trying to connect so I proceeded with the steps to progress and was successful. I don't even have a fydeos account on here at all!

I assume you could follow these steps the way I did to get it on a he's without having the fydeos account as well (this was all on a flash drive)
 
  • Like
Reactions: chukzde

lucaoldb

Senior Member
Apr 20, 2012
619
307
83
MILAN
Thanks for the walkthrough! Thankfully I'm familiar with VIM so your instructions were easy peasy.

I did up until here on my flash drive with my main laptop but since it's AMD and won't run Android apps or Linux, I switched to my Intel. First boot let me log into Google right away and appeared to have Android enabled but kept erroring when trying to connect so I proceeded with the steps to progress and was successful. I don't even have a fydeos account on here at all!

I assume you could follow these steps the way I did to get it on a he's without having the fydeos account as well (this was all on a flash drive)
Yes, I had just reported the way I had gone, but I was quite sure that some steps were redundant:)
 

coolloser

Senior Member
Sep 25, 2009
400
104
63
Calgary
Yes, I had just reported the way I had gone, but I was quite sure that some steps were redundant:)
I'm just glad you were successful, I knew there had to be a way to do it!
I'll try installing it onto the hard drive maybe tonight, it'll be a triple boot setup with win 7 and 10 though so I may try and find a different old computer to try instead to save the head ache...
 

primod808

Senior Member
Mar 5, 2011
371
64
58
TOYOHASHI
I have fyde os on USB working but my issue is full install on my laptop is using EMMC storage and when installing it aborts at the end. What are the commands to install on EMMC drive? Thanks again.
 

Tiggi2017

Member
Mar 28, 2017
21
6
0
Hello. Thank you very much for these instructions.

But i got stuck at this point

"After rebooting, you can go to chromium extensions and remove the FydeOs extension (the one which sends your data to their servers) and you can go to the shelf and remove the installer with the chinese name, by simply clicking it."

I can't delete these apps because they seem to be installed with enterprise policies. Can someone help please?:silly:
 

primod808

Senior Member
Mar 5, 2011
371
64
58
TOYOHASHI
Ok feeling stupid I did his before but now I'm having trouble putting the commands. Stuck after incognito enabled secondary account sync flag then it ask to reboot browser. Not the computer reboot but chrome browser reboot but it doesn't prompt me to login to my Google account. Went back to she'll mount remount to try again but get this. After cd etc/chromium/policies/managed hit enter add sudo rm *.* It say cannot remove no such file found. When i did it the first time I can get to the vim part I commented last 2 lines and added the Google enabled line then i :wq to save and quit. Do suppose save and quit right or does it save automatically?
 

Attachments

coolloser

Senior Member
Sep 25, 2009
400
104
63
Calgary
Ok feeling stupid I did his before but now I'm having trouble putting the commands. Stuck after incognito enabled secondary account sync flag then it ask to reboot browser. Not the computer reboot but chrome browser reboot but it doesn't prompt me to login to my Google account. Went back to she'll mount remount to try again but get this. After cd etc/chromium/policies/managed hit enter add sudo rm *.* It say cannot remove no such file found. When i did it the first time I can get to the vim part I commented last 2 lines and added the Google enabled line then i :wq to save and quit. Do suppose save and quit right or does it save automatically?

The file is removed which is why it can't find it. wq saves and quits the editor so that's ready. Try a full reboot and see if adding a new account goes through Google now instead of fyde servers.
 

coolloser

Senior Member
Sep 25, 2009
400
104
63
Calgary
[
I checked it's like it never saved the first time i don't see google-account-enabled I always have to keep adding the line.
you'll have to mount the drive as read and write again then apply changes.
shell
sudo su (enter your pw)
sudo mount -o remount,rw /
Then edit the conf file
cd /etc
sudo vim chrome_dev.conf
 

primod808

Senior Member
Mar 5, 2011
371
64
58
TOYOHASHI
[


you'll have to mount the drive as read and write again then apply changes.
shell
sudo su (enter your pw)
sudo mount -o remount,rw /
Then edit the conf file
cd /etc
sudo vim chrome_dev.conf
Strange I always do that but it never keeps my changes every time I check to see if my changes applied it never saves it. In the instructions op it didn't say to save I use :wq close tab and go to chrome://flags enabled secondary account let it reboot also did full system reboot and still doesn't prompt me for my Google account. Check again in vim and I always see that my changes never is saved.
 

coolloser

Senior Member
Sep 25, 2009
400
104
63
Calgary
Strange I always do that but it never keeps my changes every time I check to see if my changes applied it never saves it. In the instructions op it didn't say to save I use :wq close tab and go to chrome://flags enabled secondary account let it reboot also did full system reboot and still doesn't prompt me for my Google account. Check again in vim and I always see that my changes never is saved.
It is weird!
Try saving the file with :w before quitting with :q to see if there are errors shown