• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question G cam

Search This thread

althafjava

Member
Feb 13, 2021
27
1

Attachments

  • Screenshot_20211003-061355_Chrome.jpg
    Screenshot_20211003-061355_Chrome.jpg
    557.2 KB · Views: 209

stillka

Senior Member
Mar 9, 2008
702
95
Presov
Samsung Galaxy S20 FE

althafjava

Member
Feb 13, 2021
27
1

sanderbos

Member
Nov 28, 2018
23
27
Amsterdam
I am using:

Hello stillka,

is that on A52 or A52s?
The question was for A52s, but I think since you were also active in another thread that you are using an A52?

They have different chipsets. I have now tried maybe 10 different gcam versions and they all have the same problem on A52s, that the viewfinder freezes after 3-4 seconds (even before taking a picture).
 

althafjava

Member
Feb 13, 2021
27
1
Hello stillka,

is that on A52 or A52s?
The question was for A52s, but I think since you were also active in another thread that you are using an A52?

They have different chipsets. I have now tried maybe 10 different gcam versions and they all have the same problem on A52s, that the viewfinder freezes after 3-4 seconds (even before taking a picture).
Actually I had A52 ... Then I got a A52s... Now using A52s. ..no G cam is working
 

stillka

Senior Member
Mar 9, 2008
702
95
Presov
Samsung Galaxy S20 FE
Hello stillka,

is that on A52 or A52s?
The question was for A52s, but I think since you were also active in another thread that you are using an A52?

They have different chipsets. I have now tried maybe 10 different gcam versions and they all have the same problem on A52s, that the viewfinder freezes after 3-4 seconds (even before taking a picture).
I am sorry abou that, my phone was A52 5G that time...
 

sanderbos

Member
Nov 28, 2018
23
27
Amsterdam
I am sorry abou that, my phone was A52 5G that time...
Okay, thank you and althafjava both for replying.

So at least here there is nobody who got it to work on A52s..

There was actually a bunch of S21 users with the exact same issue, but the versions they have with fixes for them don't seem to work either on A52s. I just hope since it's very new that it will be fixed, but it is so weird that it works in those few seconds before it freezes (you can take a high quality picture if you press the shutter fast enough).
 

althafjava

Member
Feb 13, 2021
27
1
Okay, thank you and althafjava both for replying.

So at least here there is nobody who got it to work on A52s..

There was actually a bunch of S21 users with the exact same issue, but the versions they have with fixes for them don't seem to work either on A52s. I just hope since it's very new that it will be fixed, but it is so weird that it works in those few seconds before it freezes (you can take a high quality picture if you press the shutter fast enough).
Well I still don't know what is the Mistry
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Where did you get the Morgenman xml config? Can you share the link?

    EDIT: FOUND IT!
    I'm so happy for you, that you really finally did find it and that you bothered to share this fantastic news with the whole world. And in all caps no less! Thank you very much for this enormously interesting update.
    1
    I try to Google it but didn't make it, can you help me?
    Here you go
  • 9
    Okay, I actually got something working on A52s, thanks to a comment from Windoors here:

    You have to change the Photo Session, and no I have no idea what that is or what the values below actually mean.


    To make it concrete, here is how I got GCam working on the A52s (emphasis on 'S'):

    - Download and install
    I picked the ruler package name version
    - Load luke-A52-BSG-GV1.xml from the configs section of the URL above (location of file does not matter, double tap next to shutter button and select it).
    - Now you have a camera app that freezes up after 3 seconds on A52s (you can still take pictures before that freeze)
    - Go to the Settings, then
    Modules
    Back (1.0)
    Session of photo modes (near the bottom of the list)
    and enter the value 61444
    Then do the same for
    Settings / Modules / Back (0.5) / Session of photo modes / 61444
    Settings / Modules / Front (1.0) / Session of photo modes / 61444
    (I don't think the Back 1.1 and Front 0.8 do anything, so I don't think they need changing)

    And presto working GCam with all camera's working, both for photos and videos.
    Is 61444 the best value? No idea, I have no idea what it even means, so I will experiment more.

    If you want to try it with other GCam versions, that 'Session' value is stored in different locations.
    For instance in Gcam-8.1.101.build-V6.2.211013 from Arnova8G2 it is under Settings|Advanced|Stream Config|Enable OPMode and then set it for Main
    and in MGC_8.3.252_V0e it is under Settings|Photo modes session config|Session ID
    But both of these versions at least initially appear to have less stability and features, so I am at least for continuing to experiment with MGC_8.1.101_A9_GV1u for now.
    1
    Working for me thx!
    1
    Okay, I actually got something working on A52s, thanks to a comment from Windoors here:

    You have to change the Photo Session, and no I have no idea what that is or what the values below actually mean.


    To make it concrete, here is how I got GCam working on the A52s (emphasis on 'S'):

    - Download and install
    I picked the ruler package name version
    - Load luke-A52-BSG-GV1.xml from the configs section of the URL above (location of file does not matter, double tap next to shutter button and select it).
    - Now you have a camera app that freezes up after 3 seconds on A52s (you can still take pictures before that freeze)
    - Go to the Settings, then
    Modules
    Back (1.0)
    Session of photo modes (near the bottom of the list)
    and enter the value 61444
    Then do the same for
    Settings / Modules / Back (0.5) / Session of photo modes / 61444
    Settings / Modules / Front (1.0) / Session of photo modes / 61444
    (I don't think the Back 1.1 and Front 0.8 do anything, so I don't think they need changing)

    And presto working GCam with all camera's working, both for photos and videos.
    Is 61444 the best value? No idea, I have no idea what it even means, so I will experiment more.

    If you want to try it with other GCam versions, that 'Session' value is stored in different locations.
    For instance in Gcam-8.1.101.build-V6.2.211013 from Arnova8G2 it is under Settings|Advanced|Stream Config|Enable OPMode and then set it for Main
    and in MGC_8.3.252_V0e it is under Settings|Photo modes session config|Session ID
    But both of these versions at least initially appear to have less stability and features, so I am at least for continuing to experiment with MGC_8.1.101_A9_GV1u for nfol

    Okay, I actually got something working on A52s, thanks to a comment from Windoors here:

    You have to change the Photo Session, and no I have no idea what that is or what the values below actually mean.


    To make it concrete, here is how I got GCam working on the A52s (emphasis on 'S'):

    - Download and install
    I picked the ruler package name version
    - Load luke-A52-BSG-GV1.xml from the configs section of the URL above (location of file does not matter, double tap next to shutter button and select it).
    - Now you have a camera app that freezes up after 3 seconds on A52s (you can still take pictures before that freeze)
    - Go to the Settings, then
    Modules
    Back (1.0)
    Session of photo modes (near the bottom of the list)
    and enter the value 61444
    Then do the same for
    Settings / Modules / Back (0.5) / Session of photo modes / 61444
    Settings / Modules / Front (1.0) / Session of photo modes / 61444
    (I don't think the Back 1.1 and Front 0.8 do anything, so I don't think they need changing)

    And presto working GCam with all camera's working, both for photos and videos.
    Is 61444 the best value? No idea, I have no idea what it even means, so I will experiment more.

    If you want to try it with other GCam versions, that 'Session' value is stored in different locations.
    For instance in Gcam-8.1.101.build-V6.2.211013 from Arnova8G2 it is under Settings|Advanced|Stream Config|Enable OPMode and then set it for Main
    and in MGC_8.3.252_V0e it is under Settings|Photo modes session config|Session ID
    But both of these versions at least initially appear to have less stability and features, so I am at least for continuing to experiment with MGC_8.1.101_A9_GV1u for now.


    Had the freezing bug before I stumbled upon your post. I was afraid it gonna mess up the phone but it was worth the shot!
    Thanks a lot !

    PS : Just got a new A52S (8/256) yesterday, I'm wondering why XDA doesn't have a proper page for the model (I know for sure that it has the same camera setups as the previous models (A52 LTE and A52 5G)
    1
    This is the reason of my question if it could be possible to stack more than just 15 shots (I'm not a developer and I have no idea :) )

    I am a developer, but I also have no idea! :)
    Like I said before, I really have not ever taken a useful picture in this mode myself (and it's cloudy again here tonight)

    If you go to the GCam Settings|Modules|Back (1.0)|Astro max exposure time
    you can force it to 35 seconds. If you then take a picture of night sky (or at least a pitch dark room) it will go to 1 minute 55 seconds of processing. So I wonder whether this 10 second limit is really a thing. But in this GCam version at least on A52s you cannot set it beyond 35 seconds (also not if you try to sneakily force it in the xml config file, which I just tried).

    But you are not limited to this GCam version. As I said at the end of the comment of October 24, you are not limited to this one GCam version, it is just that in other versions you have go and find the 'Photo Session Id' setting somewhere in the settings. So you can try to find a GCam version that a) let's you configure the astro mode more and b) let's you set the photo session id to prevent the viewfinder from freezing.

    Or did the people in the Telegram group say it is limited for all GCam versions on this phone (again, you can set it to 35 seconds it seems to me, but I cannot really try it out with a real sky).
    1
    It's cloudy here, too :) but I tryed in a dark room. With a gcam in my old LG G5, i got a total time of 4 minutes and a bunch of seconds, while with a52s less than two minutes.

    I tryed to set it to a longer exposure time: 35 seconds will be useless for stars because they move, a good value should be around 16 seconds (which is the base setting for astrophotagraphy mode in the pixel phones)

    The final images seem about the same to me, probably because this phone model cannot take single shots longer than 10 seconds, no matter what gcam settings are.

    In a telegram group abaut a52s gcam, I found this:
    "-goto night sight turn on astro from drop down menu & IMPORTANT THING IS KEEP 8 SEC PER FRAME "

    This a short video about the astro mode on pixels: