[G925F] Android Marshmallow 6.0.1 rooted - BETA 2 - TWRP

Search This thread

eltoffer

Senior Member
Aug 17, 2012
283
48
Metepec
Ok i noticed not many has the latest MM beta, so there you are:

NOTE: im not responsible for any damage to your phone, by proceeding knox will be tripped

Requirements:

1.- No matter what firmware you have installed, but i would recommend to start from 6.0
2.- Install TWRP
  • 5.1.1
    - Into download mode flash TWRP (AP) via Odin (UNMARK auto-reboot)
    - Reboot into recovery and do a backup, very important
    - Reboot into download mode again flash this kernel (AP) via Odin
    - Reboot your phone
  • 6.0
    - Into download mode flash this old_bl (BL) via Odin (UNMARK auto-reboot)
    - Reboot into download mode again flash TWRP (AP) via Odin (UNMARK auto-reboot)
    - Reboot into recovery and do a backup, very important
    - Once more into download mode flash this bootloader (BL)
    - Reboot your phone
3.- Copy 6.0.1 into /sdcard/TWRP/BACKUPS/XXXXXXXXXXXXX/ XXXXXXXX should be numbers and letters each phone is different, inside you should see your previews backup
4.- Reboot into recovery
only for 6.0
- Into download mode flash this old_bl (BL) via Odin (UNMARK auto-reboot)
- Now reboot into recovery
5.- Go to restore and apply the 6.0.1 backup
6.- Wipe cache and dalvik then install this superSU
7.- Reboot into download mode and flash this sboot (BL)
8.- Enjoy 6.0.1 rooted

NOTE if you have no network just rollback your EFS from your own backup to enter into TWRP you need to flash the old_bl each time and then flash back the sboot to allow the phone boot up (this due to TWRP incompatibility with the MM BL)

Give the phone some time from the first boot
 
Last edited:

rockykv2

Senior Member
Feb 27, 2009
71
5
can you make a video of this or details steps.
on also pls advice if this safe to flash on 5.1.1.
 

killyouridols

Senior Member
Sep 15, 2009
641
129
Essex
Oh, bloody hell. Just went back to 5.1.1 now I want to try this. Sod it, Ill let a few of you be guinea pigs first.

Nice one OP.
 

bluedragon38

Senior Member
Jul 10, 2011
829
57
I will give it a try this evening ;) but I must go on 6.0 before! :D
any link for xposed marshmallow?
 

killyouridols

Senior Member
Sep 15, 2009
641
129
Essex
Went for it in the end, patience got the better of me. Works fine, and is booting now.

Will update after a bit of use

EDIT: No Mobile Signal/Mobile Network settings
 
Last edited:

Flash-User

Senior Member
Jul 29, 2012
310
153
right, rom is running, but no signal due to "Unknown" Baseband.
baseband from rom wont work
6.0 baseband wont work
5.1.1 baseband even wont work. maybe there is a bug in the experimental twrp version to install 6.0 modems.

Maybe there is a possibility to fix it with an odin 6.0.1 modem file.
 
Last edited:

eltoffer

Senior Member
Aug 17, 2012
283
48
Metepec
I will give it a try this evening ;) but I must go on 6.0 before! :D
any link for xposed marshmallow?
no exposed for MM i think

Not working for me, it just boots back into recovery and won't even think about booting the ROM at all.
did you do the wipes and flash the sboot?

Went for it in the end, patience got the better of me. Works fine, and is booting now.

Will update after a bit of use

EDIT: No Mobile Signal/Mobile Network settings

I have the same issue with signal. :/

right, rom is running, but no signal due to "Unknown" Baseband.
baseband from rom wont work
6.0 baseband wont work
5.1.1 baseband even wont work. maybe there is a bug in the experimental twrp version to install 6.0 modems.

Maybe there is a possibility to fix it with an odin 6.0.1 modem file.

let me fix this guys, thanks for your feedback, be patience

same here....
no root
and not be able to start recovery mode :/
to load recovery you need ALWYAS to flash back the old_bl while there is a TWRP compatible with the MM BL

Hi, backup have a efs partition. We must also restore?
No, will fix this thanks
 
  • Like
Reactions: Flash-User

Smaky07

Member
Sep 11, 2007
32
5
45
Toulouse
no exposed for MM i think


did you do the wipes and flash the sboot?







let me fix this guys, thanks for your feedback, be patience


to load recovery you need ALWYAS to flash back the old_bl while there is a TWRP compatible with the MM BL


No, will fix this thanks
I'm affraid that with the restoration of your EFS partition we have bricked our phone. This must be the reason for no baseband version and no IMEI anymore...
 

eltoffer

Senior Member
Aug 17, 2012
283
48
Metepec
Maybe or maybe is just the modem related issue in working on it, you could try to restore your EFS partition from TWRP and report back to discard this

Enviado desde mi SM-G925F mediante Tapatalk
 

AdisCZ

Senior Member
May 8, 2011
176
29
30
Prague
I can't restore my EFS, don't know why.... I will flash my stock firmware and then I will see. How long does it take to fix no baseband issue on this 6.0.1? I'm trying to fix this F**** issue for 6 hours.... No result!
 

eltoffer

Senior Member
Aug 17, 2012
283
48
Metepec
I can't restore my EFS, don't know why.... I will flash my stock firmware and then I will see. How long does it take to fix no baseband issue on this 6.0.1? I'm trying to fix this F**** issue for 6 hours.... No result!
i working on it, but the solution would be

1.- flash back the EFS backup fro your own
2.- flash the modem.bin that im extracting (will upload in a moment)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 24
    Ok i noticed not many has the latest MM beta, so there you are:

    NOTE: im not responsible for any damage to your phone, by proceeding knox will be tripped

    Requirements:

    1.- No matter what firmware you have installed, but i would recommend to start from 6.0
    2.- Install TWRP
    • 5.1.1
      - Into download mode flash TWRP (AP) via Odin (UNMARK auto-reboot)
      - Reboot into recovery and do a backup, very important
      - Reboot into download mode again flash this kernel (AP) via Odin
      - Reboot your phone
    • 6.0
      - Into download mode flash this old_bl (BL) via Odin (UNMARK auto-reboot)
      - Reboot into download mode again flash TWRP (AP) via Odin (UNMARK auto-reboot)
      - Reboot into recovery and do a backup, very important
      - Once more into download mode flash this bootloader (BL)
      - Reboot your phone
    3.- Copy 6.0.1 into /sdcard/TWRP/BACKUPS/XXXXXXXXXXXXX/ XXXXXXXX should be numbers and letters each phone is different, inside you should see your previews backup
    4.- Reboot into recovery
    only for 6.0
    - Into download mode flash this old_bl (BL) via Odin (UNMARK auto-reboot)
    - Now reboot into recovery
    5.- Go to restore and apply the 6.0.1 backup
    6.- Wipe cache and dalvik then install this superSU
    7.- Reboot into download mode and flash this sboot (BL)
    8.- Enjoy 6.0.1 rooted

    NOTE if you have no network just rollback your EFS from your own backup to enter into TWRP you need to flash the old_bl each time and then flash back the sboot to allow the phone boot up (this due to TWRP incompatibility with the MM BL)

    Give the phone some time from the first boot
    3
    can you make a video of this or details steps.
    on also pls advice if this safe to flash on 5.1.1.

    i did it myself yesterday i was on 5.1.1 and its safe, if you stuck on any step i would advise you ;)
    1
    Damn , my download crash @ 1.3Go .... And impossible to download again -_-
    1
    I will give it a try this evening ;) but I must go on 6.0 before! :D
    any link for xposed marshmallow?
    no exposed for MM i think

    Not working for me, it just boots back into recovery and won't even think about booting the ROM at all.
    did you do the wipes and flash the sboot?

    Went for it in the end, patience got the better of me. Works fine, and is booting now.

    Will update after a bit of use

    EDIT: No Mobile Signal/Mobile Network settings

    I have the same issue with signal. :/

    right, rom is running, but no signal due to "Unknown" Baseband.
    baseband from rom wont work
    6.0 baseband wont work
    5.1.1 baseband even wont work. maybe there is a bug in the experimental twrp version to install 6.0 modems.

    Maybe there is a possibility to fix it with an odin 6.0.1 modem file.

    let me fix this guys, thanks for your feedback, be patience

    same here....
    no root
    and not be able to start recovery mode :/
    to load recovery you need ALWYAS to flash back the old_bl while there is a TWRP compatible with the MM BL

    Hi, backup have a efs partition. We must also restore?
    No, will fix this thanks
    1
    i rolled back my backup with my efs partition and all works fine. IMEI and baseband are back and running.