⚠️Galaxy A51 Root || Unlock Bootloader || Flash Official Firmware [Binary 3] May

Search This thread


Senior Member
Jun 3, 2022
Galaxy A51

One UI Version is 4.1

Android version is 12

Hi, below is the process I have drawn up to root my A51, am I missing anything?

I have un-locked the boot loader. Are these the only two files I need to root the phone?



Or have I got the wrong files and if so could someone be kind enough to point me to the correct link for the correct files.

Transfer Disable_Dm-Verity_ForceEncrypt_03.04.2020.zip from laptop to phone external SD Card

1. Turn off the phone

2. Pres and hold vol up + vol down, and connect usb cable to laptop

3. Entering download mode

4. Open odin in your laptop, click AP, choose file recovery disabler vb meta.tar, uncheck auto reboot in option.

5. Click start, until get it pass text

6. Disconnect usb cable

7. Press and hold power + vol down, when screen off, press and hold power + vol up, when Samsung logo appeared,
release power, keep hold vol up, entering twrp recovery

8. Wipe >> format data >> yes >> enter

9. Reboot recovery

10. Entering twrp, flash Disable_Dm-Verity_ForceEncrypt_03.04.2020.zip

11. Wipe >> format data >> reboot recovery

12. Flash Magisk (optional for root) and flash Disable_Dm-Verity_ForceEncrypt_03.04.2020.zip

13. Reboot system


Senior Member
Jun 3, 2022
I have a bricked, Galaxy A51, One UI Version is 4.1, Android version is 12, Product Name – SM-A515F.

Prior to bricking, In download mode, OEM LOCK – OFF (U), FRP LOCK – OFF, KG STATE – Checking Current Binary – Samsung Official

Using Odin version Odin3-v3.14.1; I have ran through the installation process of the TWRP recovery procedure and received a pass in Odin that all the TWRP recoveries below I have tried have installed at each time so have in essence Installed.

(Twrp+vbmeta_A11.tar, TWRP-11-3.6.0-a51-20220210-1636.tar, TWRP-11-3.6.1-a51-20220228-2050.tar, TWRP-11-3.6.1-a51-20220321-1406-hotfix.tar, TWRP-11-3.6.2-a51-20220602-0515.tar, twrp-a51-3.5.0_10-1_ianmacd.tar)

Post TWRP installation, if I leave the cable plugged into the phone after the pass in Odin. On pressing the correct sequence of power and up/down volume buttons it does not boot into recovery it just shows a recharge sign on the phones screen and stays there, nothing else happens after like fifteen minutes.

If I unplug the cable in the phone from the laptop post TWRP installation and on pressing the correct sequence of power and up/down volume buttons. Like now I am stuck in a boot loop session, have been for twelve hours now. From the Samsung Logo warning that I have unofficial recovery software installed on the phone to a message that the phones boot loader has been unlocked and the world will fall in. Then the phone switches itself off for one second and the boot loop returns.

The phone does switch itself off for one second until then it switches itself back on and continues this frustrating boot loop session, actually as I write the battery has just failed and the phone is now power dead.

When the phone switches itself off for one second, I can press both +/- volume buttons and connect to the laptop to open the phone up in its download mode; it still states in download mode that the phone is OEM LOCK – OFF (U), FRP LOCK – OFF, KG STATE – Checking Current Binary – Samsung Official

The TWRP recoveries I have installed are,

Twrp+vbmeta_A11.tar, TWRP-11-3.6.0-a51-20220210-1636.tar, TWRP-11-3.6.1-a51-20220228-2050.tar, TWRP-11-3.6.1-a51-20220321-1406-hotfix.tar, TWRP-11-3.6.2-a51-20220602-0515.tar, twrp-a51-3.5.0_10-1_ianmacd.tar.

They all installed fine with a pass in Odin, but I was unable to open the phone up in recovery by following the correct sequence of power and up/down volume buttons.
Is the phone bricked for good?

If it is will I need to install the official stock ROM. I have no idea which stock Rom to download and install. If this is the case could someone be kind enough to post me a link to where I can down load the correct stock ROM to down load and install via Odin.

Thanks for reading and any help received.


Senior Member
Jun 3, 2022
Here’s an update,

I have now reverted back to Stock Rom and I find it impossible to boot into Stock Recoveries.

I have owned this phone over eighteen months and have never before tried to boot into recoveries.

I have tried every method available online, power and volume up button, power and volume down button, power and volume up button while ear phones are plugged in the same with a USB cable plugged in.

But I can still boot into download mode though.

So this might be the reason why I could not root and install TWRP as the phone itself will not boot into recovery. What to do, I have no idea.

When in down load mode.

OEM LOCK – OFF (U), FRP LOCK – OFF, KG STATE – PRENORMAL Current Binary – Samsung Official
So now I have reverted back to KG STATE – PRENORMAL, and the phone is showing no OEM unlock in developer options.

But on boot the phone is still warning me that the boot loader has been unlocked.

I downloaded stock ROM, and extracted these files.

AP_A5 BL_A515FXXU5FVE2_CL23686045_QB51779782_REV00_user_low_ship.tar.md5

They all installed fine in Odin and I received a pass. The phone booted and is working fine.

But I cannot boot into stock recovery.

My only perquisites I have not tried are I have not yet gone through the sequence to get OEM unlock showing in developer options. I am also not connected to any networks and have no sim card in the phone.

So anyone not able to root and install TWRP, maybe your phone itself will not boot into recovery in stock ROM.

Any suggestions would be most appreciated.

Top Liked Posts

  • There are no posts matching your filters.
  • 12
    Fully Working Root Solution


    First, I would like to thanks @map220v, without his efforts, none of this would be possible. I’m justing putting the pieces together to help others root this phone as he helped me.
    Second, this is an ADVANCED process, so I deduce most of you know how to do many things needed in here, so I’ll not explain, for example, how you get your bootloader unlocked.
    Tird, I recommend you do this ony if you REALLY can’t use your phone without root, otherwise, wait for TWRP release.


    No bloatware
    More space available
    Battery drains slowly
    Frequent updates
    178044 points in Antutu v8


    YOUR WARRANTY IS NOW VOID and blablabla
    Poor interface (it's an Android 10 PURE system)
    No Samsung’s facilitations/resources/beauty
    Screen transitions are flickering (no big deal)

    Unlocked bootloader
    A full backup (you’ll lose everything stored in your phone)
    Both Windows AND Linux (I used Windows installed and Kalix Live USB) OR Windows with Linux Bash System (https://itsfoss.com/install-bash-on-windows/) -tip given by @ToddNachste
    Patience (A LOT)
    About 30 GB free

    Files needed:
    Download with Frija or SamFirm THE SAME firmware you’re running now
    Download a GSI Android 10 A/B Gapps arm64v8 from (https://github.com/phhusson/treble_experimentations/wiki/Generic-System-Image-(GSI)-list) -I’m using AOSP 10 v215, but I believe it’s working with more GSI’s
    LZ4 Extractor (https://github.com/lz4/lz4/releases)
    Simg2img (https://forum.xda-developers.com/general/general/dev-simg2img-windows-t3156459)
    LPunpack Tool (https://drive.google.com/file/d/1mgEnQqFOajLnRBX2YYsLL11J2-osPKD_/view)
    Odin (https://dl2018.sammobile.com/Odin3-v3.14.1.zip)
    Permissive kernel (https://drive.google.com/file/d/1Jq8JeEnzBPCDBjC_ewVxbWjhJ9q4G21G/view?usp=sharing) -thanks to map220v

    In Windows:
    1) Extract the AP_file.tar.md5 from your firmware.zip file using 7zip
    2) Extract the super.img.lz4 file from the AP_file.tar.md5 file using 7zip
    3) Put super.img.lz4 file in LZ4 folder and run in CMD the command
    lz4.exe -d super.img.lz4 superLZ4.img
    4) Put superLZ4.img file in Simg2img folder and run in CMD the command
    simg2img.exe -i superLZ4.img -o superSIMG.img
    In Linux OR Bash shell:
    1) Put superSIMG.img in otatools/bin folder and extract it in Linux terminal using the command
    ./lpunpack --slot=0 superSIMG.img <destination dir> (I recommend you create a folder for this)
    2) Put, in the folder where you extracted superSIMG.img, the GSI file you downloaded and rename it to system.img. Now you should have odm.img, system.img, vendor.img and product.img files in the same folder. You may also need to delete/remane the original system.img file before renaming the GSI file.
    3) Now you’re going to make a brand new super.img file containing all 4 files of the previous step. This is a critical and tricky step. Run Linux terminal and type:
    ./lpmake --metadata-size 65536 --super-name super --metadata-slots 2 --device super:4294967296 --group main:4293513600 --partition system:readonly:1577095168:main --image system=./system.img --partition vendor:readonly:342155264:main --image vendor=./vendor.img --partition odm:readonly:643456:main --image odm=./odm.img --sparse --output ./super.img

    Note that in this code, the numbers highlighted in bold are the sizes of the 3 .img files you extracted (odm, vendor and product) in step 2 plus system.img you downloaded/renamed, IN BYTES. Update the code with YOUR files's sizes!

    system:readonly:1577095168:main (size of unsparsed system.img in bytes)
    vendor:readonly:342155264:main (size of vendor.img in bytes)
    odm:readonly:643456:main (size of odm.img in bytes)
    as @phhusson stated (thanks!), no need sto use product.img, just supress it at all

    --group main:4293513600 (main partition size 1577095168+342155264+643456=2776752512)
    *The size of main is the sum of the 4 .img files*

    You may face two different problems here:
    1) Odm.img file requested a not avaliable space. Just sum and update main’s size.
    2) System.img is larger than expected. Just sum and update main’s size again.

    Your original super.img file is now created, like Samsung does. Congrats!

    Back in Windows:
    1) Create, using 7zip, anyname.tar file cointaining just the super.img you created. Simple.
    2) Open Odin, untick Auto Reboot, add anyname.tar file to AP, put your phone in Download Mode and flash it. Flash boot(NoForcedEnforce).tar the same way.
    3) Reboot your phone, do a Factory Reset in original recovery.

    In Android:
    1) Install terminal emulator and run the following commands:
    setenforce 0
    getenforce (it should show Permissive)

    Job is done.
    Latest recommended firmware for latest update faster: (Updated weekly).

    WARNING: You can't downgrade anymore once you flashed U3 update !

    TWRP is needed to patch the Android 10 Vbmeta_samsung.img

    You will need:

    -Odin v3.14.1

    -Galaxy A51 Latest USB Driver

    You want to download latest firmware directly from server? (fast download)
    Samfirm 0.4.1 or Frija 1.4.2
    Frija not working ? install both vcredist_x00 for your device !

    (Check your windows settings to know which version to install).

    (Microsoft Visual C++ 2010 Redistributable Package) and (Microsoft Visual C++ 2008 Redistributable Package)

    -https://www.microsoft.com/en-US/download/details.aspx?id=29 (x86) 2008
    -https://www.microsoft.com/en-US/download/details.aspx?id=5555 (x86) 2010
    -https://www.microsoft.com/en-US/download/details.aspx?id=15336 (64bit) 2008
    -https://www.microsoft.com/en-US/download/details.aspx?id=14632 (64bit) 2010

    -Open Frija and type in your model (mine is SM-A515F) and your CSC : (mine is LUX).

    (All CSC's and models on Samfrew: https://samfrew.com/model/SM-A515F/).

    -Download and extract SM-A515XX_1_00000000000000_xxxxxxxxxx_fac.zip

    On your device:
    If you want to unlock bootloader:

    -Go to Settings then to About phone and find your build number.

    -Tap on your build number 6 times until you see “You’re now a developer”.

    -Go in Developer options > enable OEM unlocking.

    -Connect the device to your PC.

    -Power off your device with POWER and volume DOWN and directly hold volume UP and DOWN together!

    -Device will boot in DOWNLOAD MODE.

    -Long press volume UP to unlock the bootloader. This will wipe your data and automatically reboot your device!

    If you dont want to unlock bootloader:.

    -Download and extract Odin and open it as administrator.

    Still in DOWNLOAD MODE:

    -Click on BL and select BL_A515FXXXU1AXXX_CL16843479_QB27603640_REV00_user_low_ship_MULTI_CERT.tar.md5

    -Click on AP and select AP_A515FXXXU1AXXX_CL16843479_QB27603640_REV00_user_low_ship_MULTI_CERT_meta_OS9.tar.md5

    -Click on CP and select CP_A515FXXXU1AXXX_CP14483800_CL16843479_QB27603640_REV00_user_low_ship_MULTI_CERT.tar.md5

    (If you want to keep your data don't flash CSC).
    -Click on CSC and select CSC_OMC_OXM_A515FXOXM1AXXX_CL16843479_QB27603640_REV00_user_low_ship_MULTI_CERT.tar.md5

    -Click on USERDATA and select HOME_CSC_OMC_OXM_A515FXOXM1AXXX_CL16843479_QB27603640_REV00_user_low_ship_MULTI_CERT.tar.md5

    -Click on START and wait for installation, when done you can unplug your device.

    Your KNOX status will be tripped if you follow this tutorial...​
    What's knox ? : https://www.google.com/search?q=samsung+knox+explained

    -Download the latest stock firmware for your Samsung Galaxy A51 with Samfirm/Frija app (faster) or Samfrew/Sammobile website (way slower).


    -Extract the SM-A515XX_1_EXAMPLE_0000000000_fac.zip file with 7zip or any other unzipper.

    -Copy the (AP_A515XXXXU1XXXX_CL00000000_QB00000000_REV00_user_low_ship_MULTI_CERT_meta_OS10.tar.md5) file and transfer it to your internal storage.

    -Download and install Magisk Manager APK https://github.com/topjohnwu/Magisk/releases/download/manager-v7.5.1/MagiskManager-v7.5.1.apk

    -Open Magisk Manager and go to Install > Install > Select and Patch a file.

    -Navigate through the storage and select the extracted AP file.
    The firmware will be patched and will be found in Internal Storage/Download/magisk_patched.tar.

    -Transfer the patched file to your PC.

    -Turn OFF your device and boot into DOWNLOAD MODE.

    -In Odin, click on AP and select the patched tar file, Uncheck “Auto Reboot” and click on Install.

    The tool will flash Magisk V20 on your Samsung Galaxy A51.

    To boot in recovery or boot the system with Magisk installed:

    1. Powering up normally → System without Magisk
    2. Power + Volume Up → Bootloader warning → Release all buttons → System with Magisk
    3. Power + Volume Up → Bootloader warning → Keep holding volume up → Actual recovery
    Please post in English!

    Per XDA rule #4:
    4. Use the English language.
    We understand that with all the different nationalities, not everyone speaks English well, but please try. If you're really unable to post in English, use an online translator. You're free to include your original message in your own language, below the English translation. (This rule covers your posts, profile entries and signature). You could try :- https://translate.google.com/ or https://www.babelfish.com/ or use one of your choice.
    Please be respectful of all XDA rules, and other members as well.
    Thank you for your cooperation.
    Could you tell how you used lpmake to repack the image? It's always creating an empty image in my case.:eek:

    lpmake --metadata-size 65536 --super-name super --metadata-slots 2 --device super:4294967296 --group main:4293513600 --partition product:readonly:1516761088:main --image product=./product.img --partition system:readonly:1577095168:main --image system=./system.img --partition vendor:readonly:342155264:main --image vendor=./vendor.img --partition odm:readonly:643456:main --image odm=./odm.img --sparse --output ./super.img

    product:readonly:1516761088:main (size of product.img in bytes)
    system:readonly:1577095168:main (size of unsparsed system.img in bytes)
    vendor:readonly:342155264:main (size of vendor.img in bytes)
    odm:readonly:643456:main (size of odm.img in bytes)

    --group main:4293513600 (main partition size 1516761088+1577095168+342155264+643456=4293513600)
    Vbmeta file that I created that allows RW in every partition. I used the code provided on Ian MacDonald telegram channel
    View attachment vbmeta-A515F.tar