• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Galaxy S10+ SM-G975F Galaxy Watch pairing issue with Magisk

Search This thread

Xenenon

Member
Oct 7, 2014
5
0
Hello,

I am curious to see if anyone else had or still has this issue and if there is a fix for it.

Devices involved:
Phone - Samsung Galaxy S10 Plus (SM-G975F) Android Version: 10.0 Build Number G975FXXU4CTC9
Watch - Samsung Galaxy Watch 46mm (NO LTE)

Before rooting with Magisk I was able to pair the watch to the phone using the Galaxy Wearable App and use the watch with no problems. (And it still connects with my unrooted Xiaomi mi 9T)

After rooting my s10+ with Magisk (latest stable and also previous version) I was no longer able to pair the watch. It would start out fine by showing a matching passkey on both devices. I accept the code and they would begin to pair. Once the watch displays "Use phone to complete setup" is when the problems presented.

The Galaxy Wearable app will say its pairing the devices but shows nothing and keeps sending a notification saying it sees the watch and asks to connect or cancel. I tap connect and I get a white screen with a spinning circle. After 3-5 seconds the white screen goes away and 3-5 seconds later I am asked to connect the watch again.

If I go to Settings>Connections>Bluetooth (on the phone) I can see the watch is paired but the app will not complete setup. (I can pair to my car Bluetooth and JBL Xtreme speaker with no problems)

I am using Magisk Hide on the Galaxy Watch Plugin, Galaxy Wearable App, and Samsung Accessory Service but that hasn't helped. Nor does uninstalling and reinstalling Galaxy Wearable App.

Any thoughts?
Please help me, im messing around with this crap since 4 days. (I restored the phone about 20 times with odin an retryed again and again)
 

P_D_M

Member
Aug 27, 2013
28
16
Could it be related to tripping knox through rooting (i.e. then some of the Samsung apps will not work e.g. Samsung Health)? I am unable to register S.Health and Wearable (on my rooted S7 edge) will not work.

However, working fine on non-rooted S10+.
 

lladwein

Senior Member
Aug 14, 2012
641
404
My Galaxy S3 Frontier works fine on Stock rooted + Lineage OS 17.1 .

there is a mgaisk module you can try called "Bluetooth Libary Patcher". Find it in Magisk -- Downloads -- and search for it there (just type bluetooth in search panel on top)

as i said, my watch works as it should.

and for Samsung helath: if youre rooted you just have to add one line in build.prop: ro.config.tima=1
 

GeekSiddiqi

Member
Apr 13, 2020
6
1
My Galaxy S3 Frontier works fine on Stock rooted + Lineage OS 17.1 .

there is a mgaisk module you can try called "Bluetooth Libary Patcher". Find it in Magisk -- Downloads -- and search for it there (just type bluetooth in search panel on top)

as i said, my watch works as it should.

and for Samsung helath: if youre rooted you just have to add one line in build.prop: ro.config.tima=1

oops! It did not work on mine S10+
Getting frustrated day by day!
 

GeekSiddiqi

Member
Apr 13, 2020
6
1
Hello,

I am curious to see if anyone else had or still has this issue and if there is a fix for it.

Devices involved:
Phone - Samsung Galaxy S10 Plus (SM-G975F) Android Version: 10.0 Build Number G975FXXU4CTC9
Watch - Samsung Galaxy Watch 46mm (NO LTE)

Before rooting with Magisk I was able to pair the watch to the phone using the Galaxy Wearable App and use the watch with no problems. (And it still connects with my unrooted Xiaomi mi 9T)

After rooting my s10+ with Magisk (latest stable and also previous version) I was no longer able to pair the watch. It would start out fine by showing a matching passkey on both devices. I accept the code and they would begin to pair. Once the watch displays "Use phone to complete setup" is when the problems presented.

The Galaxy Wearable app will say its pairing the devices but shows nothing and keeps sending a notification saying it sees the watch and asks to connect or cancel. I tap connect and I get a white screen with a spinning circle. After 3-5 seconds the white screen goes away and 3-5 seconds later I am asked to connect the watch again.

If I go to Settings>Connections>Bluetooth (on the phone) I can see the watch is paired but the app will not complete setup. (I can pair to my car Bluetooth and JBL Xtreme speaker with no problems)

I am using Magisk Hide on the Galaxy Watch Plugin, Galaxy Wearable App, and Samsung Accessory Service but that hasn't helped. Nor does uninstalling and reinstalling Galaxy Wearable App.

Any thoughts?
Please help me, im messing around with this crap since 4 days. (I restored the phone about 20 times with odin an retryed again and again)

Anything you figure out!
Please do share with me!!!!
 
  • Like
Reactions: Xenenon

bwilk316j

Member
Feb 4, 2018
30
4
38
Louisiana
Beyone Rom 6.7

If you have questions better go to reddit and ask for help
XDA is dead

But do you lose the Samsung stock camera with this Rom? I have the same exact problem as you. When I was running the Evolution X custom Rom I could connect. But I wasn't happy with the camera that Rom provided. The stock camera on this phone is so amazing and one of the main reasons I bought the phone. I feel cheated when I have to give that up
 

Zotyoo

Member
Jul 11, 2015
22
5
Hi! Given a Samsung Galaxy Watch Active 2 (LTE) watch and a rooted Galaxy S10 (Android Q). Bluetooth pairing starts but does not end. Two Magisk modules id have been installed but I can't pair them. Is there anything you can bring together? So much for all the stupidity to read, but no answer or stupidity throughout. I can't install Viper4android on the same phone under Android 10. Magisk 21.4, but the 2.7 Viper doesn’t go up. It is installed by plugin, but not among applications. Can these be solved somehow? There was no problem under Android 9. Unfortunately, for the latest Android Q version, XEH version November 27, 2020, TWRP is not trable either. I download the right version, with Magisk, I boot into the AP with Odin, then start button, and odin closes immediately. Nothing goes on this ****ty Android Q. I am waiting for help together or separately! Thanks!
 

rxk

Senior Member
Apr 9, 2010
123
7
Any update on this issue?
I have problem pairing my Galaxy S21 Ultra and Galaxy Watch Active 2.

No pairing issues before rooting (stock firmware). After rooting using both stable Magisk V22 and Canary 22005, it stuck on Finalizing Pairing screen. I also noticed that the Bluetooth and Samsung accessory icons briefly shown on the notification bar (appear part of the screen) and then disappear.

I hope someone has solution to this.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Install adb to your PC (Portable mini adb available over XDA, just extract and use)
    - enable usb debugging from developer option on android
    - connect device
    Code:
    adb shell
    su
    mount -o remount,rw /vendor
    i=`grep -lr 'security.wsm' /vendor/etc/vintf` && [ ! -z $i ] && [ $i != *.bak ] && cp --preserve=all $i $i.bak && sed -i '/<.*security.wsm.*/,/<hal format="hidl">/d' $i
    mount -o remount,ro /vendor

    Reboot and your watch will connect to rooted device with A11
    1
    Hello,

    I am curious to see if anyone else had or still has this issue and if there is a fix for it.

    Devices involved:
    Phone - Samsung Galaxy S10 Plus (SM-G975F) Android Version: 10.0 Build Number G975FXXU4CTC9
    Watch - Samsung Galaxy Watch 46mm (NO LTE)

    Before rooting with Magisk I was able to pair the watch to the phone using the Galaxy Wearable App and use the watch with no problems. (And it still connects with my unrooted Xiaomi mi 9T)

    After rooting my s10+ with Magisk (latest stable and also previous version) I was no longer able to pair the watch. It would start out fine by showing a matching passkey on both devices. I accept the code and they would begin to pair. Once the watch displays "Use phone to complete setup" is when the problems presented.

    The Galaxy Wearable app will say its pairing the devices but shows nothing and keeps sending a notification saying it sees the watch and asks to connect or cancel. I tap connect and I get a white screen with a spinning circle. After 3-5 seconds the white screen goes away and 3-5 seconds later I am asked to connect the watch again.

    If I go to Settings>Connections>Bluetooth (on the phone) I can see the watch is paired but the app will not complete setup. (I can pair to my car Bluetooth and JBL Xtreme speaker with no problems)

    I am using Magisk Hide on the Galaxy Watch Plugin, Galaxy Wearable App, and Samsung Accessory Service but that hasn't helped. Nor does uninstalling and reinstalling Galaxy Wearable App.

    Any thoughts?
    Please help me, im messing around with this crap since 4 days. (I restored the phone about 20 times with odin an retryed again and again)

    Anything you figure out!
    Please do share with me!!!!