• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Galaxy S5 SM-G900M boot loop (?)

Search This thread

jjkjlal

Member
Oct 14, 2019
6
1
Hey there I have a Galaxy S5 that was running LineageOS, I started having some trouble recharging it, couldn't figure out if it was the battery or recharger.

I decided to leave it at a repair shop and afterwards buy a new battery from them. The first day it was working normally and I left it the whole day just recharging but then it started having some problems rebooting automatically. Now it keeps "rebooting" all the time which wasn't a problem with the old battery, the Galaxy S5 logo appears then it reboots and appears again etc.
I can't boot into recovery either but strangely enough I can get into download mode without it rebooting and it seems to work fine, even unplugged from any power source, this confuses me because I thought it was the battery.

Without being connected to a USB cable:
Power: Vibrates, Galaxy S5 logo appears, "recovery booting..." appears on top left, reboots immediately afterwards (doesn't enter recovery).
Volume UP + Home + Power: Vibrates, nothing appears on screen, slight flash on the screen as if it was damaged (but it isn't).
Volume DOWN + Home + Power: Boots into download mode absolutely fine, screen working 100%, doesn't reboot (can flash normally).

Being connected to a USB cable:
As soon as I connect it, the phone automatically tries to turn on as if I pressed the Power button ("recovery booting..." appears on top left), keeps rebooting as mentioned before, if I remove the battery while keeping it plugged in, it keeps doing the same thing but the Galaxy S5 Logo lasts longer on the screen and no "recovery booting..." appears on top left.
Volume UP + Home + Power: Same as just pressing Power mentioned before, keeps rebooting as mentioned but no slight flashes and screen works unlike when unplugged.
Volume DOWN + Home + Power: Boots into download mode absolutely fine, screen working 100%, doesn't reboot (can flash normally).

What I've tried so far:
Flash original ROM with Odin, flashed fine but still rebooting.
Flash TWRP on top of original ROM with Odin, flashed fine but still rebooting.
Flash "G900MUBU1BOE1_IUS1BOE1_v5.0_Repair_Firmware" along with the included .pit file, flashed fine but still rebooting.
Flash https://www.sammobile.com/samsung/galaxy-s5/firmware/SM-G900M/ZVV/download/G900MUBU1CPF2/88002/, flashed fine but still rebooting.
Flash "G900MUBU1BOK3", flashed fine but still rebooting.
Flash "G900MUBU1ANG3", flashed fine but still rebooting.

Download mode info:
ODIN MODE
PRODUCT NAME: SM-G90M
CURRENT BINARY: Samsung Official
SYSTEM STATUS: Custom
REACTIVATION LOCK(KK): Off
KNOX WARRANTY VOID: 0x1 (2)
QUALCOMM SECUREBOOT: Enable (CSB)
RP SWREV: S1, T1, R1, A1, P1
SECURE DOWNLOAD: Enable
UDC START

Anyone knows what could be the cause? If more info is needed on model, battery etc let me know.
Thanks in advance.
 
Last edited:

blinky8u

New member
Dec 16, 2019
3
0
Did you ever manage to fix this problem?

Im having the same drama... and im only a basic user looking to use the stock OS again.

cheers
 

vantt1

Senior Member
Dec 23, 2011
729
555
Same problem here, with a G900I. No luck, I've tried two "4 file" repair firmwares with repartitioning and one stock single file, no luck either.