• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Galaxy S7 edge won't turn ON and no charging indications

Search This thread

coowkeee

Senior Member
Oct 24, 2013
217
28
Philippines
www.arisramirez.com
Hi

My phone was stuck at black screen with blue LED light. I waited for it to drain completely, and then charge it so I can flash new firmware. I enter download mode, flash new firmware and it was a success. It restarts and then stuck again on blue screen with Android robot and some like no signal tv effects on the screen, which I think it crashed. Then I forced restart it using vol down+power and it boots up with blue screen wtih "no command" error. I tried restarting it again and it fully dies on me. It won't turn on again.

Button combinations seem not working, no charging indications.

How can I fix this?

Is it bricked? If so, changing motherboard will fix this?
 

waqar747

Member
Oct 5, 2007
27
2
Try leaving it on charge for a while. The charging light should light up. When you go in recovery, on the "no command" screen, press and hold power button and press the vol. up button. That will take you to the admin / recovery screen.
I didn't know it either and was thinking the recovery is corrupt or not working. It is actually waiting for that command from you (power+vol. up). Once in, you can navigate through the menu using vol. up and down to move and power to select an option.
 

coowkeee

Senior Member
Oct 24, 2013
217
28
Philippines
www.arisramirez.com
Try leaving it on charge for a while. The charging light should light up. When you go in recovery, on the "no command" screen, press and hold power button and press the vol. up button. That will take you to the admin / recovery screen.
I didn't know it either and was thinking the recovery is corrupt or not working. It is actually waiting for that command from you (power+vol. up). Once in, you can navigate through the menu using vol. up and down to move and power to select an option.

I manage to get the phone working again and booted up on "No Command" screen again. Holding vol up and power doesn't work. But I manage to do download mode instead, installed new firmware and again, it crashes after Odin successfully pass it.

I attached a photo of the crash.

Btw I think it's charging now but there's no LED light.
-_- Just both this few months ago.

EDIT: also when I restart my phone using vol down, home, and power keys to restart my phone then Vol up+power+home or without home, it skips the factory reset and jumps to "No Command" again. -_-
 
Last edited:

coowkeee

Senior Member
Oct 24, 2013
217
28
Philippines
www.arisramirez.com
Update:

I tried to downgrade it, and now I'm stuck installing updates, can't go past it. -_-

oh god, last time Lg G4 gave me headache and now my s7 edge is suffering from abnormalities too. -_-
 

Pavamarea

Senior Member
Sep 18, 2013
363
65
São Paulo
I had this same problem, I sent the web store that I imported and I am waiting for answers, because it is still under warranty. With each passing day I see more of this problem happening, I find it very worrisome.
 

VuBoo

Senior Member
Dec 30, 2009
221
66
Its a hardware issue mate. Had this recently and changed the Mainboard. You should let it replaced if u are in warranty.

Greets
 

coowkeee

Senior Member
Oct 24, 2013
217
28
Philippines
www.arisramirez.com
UPDATE:

After flashing different kinds of Nougat firmwares nothing happens. Charging light and key lights are dead at this point. Then I flashed some MM firmware, one of these firmware gives life back to the dead LED lights on the notification and keys but phone still can't get pass the blue screen with "erasing" or "installing updates" message. After multiple times of force rebooting it by pressing vol down+power, it booted itself to recovery mode(thanks god!) and I don't know why. Lol. Wipe cached it and factory reset and still brought me back to "erasing" or "installing updates" blue screen. Then finally, after flashing the UK stock MM, all lights came back to life. It's working fine right now and I don't think I'll update it to Android N just yet.
 

vini3237

Member
Jun 21, 2017
10
0
UPDATE:

After flashing different kinds of Nougat firmwares nothing happens. Charging light and key lights are dead at this point. Then I flashed some MM firmware, one of these firmware gives life back to the dead LED lights on the notification and keys but phone still can't get pass the blue screen with "erasing" or "installing updates" message. After multiple times of force rebooting it by pressing vol down+power, it booted itself to recovery mode(thanks god!) and I don't know why. Lol. Wipe cached it and factory reset and still brought me back to "erasing" or "installing updates" blue screen. Then finally, after flashing the UK stock MM, all lights came back to life. It's working fine right now and I don't think I'll update it to Android N just yet.


I'm facing the same problem, Can you pass me a step by step friend please?
 

Jonalyns

New member
Feb 3, 2018
1
0
Hello..my phone keeps flickering i dont know whats the problem..i already thurned it off many times but when i switch it on it keeps on flickering my phone is s7..i dont know what to do..hoping that somebody will answer me
 

[email protected]

New member
Nov 24, 2018
1
0
UPDATE:

After flashing different kinds of Nougat firmwares nothing happens. Charging light and key lights are dead at this point. Then I flashed some MM firmware, one of these firmware gives life back to the dead LED lights on the notification and keys but phone still can't get pass the blue screen with "erasing" or "installing updates" message. After multiple times of force rebooting it by pressing vol down+power, it booted itself to recovery mode(thanks god!) and I don't know why. Lol. Wipe cached it and factory reset and still brought me back to "erasing" or "installing updates" blue screen. Then finally, after flashing the UK stock MM, all lights came back to life. It's working fine right now and I don't think I'll update it to Android N just yet.
bro may step by step ka ba panu mo nasolve? pareho kasi ng nangyari sa s7 ko