Question Galaxy watch 4 classic 46mm gps not working

Search This thread


Oct 24, 2012
Hi guys, after update watch to one UI 4.5 on last September, gps can't find location on Samsung health, Strava and same apps. Yesterday I updated watch to October update, but problem not solved. Can anyone help me?


  • Screenshot_20221013_101134_gnss.png
    37.1 KB · Views: 57
  • Screenshot_20221013_101114_weargpsfix.png
    20.3 KB · Views: 57


Senior Member
  • Like
Reactions: yasador and galaxys


Senior Member
Also check this out (and the comments)
"If you open the workout widget on the watch and choose your workout from there instead of just selecting the run widget, you can see at the top of the screen that GPS and Heartrate are blinking. When they both are solid and you see your heart rate you are ready to press run or walk, etc. That way you know everything is locked in before you start your workout."
The problem is with the internal gps connection of the watch
The Google Fit app uses the phone's GPS
Few people have noticed this problem and Samsung has cleverly avoided fixing it
Has anyone been able to solve the problem?????????
Maybe in your watch, my GPS still works fine.
I don't use Google Fit and I don't exercise/hike with my phone - just the GW4 Classic 42mm.
GPS works fine and tracks/routes are recorded fine (within accuracy of the receiver).
Only existing issue is that auto-detection of exercise (walk/run/cycle) works but does not initiate GPS route recording; you need to start the exercise manually to have route recorded.


Senior Member
Weird, but worked for me>>>
removed original straps from watch
cleaned watch dial
powered off and heated up with hair dryer
powered on in outdoor
and voila!! GPS fixed. i have tracked cycling, running working fine now!
also i have changed straps locations (means, swapped upper and bottom straps)

Top Liked Posts