Galaxy Wearable App on Rooted Phone Help

Search This thread

kmanxx

Member
Dec 5, 2017
8
0
Hello, I am trying to install the new Wearable app on my galaxy s9 that is running a custom rom / rooted. The app says it is not compatible due to the phone being modified in an unauthorized way. I know people got the previous wear app to work on rooted phones, any chance to get this one to work as well? It is needed to pair with the new Galaxy Watch.
 

Docmjldds

Senior Member
Jan 27, 2010
5,056
709
Henderson, NV
I'm on an S9, rooted, on a custom rom in Cross Development (TGP ROM) and Galaxy Wearable runs fine. I would post your issue in the specific Forum here that you are using.
 

kmanxx

Member
Dec 5, 2017
8
0
Hmm okay, I'll try, just seems wierd and haven't found anything similar to it online. Here's a screenshot of what it says
158lgFT.png
 
Last edited:

To_O

Member
Jul 26, 2018
27
93
Same problem here with a Galaxy S6 G920F (AOSP Extended, Android 8.1.0) rooted with Magisk even if Magisk Hide is selected for Galaxy Wearable.

Edit : I've found a fix ! See the post below ;)
 
Last edited:

To_O

Member
Jul 26, 2018
27
93
Hi,

I'm coming back since I've found a workaround for Galaxy Wearable to work again.

So here is what I have done (for Samsung device with custom ROM only) :
If it's not already done, install the "MagiskHide Props Config" module from Magisk and then reboot.

Open a terminal emulator and run "su" then "props", when the module is loaded, type "1" to edit fingerprint, choose Google, then Pixel 3 (even if you're not on Android 9). For all of the manipulations when the module asks you to reboot, don't reboot.

After that, go back to the main menu and choose "Improved hiding" and enable it.

Then, go back to the main menu again and choose "Add/Edit custom props". Now we need to change everything that is related to Samsung.
Do theses steps for every prop we need to edit :
1. Type "n" to add a custom prop
2. Now we need to say which prop we need to edit : "ro.product.brand", "ro.product.device", "ro.product.manufacturer", "ro.product.model", "ro.product.name" and "ro.vendor.product.manufacturer" (Type only one of them and without the " ")
3. If the value already exists it will show you what is the actual value of the prop, and if it doesn't exist, double check that you didn't make any mistake when typing it and if not, skip it.
4. Then type respectively : "google", "crosshatch", "google", "Pixel 3", "crosshatch" and "google" (without " ")
5. The module will asks you for when do you want this to be applied ? Just keep "default" and validate with "y"

6. When you have done this for the 6 props, you should have something like the screenshots.

Now you can reboot your phone, delete all the data of the Galaxy Wearable app and it should open ! And also don't forget to hide it with Magisk Hide before clearing data.

What we have done here is to change all of the values of a Samsung related phone to a non Samsung phone, and I think that the app is checking a specific thing (like a TouchWiz related thing), and if it can't find it, the phone is unofficial and the app doesn't want to run. But with the other brands they can't do that so the app is running without problem.

Last thing, if doesn't work even with that, go to Settings, About phone and check if it's now shown as a Pixel 3, if not, there might be an issue somewhere else. Make sure that your ROM passes SafetyNet. Or if you want, you can open a build prop editor, search for "samsung", "zeroflte" (Galaxy S6 specific), etc... and see if there is a prop that I/you missed and change it to "google", "crosshatch", etc...

So let me know if it has worked for you : Working on the Note 3, Galaxy S7 Edge

PS : Sorry for my English if I have made mistakes.
 

Attachments

  • Screenshot_Terminal_Emulator_20181031-142934.png
    Screenshot_Terminal_Emulator_20181031-142934.png
    109.6 KB · Views: 8,593
  • Screenshot_Terminal_Emulator_20181031-144256.png
    Screenshot_Terminal_Emulator_20181031-144256.png
    71 KB · Views: 10,073
  • Screenshot_Terminal_Emulator_20181031-144300.png
    Screenshot_Terminal_Emulator_20181031-144300.png
    72.3 KB · Views: 8,854
  • Screenshot_Terminal_Emulator_20181031-144304.png
    Screenshot_Terminal_Emulator_20181031-144304.png
    72.6 KB · Views: 8,259
  • Screenshot_Terminal_Emulator_20181031-144341.png
    Screenshot_Terminal_Emulator_20181031-144341.png
    71.1 KB · Views: 6,765
  • Screenshot_Terminal_Emulator_20181031-144345.png
    Screenshot_Terminal_Emulator_20181031-144345.png
    72.2 KB · Views: 6,822
  • Screenshot_Terminal_Emulator_20181031-144350.png
    Screenshot_Terminal_Emulator_20181031-144350.png
    74.3 KB · Views: 8,581
Last edited:

blah44000

New member
Jul 19, 2009
3
1
Galaxy Wearable on Note 3 Lineageos 14.1

Great, Great, that works. Good job.
Samsung Note 3 (N9005) + Lineageos 14.1 + Samsung Gear S3
Thanks a lot.
:good:
 
  • Like
Reactions: To_O

To_O

Member
Jul 26, 2018
27
93
can i use this method with my poco f1?

If you can launch the Galaxy Wearable app without any errors it should be ok and you don't need to use this guide. If it's not working, make sure your phone is passing Safety Net and Galaxy Wearable is hidden in Magisk Hide. Then clear the app data and try again. If it's not working after that, try the guide
 

waleedoo81

New member
Oct 28, 2008
4
0
the app is launching and the phone has passed the safety net check + its already hidden in magisk hide but still not working

i followed the guide with no luck

i couldn't enable (improved hiding )
getting this error (prop file modification currently disabled)
 

To_O

Member
Jul 26, 2018
27
93
the app is launching and the phone has passed the safety net check + its already hidden in magisk hide but still not working

i followed the guide with no luck

i couldn't enable (improved hiding )
getting this error (prop file modification currently disabled)

For this error, look at documentation of the module itself it should be explained why you have this. I don't want to say something wrong.
 

esi2121

Senior Member
May 12, 2010
196
23
OnePlus 7 Pro
phone didnt boot after change all props ..on s6 los 16

---------- Post added at 01:18 PM ---------- Previous post was at 01:17 PM ----------

Hi,

I'm coming back since I've found a workaround for Galaxy Wearable to work again.

So here is what I have done (for Samsung device with custom ROM only) :
If it's not already done, install the "MagiskHide Props Config" module from Magisk and then reboot.

Open a terminal emulator and run "su" then "props", when the module is loaded, type "1" to edit fingerprint, choose Google, then Pixel 3 (even if you're not on Android 9). For all of the manipulations when the module asks you to reboot, don't reboot.

After that, go back to the main menu and choose "Improved hiding" and enable it.

Then, go back to the main menu again and choose "Add/Edit custom props". Now we need to change everything that is related to Samsung.
Do theses steps for every prop we need to edit :
1. Type "n" to add a custom prop
2. Now we need to say which prop we need to edit : "ro.product.brand", "ro.product.device", "ro.product.manufacturer", "ro.product.model", "ro.product.name" and "ro.vendor.product.manufacturer" (Type only one of them and without the " ")
3. If the value already exists it will show you what is the actual value of the prop, and if it doesn't exist, double check that you didn't make any mistake when typing it and if not, skip it.
4. Then type respectively : "google", "crosshatch", "google", "Pixel 3", "crosshatch" and "google" (without " ")
5. The module will asks you for when do you want this to be applied ? Just keep "default" and validate with "y"

6. When you have done this for the 6 props, you should have something like the screenshots.

Now you can reboot your phone, delete all the data of the Galaxy Wearable app and it should open ! And also don't forget to hide it with Magisk Hide before clearing data.

What we have done here is to change all of the values of a Samsung related phone to a non Samsung phone, and I think that the app is checking a specific thing (like a TouchWiz related thing), and if it can't find it, the phone is unofficial and the app doesn't want to run. But with the other brands they can't do that so the app is running without problem.

Last thing, if doesn't work even with that, go to Settings, About phone and check if it's now shown as a Pixel 3, if not, there might be an issue somewhere else. Make sure that your ROM passes SafetyNet. Or if you want, you can open a build prop editor, search for "samsung", "zeroflte" (Galaxy S6 specific), etc... and see if there is a prop that I/you missed and change it to "google", "crosshatch", etc...

So let me know if it has worked for you : Working on the Note 3, Galaxy S7 Edge

PS : Sorry for my English if I have made mistakes.

on s6 los 16 phone didnt boot after change all props
 

To_O

Member
Jul 26, 2018
27
93
phone didnt boot after change all props ..on s6 los 16

---------- Post added at 01:18 PM ---------- Previous post was at 01:17 PM ----------



on s6 los 16 phone didnt boot after change all props

Oh, that's strange, maybe it is caused by Android Pie, to be honest I don't know, try to swipe the props with a different model
 
  • Like
Reactions: esi2121

Crowland

Senior Member
Jan 17, 2015
90
11
Here is what I did to get my watch to work.

Download from play store build prop editor. https://play.google.com/store/apps/details?id=com.jrummy.apps.build.prop.editor

Allow build prop editor root access.

Search Samsung replace samsung or the brand of your phone with htc ( not the model and the brand must be in lower case )

Reboot

Download Samsung accsessory service, galaxy wear app, gear s plugin or any other plugins, Samsung health ( if you want health, Samsung pay won't work ) from the apkmirror

Install apps in the order same as above.

reboot again

set up your watch.

Enjoy.

Sent from my [device_name] using XDA-Developers Legacy app
 

Top Liked Posts

  • There are no posts matching your filters.
  • 79
    Hi,

    I'm coming back since I've found a workaround for Galaxy Wearable to work again.

    So here is what I have done (for Samsung device with custom ROM only) :
    If it's not already done, install the "MagiskHide Props Config" module from Magisk and then reboot.

    Open a terminal emulator and run "su" then "props", when the module is loaded, type "1" to edit fingerprint, choose Google, then Pixel 3 (even if you're not on Android 9). For all of the manipulations when the module asks you to reboot, don't reboot.

    After that, go back to the main menu and choose "Improved hiding" and enable it.

    Then, go back to the main menu again and choose "Add/Edit custom props". Now we need to change everything that is related to Samsung.
    Do theses steps for every prop we need to edit :
    1. Type "n" to add a custom prop
    2. Now we need to say which prop we need to edit : "ro.product.brand", "ro.product.device", "ro.product.manufacturer", "ro.product.model", "ro.product.name" and "ro.vendor.product.manufacturer" (Type only one of them and without the " ")
    3. If the value already exists it will show you what is the actual value of the prop, and if it doesn't exist, double check that you didn't make any mistake when typing it and if not, skip it.
    4. Then type respectively : "google", "crosshatch", "google", "Pixel 3", "crosshatch" and "google" (without " ")
    5. The module will asks you for when do you want this to be applied ? Just keep "default" and validate with "y"

    6. When you have done this for the 6 props, you should have something like the screenshots.

    Now you can reboot your phone, delete all the data of the Galaxy Wearable app and it should open ! And also don't forget to hide it with Magisk Hide before clearing data.

    What we have done here is to change all of the values of a Samsung related phone to a non Samsung phone, and I think that the app is checking a specific thing (like a TouchWiz related thing), and if it can't find it, the phone is unofficial and the app doesn't want to run. But with the other brands they can't do that so the app is running without problem.

    Last thing, if doesn't work even with that, go to Settings, About phone and check if it's now shown as a Pixel 3, if not, there might be an issue somewhere else. Make sure that your ROM passes SafetyNet. Or if you want, you can open a build prop editor, search for "samsung", "zeroflte" (Galaxy S6 specific), etc... and see if there is a prop that I/you missed and change it to "google", "crosshatch", etc...

    So let me know if it has worked for you : Working on the Note 3, Galaxy S7 Edge

    PS : Sorry for my English if I have made mistakes.
    4
    Here is what I did to get my watch to work.

    Download from play store build prop editor. https://play.google.com/store/apps/details?id=com.jrummy.apps.build.prop.editor

    Allow build prop editor root access.

    Search Samsung replace samsung or the brand of your phone with htc ( not the model and the brand must be in lower case )

    Reboot

    Download Samsung accsessory service, galaxy wear app, gear s plugin or any other plugins, Samsung health ( if you want health, Samsung pay won't work ) from the apkmirror

    Install apps in the order same as above.

    reboot again

    set up your watch.

    Enjoy.

    Sent from my [device_name] using XDA-Developers Legacy app
    3
    Same problem here with a Galaxy S6 G920F (AOSP Extended, Android 8.1.0) rooted with Magisk even if Magisk Hide is selected for Galaxy Wearable.

    Edit : I've found a fix ! See the post below ;)
    3
    Hey works -partially on Samsung S9 with lineageos 16.0.

    3 attempts so far:

    Hiding magisk with magiskhide from "galaxy wear" is mandatory with all attempts.

    #1 - according to guide by To_O at 2018-10-31 4:10PM in this thread.
    Method: edit ALL samsung/phone reference with magisk hide props editor to google/Pixel 3. "ro.vendor.product.manufacturer" not edited - no such entry. "Improved hiding" removed from magiskhide props editor since v5.
    Hiding magisk with magiskhide from "galaxy wear" is mandatory.
    Result: galaxy wear app was able to start. Additional plugins (Samsung accessory service, galaxy watch plugin) hat to be downloaded from apk mirror. Phone paired successfully.
    BUT: after the next FULL reboot, the phone stuck in lock screen. Unlocking with pattern/fingerprint resulted in black screen an locked phone again. Restored via twrp recovery.
    Comment: situation could be reproduced several times from clean rom install and twrp backups. Lockscreen loop starts as soon as any lockscreen (pin/pattern) is activated. No "problem" when lockscreens are disabled.
    Assessment: likely interference with security features.

    #2 - according to chrigi's blog (google it with "Samsung gear app s5")
    Methods: edit only ro.product.brand and ro.product.manufacturer to "htc"
    Result: galaxy wear app was able to start. Additional plugins (Samsung accessory service, galaxy watch plugin) hat to be downloaded from apk mirror. Phone paired successfully.
    BUT: camera safes only blank grey pictures (already noticed by other users in chrigi's blog on other phones.
    Comment: no further tryout performed. Not worth it.

    #3 - mixture of #1 and #2
    Method: edit only ro.product.brand and ro.product.manufacturer to "google".
    Result: galaxy wear app was able to start. Additional plugins (Samsung accessory service, galaxy watch plugin) hat to be downloaded from apk mirror. Phone paired successfully. No camera app misbehavior in camera app and lock screen - so far. Several full reboot without any issue.
    Comment: The result was created via "backwards" engineering. Started with #1 - installing galaxy wear app - started successfully - downloaded and installed additional apk - galaxy watch paired successfully - created system/data/boot backup in twrp - implemented lock screen pattern - full reboot (power off/wait/reboot) - lock screen loop - restored backup - edited props again - removed all edited entrys except "ro.product.brand" (google) and "ro.product.manufacturer" (google) - tryed galaxy wear app - still working - full reboot - still working - implemented lock screen pattern/fingerprint - still working - full reboot - still working.
    (I rebooted another 27 times just because I was ecstatic that I managed to get this working... So far)

    Current status: I haven't noticed any other strange behaviour SO FAR. Several phone features (calling, ...) haven't been used since the editing. App misbehavior from conflict of entrys in props is possible.

    EDIT: If you experience increased battery drain after changing the props: wipe cache/dalvik.

    Current personal status: still happy this is working since I successfully bricked my previous Ph-1 not 48h ago.
    Stay tuned for "ups, I did it again" ;)
    2
    Hi,

    I'm coming back since I've found a workaround for Galaxy Wearable to work again.

    So here is what I have done (for Samsung device with custom ROM only) :
    If it's not already done, install the "MagiskHide Props Config" module from Magisk and then reboot.

    Open a terminal emulator and run "su" then "props", when the module is loaded, type "1" to edit fingerprint, choose Google, then Pixel 3 (even if you're not on Android 9). For all of the manipulations when the module asks you to reboot, don't reboot.

    After that, go back to the main menu and choose "Improved hiding" and enable it.

    Then, go back to the main menu again and choose "Add/Edit custom props". Now we need to change everything that is related to Samsung.
    Do theses steps for every prop we need to edit :
    1. Type "n" to add a custom prop
    2. Now we need to say which prop we need to edit : "ro.product.brand", "ro.product.device", "ro.product.manufacturer", "ro.product.model", "ro.product.name" and "ro.vendor.product.manufacturer" (Type only one of them and without the " ")
    3. If the value already exists it will show you what is the actual value of the prop, and if it doesn't exist, double check that you didn't make any mistake when typing it and if not, skip it.
    4. Then type respectively : "google", "crosshatch", "google", "Pixel 3", "crosshatch" and "google" (without " ")
    5. The module will asks you for when do you want this to be applied ? Just keep "default" and validate with "y"

    6. When you have done this for the 6 props, you should have something like the screenshots.

    Now you can reboot your phone, delete all the data of the Galaxy Wearable app and it should open ! And also don't forget to hide it with Magisk Hide before clearing data.

    What we have done here is to change all of the values of a Samsung related phone to a non Samsung phone, and I think that the app is checking a specific thing (like a TouchWiz related thing), and if it can't find it, the phone is unofficial and the app doesn't want to run. But with the other brands they can't do that so the app is running without problem.

    Last thing, if doesn't work even with that, go to Settings, About phone and check if it's now shown as a Pixel 3, if not, there might be an issue somewhere else. Make sure that your ROM passes SafetyNet. Or if you want, you can open a build prop editor, search for "samsung", "zeroflte" (Galaxy S6 specific), etc... and see if there is a prop that I/you missed and change it to "google", "crosshatch", etc...

    So let me know if it has worked for you : Working on the Note 3, Galaxy S7 Edge

    PS : Sorry for my English if I have made mistakes.

    You only need to change the following props...so make less work for yourself

    ro.product.manufacturer
    ro.vendor.product.manufacturer


    i just change both to Google via MagiskHide Props Config

    Theyre the only ones ive ever needed to change on my Note 4...without these 2 changed on Android 10 i cannot run the app, with just those two changed, all is perfection

    ---------- Post added at 08:02 AM ---------- Previous post was at 07:55 AM ----------

    This is a great idea! However, Samsung Wear also need another app called Galaxy Watch Plugin, so I would have to clone both apps, randomizing the device (the app cloner does not let me chose a specific device), and I am not sure if it will work. I will try it and let you know.

    You cant clone the wearables plugins, so cloning will fail

    Just use the MagiskHide Props Config method, its the only reliable way