• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Galaxy Wearable App on Rooted Phone Help

Search This thread

ChiefSaad7

New member
May 15, 2021
1
0
Hi,

I'm coming back since I've found a workaround for Galaxy Wearable to work again.

So here is what I have done (for Samsung device with custom ROM only) :
If it's not already done, install the "MagiskHide Props Config" module from Magisk and then reboot.

Open a terminal emulator and run "su" then "props", when the module is loaded, type "1" to edit fingerprint, choose Google, then Pixel 3 (even if you're not on Android 9). For all of the manipulations when the module asks you to reboot, don't reboot.

After that, go back to the main menu and choose "Improved hiding" and enable it.

Then, go back to the main menu again and choose "Add/Edit custom props". Now we need to change everything that is related to Samsung.
Do theses steps for every prop we need to edit :
1. Type "n" to add a custom prop
2. Now we need to say which prop we need to edit : "ro.product.brand", "ro.product.device", "ro.product.manufacturer", "ro.product.model", "ro.product.name" and "ro.vendor.product.manufacturer" (Type only one of them and without the " ")
3. If the value already exists it will show you what is the actual value of the prop, and if it doesn't exist, double check that you didn't make any mistake when typing it and if not, skip it.
4. Then type respectively : "google", "crosshatch", "google", "Pixel 3", "crosshatch" and "google" (without " ")
5. The module will asks you for when do you want this to be applied ? Just keep "default" and validate with "y"

6. When you have done this for the 6 props, you should have something like the screenshots.

Now you can reboot your phone, delete all the data of the Galaxy Wearable app and it should open ! And also don't forget to hide it with Magisk Hide before clearing data.

What we have done here is to change all of the values of a Samsung related phone to a non Samsung phone, and I think that the app is checking a specific thing (like a TouchWiz related thing), and if it can't find it, the phone is unofficial and the app doesn't want to run. But with the other brands they can't do that so the app is running without problem.

Last thing, if doesn't work even with that, go to Settings, About phone and check if it's now shown as a Pixel 3, if not, there might be an issue somewhere else. Make sure that your ROM passes SafetyNet. Or if you want, you can open a build prop editor, search for "samsung", "zeroflte" (Galaxy S6 specific), etc... and see if there is a prop that I/you missed and change it to "google", "crosshatch", etc...

So let me know if it has worked for you : Working on the Note 3, Galaxy S7 Edge

PS : Sorry for my English if I have made mistakes.
Can anyone please guide me from instruction #2? Thanks
 

natsou

New member
Nov 24, 2007
4
0
Hi,

I'm coming back since I've found a workaround for Galaxy Wearable to work again.

So here is what I have done (for Samsung device with custom ROM only) :
If it's not already done, install the "MagiskHide Props Config" module from Magisk and then reboot.

Open a terminal emulator and run "su" then "props", when the module is loaded, type "1" to edit fingerprint, choose Google, then Pixel 3 (even if you're not on Android 9). For all of the manipulations when the module asks you to reboot, don't reboot.

After that, go back to the main menu and choose "Improved hiding" and enable it.

Then, go back to the main menu again and choose "Add/Edit custom props". Now we need to change everything that is related to Samsung.
Do theses steps for every prop we need to edit :
1. Type "n" to add a custom prop
2. Now we need to say which prop we need to edit : "ro.product.brand", "ro.product.device", "ro.product.manufacturer", "ro.product.model", "ro.product.name" and "ro.vendor.product.manufacturer" (Type only one of them and without the " ")
3. If the value already exists it will show you what is the actual value of the prop, and if it doesn't exist, double check that you didn't make any mistake when typing it and if not, skip it.
4. Then type respectively : "google", "crosshatch", "google", "Pixel 3", "crosshatch" and "google" (without " ")
5. The module will asks you for when do you want this to be applied ? Just keep "default" and validate with "y"

6. When you have done this for the 6 props, you should have something like the screenshots.

Now you can reboot your phone, delete all the data of the Galaxy Wearable app and it should open ! And also don't forget to hide it with Magisk Hide before clearing data.

What we have done here is to change all of the values of a Samsung related phone to a non Samsung phone, and I think that the app is checking a specific thing (like a TouchWiz related thing), and if it can't find it, the phone is unofficial and the app doesn't want to run. But with the other brands they can't do that so the app is running without problem.

Last thing, if doesn't work even with that, go to Settings, About phone and check if it's now shown as a Pixel 3, if not, there might be an issue somewhere else. Make sure that your ROM passes SafetyNet. Or if you want, you can open a build prop editor, search for "samsung", "zeroflte" (Galaxy S6 specific), etc... and see if there is a prop that I/you missed and change it to "google", "crosshatch", etc...

So let me know if it has worked for you : Working on the Note 3, Galaxy S7 Edge

PS : Sorry for my English if I have made mistakes.
Thank you so much
worked perfectly well
I just then had a problem with the watch plung in that the play store wouldn't accept to load on my phone => downloaded 1) samsung acessory services 2) galaxy wear 3) galaxy watch active plug in on APL mirror and it worked fine after
 

#mcl

Senior Member
Mar 26, 2020
80
18
Spain
Google Pixel 4 XL
Hi,

I'm coming back since I've found a workaround for Galaxy Wearable to work again.

So here is what I have done (for Samsung device with custom ROM only) :
If it's not already done, install the "MagiskHide Props Config" module from Magisk and then reboot.

Open a terminal emulator and run "su" then "props", when the module is loaded, type "1" to edit fingerprint, choose Google, then Pixel 3 (even if you're not on Android 9). For all of the manipulations when the module asks you to reboot, don't reboot.

After that, go back to the main menu and choose "Improved hiding" and enable it.

Then, go back to the main menu again and choose "Add/Edit custom props". Now we need to change everything that is related to Samsung.
Do theses steps for every prop we need to edit :
1. Type "n" to add a custom prop
2. Now we need to say which prop we need to edit : "ro.product.brand", "ro.product.device", "ro.product.manufacturer", "ro.product.model", "ro.product.name" and "ro.vendor.product.manufacturer" (Type only one of them and without the " ")
3. If the value already exists it will show you what is the actual value of the prop, and if it doesn't exist, double check that you didn't make any mistake when typing it and if not, skip it.
4. Then type respectively : "google", "crosshatch", "google", "Pixel 3", "crosshatch" and "google" (without " ")
5. The module will asks you for when do you want this to be applied ? Just keep "default" and validate with "y"

6. When you have done this for the 6 props, you should have something like the screenshots.

Now you can reboot your phone, delete all the data of the Galaxy Wearable app and it should open ! And also don't forget to hide it with Magisk Hide before clearing data.

What we have done here is to change all of the values of a Samsung related phone to a non Samsung phone, and I think that the app is checking a specific thing (like a TouchWiz related thing), and if it can't find it, the phone is unofficial and the app doesn't want to run. But with the other brands they can't do that so the app is running without problem.

Last thing, if doesn't work even with that, go to Settings, About phone and check if it's now shown as a Pixel 3, if not, there might be an issue somewhere else. Make sure that your ROM passes SafetyNet. Or if you want, you can open a build prop editor, search for "samsung", "zeroflte" (Galaxy S6 specific), etc... and see if there is a prop that I/you missed and change it to "google", "crosshatch", etc...

So let me know if it has worked for you : Working on the Note 3, Galaxy S7 Edge

PS : Sorry for my English if I have made mistakes.
Really thanks!!! I've just got a Galaxy Watch Active and had problems to connect it to my Galaxy S9 on DotOS ROM running Android 11. Loving it and didn't want to go back to stock just to get this app working.
Really thank you!!!! 😊😊😊
 

Quinquadrate

Member
Dec 25, 2019
12
3
Hi,

I'm coming back since I've found a workaround for Galaxy Wearable to work again.

So here is what I have done (for Samsung device with custom ROM only) :
If it's not already done, install the "MagiskHide Props Config" module from Magisk and then reboot.

Open a terminal emulator and run "su" then "props", when the module is loaded, type "1" to edit fingerprint, choose Google, then Pixel 3 (even if you're not on Android 9). For all of the manipulations when the module asks you to reboot, don't reboot.

After that, go back to the main menu and choose "Improved hiding" and enable it.

Then, go back to the main menu again and choose "Add/Edit custom props". Now we need to change everything that is related to Samsung.
Do theses steps for every prop we need to edit :
1. Type "n" to add a custom prop
2. Now we need to say which prop we need to edit : "ro.product.brand", "ro.product.device", "ro.product.manufacturer", "ro.product.model", "ro.product.name" and "ro.vendor.product.manufacturer" (Type only one of them and without the " ")
3. If the value already exists it will show you what is the actual value of the prop, and if it doesn't exist, double check that you didn't make any mistake when typing it and if not, skip it.
4. Then type respectively : "google", "crosshatch", "google", "Pixel 3", "crosshatch" and "google" (without " ")
5. The module will asks you for when do you want this to be applied ? Just keep "default" and validate with "y"

6. When you have done this for the 6 props, you should have something like the screenshots.

Now you can reboot your phone, delete all the data of the Galaxy Wearable app and it should open ! And also don't forget to hide it with Magisk Hide before clearing data.

What we have done here is to change all of the values of a Samsung related phone to a non Samsung phone, and I think that the app is checking a specific thing (like a TouchWiz related thing), and if it can't find it, the phone is unofficial and the app doesn't want to run. But with the other brands they can't do that so the app is running without problem.

Last thing, if doesn't work even with that, go to Settings, About phone and check if it's now shown as a Pixel 3, if not, there might be an issue somewhere else. Make sure that your ROM passes SafetyNet. Or if you want, you can open a build prop editor, search for "samsung", "zeroflte" (Galaxy S6 specific), etc... and see if there is a prop that I/you missed and change it to "google", "crosshatch", etc...

So let me know if it has worked for you : Working on the Note 3, Galaxy S7 Edge

PS : Sorry for my English if I have made mistakes.

This still works on android 11 with my galaxy s10+

Thank you!!

If anyone was wondering, you can use "redfin" instead of "crosshatch", and "Pixel 5" instead of "Pixel 3" to make your device appear as a Pixel 5.
 

Gitter1967

New member
Aug 27, 2020
1
0
runs perfectly with S8 +, Galaxy Watch46mm and Sakura 5.1 Android11. After I had also changed Google and reset the watch, the pairing could be ended. Many Thanks
 

jmeas

Member
Apr 4, 2013
12
0
Sakura 5.1 Android11: Only had to change two custom props to get it to work. Made them both google.

ro.product.manufacturer
ro.vendor.product.manufacturer
 
Last edited:

Trance_Nation

New member
Jun 18, 2010
3
1
Hello guys, tried To_O's way but i still have problems..
I have always had access to Galaxy Wearable but the problem i have is that after i have selected my Gear S3 Classic and it starts to pair, it just stops to pair, the animation is still loading but nothing happens.
If i close the app and then enter Galaxy Wearable the watch is there but it can not connect to eachother..

Could this still be a problem related to this thread? or what can i do to get it to pair? I have tried with an Galaxy watch also but still the same issue..
Thanks.
 

zhero_gee

Member
Jan 21, 2017
26
1
hello. samsung galaxy s9 running Resurrection remix Android 8.1
I cannot find "improved hiding" in the main menu at all.
any help is greatly appreciated
 

eletricman77

Member
Aug 16, 2016
9
0
hello, I made the changes with the terminal emulator some time ago and it worked until days ago (google px3 etc.). Now it keeps giving me error Samsung Gear Plugin close application and I can't get my Gear Frontier to work anymore, I have tried all the vati reset and also to reinstall the Lineage 17.1.
please help me. sorry for my english
 

SonnenTeddy69

Member
Oct 1, 2019
5
0
Leipzig
Hello, everyone,
maybe someone can help me here. Unfortunately, Samsung seems to be blocking rooted phones. Clock is recognized, but hangs at the last point when pairing. I found the following here:

Open a terminal emulator and run "su" then "props", when the module is loaded, type "1" to edit fingerprint, choose Google, then Pixel 3 (even if you're not on Android 9). For all of the manipulations when the module asks you to reboot, don't reboot.

After that, go back to the main menu and choose "Improved hiding" and enable it.

Then, go back to the main menu again and choose "Add/Edit custom props". Now we need to change everything that is related to Samsung.
Do theses steps for every prop we need to edit :
1. Type "n" to add a custom prop
2. Now we need to say which prop we need to edit : "ro.product.brand", "ro.product.device", "ro.product.manufacturer", "ro.product.model", "ro.product.name" and "ro.vendor.product.manufacturer" (Type only one of them and without the " ")
3. If the value already exists it will show you what is the actual value of the prop, and if it doesn't exist, double check that you didn't make any mistake when typing it and if not, skip it.
4. Then type respectively : "google", "crosshatch", "google", "Pixel 3", "crosshatch" and "google" (without " ")
5. The module will asks you for when do you want this to be applied ? Just keep "default" and validate with "y"

6. When you have done this for the 6 props, you should have something like the screenshots.

Now you can reboot your phone, delete all the data of the Galaxy Wearable app and it should open ! And also don't forget to hide it with Magisk Hide before clearing data.

What we have done here is to change all of the values of a Samsung related phone to a non Samsung phone, and I think that the app is checking a specific thing (like a TouchWiz related thing), and if it can't find it, the phone is unofficial and the app doesn't want to run. But with the other brands they can't do that so the app is running without problem.

Unfortunately, I can't find some settings on the S20FE and don't know whether it really works. Unfortunately, my English isn't the best either
 

ZiiZ00

New member
Feb 21, 2015
3
0
Hi,

I'm coming back since I've found a workaround for Galaxy Wearable to work again.

So here is what I have done (for Samsung device with custom ROM only) :
If it's not already done, install the "MagiskHide Props Config" module from Magisk and then reboot.

Open a terminal emulator and run "su" then "props", when the module is loaded, type "1" to edit fingerprint, choose Google, then Pixel 3 (even if you're not on Android 9). For all of the manipulations when the module asks you to reboot, don't reboot.

After that, go back to the main menu and choose "Improved hiding" and enable it.

Then, go back to the main menu again and choose "Add/Edit custom props". Now we need to change everything that is related to Samsung.
Do theses steps for every prop we need to edit :
1. Type "n" to add a custom prop
2. Now we need to say which prop we need to edit : "ro.product.brand", "ro.product.device", "ro.product.manufacturer", "ro.product.model", "ro.product.name" and "ro.vendor.product.manufacturer" (Type only one of them and without the " ")
3. If the value already exists it will show you what is the actual value of the prop, and if it doesn't exist, double check that you didn't make any mistake when typing it and if not, skip it.
4. Then type respectively : "google", "crosshatch", "google", "Pixel 3", "crosshatch" and "google" (without " ")
5. The module will asks you for when do you want this to be applied ? Just keep "default" and validate with "y"

6. When you have done this for the 6 props, you should have something like the screenshots.

Now you can reboot your phone, delete all the data of the Galaxy Wearable app and it should open ! And also don't forget to hide it with Magisk Hide before clearing data.

What we have done here is to change all of the values of a Samsung related phone to a non Samsung phone, and I think that the app is checking a specific thing (like a TouchWiz related thing), and if it can't find it, the phone is unofficial and the app doesn't want to run. But with the other brands they can't do that so the app is running without problem.

Last thing, if doesn't work even with that, go to Settings, About phone and check if it's now shown as a Pixel 3, if not, there might be an issue somewhere else. Make sure that your ROM passes SafetyNet. Or if you want, you can open a build prop editor, search for "samsung", "zeroflte" (Galaxy S6 specific), etc... and see if there is a prop that I/you missed and change it to "google", "crosshatch", etc...

So let me know if it has worked for you : Working on the Note 3, Galaxy S7 Edge

PS : Sorry for my English if I have made mistakes.
Absolute Legend, Thank you so much <3
 

SilentStray

Member
Feb 24, 2014
33
5
Original Method would not work for me.

Device: Samsung Galaxy S10 SM-G973F
OS: LineageOS 18.1
Gapps: Pico
Magisk: V23

Alternate that worked:

Follow the original method:

"Open a terminal emulator and run "su" then "props", when the module is loaded, type "1" to edit fingerprint, choose Google, then Pixel 3 ---(even if you're not on Android 9). For all of the manipulations when the module asks you to reboot, don't reboot."

"Then, go back to the main menu again and choose" 3 - Device simulation

Type (include commas): 1,3,9,10

then
Type 1 to Enable on the following screen
then
Type Y to confirm and reboot

Go back into Magisk and in MagiskHide select all apps minus those you need root for.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 70
    Hi,

    I'm coming back since I've found a workaround for Galaxy Wearable to work again.

    So here is what I have done (for Samsung device with custom ROM only) :
    If it's not already done, install the "MagiskHide Props Config" module from Magisk and then reboot.

    Open a terminal emulator and run "su" then "props", when the module is loaded, type "1" to edit fingerprint, choose Google, then Pixel 3 (even if you're not on Android 9). For all of the manipulations when the module asks you to reboot, don't reboot.

    After that, go back to the main menu and choose "Improved hiding" and enable it.

    Then, go back to the main menu again and choose "Add/Edit custom props". Now we need to change everything that is related to Samsung.
    Do theses steps for every prop we need to edit :
    1. Type "n" to add a custom prop
    2. Now we need to say which prop we need to edit : "ro.product.brand", "ro.product.device", "ro.product.manufacturer", "ro.product.model", "ro.product.name" and "ro.vendor.product.manufacturer" (Type only one of them and without the " ")
    3. If the value already exists it will show you what is the actual value of the prop, and if it doesn't exist, double check that you didn't make any mistake when typing it and if not, skip it.
    4. Then type respectively : "google", "crosshatch", "google", "Pixel 3", "crosshatch" and "google" (without " ")
    5. The module will asks you for when do you want this to be applied ? Just keep "default" and validate with "y"

    6. When you have done this for the 6 props, you should have something like the screenshots.

    Now you can reboot your phone, delete all the data of the Galaxy Wearable app and it should open ! And also don't forget to hide it with Magisk Hide before clearing data.

    What we have done here is to change all of the values of a Samsung related phone to a non Samsung phone, and I think that the app is checking a specific thing (like a TouchWiz related thing), and if it can't find it, the phone is unofficial and the app doesn't want to run. But with the other brands they can't do that so the app is running without problem.

    Last thing, if doesn't work even with that, go to Settings, About phone and check if it's now shown as a Pixel 3, if not, there might be an issue somewhere else. Make sure that your ROM passes SafetyNet. Or if you want, you can open a build prop editor, search for "samsung", "zeroflte" (Galaxy S6 specific), etc... and see if there is a prop that I/you missed and change it to "google", "crosshatch", etc...

    So let me know if it has worked for you : Working on the Note 3, Galaxy S7 Edge

    PS : Sorry for my English if I have made mistakes.
    4
    Here is what I did to get my watch to work.

    Download from play store build prop editor. https://play.google.com/store/apps/details?id=com.jrummy.apps.build.prop.editor

    Allow build prop editor root access.

    Search Samsung replace samsung or the brand of your phone with htc ( not the model and the brand must be in lower case )

    Reboot

    Download Samsung accsessory service, galaxy wear app, gear s plugin or any other plugins, Samsung health ( if you want health, Samsung pay won't work ) from the apkmirror

    Install apps in the order same as above.

    reboot again

    set up your watch.

    Enjoy.

    Sent from my [device_name] using XDA-Developers Legacy app
    3
    Same problem here with a Galaxy S6 G920F (AOSP Extended, Android 8.1.0) rooted with Magisk even if Magisk Hide is selected for Galaxy Wearable.

    Edit : I've found a fix ! See the post below ;)
    3
    Hey works -partially on Samsung S9 with lineageos 16.0.

    3 attempts so far:

    Hiding magisk with magiskhide from "galaxy wear" is mandatory with all attempts.

    #1 - according to guide by To_O at 2018-10-31 4:10PM in this thread.
    Method: edit ALL samsung/phone reference with magisk hide props editor to google/Pixel 3. "ro.vendor.product.manufacturer" not edited - no such entry. "Improved hiding" removed from magiskhide props editor since v5.
    Hiding magisk with magiskhide from "galaxy wear" is mandatory.
    Result: galaxy wear app was able to start. Additional plugins (Samsung accessory service, galaxy watch plugin) hat to be downloaded from apk mirror. Phone paired successfully.
    BUT: after the next FULL reboot, the phone stuck in lock screen. Unlocking with pattern/fingerprint resulted in black screen an locked phone again. Restored via twrp recovery.
    Comment: situation could be reproduced several times from clean rom install and twrp backups. Lockscreen loop starts as soon as any lockscreen (pin/pattern) is activated. No "problem" when lockscreens are disabled.
    Assessment: likely interference with security features.

    #2 - according to chrigi's blog (google it with "Samsung gear app s5")
    Methods: edit only ro.product.brand and ro.product.manufacturer to "htc"
    Result: galaxy wear app was able to start. Additional plugins (Samsung accessory service, galaxy watch plugin) hat to be downloaded from apk mirror. Phone paired successfully.
    BUT: camera safes only blank grey pictures (already noticed by other users in chrigi's blog on other phones.
    Comment: no further tryout performed. Not worth it.

    #3 - mixture of #1 and #2
    Method: edit only ro.product.brand and ro.product.manufacturer to "google".
    Result: galaxy wear app was able to start. Additional plugins (Samsung accessory service, galaxy watch plugin) hat to be downloaded from apk mirror. Phone paired successfully. No camera app misbehavior in camera app and lock screen - so far. Several full reboot without any issue.
    Comment: The result was created via "backwards" engineering. Started with #1 - installing galaxy wear app - started successfully - downloaded and installed additional apk - galaxy watch paired successfully - created system/data/boot backup in twrp - implemented lock screen pattern - full reboot (power off/wait/reboot) - lock screen loop - restored backup - edited props again - removed all edited entrys except "ro.product.brand" (google) and "ro.product.manufacturer" (google) - tryed galaxy wear app - still working - full reboot - still working - implemented lock screen pattern/fingerprint - still working - full reboot - still working.
    (I rebooted another 27 times just because I was ecstatic that I managed to get this working... So far)

    Current status: I haven't noticed any other strange behaviour SO FAR. Several phone features (calling, ...) haven't been used since the editing. App misbehavior from conflict of entrys in props is possible.

    EDIT: If you experience increased battery drain after changing the props: wipe cache/dalvik.

    Current personal status: still happy this is working since I successfully bricked my previous Ph-1 not 48h ago.
    Stay tuned for "ups, I did it again" ;)
    2
    Hi,

    I'm coming back since I've found a workaround for Galaxy Wearable to work again.

    So here is what I have done (for Samsung device with custom ROM only) :
    If it's not already done, install the "MagiskHide Props Config" module from Magisk and then reboot.

    Open a terminal emulator and run "su" then "props", when the module is loaded, type "1" to edit fingerprint, choose Google, then Pixel 3 (even if you're not on Android 9). For all of the manipulations when the module asks you to reboot, don't reboot.

    After that, go back to the main menu and choose "Improved hiding" and enable it.

    Then, go back to the main menu again and choose "Add/Edit custom props". Now we need to change everything that is related to Samsung.
    Do theses steps for every prop we need to edit :
    1. Type "n" to add a custom prop
    2. Now we need to say which prop we need to edit : "ro.product.brand", "ro.product.device", "ro.product.manufacturer", "ro.product.model", "ro.product.name" and "ro.vendor.product.manufacturer" (Type only one of them and without the " ")
    3. If the value already exists it will show you what is the actual value of the prop, and if it doesn't exist, double check that you didn't make any mistake when typing it and if not, skip it.
    4. Then type respectively : "google", "crosshatch", "google", "Pixel 3", "crosshatch" and "google" (without " ")
    5. The module will asks you for when do you want this to be applied ? Just keep "default" and validate with "y"

    6. When you have done this for the 6 props, you should have something like the screenshots.

    Now you can reboot your phone, delete all the data of the Galaxy Wearable app and it should open ! And also don't forget to hide it with Magisk Hide before clearing data.

    What we have done here is to change all of the values of a Samsung related phone to a non Samsung phone, and I think that the app is checking a specific thing (like a TouchWiz related thing), and if it can't find it, the phone is unofficial and the app doesn't want to run. But with the other brands they can't do that so the app is running without problem.

    Last thing, if doesn't work even with that, go to Settings, About phone and check if it's now shown as a Pixel 3, if not, there might be an issue somewhere else. Make sure that your ROM passes SafetyNet. Or if you want, you can open a build prop editor, search for "samsung", "zeroflte" (Galaxy S6 specific), etc... and see if there is a prop that I/you missed and change it to "google", "crosshatch", etc...

    So let me know if it has worked for you : Working on the Note 3, Galaxy S7 Edge

    PS : Sorry for my English if I have made mistakes.

    You only need to change the following props...so make less work for yourself

    ro.product.manufacturer
    ro.vendor.product.manufacturer


    i just change both to Google via MagiskHide Props Config

    Theyre the only ones ive ever needed to change on my Note 4...without these 2 changed on Android 10 i cannot run the app, with just those two changed, all is perfection

    ---------- Post added at 08:02 AM ---------- Previous post was at 07:55 AM ----------

    This is a great idea! However, Samsung Wear also need another app called Galaxy Watch Plugin, so I would have to clone both apps, randomizing the device (the app cloner does not let me chose a specific device), and I am not sure if it will work. I will try it and let you know.

    You cant clone the wearables plugins, so cloning will fail

    Just use the MagiskHide Props Config method, its the only reliable way