• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[GAPPS][4.4.x] Unofficial GApps [12-Dec-2013]

Did this GApps package work well for you?

  • Yes.

    Votes: 95 72.0%
  • No.

    Votes: 37 28.0%

  • Total voters
    132
Search This thread

Kaydin

Senior Member
Sep 19, 2010
211
165
Put together using PA GApps's structure and updated files from different ROMs, together with factory images.. The install script will show the it'll install pa_gapps-full-4.4-20131126-signed.zip, but, in reality, it will install the new files compatible with 4.4.x The backup script works, but I highly recommend installing GApps at each ROM update, since, sometimes, it just doesn't work very well. I always flash GApps when updating, and I never have issues this way.

You can either wait for the OP of PA GApps to update the package, or use this.

I am not responsible for any damage to the device. Do a backup before, just in case! A boot loop is the worst case scenario that can happen. Didn't happen on my end, and I hope it won't happen to you guys, either.


Enjoy!


UPDATE 12-Dec-2013


Pack updated with 4.4.2 files.
NOT compatible with ART (didn't test, though - might as well work, since the base structure and files from PA's GApps and BaNkS' GApps are ART-compatible; in case you want to test out, do a nandroid first!)

PhotoSphere installs only on hammerhead, manta, mako, razor; no Google Dialer
Link #1

PhotoSphere and GDialer for all devices (Might cause errors, two dialers & two cameras, beware! It's a forced method, by including both the dialer and camera in /system/app and /system/priv-app)
Link #1

GApps mini modular package
Link #1



Credits go to BaNkS for letting me use files from his GApps.
Credits go to hanschke for testing out.
Credits go to TKruzze for the structure of GApps.
 
Last edited:

Dan1234567890

Senior Member
Dec 27, 2012
435
228
Looks like when this was inside PA thread, there were a lot of questions, but in separate thread, everthing is clear, and no problems or questions reported so far :eek::cool::thumbup:

Sent from my Nexus 4 using Tapatalk
 
  • Like
Reactions: DLM2583

Kaydin

Senior Member
Sep 19, 2010
211
165
Looks like when this was inside PA thread, there were a lot of questions, but in separate thread, everthing is clear, and no problems or questions reported so far :eek::cool::thumbup:

Sent from my Nexus 4 using Tapatalk

Weird, indeed, hah. Maybe some users are not interested in this package.

This is exactly what I'm looking for. Thank you so much! ^_^

Are you going to continue this if ever there will be an update?

Maybe. I'd like to push updates as fast as I can, since I am also using this GApps.
 

Kaydin

Senior Member
Sep 19, 2010
211
165
Flashed this with KITKANG 4.4.1 and I get constant force closes on the dialer and it also says I have no sim card.. Man I really want that google dialer so I'm not giving up just yet..

From what I know, not even the official PA Gapps works well with CM. By the way, what kernel are you using? Do you know about the CAF business on CM?
 

paychex

Senior Member
Aug 10, 2013
1,286
521
Baltimore
Flashed this with KITKANG 4.4.1 and I get constant force closes on the dialer and it also says I have no sim card.. Man I really want that google dialer so I'm not giving up just yet..

From what I know, not even the official PA Gapps works well with CM. By the way, what kernel are you using? Do you know about the CAF business on CM?

I'm on CM and haven't had one force close. I'm also not using ART.

Only problem is when I flash a nightly the photosphere camera and the google dialer are gone. Guess I'm gonna have to flash gapps every time like the old days (instead of crying like a baby about it)
 

goldenratio

Senior Member
Aug 3, 2010
146
88
From what I know, not even the official PA Gapps works well with CM. By the way, what kernel are you using? Do you know about the CAF business on CM?

I don't think it's true... I had no problems running the PA GAPPS on CM 11 nightlies, including a working photosphere camera.

Different kernels on CM 11 are trickier, because of the CAF issues you mentioned, but as far as I know the GAPPS work just fine.
 

cjwaggsrx8

Senior Member
Jun 3, 2011
1,135
419
I flashed these gapps on slimkat and everything is running great. :)

Thanks.

Sent from my Nexus 4

Same here only I'm on the 12-7 cm nightly.. Working most excellent thanks a bunch kaydin!!

Sent from my Nexus 5 using XDA Premium 4 mobile app

---------- Post added at 03:21 AM ---------- Previous post was at 03:19 AM ----------

From what I know, not even the official PA Gapps works well with CM. By the way, what kernel are you using? Do you know about the CAF business on CM?

Everything works except the Google dialer.. Just doesn't flash no biggie cause I like the aosp dialer anyway. But I can confirm full functionality with cm11 4.4.1

Sent from my Nexus 5 using XDA Premium 4 mobile app
 
  • Like
Reactions: Kaydin

Xxderek0822xx

Senior Member
Apr 12, 2011
248
188
Dunmore
Same here only I'm on the 12-7 cm nightly.. Working most excellent thanks a bunch kaydin!!

Sent from my Nexus 5 using XDA Premium 4 mobile app

---------- Post added at 03:21 AM ---------- Previous post was at 03:19 AM ----------



Everything works except the Google dialer.. Just doesn't flash no biggie cause I like the aosp dialer anyway. But I can confirm full functionality with cm11 4.4.1

Sent from my Nexus 5 using XDA Premium 4 mobile app

Which gapps should I flash if I'm on purity 4.4.1 hammerhead? Thanks

Sent from my Candy Painted Nexus 5

Click here for my NFL Lockrings and other mods
 

Kaydin

Senior Member
Sep 19, 2010
211
165
Which gapps should I flash if I'm on purity 4.4.1 hammerhead? Thanks

Sent from my Candy Painted Nexus 5

Click here for my NFL Lockrings and other mods

You can flash any version, depending on your needs. I go for the first version (PhotoSphere installs only on hammerhead, manta, mako, razor; no Google Dialer), though. I don't need the Google Dialer, but I do need PhotoSphere, and, on my Nexus 5, it will install automatically.

Guys, i have issues with this package, i constantly get the error message "Unfortunately, com.android.phone has stopped" how do i fix this issue?

What ROM and kernel are you using?

I'm on CM and haven't had one force close. I'm also not using ART.

Only problem is when I flash a nightly the photosphere camera and the google dialer are gone. Guess I'm gonna have to flash gapps every time like the old days (instead of crying like a baby about it)

Great to hear it's running great! Well, I always flash GApps when I install a new nightly on Omni. It's just another few taps.

I don't think it's true... I had no problems running the PA GAPPS on CM 11 nightlies, including a working photosphere camera.

Different kernels on CM 11 are trickier, because of the CAF issues you mentioned, but as far as I know the GAPPS work just fine.

Oh, I might have read wrong that PA GApps doesn't work on CM11 nightlies. Good to hear they actually do work.
 
Last edited:

Kaydin

Senior Member
Sep 19, 2010
211
165
My phone doesn't support photosphere because lacks of hardware. Which gapps that's doesn't have photosphere that support my device? Thanks :p

PhotoSphere installs only on hammerhead, manta, mako, razor; no Google Dialer. This will only install PhotoSphere camera on hammerhead, manta, mako, razor, and it won't include Google Dialer.



Also, for all of you, you are all welcome.
 
Last edited:

jameseytickner

Senior Member
Oct 16, 2013
239
116
London
You can flash any version, depending on your needs. I go for the first version (PhotoSphere installs only on hammerhead, manta, mako, razor; no Google Dialer), though. I don't need the Google Dialer, but I do need PhotoSphere, and, on my Nexus 5, it will install automatically.



What ROM and kernel are you using?



Great to hear it's running great! Well, I always flash GApps when I install a new nightly on Omni. It's just another few taps.



Oh, I might have read wrong that PA GApps doesn't work on CM11 nightlies. Good to hear they actually do work.

Im using the CM11 LG G2 D802 Nightly, with stock kernel
 

DaringDomino3s

Senior Member
Feb 10, 2013
172
50
Bradenton
Woks fine with omniRom 4.4.1 release nightly (homemade), here.
I'm impatient and pagapps 11/26 was NOT playing well with others causing force closes, rail especially with ART.
I wiped system, cache and dalvik (kept data), flashed omni v2 of yr apps (i have m7ul) and supersu, flashed omni and it stopped my apps fc's (yay!) only thing is it gave me a second camera and gallery (i thought gallery is gone on 4.4.1) but I just fixed my nova homescreen and so far so good.

I'll report any issues should arise. Thank you, for the quick fix, it.can.make testing a pain, and also for understanding that flashaholism is a real-life disease (thats not a noob asking for an ETA, it's his addiction talking ):silly:
 

Kaydin

Senior Member
Sep 19, 2010
211
165
Woks fine with omniRom 4.4.1 release nightly (homemade), here.
I'm impatient and pagapps 11/26 was NOT playing well with others causing force closes, rail especially with ART.
I wiped system, cache and dalvik (kept data), flashed omni v2 of yr apps (i have m7ul) and supersu, flashed omni and it stopped my apps fc's (yay!) only thing is it gave me a second camera and gallery (i thought gallery is gone on 4.4.1) but I just fixed my nova homescreen and so far so good.

I'll report any issues should arise. Thank you, for the quick fix, it.can.make testing a pain, and also for understanding that flashaholism is a real-life disease (thats not a noob asking for an ETA, it's his addiction talking ):silly:

You probably installed "PhotoSphere & Google Dialer included for all devices".

Thank you for reporting! And yes, indeed, flashaholism is a real-life disease. That's why I built this package. Couldn't wait for the factory images to get released, haha!

Are you going to update your gapps to 4.4.2? (if there are any changes)

Yeah, I will update the package today.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 39
    Put together using PA GApps's structure and updated files from different ROMs, together with factory images.. The install script will show the it'll install pa_gapps-full-4.4-20131126-signed.zip, but, in reality, it will install the new files compatible with 4.4.x The backup script works, but I highly recommend installing GApps at each ROM update, since, sometimes, it just doesn't work very well. I always flash GApps when updating, and I never have issues this way.

    You can either wait for the OP of PA GApps to update the package, or use this.

    I am not responsible for any damage to the device. Do a backup before, just in case! A boot loop is the worst case scenario that can happen. Didn't happen on my end, and I hope it won't happen to you guys, either.


    Enjoy!


    UPDATE 12-Dec-2013


    Pack updated with 4.4.2 files.
    NOT compatible with ART (didn't test, though - might as well work, since the base structure and files from PA's GApps and BaNkS' GApps are ART-compatible; in case you want to test out, do a nandroid first!)

    PhotoSphere installs only on hammerhead, manta, mako, razor; no Google Dialer
    Link #1

    PhotoSphere and GDialer for all devices (Might cause errors, two dialers & two cameras, beware! It's a forced method, by including both the dialer and camera in /system/app and /system/priv-app)
    Link #1

    GApps mini modular package
    Link #1



    Credits go to BaNkS for letting me use files from his GApps.
    Credits go to hanschke for testing out.
    Credits go to TKruzze for the structure of GApps.
    9
    Since PA GApps's philosophy kinda shifted from mine, I will continue my own GApps by modifying PA GApps. TKruzze decided to bring the Google experience with his GApps. Personally, I only use the Google Camera, so, the Google experience is not what I really need. I won't be removing the Messaging app and the AOSP browser. Choice is what I promote, really. Update will come soon.
    5
    First post updated with latest files.

    Decided to work this out, since I skipped school today. Tried to update all the files.
    4
    :eek: You shouldn't skip school to update the files. But thanks for doing.

    I didn't skip school for updating the files. I updated the files since I skipped school. There's a difference. You're welcome, hehe! :p
    4
    Looks like when this was inside PA thread, there were a lot of questions, but in separate thread, everthing is clear, and no problems or questions reported so far :eek::cool::thumbup:

    Sent from my Nexus 4 using Tapatalk

    Weird, indeed, hah. Maybe some users are not interested in this package.

    This is exactly what I'm looking for. Thank you so much! ^_^

    Are you going to continue this if ever there will be an update?

    Maybe. I'd like to push updates as fast as I can, since I am also using this GApps.