[GAPPS][6.0/5.1/5.0][arm/arm64] Official Slim GApps

Status
Not open for further replies.
Search This thread

dankoman

Senior Member
Oct 13, 2008
3,601
22,335
Philly
aMfVkQx.png


Welcome!

The purpose of this thread is to provide a dedicated discussion area for Slim GApps so we can monitor and correct gapps-related issues more quickly before moving the packages from beta to stable, and also to provide users with the means to customize and build their own gapps packages from "source." Enjoy, and thanks for choosing Slim!


DOWNLOAD LINKS:

6.0 marshmallow
mirror1
mirror2
6.0 changelog here
no multi-dpi for 6.0. explanation here

6.x MARSHMALLOW PACKAGE CONTENTS:
c1mgySg.png

ATTENTION:
GOOGLE NOW ON-TAP and "OKAY, GOOGLE" ANYWHERE features require MINI GAPPS!



5.1 lollipop
mirror1
mirror2
5.1 changelog here
no more multi-dpi support
5.1 multi-dpi add-on changelog here




5.x LOLLIPOP PACKAGE CONTENTS:
DxIBZqe.png

ATTENTION:
"OKAY, GOOGLE" ANYWHERE feature requires MINI GAPPS!


logo/artwork design by @steel89 :cool:
thanks for contributions:
@BaNkS
@TKruzze
@Chainfire
@VictorLapin
@uzenelse
@raulx222
@xanaxdroid
@Deltadroid
@MastahF

XDA:DevDB Information
[GAPPS][6.0/5.1/5.0][arm/arm64] Official Slim GApps, ROM for the AT&T Samsung Galaxy S III

Contributors
dankoman, Slimroms, prbassplayer
Source Code: http://github.com/dankoman30/slim_gapps

ROM OS Version: 6.0.x Marshmallow

Version Information
Status: Beta

Created 2014-07-01
Last Updated 2016-04-08
 
Last edited by a moderator:

dankoman

Senior Member
Oct 13, 2008
3,601
22,335
Philly
Roll your own

Want to customize and build your own gapps packages? You've come to the right place!

1) download and install apache ant (http://ant.apache.org/) - if you're on windows, add apache ant's binary to your PATH string
2) clone the repo (https://github.com/dankoman30/slim_gapps)
Code:
you:~$ [B]git clone https://github.com/dankoman30/slim_gapps.git[/B]
3) cd into the repo working directory
Code:
you:~$ [B]cd slim_gapps[/B]
4) checkout the branch you want to build on (mm6.0 is default branch)
Code:
you:~/slim_gapps$ [B]git checkout mm6.0[/B]  [COLOR="SeaGreen"]// for android 6.x.x (marshmallow)[/COLOR]
you:~/slim_gapps$ [B]git checkout lp5.1[/B]  [COLOR="SeaGreen"]// for android 5.1.x (lollipop)[/COLOR]
5) open up build.xml in a text editor and you can add (or remove) include/exclude lines to the filesets to customize the contents of your gapps builds as you see fit
Code:
you:~/slim_gapps$ [B]nano build.xml[/B]
6) run ant from the command line, and the packages will start building
Code:
you:~/slim_gapps$ [B]ant[/B]
7) flash and enjoy your custom gapps package! build(s) will be in the slim_gapps/build directory
 
Last edited:

inffy

Senior Member
Jun 26, 2005
3,435
2,387
Helsinki, Finland
Hmm..how about the Google Email and Exchange sync support, are they included in normal and full? The versions what are on the play store?
 

s3icc0

Senior Member
Mar 25, 2011
1,947
727
@dankoman
hey man maybe it will be nice to see indication on apps already TRDS apps missing TRDS and apps they dont need to be TRDS (like the service apps or invisible apps working at background)
 
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 698
    aMfVkQx.png


    Welcome!

    The purpose of this thread is to provide a dedicated discussion area for Slim GApps so we can monitor and correct gapps-related issues more quickly before moving the packages from beta to stable, and also to provide users with the means to customize and build their own gapps packages from "source." Enjoy, and thanks for choosing Slim!


    DOWNLOAD LINKS:

    6.0 marshmallow
    mirror1
    mirror2
    6.0 changelog here
    no multi-dpi for 6.0. explanation here

    6.x MARSHMALLOW PACKAGE CONTENTS:
    c1mgySg.png

    ATTENTION:
    GOOGLE NOW ON-TAP and "OKAY, GOOGLE" ANYWHERE features require MINI GAPPS!



    5.1 lollipop
    mirror1
    mirror2
    5.1 changelog here
    no more multi-dpi support
    5.1 multi-dpi add-on changelog here




    5.x LOLLIPOP PACKAGE CONTENTS:
    DxIBZqe.png

    ATTENTION:
    "OKAY, GOOGLE" ANYWHERE feature requires MINI GAPPS!


    logo/artwork design by @steel89 :cool:
    thanks for contributions:
    @BaNkS
    @TKruzze
    @Chainfire
    @VictorLapin
    @uzenelse
    @raulx222
    @xanaxdroid
    @Deltadroid
    @MastahF

    XDA:DevDB Information
    [GAPPS][6.0/5.1/5.0][arm/arm64] Official Slim GApps, ROM for the AT&T Samsung Galaxy S III

    Contributors
    dankoman, Slimroms, prbassplayer
    Source Code: http://github.com/dankoman30/slim_gapps

    ROM OS Version: 6.0.x Marshmallow

    Version Information
    Status: Beta

    Created 2014-07-01
    Last Updated 2016-04-08
    168
    Roll your own

    Want to customize and build your own gapps packages? You've come to the right place!

    1) download and install apache ant (http://ant.apache.org/) - if you're on windows, add apache ant's binary to your PATH string
    2) clone the repo (https://github.com/dankoman30/slim_gapps)
    Code:
    you:~$ [B]git clone https://github.com/dankoman30/slim_gapps.git[/B]
    3) cd into the repo working directory
    Code:
    you:~$ [B]cd slim_gapps[/B]
    4) checkout the branch you want to build on (mm6.0 is default branch)
    Code:
    you:~/slim_gapps$ [B]git checkout mm6.0[/B]  [COLOR="SeaGreen"]// for android 6.x.x (marshmallow)[/COLOR]
    you:~/slim_gapps$ [B]git checkout lp5.1[/B]  [COLOR="SeaGreen"]// for android 5.1.x (lollipop)[/COLOR]
    5) open up build.xml in a text editor and you can add (or remove) include/exclude lines to the filesets to customize the contents of your gapps builds as you see fit
    Code:
    you:~/slim_gapps$ [B]nano build.xml[/B]
    6) run ant from the command line, and the packages will start building
    Code:
    you:~/slim_gapps$ [B]ant[/B]
    7) flash and enjoy your custom gapps package! build(s) will be in the slim_gapps/build directory
    87
    okay, regarding 5.x gapps and 4.4 gapps, here's the scoop:

    i am busy working on a lot more than just gapps for slim team, though gapps do remain a high priority. for anyone still using 4.4, i can update the gapps if you want me to, but updated versions of apps will not be TRDS for now. since google has updated nearly ALL their apps, i pretty much have to re-do everything anyway. TRDS versions are not my top priority at the moment because we are still in the deciding/planning stage in regards to how exactly TRDS will be handled in 5.0. some may think it's a good idea to wait to see how google handles dark/light themes in the near future (yes, dark material theme is coming to lollipop, android engineers have confirmed). android auto stuff is nearing release as well, and we already know it will have built-in day/night transitions (see 57:30 in this video), which we will more than likely be able to implement once the android auto SDK is released (supposed to happen in late 2014 according to google).

    anyway, i guess the point i'm trying to make is that the reason i haven't done updated kitkat gapps is because i haven't done any TRDS versions of apps for LP gapps. when i do, most of the apps will be backwards-compatible (only one or two aren't), and updating kitkat gapps with TRDS versions will be as easy for me as reusing the LP versions, zipping it up, re-hosting the file, and posting the link.

    the reason you can't use LP gapps on kitkat is NOT because the apps are drastically different. the reason is that the file structure has changed in LP. (e.g.- apps are now stored in /system/<app_name>/<app_name>.apk whereas before they were stored in /system/<app_name>.apk. also, now apps can have their own specific libs, stored in the /system/<app_name>/lib/arm/<lib_name>.so).

    in addition to all the stuff i do for slim (which takes a LOT of time), i also have a life, a job that is 53 miles from my house, and an excruciating commute to and from work. i contribute to the project where i can and when i have the time, so hang tight, and know that your patience is greatly appreciated. :D
    58
    gapps 406 will be the first public release of 5.0 gapps. it is now available for download. i have updated the second post in this thread to include links to here.

    gapps 385 has been moved to stable. it is the last official build of 4.4 gapps, but i will do occasional updates for you guys - they'll just be hosted elsewhere.

    i shouldn't have to tell anyone not to flash 5.0 gapps over a 4.4 rom, but you can try if you want. i have modified the edify updater script to prevent this as a fail-safe.

    these are NOT TRDS (for now), but they do have the necessary mods to allow for multi-DPI.

    please either wipe your system manually or clean flash before initially flashing these, and report back if you have any problems. thanks guys - enjoy :D
    55
    Isnt there a way I can build your gapps packages myself?

    okay, i started a repo on github for LP gapps also. you can clone it from https://github.com/dankoman30/slimlp_gapps

    if you take a look inside the build.xml in the root directory of that repo, you can see the script that is responsible for generating the gapps packages. by modifying this script, you can add/remove apps to suit your needs.

    the build is initiated by running "ant" from the root directory on command line. if you don't have ant installed, you can get it by running "sudo apt-get install ant" from the command line.

    here's more info on apache ant.

    i'll be keeping this repository updated, so track it if you're doing your own builds.