[GAPPS][CLOSED][4.4.4] PA-GOOGLE APPS (All ROM's) [CLOSED]

Status
Not open for further replies.
Search This thread

wyf88

New member
Dec 10, 2014
2
1
Thank you TKruzze for bringing us such great gapps packages! After I flashed the new 2.0 version successfully, I got a warning indicating a potential conflict between Omnirom and Google Maps and YouTube. Actually YouTube works well for me, while the recent versions of Google Maps were found to FC even before the flashing. It happens several seconds after I open the app, when a blank screen show up before it forces close. I took a screenshot and upload it to the attachment.

I'm not sure if it's a problem of Omnirom or PA Gapps. I'm not allowed to post outside links so I have to paste the log here:
# Begin PA GApps Install Log
--------------------------------------------------------------------------------
ROM Android Version | 4.4.4
ROM ID | omni_i9103-userdebug 4.4.4 KTU84P 431 test-keys
ROM Version | OmniROM-4.4.4-20141210-i9103-NIGHTLY
Device Recovery | TWRP 2.6.3.0
Device Type | GT-I9103
Device Model | GT-I9103
Device CPU | armeabi-v7a armeabi
getprop Density | 240
default.prop Density | 240
build.prop Density | 240
Display Density Used | 240ppi
Android Runtime | Clean
Xposed Detected | Clean
Install Type | Clean[Data Wiped]
Google Camera Installed?| Clean
Google Keyboard Installed?| Clean
Google Email Installed?| Clean
FaceUnlock Compatible | true
Google Camera Compatible | true
Current GApps Version | NO GApps Installed
Curent PA GApps Package | NO GApps Installed
Installing GApps Version | 20141207
Installing GApps Type | stock
Config Type | exclude
Using gapps-config | /sdcard/.gapps-config
Remove Stock/AOSP Browser | true
Remove Stock/AOSP Launcher | true
Remove Stock/AOSP MMS App | true
Remove Stock/AOSP Pico TTS | true
Install Google Gallery | false
Google Gallery Device | none
Installing Play Services | 6.5.87 (1599771-034)
Total System Size (KB) | 604736
Used System Space (KB) | 302236
Current Free Space (KB) | 302500
Post Install Free Space (KB) | 7404 << See Calculations Below
--------------------------------------------------------------------------------
?Previously installed with PA GApps
# End PA GApps Install Log

!!! WARNING !!! - A potential conflict may exist between these GApps and your
ROM. The information is contained in the log portion below. Please report this
information immediately to the PA GApps developer (TKruzze) in the XDA forum.

# Begin GApps <> ROM Deletion Conflict List
/system/app/Maps.apk
/system/app/YouTube.apk
# End GApps <> ROM Deletion Conflict List

# Begin GApps Size Calculations
--------------------------------------------------
TYPE | DESCRIPTION | SIZE | TOTAL
| Current Free Space | 302500 | 302500
Remove | Existing GApps | + 0 | 302500
Remove | Obsolete Files | + 360 | 302860
Remove | browser | + 3004 | 305864
Remove | calendarstock | + 1852 | 307716
Remove | camerastock | + 3756 | 311472
Remove | emailstock | + 4724 | 316196
Remove | exchangestock | + 1136 | 317332
Remove | gallerystock | + 5656 | 322988
Remove | keyboardstock | + 34112 | 357100
Remove | launcher | + 1420 | 358520
Remove | mms | + 3108 | 361628
Remove | picotts | + 6548 | 368176
Remove | studio | + 5540 | 373716
Install | Core?| - 20836 | 352880
Install | GMSCore?| - 30156 | 322724
Install | calendargoogle?| - 19580 | 303144
Install | cameragoogle?| - 28652 | 274492
Install | cloudprint?| - 3560 | 270932
Install | drive?| - 12344 | 258588
Install | ears?| - 2396 | 256192
Install | emailgoogle?| - 6996 | 249196
Install | faceunlock?| - 16664 | 232532
Install | gmail?| - 10988 | 221544
Install | googlenow?| - 12108 | 209436
Install | googleplus?| - 30516 | 178920
Install | googletts?| - 15284 | 163636
Install | hangouts?| - 16992 | 146644
Install | keep?| - 8596 | 138048
Install | keyboardgoogle?| - 19376 | 118672
Install | maps?| - 14192 | 104480
Install | newswidget?| - 4184 | 100296
Install | quickoffice?| - 13848 | 86448
Install | search?| - 34688 | 51760
Install | speech?| - 22480 | 29280
Install | street?| - 260 | 29020
Install | sunbeam?| - 64 | 28956
Install | youtube?| - 12336 | 16620
| Buffer Space?| - 9216 | 7404
--------------------------------------------------
Post Install Free Space | 7404
--------------------------------------------------
?Required (ALWAYS Installed)
?Optional (may be removed)

# End GApps Size Calculations

# Begin User's gapps-config
Books
BkSync
CalSync
Chrome
Earth
GalleryGoogle
Movies
Music
NewsStand
PlayGames
Talkback
Wallet

Browser
CalendarStock
CameraStock
EmailStock
ExchangeStock
GalleryStock
KeyboardStock
Launcher
MMS
PicoTTS
Studio
# End User's gapps-config

Thanks a lot!
 

Attachments

  • Screenshot_2014-12-10-21-40-30.png
    Screenshot_2014-12-10-21-40-30.png
    13.1 KB · Views: 2,880

TKruzze

Senior Member
Jul 25, 2010
1,660
23,761
Ann Arbor, MI
I am having a strange problem. Last time I used this installer is when I tested the beta 2.0 installer + multirom combination (when I said that I had to use PA-GApss folder for the installer to recognize the .gapps-config file). That time I flashed it in a secondary Kitkat ROM. Now I am running SimpleAOSP-Lollipop only (primary).
Yesterday I noticed that I can't delete the PA-GApps folder & files. It seems to be related with permission errors, but the permissions & owner are the same as all the other folders! I tried multiple file managers, full wipe and clean install of another ROM, tried to delete it from terminal/adb (with root permissions), tried to chmod, nothing. My only option is to format the storage (haven't done that yet).

Has anyone else had this problem? Is it even related with PA-GApps installer?

Code:
-rw-rw---- root     sdcard_r 420451139 2014-11-22 00:55 pa_gapps-stock-4.4.4-20141121-signed.zip
-rw-rw---- root     sdcard_r    27337 2014-12-09 20:58 pa_gapps_debug_info.tar.gz
-rw-rw---- root     sdcard_r     3174 2014-12-09 20:58 pa_gapps_log.txt
Since I never touch Ownership, Permissions, or Contexts on any of these files, the problem couldn't be related to the installer. It's more likely related to your Recovery.



I got a warning indicating a potential conflict between Omnirom and Google Maps and YouTube. Actually YouTube works well for me, while the recent versions of Google Maps were found to FC even before the flashing. It happens several seconds after I open the app, when a blank screen show up before it forces close. I took a screenshot and upload it to the attachment.

I'm not sure if it's a problem of Omnirom or PA Gapps. I'm not allowed to post outside links so I have to paste the log here:
# Begin PA GApps Install Log
!!! WARNING !!! - A potential conflict may exist between these GApps and your
ROM. The information is contained in the log portion below. Please report this
information immediately to the PA GApps developer (TKruzze) in the XDA forum.

# Begin GApps <> ROM Deletion Conflict List
/system/app/Maps.apk
/system/app/YouTube.apk
# End GApps <> ROM Deletion Conflict List
Thanks for the report. What this means is that even though there are no GApps installed on your device, the installer detected Maps and YouTube. So, either OmniROM is now including these apps in their ROM or, possibly, you flashed something else before these GApps (Chainfire's SuperSU?) that created those files on your device.

I added this into the installer to make certain I was not accidentally deleting any important files from your ROM. However, that's not the case here.
 
  • Like
Reactions: osm0sis

KreAch3R

Inactive Recognized Developer
Nov 15, 2010
1,076
1,985
Since I never touch Ownership, Permissions, or Contexts on any of these files, the problem couldn't be related to the installer. It's more likely related to your Recovery.



Thanks for the report. What this means is that even though there are no GApps installed on your device, the installer detected Maps and YouTube. So, either OmniROM is now including these apps in their ROM or, possibly, you flashed something else before these GApps (Chainfire's SuperSU?) that created those files on your device.

I added this into the installer to make certain I was not accidentally deleting any important files from your ROM. However, that's not the case here.
Thanks for the reply! I thought so, but I wanted to eliminate that. So that leaves us with twrp and multirom-twrp specifically.
 

wyf88

New member
Dec 10, 2014
2
1
Since I never touch Ownership, Permissions, or Contexts on any of these files, the problem couldn't be related to the installer. It's more likely related to your Recovery.



Thanks for the report. What this means is that even though there are no GApps installed on your device, the installer detected Maps and YouTube. So, either OmniROM is now including these apps in their ROM or, possibly, you flashed something else before these GApps (Chainfire's SuperSU?) that created those files on your device.

I added this into the installer to make certain I was not accidentally deleting any important files from your ROM. However, that's not the case here.

Thank you for your prompt reply! You are right, I did flash SuperSU before GApps. The warning did not appear in my previous attempt when I flashed GApps before SuperSU. I guess the sequence does not matter?
As for the crashing of Google Maps, I see some complaints in Google play store too so I think it has nothing to do with the warning here.
 
Last edited:
  • Like
Reactions: TKruzze

Brocon6

New member
Dec 10, 2014
1
0
Struggling hard with the gapps

Sooo I've spent all day trying to get a newer version of liquid smooth to work on the old nexus 4. I usually figure these things out but its gotten to the point where I'm out of ideas. Maybe i've just done something wrong along the way. Anyway, I can get 4.0 (hope thats what I should be installing). At one point I was getting a message saying the setup wizard was cancelled. I've tried so many different gapps that I don't know what to do. I tried the newest one Liquid_gapps.4.4.4.build.8.1.zip which is straight from the downloads section of the liquid smooth website. All the other ones I did failed but the 8.1 zip installed no problem yet theres nothing on my screen. Obviously I've messed up in some way and any help would be appreciated.
 

hlxanthus

Senior Member
Jun 10, 2011
1,523
1,177
Sooo I've spent all day trying to get a newer version of liquid smooth to work on the old nexus 4. I usually figure these things out but its gotten to the point where I'm out of ideas. Maybe i've just done something wrong along the way. Anyway, I can get 4.0 (hope thats what I should be installing). At one point I was getting a message saying the setup wizard was cancelled. I've tried so many different gapps that I don't know what to do. I tried the newest one Liquid_gapps.4.4.4.build.8.1.zip which is straight from the downloads section of the liquid smooth website. All the other ones I did failed but the 8.1 zip installed no problem yet theres nothing on my screen. Obviously I've messed up in some way and any help would be appreciated.
Logs or it didn't happen ?
 

demlv

Senior Member
Sep 16, 2008
552
231
Las Vegas, NV
Did you even bother to read the log? . . . To solve your problem, please read FAQ #8 on the OP. As noted by me and others hundreds of times in the past, these GApps were never meant for Stock ROM's.

@TKruzze -- Might I suggest you consider revising the thread's title in order to limit this recurring issue? ;)

Instead of "PA-GOOGLE APPS (All ROM's)" you might try "PA-GOOGLE APPS (All Custom ROM's)" or better yet "PA-GOOGLE APPS (for custom ROM's ONLY/not for stock firmwares)"

Peace.

---------- Post added at 07:09 PM ---------- Previous post was at 07:08 PM ----------

Did you even bother to read the log? . . . To solve your problem, please read FAQ #8 on the OP. As noted by me and others hundreds of times in the past, these GApps were never meant for Stock ROM's.

@TKruzze -- Might I suggest you consider revising the thread's title in order to limit this recurring issue? ;)

Instead of "PA-GOOGLE APPS (All ROM's)" you might try "PA-GOOGLE APPS (All Custom ROM's)" or better yet "PA-GOOGLE APPS (for custom ROM's ONLY/not for stock firmwares)"

Peace.
 

KreAch3R

Inactive Recognized Developer
Nov 15, 2010
1,076
1,985
I think it's a problem with permissions. If you transfer files with adb or mtp while in TWRP, you won't be able to delete the files in android.

CONFIRMED: I managed to reproduce the problem by creating folders and files in TWRP and try to delete from android. Same error. Nice catch! I think this is a serious bug, I will try to post it / notify the TWRP team.
 

trzesickipiotr

Senior Member
Feb 25, 2014
56
15
Warsaw
OHi
Sorry if this was discussed before. I've searched through this thread and haven't found anything similar to my situation.

Short story:
I had a clean install of the Liquid Smooth 3.2 rom on my maguro. Then I flashed Pico Modular Package from this thread and DirtyV kernel and rebooted. After google account setup all my previous apps were reinstalled including Google Calendar. Now I have both stock AOSP Calendar app (included in Rom I think) and Google Calendar from Play Store. Google Calendar doesn't show any calendar to synchronize and AOSP calendar doesn't synchronize (in settings there is an exclamation mark by the calendar synchronization icon). When I uninstall Google Calendar the AOSP calendar starts to synchronize. I also tried to uninstall AOSP calendar using Titanium Backup, but it didn't make the Google Calendar to start synchronizing.

What can I do now?
Is there any script/zip to replace AOSP Calendar with the Google one? Can I dirty flash different gapps package that can do that?

I'm not the developer, so I'll be grateful for your instructions.

PT
 

mikeoswego

Senior Member
May 4, 2014
903
773
Northern Indiana
I had a clean install of the Liquid Smooth 3.2 rom on my maguro. Then I flashed Pico Modular Package

Is there any script/zip to replace AOSP Calendar with the Google one? Can I dirty flash different gapps package that can do that?

Is the Pico package the largest GApps package that will fit on your device? If so, try creating a .gapps-config in the same directory as the GApps .zip file. In the .gapps-config file put in the following as the only line: CalendarStock
This will cause the GApps installer to remove the stock calendar app and maybe it will then work when you install Google Calendar from the Play Store.

If you can fit a larger GApps package, the Micro Modular package includes Google Calendar and will also remove the stock calendar as part of the installation.
 
Last edited:

Mark7z

Member
Nov 1, 2014
22
2
Philadelphia, PA
Here's my log here. What's wrong here it worked before with previous verisons of gapps

# Begin PA GApps Install Log
--------------------------------------------------------------------------------
ROM Android Version | 4.4.2
ROM ID | KOT49H.N900TUVUENK3
ROM Version |
Device Recovery | TWRP 2.8.1.0
Device Type | hltetmo
Device Model | SM-N900T
Device CPU | armeabi-v7a armeabi
getprop Density |
default.prop Density |
build.prop Density | 480
Display Density Used | 480ppi
Android Runtime | Dalvik
Xposed Detected | undetermined
Install Type | Dirty[Data NOT Wiped]
Google Camera Installed� | false
Google Keyboard Installed� | false
Google Email Installed� | false
FaceUnlock Compatible | true
Google Camera Compatible | true
Current GApps Version | NON PA GApps Currently Installed (FAILURE)
--------------------------------------------------------------------------------
� Previously installed with PA GApps
# End PA GApps Install Log

INSTALLATION FAILURE: PA GApps can only be installed on top of an existing
PA GApps installation. Since you are currently using another GApps package, you
will need to wipe (format) your system partition before installing PA GApps.


# Begin User's gapps-config
*** NOT USED ***
# End User's gapps-config
 
Status
Not open for further replies.

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone