• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[GAPPS][DAILY] Open GApps for Android; All Android Versions & Devices

Search This thread

Vinnom

Senior Member
Jun 21, 2012
1,705
1,143
Campinas
Xiaomi Poco F1
I've just tried to install Open GApps 20210130. My setup:

Device: beryllium
ROM: awaken 1.5.2

Issue: I couldn't restore my data. In Setup Wizard, it just go through it to adding lockscreen security and fingerprint. If you go all the steps and try to restore data later, the app crashes. I've tried with almost all OpenGApps versions (excluding super) w/o a boot in between ROM and GApps and I've tried booting first and then installing the GApps, neither worked.

I've took a logcat with the full version but the issue happened with all of them.
 

Attachments

  • gapps-full-20210130.txt
    803.3 KB · Views: 6
  • Device_Space_After.txt
    2.5 KB · Views: 1
  • gapps-config_processed.txt
    562 bytes · Views: 2
  • gapps-remove_revised.txt
    4 KB · Views: 1
  • open_gapps_log.txt
    6.6 KB · Views: 3
  • System_Files_Before.txt
    534.1 KB · Views: 1
  • Device_Space_Before.txt
    2.5 KB · Views: 1
  • gapps-config_original.txt
    3.6 KB · Views: 1
  • System_Files_After.txt
    554.4 KB · Views: 1
  • Like
Reactions: Meowdib
Black Screen during Setup Wizard - Android 10

Anyone having setup wizard just turning straight black issue, is it a crash? Having this issue in last 4-5 builds, clean flashed. There is no navigation bar too.
Please also grab logcat, and add more info about your issue (Android version, GApps package variant, architecture), and send me the debug log file (it's an archive should be present in the same folder where your GApps zip file is during the install).

An other user reported the same issue on official LineageOS 17.1 in the Lineage subreddit here:

"Blank screen during setup wizard using stock Open GApps ...Oneplus 7T Pro: lineage-17.1-20210126-nightly-hotdog-signed.zip open_gapps-arm64-10.0-stock-20210127.zip ...When I flash full Open GApps instead, everything is working fine."

If you sideloaded Open GApps it automatically creates a log named open_gapps_log.txt in the internal sdcard.
***
 
Last edited:
  • Like
Reactions: Naxiz

Naxiz

Senior Member
Jan 12, 2012
66
39
Groningen
ict-crew.nl
Hey! Thanks @curiousrom, this is exactly my problem!

So I installed lineage-17.1-20210126-nightly-hotdog-signed.zip and open_gapps-arm64-10.0-stock-20210127.zip, nothing else. Now the setup wizard just shows a black screen after the "checking info" step.

I've gathered some more info: if I skip the setup wizard and go to developer options, there are no WebView implementations available. I tried using a `gapps-config.txt` file to keep the stock WebView implementation, but that doesn't help. Using the full GApps package everything is working as it should.

The GApps log is attached to my post! :) I couldn't add the debug log so it is here on Google Drive: https://drive.google.com/file/d/1ezcfKn10sia5LVO_XNk732vsZ3mmbgeR/view

New builds, including the fixes from #905 (this time without the fixes from #902 and #903) are up: ARM | ARM64

There is a new PlayStoreOverlay specific for R to allow Google apps to be installed from non-Play Store locations (thanks to @coin3x and @r6680jc from the Telegram discussion group!).

Also we should now have Chrome and Webview working properly due to the return of the SDK29+ verions of these apps.

EDIT: and they're up. Enjoy, and report any issues you've encountered.

Could this be related to my issue? I would love to try the test build, but it only seems to be for Android 11. Will this fix also become available for Android 10?

--- EDIT ---

Using the following gapps-config it's working!

Code:
Exclude

WebViewGoogle
WebViewStub

+WebViewStock
 

Attachments

  • open_gapps_log.txt
    7.1 KB · Views: 12
Last edited:
  • Like
Reactions: curiousrom

Vinnom

Senior Member
Jun 21, 2012
1,705
1,143
Campinas
Xiaomi Poco F1
recovery.log is notably missing, can you upload it as well?
sure!

Sorry the delay, as I wasn't quoted and new xda isn't as good as the old one to follow participated threads, I didn't see your request.

PS: I've tried to upload it together with the others, but I think 9 is the maximum and I didn't upload it anywhere - if so I could share the link.

EDIT: for some reason, xda is refusing to updload it, so I saved it into this deldog
 
  • Like
Reactions: osm0sis

armars

Senior Member
Jul 24, 2011
53
2
since for arm 6.0 it left only one mirror in San Diego

downloading arm 6.0 packages are impossible :(

every single day there are network problems so download crashes

also resuming is not possible :(
it is not only my problem
I asked my friends in different countries to try
result is same :(
even downloading from LA has same results

it is maybe 60 or more days


every time I report here in forum


but problem still exists


file is aroma version arm 6.0
 
  • Like
Reactions: artiG

dwardo

Senior Member
Jan 15, 2011
472
324
France
Hello,

I'm running LineageOS 17.1 on my Nexus 6 and my OnePlus 6T with OpenGapps (nano variant).

After a recent upgrade of both LineageOS build (2021 02 17) and OpenGapps 10 nano (2021 02 13) on my OnePlus 6T my Android Auto (6.1.610534) started not being happy ("no app compatible with USB device") when connecting to my car head unit (Rlink2)
Screenshot_20210217-203311_Galerie.png


My Nexus 6 with Lineageos build from 2021 02 06 and OpenGapps 10 nano from 2021 02 06 was still working flawlessly with Android Auto (6.0.615343) and my car head unit...

So I did a few tests on Nexus 6 to figure what was the cause : the LineageOS upgrades or OpenGapps Upgrades

Open Gapps 10 nano 202102 06OpenGapps 10 nano 2021 02 17
LineageOS 17.1 build 2021 02 06OKProblem
LineageOS 17.1 build 2021 02 17OKProblem

This clearly suggested OpenGapps was the culprit and was confirmed by downgrading my OnePlus 6T to OpenGapps build 2021 02 06 which also solved its Android Auto issue.

So something is not OK in OpenGapps 10 nano builds 2021 02 13 to 2021 02 17... and maybe ealier as I haven't tested builds 2021 02 07 to 2021 02 12...
Anything <= 2021 02 06 works.

I can do tests if it can help narrow things down...


UPDATE:
Issue still present in openGapps 10 nano 2021 04 14
 
Last edited:

Cavaler

Member
Dec 26, 2012
39
7
Saint-Petersburg
Xiaomi Mi 9
Hello.
I am trying to use latest test version of GApps for Android 11 (HavocOS 4.2 ROM for Xiaomi Mi 9), and I encountered a problem.

Data migration from cloud is not working, since seemingly now Backup and Restore tool requires Data Transfer Tool (pixelmigrate), which is not installed:
03-05 14:51:57.808 8095 8095 E AndroidRuntime: FATAL EXCEPTION: main
03-05 14:51:57.808 8095 8095 E AndroidRuntime: Process: com.google.android.apps.restore, PID: 8095
03-05 14:51:57.808 8095 8095 E AndroidRuntime: android.content.ActivityNotFoundException: No Activity found to handle Intent { act=com.google.android.apps.pixelmigrate.ACTION_D2D_MIGRATE_FLOW (has extras) }

I managed to circumvent it by manually extracting AndroidMigratePrebuilt.apk from GApps package, installing it, granting it all possible permissions from GUI and also granting android.permission.WRITE_SECURE_SETTINGS manually via adb.

But I really hope it will be fixed in future releases.
 
  • Like
Reactions: luc_luke

T_I

Senior Member
Mar 22, 2012
906
1,269
Hi, Nokia PL2, Lineage 18.1 (0308) and opengapps 0130 nano. After adding an account, no calendar or contacts sync is available. With google calendar app added, calendar sync is available, contacts won't sync even with google contacts installed. (google contacts asks to configure an account)

Edit: installed pico opengapps (0130) and contacts sync. Looks like there is an issue with the nano packaging.
 
Last edited:

Magendanz

Senior Member
Mar 25, 2008
786
737
Issaquah, WA
www.Vote4Chad.com
Hello, Nexus 6 latest LOS 17.1 here.
Since a few OpenGapps releases, Photos and Google news crash on startup. I'm using stock version of Gapps. Anyone with the same issue?
Yes, I'm seeing the same thing on both arm and arm64 builds for 10.0. I'm rolling back to see if I can determine the last known good build.

UPDATE: I rolled all the way back to the 20210130 build and was still seeing the problem with Google News, but Google Photo was fine in the 20210311 build. I think I'm just going to stick with the 20210311 build and manually replace the Newsstand folder.

BTW, the problem seems to be a missing resource (Resources$NotFoundException: Resource ID #0x7f08038a).

UPDATE 2: Glad to see a 20210324 build today, and Google Photo is working again! Google News, however, still crashes on launch and only works for me when Newsstand is replaced with version 5.29.0.21022310.
 

Attachments

  • debug.log
    10.4 KB · Views: 3
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 17
    So 11 is finally officially available (pico/nano only)!

    Yup, it's true - we have released pico and nano versions to the public.
    Other variants are coming as soon as we confirm that everything's working properly.

    This is nothing new and was anounced yesterday via TG. But the still open question is, if Pico does include the stub app for Android Auto or not to make it work again. There is no description that explains this circumstance. Can anybody of you tell me and the other AA interested people, if AA works again with the official pico build of today or not?

    Sadly, there are no "notes for Android 11" in github or gibt's in the two package descriptions for pico or nano. These are the places, where this Information should be found.

    Personally I'd like to see AA stub in the pico package. Everybody who does not want that can easily perform an exclude install for AA stub via configfile.

    Android Auto stub is coming to the pico as well in the next build. I'll update the release notes and Wiki as soon as I have a bit of free time, stay tuned.
    9
    Android Auto stub is coming to the pico as well in the next build. I'll update the release notes and Wiki as soon as I have a bit of free time, stay tuned.

    I updated the wiki https://github.com/opengapps/opengapps/wiki/Package-Comparison and the respective package pages.

    Could you edit the Android 11.0 state in https://sourceforge.net/projects/opengapps/files/ please?

    BTW thanks for all the fish. :cool: 👍
    ***
    5
    So 11 is finally officially available (pico/nano only)!
    5
    My Unofficial 11.0 builds

    With @Nezorflame's permission, I ran my own unofficial builds dated 0719 for the full set of packages, since only official pico and nano builds have been released for now. I used the master source branch. arm and arm64 are up now and x86 and x86_64 are on their way as I write this post.

    Unofficial OpenGApps 11.0
    4
    Can somebody send me older version without Google Searchbar, not fun.
    Android 6 Arm.
    Pico build does not contain Google Search.

    OpenGapps Wiki [GitHub] - Package Comparison - Link

    ---

    You can also customize the install using a gapps-config file.

    OpenGapps Wiki [GitHub] - Advanced Features and Options - Link

    Since Exclude is the default, you just need a config file that contains Search.
    Code:
    Search
    Nano and above will exclude Google search when you install OpenGApps.

    ---

    If you install the Nano package and use the Include config from the the Wiki, comment out Search.
    Code:
    Include
    
    # Pico+
    CalSync                 # Install Google Calendar Sync (if Google Calendar is being installed)
    DialerFramework         # Install Dialer Framework (Android 6.0+)
    GoogleTTS               # Install Google Text-to-Speech Engine (Micro+ on 5.0-, Pico+ on 6.0+)
    PackageInstallerGoogle  # Install Package Installer (Android 6.0 only & Android 8.0+)
    
    # Nano+
    BatteryUsage            # Install Device Health Services (Android 7.1+)
    Markup                  # Install Markup (ARM64 + Android 9.0+)
    # Search                  # Install Google App (excluding excludes GoogleNow/PixelLauncher)
    SoundPicker             # Install SoundPicker
    Speech                  # Install Offline Speech Files
    Wellbeing               # Install Digital Wellbeing (Android 9.0+)
    You will get the four from Pico and five out of six from Nano.
    Google search is commented out so it is ignored and will not be installed.

    Cheers. :cowboy:
  • 830
    Questions? Use Q&A!
    Please read the FAQ before reporting any bugs or errors!
    If you post in the main thread not having read the FAQ or error message itself, not included a debug log when reporting a malfuction or reporting a Force Closure without a logcat, your post will be ignored by the developers!
    Not because we are evil, but because the same questions keep popping up over and over again and too often we get a "X doesn't work, plz fix" without any clue what is happening. We don't have telepathic connection to your device and all the time unnecessarily wasted on this can't be spend on development of Open GApps itself.

    The Latest builds of Open GApps for Android can easily be downloaded from the:


    I work on this project for FREE and putting in a lot of hours into it. While not mandatory, donations encourage me to continue to further pursue this project and I'd deeply appreciate them, if you feel generous.
    Donate to The Open GApps Project


    Are you a ROM developer and want to hotlink to the latest Open GApps package? Then check this wiki entry for details.
    Please don't publicly mirror the prebuilt packages without explicit consent of @MastahF, to ensure that users will always be directed to the very latest version and the source code of the project.


    About The Open GApps Project
    Open GApps is a Google Apps package completely developed by writing buildscripts which allow for the automated creation of new up-to-date packages automatically.
    The development process is completely open-source (GPLv3) and the goal is to have multiple contributors involved, to secure and reinforce the sustainability of Open GApps development.
    Builds are generated every (European) night automatically (if there are any changes) and uploaded to GitHub.

    Official AROMA Open GApps package is developed in collaboration with long-time LP-AROMA-developer @raulx222 and has a dedicated XDA thread
    For any questions about the AROMA installer development, please refer to that thread. Of course, general support questions can also be asked in our own Q&A thread.

    Official Open GApps For Stock support is developed in collaboration with @Rapper_skull and has a dedicated XDA thread
    For any questions about the GApps for Stock development, please refer to that thread. Of course, general support questions can also be asked in our own Q&A thread.

    The x86 package branch of the package is focused on Zenfone support and is maintained by @deadman96385 of the famous Zenfone GApps packages and has its own topic for x86 related questions

    For those that cook their own ROM, an AOSP-build mechanism for Open GApps has been developed by @blystad and can be found at GitHub, remember that you should not bundle any pre-packaged Google Apps with any ROMs you want to distribute further though.

    To gather all the various APKs that are necessary for the packages our master of the APK Universe @MNBooZe has written a tool called APKCrawler that scrape these from the internet, e.g. from APKMirror, it can be found at GitHub too.

    Characteristic of Open GApps:

    • Some highlights about the characteristics of the Open GApps packages:
    • All platforms and and all Android versions are supported
    • DPI-optimized support for all Google packages (unlike other GApps)
    • Frequently updated Google Apps: The pre-built OpenGApps.org packages are updated every (European) night (if there are any updated Google Apps available)
    • Strong compression, allowing for relatively small downloads of even the most complete packages
    • Automatic backup: It is not necessary to re-flash Google Apps when you flash a ROM update. Most ROMs support this (addon.d) function
    • The installer checks your device’s capabilities, like the system partition size. It will notify you, before making any changes, if it finds any problems
    • Several package variations, from a Google Super Package (includes all applications that ever shipped on a Google device), to a Stock package that equals the set of applications found on the most current and complete Nexus, to smaller, minimalist packages and an AROMA package that allows graphically selection of what to install
    • A special ‘for Stock ROM’ installation mode that allows to update the Google Apps on Stock ROMs that conform to the original Google Nexus filesystem structure
    • All package installations can be customized to your individual preferences using our Advanced Features and Options

    The idea behind this project:
    I believe a big source of the problem for many GApps packages to stay up-to-date (or not be forfeited) is the lack of time for developers to do labour-intensive repetive every time a new google-app apk is released.
    That is why I have taken it upto myself to write some Linux shell scripts to automate the packaging and to share these efforts with the world with the goal to create a team to continue this package together under the name Open GApps.


    This project should not be managed by a person, but by a team, so volunteers willing to help are more than welcome!

    Open GApps installer uses open source third-party tools, like busybox and xzdec, compiled by @YashdSaraf; See his busybox thread for more info.
    Open GApps is originally based on the now discontinued PA GApps package of @TKruzze and @osm0sis
    25
    Tomorrow there will be 7.0 builds
    Small update concerning Nougat: everything is almost in place, only HotWord Enrollment is not de-odexable yet.
    So tomorrow there will be 7.0 builds, ready for when the first source and custom ROMs will drop.
    Of course beta-quality because they cannot be tested yet, so be careful.
    There are some minor changes, Google changed their keyboard stuff, so there will be no swypelibs possible anymore.
    Google VR Services is backported to all Android versions (so all the way from 4.4 to 6.0) but ofc not yet known how well it will work.
    Also there are some new 7.0 core apps for Google's Shared Android Services (com.google.android.ext.shared; com.google.android.ext.services)
    Trusted Face's unlock has also some major changes, it seems the pittpatt suff is not necessary anymore for 7.0.

    That's it for now
    25
    For those who hadn't spotted it yet: we can celebrate 1 year of Open GApps :)
    http://opengapps.org/blog/post/2016/05/09/open-gapps-first-anniversary/
    23
    Sorry to drop in but needed to clean up some unnecessary posts that were burying more legitimate posts to the thread.

    Going into someone's thread and demanding they make you something is not only just plain rude, it goes against everything XDA is about. Numerous people suggested a way for you to remove the gapps and you chose to ignore them. The dev isn't going to make an uninstaller just for you. You could also always use root explorer and remove the apps that way too. Anywho, there won't be an uninstaller made so no need to continue this conversation.

    Thread Cleaned
    23
    A very small update on the latest Open GApps development focus: Recently most effort went to the APKCrawler project.
    We wanted to mature our playstorecrawler scripts and with the help of @therealssj, who is expert on the Play Store protocol, we were able to make a fully functional crawler for the Play Store (next to our regular crawling of websites like apkmirror). That means we (read: @MNBooZe) are able to fetch APKs for all dpis and all architecture straight from the Google source and greatly helps to have as complete as possible packages for every device available.