• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

GApps free - microG is all you need!

Search This thread

Oswald Boelcke

Senior Moderator / Moderator Committee
Staff member
This thread has been quite for quite some time but I'm not surprised as µG (and as usual "powered" by NanoDroid) is running without any issues on our devices. Personally, I can't confirm or reproduce the issues reported on the respective NanoDroid and microG threads; however, most likely different app portfolio, different requirements in regard to GCM/FCM, SafetyNet etc., different ROM.
Now, just posting here to share some few new experiences.
Already beginning of the year, I purchased a used Samsung Galaxy S7 edge (SM-G935F/hero2lte) that I soft-bricked shortly after. The device was really just a paperweight for many month but a few weeks ago I was able to revive it. This device is now my daily used phone running without any issues with the excellent ROM "[ROM] [UNOFFICIAL] [hero2lte] LineageOS 15.1 for microG" by @Exodusnick Again, as usual powered by NanoDroid although it wasn't necessary to patch signature spoofing this time. First time, that I'm using LOS for µG, and I'm really satisfied. Just in the very beginning I did not succeed in flashing LOS (like with other ROMs) until I changed the latest TWRP (v3.3.1-0) against v3.2.3-0! It took me about two weeks until the idea came up that TWRP might be the culprit.
And I also bought a used Samsung Galaxy S8+ (SM-G955F/dream2lte), which is currently running the excellent [ROM][UNOFFICIAL][dreamlte/dream2lte][[SM-G950F/SM-G955F][9] LineageOS 16.0 by @Stricted As usual, device is GApps-free and with µG powered by NanoDroid. The very major difference for my compared to all other devices before, this time I was required to patch signature spoofing by Smali Patcher by @fOmey But this ran and occured so smoothly and easily, I was really fascinated. The only pity is that this device cannot (yet?) be my daily used phone because I don't get Conversations and DAVx⁵ to register with my posteo.de respectively jabber.de accounts. Reported in Q&A here but no suitable reply thus far. Please be aware that this is certainly not a LOS issue or related to my current system setup. Also on stock Pie without any firewall etc. the issue occured.


TL;DR: In context of the content of this thread; LOS for µG and signature spoofing by Smali Partcher are working superb.
 

Oswald Boelcke

Senior Moderator / Moderator Committee
Staff member

jlsaviation

Member
Nov 19, 2008
14
8
Samsung Galaxy S III I9300
Oswald, after having you help me get Resurrection Remix® N v5.8.5 final running on my i9305 I was loathed to spend more time on it then to go Gapps free. An unfortunate, battery dropping out whilst booting, scenario the other day led me to have to rebuild the phone again. Since I never did get rid of mtp host and phone stopping from time to time after Gapps install I thought I might follow this thread as you suggested. I like the sound of the Boeffla kernel but what version are you using on your i9305?
 
Last edited:
  • Like
Reactions: Oswald Boelcke

Oswald Boelcke

Senior Moderator / Moderator Committee
Staff member
I like the sound of the Boeffla kernel but what version are you using on your i9305?
I'm using boeffla-kernel-6.1-beta3-boeffla-stratonz_beta8-i9305.recovery.zip

And I know the mtp host issue. I've simply frozen it without any negative interferences.
 

jlsaviation

Member
Nov 19, 2008
14
8
Samsung Galaxy S III I9300
I'm using boeffla-kernel-6.1-beta3-boeffla-stratonz_beta8-i9305.recovery.zip

And I know the mtp host issue. I've simply frozen it without any negative interferences.
Would it be possible for you to attach a copy of the zip? I've had a look at the current download page but that particular one is unavailable and when searched for in particular gets a restricted access notification.
I'm currently working through your post on page 3 and I'm a bit confused about the Aroma installer. From what little I've gleaned so far it seems to be for devs only. Am I missing something?
 
  • Like
Reactions: Oswald Boelcke

Oswald Boelcke

Senior Moderator / Moderator Committee
Staff member
Would it be possible for you to attach a copy of the zip? I've had a look at the current download page but that particular one is unavailable and when searched for in particular gets a restricted access notification.
I'm currently working through your post on page 3 and I'm a bit confused about the Aroma installer. From what little I've gleaned so far it seems to be for devs only. Am I missing something?
Here you go...
 

Attachments

  • boeffla-kernel-6.1-beta3-boeffla-stratonz_beta8-i9305.recovery.zip
    6.2 MB · Views: 1
  • Love
Reactions: jlsaviation

Oswald Boelcke

Senior Moderator / Moderator Committee
Staff member
Could you do the same for the corresponding config app.
I apologise for the delayed reply. Currently, I don't remember if any of our two i9305's is on RR or if I've Nanodroid backups of that system. If affirmative, I'm going to extract the apk. As far as I remember, Lord Boeffla doesn't provide any of his "products" any longer on the web.
Did you try with one of the other kernel manager? On my daily in use SM-G955F, I'm using FK.
 

jlsaviation

Member
Nov 19, 2008
14
8
Samsung Galaxy S III I9300
No need to apologise at all. I think you're right about Lord Boeffla, same sort of problem when it comes to a lot of the apps listed in the thread. Those that are still supported often seem to have changed the way they are implemented now so trying to follow your guide using something as old as an S3, at least with my level of knowledge, has proved a bit of a challenge. I have managed to get a working phone but it's not quite right yet. Not getting notifications (but I think I did read about having to have a google service of some kind for that to work) and some apps like Signal and Calendar just crash on opening still but I'm working on it. All feels a bit like using Linux 10 years ago
 
  • Like
Reactions: Oswald Boelcke

[DarkGUNMAN]

Member
Nov 15, 2012
14
15
Hello, haven't been here for a long time but decided I needed to do something with my old HD2 in case my current phone goes down.
After hunting the internet I tracked down a copy of NexusHD2-KitKat-CM11.0_V4.7 and installed it.. GApps won't connect and continues to crash when trying to register Goggle account, so installed MicroG - no app crashed, so then tried to register Google account - login page will not show properly or allow input, guessing it is due to WebViewChromium.jar.

I would like to install Bromite as the replacement webview, but there is no method I can find to set this as the replacement for the non-apk version of webview.

Any chance of some help on how to do this?
 

Oswald Boelcke

Senior Moderator / Moderator Committee
Staff member
Very long time ago, I replaced the "normal" webview by Bromite Webview by flashing the NanoDroid-BromiteWebView module through TWRP. I got the module from @Setialpha's thread:
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 27
    ...why do I post this? Actually, I hoped to achieve less battery drainage without Google's well known tendency to permanently collect and transmit data. However, my initial observations don't prove extended battery life but I'm going to continue tracking the battery drainage and will eventually edit the respective post in this thread. At least, I'm already definitely able to state that I've less wakelocks, alarms, and running services than before. Furthermore, some of these crazy, weird indicated *alarms* and *launch* are gone.
    Additionally, I'm monitoring the below mentioned microG-treads and recognise that quite a lot of people obviously have problems to get microG to run (honestly, as me too about six months ago, when I first attempted). Thus, I take the oportunity to provide my procedure how I've got microG to perform its desired duties.

    If you're really interested into microG I suggest to read @Shadow53's post here.

    By going "GApps free" I was able to achieve one of my decisive points to protect my own centre of gravity. However, monitoring the related microG threads I realised quite a few people have other motives for GApps free devices and seem not to have impediments for sharing and exchanging information with Google, obviously neither my personal way nor my consensus. For completeness, I like to share some of the other opinions to enable everyone to make up an own mind. Please find some posts here, here, or here. Additionally, @ale5000 provided a comparision between GApps and microG here.

    It doesn't require bravery but only the strong will to get rid of all the useless Google services and activities despite the fact that I already succeeded in not selling my private data to Google at all by the use of some tools, policies, and procedures. Just to make it more clearly, I don't and don't want to use any of the applications provided by Google (except the Google Play Store (PS) for a very specific reason described below). I'm convinced there're alternatives to each of the Google applications around, which are respecting my privacy concerns and aren't necessarily so enormously blown up. Some aren't for free but I'm happy to support a developer and the development in regard to an excellent application; some of the applications you need to pay for on Google PS you get for free in same quality and "update level" e.g. at F-Droid.

    Please allow me to mention a few of the applications I use but forgive me for not providing links to them; a simple web search will show you the way.
    Email: "K-9 Mail R2Mail2" in conjunction with "OpenKeychain"; Browser: "Slimperiance", "Orfox" together with "Orbot"; Maps & Navigation: "OsmAnd~"; SMS/MMS: "chompSMS" and "Silence" (but no WiFi or mobile data access); Weather: "Avia Weather", "Das Wetter in Deutschland", "WarnWetter", "WetterOnline"; Messenger: "Conversations" in conjunction with a XMPP-Jabber-account; Camera: the ROM inherent one; Contacts: ROM inherent but synchronised via home-WiFi with PC via "MyPhoneExplorer"; Calendar: as for contacts before; Music: "VLC" (but no WiFi or mobile data access); Launcher: "Nova"; PDF-reader: "Xodo Docs PDF Viewer" (Remark: I personally don't require the capability to open any Microsoft Office or Open Office file types on my phone).
    If you think I forgot something just ask!

    You might now ask yourself why I didn't just live without Google but moved to the microG project instead? I require following capabilities:
    • Fixing of the current location of my device both using GPS and/or WiFi or Mobile Data.
    • GCM Push Notifications.
    • Access to the Google PS, especially to have access to my paid applications, donations, and to beta programs of some applications I like.
    • Some of my preferred applications must have an indication that (a kind of) Google Play Services is available on the device in order to correctly function or even to be positively installed.
    EDIT (2017-05-02): In regard to the use of the Magisk module "NanoMod" please refer to post #14!

    First, I'm extremely happy with my "GAppsless" system - running smoothly without any problems and all functionalities I desired! I don't have benchmarks but personally I've the impression my current ROM is performing faster, smoother, simply better than with Gapps.
    To achieve a location fix runs perfectly in all three modes (including energy saving mode just by WiFi or mobile network) and definitely much faster than with GApps; GCM push notifications work; BlankStore ran as advertised, all installed apps were indicated and available updates, download of apps or updates without problems, and as advertised paid apps or beta versions were not available. Latter was the one and only reason why I installed the Google PS as the only Google application. For the procedure please see below.

    Installation was quite easily accomplished by simply following the OP of [APP] microG GmsCore - lightweight free software clone of Google Play Services by @MaR-V-iN.
    First, I ensured I'd both the Titanium Backup (TB) APK file and the TB Pro-Key APK file on my external storage the booted into recovery (in my case TWRP). I create a NANDROID backup by TWRP and then clean flashed my favourite ROM (in my case: Resurrection Remix® by @rodman01) i.e. wiped /dalvik, /cache, /system and /data (including internal storage - my Titanium backup is on external storage), factory reset. Flashed my favourite kernel, followed by flashing of Chainfire's SuperSU v2.76 (this is by my information the latest SuperSU by Chainfire himself. I refuse to go for the CCMT SuperSU v2.78, and I've issues with my kernel control application if I e.g. use phh's systemless SuperUser).
    There no need any more to flash the Xposed framework through TWRP since @rovo89's version 3.1.1 of the XposedInstaller (this is true for my GT-I9305 and might be different to other devices/ROMs). In my case, the Xposed framework is absolutely necessary as my ROM does not support signature faking and I had to use the respective FakeGapps APK. Due to @Primokorn I became aware there are other tools like Needle or Tingle (just search for them) to get signature spoofing for Nougat (until we have Xposed).
    Reboot into system.
    Remark: Quoted from MaR-V-iN's above linked thread: "...You need a 4/5/6 ROM that is GAPPS-free. Either don't install them or remove them, if your ROM ships them. Please note that microG GmsCore might run on a cleaned stock ROM, but it might also brick it or cause random bugs. Be aware that only latest Android versions (4.4+) are regularly tested and thus prioritized over older versions when issues occur..."
    Completed my desired initial ROM setup and installed the TB APK and the Pro-Key APK. Made the necessary TB setup especially the location of my backups. Restored XposedInstaller and all initially required applications via TB but definitely include F-Droid and the application with a root explorer of your desire, I'm personally using SD Maid - System cleaning tool by @Dark3n (all others were restored after installation of microG). Please do not restore or install any application, which require GCM push notifications, before having installed microG! Performed the setup for all restored applications. Installed the Xposed framework via XposedInstaller. Reboot. Installed the FakeGapps APK and activated it in Xposed. Reboot.

    I followed this procedure (http://forum.xda-developers.com/showpost.php?p=42983611&postcount=306), downloaded the "android-checkin-1.0.jar" and "bla.bat" and generated an Android ID for my Google PS account. Please be advised about this information I received from @pupsidze: "Accounts created online does NOT work with this. I have registered an account via friend's phone and it worked like a charm..." This obviously means you must use an account that was formerly created through the Google PS on an Android device.

    I downloaded following APKs on PC and moved them to my external storage:
    Install all of the above, then move into F-Droid to download the backends for UnifiedNlp as indicated in the above mentioned UnifiedNlp thread and install them. I'm personally using the two following backends: "LocalGsmNlpBackend" and "NominatimNlpBackend".
    Follow step no. 4 of the installation instructions in the OP of [APP] microG GmsCore - lightweight free software clone of Google Play Services by @MaR-V-iN. For the setup of the "LocalGsmNlpBackend", I'm using the database of "Mozilla Location Service" because the download of the OpenCellID database quite often broke down. Please be aware that the download takes quite a few time due to the size of the database (only do via WiFi!!!), and choose before the areas you interested in in order not to "overload" your storage! At this point, I rebooted then went in "BlankStore" or as it appeared as "Android Market" on my app list.
    When you open "Android Market" the first time, it requires you to enter the credentials of your Google account. Enter your Google email address, Google password and the Android ID you generated earlier. If everything worked as advertised all your already installed applications should appear in the "Android Market" after you hit "installed apps".
    I suggest to now run the self check in the microG settings. Before you do, ensure that location is enabled in the ROM settings otherwise you want get a tick mark in the last row of the check. If any other tick mark is missing just recheck your settings and especially if all permissions are granted.

    When I was at the point to restore my remaining applications via TB, I wasn't initially able to restore 6 out of my about 100-ish applications; a new installation of these applications failed, too. Just by accident, I checked the homepage of one of these apps (Öffi) and realised that one of its requirements was to have a pre-installed Maps Library v1; however, they also offered an AOSP version, which was running without GApps but microG. This was for me the first indication not to have Maps Library v1 but only v2 installed.
    I discovered (again) @MaR-V-iN's NOGAPPS Project (NetworkLocation, MapsAPI, Blank Store) thread, downloaded and flashed the Maps API Flashable Zip. All resistant applications were installable afterwards and are running properly.
    Conclusion: If some apps can't be installed it's most likely due to missing Maps Library v1.

    Last but not least, I manually installed Google PS by downloading its latest version from apkmirror.com and renamed it to Phonesky.apk. (EDIT (2017-03-25): Please be aware that @ale5000 recomments here to use version 5.1.11. Personally, I use the method described here for purchases in Google PS.) Then I created a folder called Phonesky via my root explorer in /system/priv-app/ and set its permissions to "755 (rwxr-xr-x)". I move the renamed Phonesky.apk into this folder and change its permissions to "644 (rw-r--r--)". Rebooted and was done.
    After the reboot, I noticed the following:
    • The formerly "Android Market" (BlankStore) was no longer available in the app list but a "Play Store".
    • A Google account was available under ROM settings => Accounts; however, synchronisation was automatically disabled.
    • Via Google PS, my Google account was accessible including all purchases I did.
    • At "My Apps & Games" no apps were indicated under "installed apps", under "all apps" all my installed apps were shown and the ones not installed but downloaded in the past. No "beta" tab was shown.
    • In my "donation apps" (e.g. Amplify) the donation was again indicated.
    I went to my Google account on Google Play Store (on my PC) and walked my way through all of my applications by clicking on "install" despite the indication that it was already installed. Obviously the applications apk's were again "beamed" to my device (and installed (???) again occasionally with a timely delay of about an hour). However, eventually the Play Store on the phone indicated all applications now also under "installed apps", if applicable updates were provided, the tab "beta" was created and I was back into all beta programs I had formerly joined. Play Store runs exactly the same as before when I had Gapps installed.
    Meanwhile I experienced that Play Store automatically synchronises all my apps by itself i.e. I learnt to be patient.
    Please advise if you believe I missed something or in case of any question! Be aware, I took my time to conduct all of the above; didn't do it in a single step i.e. I was running more or less two operating systems on my device simultaneously and switch back and forth. Now, I'm only (and will only be) staying on my "GAppsless" ROM!

    P.S. Before you install one of the "directly linked" apk-files recheck if it's the current version!

    CREDITS: To everybody who I mentioned in this OP or the subsequent posts. If I forgot someone I apologise. Please let me know in this case or if you want to be more prominently given credit; I'm happy to immediately follow such a request!


    EDIT (2017-04-14): Please find a more brief procedure below at post #8.


    Off topic comments are allowed as long they are generally related to the overall topic, are in the general interest of the followers of this thread and add value to the thread. The ultimate decision rests with me as the OP!
    13
    Resurrection Remix "Nougat" v5.8.3 is now GApps-free

    Thanks to the really powerful and easy to use NanoMod Magisk module by @Setialpha powered by Magisk by @topjohnwu I was able to create a GApps-free system on my Samsung GT-i9305 running Resurrection Remix RR-N-v5.8.3 by @rodman01 (RR-i9305 official thread). Excluding download times, the following complete procedure took me less than one hour this morning, and - if interested - I'd like to share the way I used with you.
    However, before I continue I need to address my very best compliments to rodman01 for such a superb ROM, to topjohnwu for the systemless root as it was the basis for going GApps free, and to Setialpha for this fantastic module, which made it so easy and fast to achieve a GApps-free device. Three times :good::good::good: and thanks very much to all of you for excellent jobs well done!:)

    As you certainly know RR doesn't come with signature spoofing by itself, which is a prerequisite to go GApps-free with the help of microG by @MaR-V-iN. Thanks very much to MaR-V-iN for allowing me/us to abandon Google from my/our devices. Without Google, not only privacy is much better protected, the device itself runs much smoother and faster. As long as Xposed was available i.e. up to Marshmellow, signature spoofing could be achieve for RR via a Xposed module but for Nougat, no Xposed available (yet???). For this reason I stayed on RR-M till I found Setialpha's thread as he provides an easy-to-use tool to achieve signature spoofing on RR-N as long as use use the Magisk su-binary. However, as mentioned in the OP there've been other tools available to get the spoofing but not as easy to use.

    Before you continue to follow me through my procedure, I'd like you to thoroughly read the OPs of all linked threads with their invaluable information.

    Download the following files via the links given in above mentioned threads and save them to your device (I used my external SD):

    1. Latest Resurrection Remix RR-N-v5.8.x
    2. Latest Magisk and the MagiskManager.apk (link to XDA-thread see above).
    3. EDIT (2017-04-30): Latest NanoMod-microG NanoMod-6.1.20170421.zip and NanoMod-patcher NanoMod-patcher-6.1.20170421.zip from here. Please be aware that there are two additional, more specific NanoMod-zips available. Use them on your own descretion; I personally like all the functionalities that come with the "overall/general" NanoMod module. EDIT (2017-04-30): My device had really severe battery drainage with the "overall" module. Battery drainage with the microG-module is not a factor at all. And I personally realised that I don't have any need for the additional things comming with the overall module. Reported my battery drainage issue together with a logcat to the dev.
    4. If desired - mapsapi.flashable.zip from here (you only need that if you're using applications that require Maps Library v1. You won't be able to install any of those apps (or restore a TB backup) before Maps Library v1 has been flashed). EDIT (2017-04-30): No requirement to do so. Maps v1 is coming with the NanoMod module. Just ensure that /data/.nanomod-setup shows nanomod.mapsv1=1 as described in the OP of the Nanomod-thread.
    If you like (as I did) create an update.zip by Titanium Backup. I saved that on my external SD, too.


    Boot into recovery (I'm using TWRP 3.0.2-1) and follow this procedure:

    1. Before you continue to do anything, create a NANDROID backup of your running system!
    2. Wipe dalvik, cache, system, data (I did not wipe internal data or external SD).
    3. Flash RR-N-v5.8.x.
    4. Flash Magiskzip.
    5. Reboot into system (Remark: The initial reboot might take a while i.e. grab a coffee; all follow-on reboots are slightly longer during the initial boot phase probably due to the revised boot.img but after that phase boot is really fast).
    6. Install the MagiskManager.apk and start it. At that point, MagiskManager stated that Magisk v12 is installed but no root available. Here, I simply re-started the phone and afterwards, MagiskManager also indicated root to be available.
    7. Re-start into recovery.
    8. Flash NanoMod (or the module you desire) and NanoMod-patcher. Do not flash mapsapi.flashable.zip, yet - at least didn't later on work for me.
    9. Flashed my TB-update.zip
    10. Reboot into system and commence to setup your device with the initial ROM configuration that enables you to proceed (e.g. WiFi/mobile data setup, location enabled (I used "high"/GPS & data), required permissions granted to the microG applications and the connected backends etc.)
    11. At this point I went into the microG settings and conducted the first self test to see how many marks were checked and what I still missed. If a check mark regarding a lacking permission is missing, just tick on it, and a dialog is going to open to grant this permission (later with the backends, it might also be a statusbar notification). For me I wanted achieve first the "location ability" i.e. I didn't care yet about the Google Play Store.
    12. I maintained in the microG settings and setup my backends. My settings for the backends can be retrieved from the screenshots. Please be aware that the download of a GSM Location Services´database can take a while (my phone still had one from end of March available).
    13. Re-check if in the self-test all marks are ticked, now.
    14. By use of the app "GPS Test", conducted such a test. This was an unbelievable experience as such many satellites were recognised immediately after the start of the app and granting of location permissions, and just after 3 - 5 seconds I had the first fix.
    15. Re-started into TWRP.
    16. Flashed mapsapi.flashable.zip
    17. Rebooted into system.
    18. In the ROM settings, created my Google account without any problems. Immediate connection to the respective Google servers; user account and password were accepted without any problems.
    19. Opened Google Play Store from the app drawer. Play Store immediate connected to my account. Made the necessary modification to the play store settings, and as you can see on the screen shot, all my apps are shown including beta's and the purchased ones.
    20. Continued to further setup my system, but microG was done at that point, and my system was GApps-free except for the play store.
    Thanks again to rodman01, topjohnwu, Setialpha, and MaR-V-i!:):good:

    EDIT (2017-06-10): Recommendation
    In order to achieve after the clean flash of a ROM exactly the desired installation of microG (or anything else that is provided by one on the NanoMod modules, I suggest to create a so called ".nanomod-setup"-file with the values in accordance the OP of the NanoMod thread (see Alter Installation part) and your preferences. Although the OP mentions different possibilities, my personal pratice is to create this file once and have it on the extSD. I do the clean flash of the ROM and if required Magisk, and boot into system. I copy .nanomod-setup to /data, boot back into TWRP and flash my NanoMod-modules.
    Mine e.g. looks like this:
    Code:
    nanomod.play=1
    nanomod.reinstall=1
    nanomod.mapsv1=1
    nanomod.overlay=0

    EDIT (2017-06-22):
    A few more details regarding the .nanomod-setup file are available in this post.

    EDIT (2017-09-17): In case of "NLP issue", missing the bottom two tickmarks in the microG settings self-test or the unability to get a location from GSM cells/WiFi please check also post #48.

    EDIT (2017-10-31): With the current version (v14.x) of Nanomod, installation is now even more easy. A setup-wizard to create the desired .nanomod-setup file is now available; it simply has to be flashed before any other Nanomod-zip is flashed. The new patcher can now be flashed immediately after flashing of the full module, the microG-module and/or the F-Droid-module; the patcher doesn't require a reboot into system anymore after the flash of the other modules. If Nanomod recognises Magisk Nanomod automatically gets installed as Magisk module unless you "tell" the setup-wizard differently.
    8
    Triggered by reading this blog (in German language), I replaced my ROM's Android Webview by Bromite WebView that is available here for downlaod and can be updated via its F-Droid Repo. Instructions for installation are available on Github.
    Webview is a component of Android that supports apps to display web content e.g. various browsers make use of it, thus it's crucial to maintain an actual and updated version of webview. My current ROM doesn't receive any updated any longer and in turn neither Android webview. For me the decisive advantages of Bromite compared to my Android/AOSP/Google webview are that the patches populated from Iridium, Inox, Brave and Ungoogled-Chromium. Additionally, updates are avaiable via F-droid as mentioned above.
    The installation instructions provide different way how to install Bromite. As I'm rooted I've chosen the following way:

    • Downloaded the Bromite apk for my architecture and SDK from the above linked page.
    • By my root explorer (MiXplorer by @HootanParsa) I deleted the webview.apk at /system/app/webview, or more precisely I cut and pasted it to my external SD card as backup if required for whatever reasons).
    • Rebooted.
    • Installed the Bromite.apk by package installer. (Remark: Direct installation from F-droid did not work. I had to install first manually the downloaded Bromite.apk; afterwards the updates via F-droid are working, too.)
    • Added the repo to F-droid.
    Some remarks and please read the FAQ's on the Bromite Github page:


    • Google Sync/Translate/Data saver does not work (no issue for me obviously).
    • Bromite supports WebRTC since version 69. While the desktop version of Chromium has an option to disable it (video/audio site settings), the Android version hasn't.
    Bromite features:

    • baked-in adblock engine with filters from EasyList, EasyPrivacy and others
    • remove click-tracking and AMP from search results
    • DNS-over-HTTPS support via Google, Cloudflare and Quad9 servers
    • StartPage, DuckDuckGo and Qwant search engines
    • chrome flags to disable custom intents and clear session on exit
    • always-incognito mode
    • completely removed safe browsing and other privacy-unfriendly features
    • anti-fingerprinting mitigations for canvas, audio, client rects, webGL and sensor APIs
    • use fixed User-Agent to conceal real model and browser version
    • privacy enhancement patches from Iridium, Inox patchset, Brave and ungoogled-chromium projects
    • import/export bookmarks
    • allow playing videos in background tabs and disable pause on switching tabs
    • all codecs included (proprietary, open H.264 etc.)
    • built with official speed optimizations
    Please consider to support Bromite's development by a donation. For details refer to the Bromite Github page.

    EDIT (2019-02-15): Yesterday, I realised that I've forgotten to update this thread with the information that the Bromite WebView can easily be installed via a NanoDroid Bromite WebView sub-module since 2018-11-09 (NanoDroid v20.0 beta). For the release notifications of this version refer to here. Brief quotation from them:
    There's a new module available as of this version: NanoDroid-BromiteWebView. It replaces standard Android WebView with the improved Bromite WebView. As the name suggests, this package includes the WebView only, not the Browser. Because reasons the Bromite WebView needs to be both a system app and a user app to properly work.

    If you install NanoDroid-BromiteWebView in Magisk Mode, the module will install the system app as user app automatically (30 seconds after Magisk initialization on first boot after module installation). In System Mode installations, issue the following command manually, as root 'pm install -r /system/app/webview/webview.apk'.

    If you install F-Droid from Full or F-Droid packages (and it's a clean flash) the Bromite F-Droid Repository is auto-added to F-Droid, on a non-clean flash, add it manually, see here.
    Personal experiences: Simply excellent; works well and without any issues. And just to reiterate: The submodule only contains the WebView but not the browser. The submodule zip-file is flashed through TWRP, and when flashing the submodule the usually ROM-inherent Android WebView is automatically replaced by the Bromite WebView.
    4
    .nanomod-setup file

    Post #14 updated:
    Recommendation
    In order to achieve after the clean flash of a ROM exactly the desired installation of microG (or anything else that is provided by one on the NanoMod modules, I suggest to create a so called ".nanomod-setup"-file with the values in accordance the OP of the NanoMod thread (see Alter Installation part) and your preferences. Although the OP mentions different possibilities, my personal pratice is to create this file once and have it on the extSD. I do the clean flash of the ROM and if required Magisk, and boot into system. I copy .nanomod-setup to /data, boot back into TWRP and flash my NanoMod-modules.
    Mine e.g. looks like this:
    Code:
    nanomod_play=1
    nanomod_reinstall=0
    nanomod_overlay=0
    nanomod_mapsv1=1
    nanomod_gsync=0
    nanomod_forcesystem=0
    A few more details regarding the .nanomod-setup file are available in this post.
    4
    Thanks to @setialpha's the continuous work and improvements to Nanomod, version 14 is out. Please be aware that Magisk v14 is mandatory with Nanomod v14.

    Please allow me to share an observation that might be interesting to others, too. I'm Gapps-free and using microG for more than two or three years, and in April about six months ago I discovered your great Nanomod modules. Since then, I'm using Nanomod-microG but always as a Magisk module; current on Nanomod v13.4-beta1 and Magisk v14.
    Already a few weeks ago, I discovered that localisation via GSM cells or WiFi wasn't possible but I didn't mind as I'm usually using localisation via "sensors" i.e. GPS. Due to the very low priority to me I didn't dig into this issue but I knew that gms core and all backends were correctly installed and data bases downloaded and present. The microG self test just did not show the last bottom two tickmarks. Interestingly, it had worked sometimes in the past but I apologise I cannot recapture with which Magisk and/or Nanomod version the issue occured the first time. Just as a remark, the issue was persistent on both of our Samsung i9305.

    Just monitoring the post in this thread over the last days and reading about NLP issues, I remembered my own one. First, I followed @kurtn advice here, and flashed @Shadow53's microg but this didn't solve the problem.
    Next step was to completely uninstall Nanomod by use of the uninstaller. I used the setup-wizard to create the setup-file to my desire but I've chosen to install Nanomod-microG directly to /system and not as a Magisk module - actually the very first time not to have Nanomod as Magsik module. Rebooted into system and back into TWRP and patched the system.

    Back in system, I made all required setups for microG (permissions, backends etc.) and no NLP issues anymore, all marks in self test or ticked, and localisation through GSM cells and WiFi is working!

    Repeated above mentioned procedure on the second i9305; also on that device no issues anymore. Conclusion: For whatever reason, the issue occured because Nanomod was installed as Magsik module.

    EDIT: I tried to reproduce the issue with one of the two devices. Flashed the uninstaller followed by the v13.4-beta1-setup.zip but did not select installation to /system. Flashed v13.4-beta1-mircoG. Successful installation as Magisk module. Booted into system, check if Nanomod was installed as Magisk module. Set location mode to "savings".
    Check microG settings self test: All tickmarks available. Opened OSMand+: Positive and good location.
    Obviously unable to reproduce (but I was ready to take a logcat). Somehow, by something I initially did this morning, I "removed" the issue.

    NLP is working and good locations via GSM cell/WiFi are provided independent of the way Nanomod-microG is installed.

    Meanwhile upgraded to Nanomod v14.0 without any issues.

    Wow .. if i said its amazing post wont b enough
    step by step explanation + app used + Ver. # used + linked to out source (website) used
    i reached here while i am in the middle of configuring Micro G and everything is working fine for me except for safety net check.
    MicroG droid helper stopped working this what i get when i check through magisk !!
    i am still working out to solve it ..
    there is one more thing .. u didnt tell what is the alternative for bookmark sync. between your devices ??
    i was using chrome but now with GApps-free i moved to fire-fox, but i think it would be better f i moved to cloud service that provide bookmark sync.

    PS. dont tell me to hit thanks !! .. coz your posts took all what i have for today
    I very much apologise but I'm unable to support in both cases:

    1. Despite certainly having everything correctly set up in microG, I was never ever able to pass the safetynet check. I'm absolutely convinced that is due to the combination of my ROM, kernel, su (in my case Magisk - even with Magisk hide), unwilling to unroot etc. However, I haven't cared and I won't care in future either as I've no requirement at all to pass the safetynet check; I definitely don't conduct any banking etc. via the cell phone and don't/won't play games like Pokemon.
      In my ROM's thread (Resurrection Remix by @rodman01), a few guys posted that they passed the safetynet check but if I correctly remember didn't use Magisk and had to unroot.
    2. Correct, no recommendation for synchronisation of bookmarks for a simple reason: I personally don't synchronise bookmarks between devices and if I had to, I'd do that manually i.e. export/import of a html-file.
    Last but not least: Since my username got the green colour I'm certainly not begging for thanks; although I like to get one if a member appreciated one of my postings i.e. I'm grateful for yours. However, I occasionally try to remind people to hit the thanks button of someone who was helpful and supportive.