Question Gboard's Assistant voice typing is jacked

Search This thread

Curiousn00b

Senior Member
I am considering the LSPosed approach as it does seem cleaner... I know a lot has changed since the XPosed days, but does LSPosed all SafetyNet to pass enough for GPay to work?
Works fine. LSposed is far better than XPosed was, as it even works without rebooting, unless you're touching the Android System Framework or SystemUI really.

Modules that touch apps just need to be enabled, then reopen the app. It wouldn't hurt to give it a shot, but yeah, works fine. Safetynet passes and all with the modified fit from Displax.
 
  • Like
Reactions: dimm0k

dimm0k

Senior Member
Jan 25, 2014
1,695
654
Google Pixel 4 XL
Works fine. LSposed is far better than XPosed was, as it even works without rebooting, unless you're touching the Android System Framework or SystemUI really.

Modules that touch apps just need to be enabled, then reopen the app. It wouldn't hurt to give it a shot, but yeah, works fine. Safetynet passes and all with the modified fit from Displax.
will definitely give this a try. you don't happen to know if LSPosed uninstalls cleanly do you?
 
I use VTT for everything and there is one bug I have that annoys the heck out of me. In a texting conversation, the first message I send is OK. For every other message after that, after I say the first word, the mic shuts off and I have to hit the mic button again to finish the message unless I close the app after I send a message. Same bug on Messenger and Messages so it's not ap specific
 

nico933

Senior Member
Jan 2, 2014
555
123
this function is so good as soo buggy
just stopped working "update vocal typing of the assistant eccc"
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    I had to factory reset it. I tried uninstalling ASI updates first with no luck. After a clean install everything works perfectly, without Pixelify. I lost voice text, live translate, Now Playing, and transcribe. I'm sure there were other features that it broke.

    The only Pixelify mod I enabled was unlimited Photos storage.
    yes, after your mention and my original suspicions I decided to look more closely into this Pixelify module. what I found and confirmed is that even if you only enable the unlimited Photos storage, there are other things that get installed/modified and one of them is ASI!! I've gone through the install script, as well as the files included in the module to comment out everything not dealing with the unlimited Photos mod. for extra measure I also removed the unneeded APKs and whatever else I could find from the module and repackaged it as a custom module for my own use. so far... it seems to be working!!
    1
    Hi, it seems like you are as desperate as I was about that stupid greyed out option. I searched for days until I found a solution at least for my case. Perhaps it also works for you.
    These are the instructions I followed:

    1. Go into Assistant Settings and select Language (Account-Settings -> Google Assistant -> Sprachen (German for Languages))
    2. Remove secondary Language by clicking on it and in Radial-Menu selecting keine (German for "None") right at the top.
    3. Go into Gboard-Settings, into Voice typing. Now the option of Assistant Voice Typing should be available. Activate it!
    4. Go back into Language-Settings for Assistant and add secondary Language again. After that just check it the Assistant Voice Typing is still activated in The GBoard settings.

    You might have to give it some time to download the necessary files. I first thought it did not work, but when I checked again a bit later, it did!

    Hope this helps.
    1
    I ran into the same problem when I added Spanish to my languages for Gboard. Then after that, Google voice assisted typing worked intermittently. There were times that it didn't work, and then times that it did.

    My remedy was sticking to just an English keyboard and flashing a whole new rom since I do it every month. I also wiped user data, because I thought whatever caused the problem was in user data.

    Then it started working again. Whatever it is by Google, it's a nasty bug.
    1
    do you have a link to this rBoard app? searches turn up rBoard theme manager, but the screenshots of the app do not look anything like yours... are you saying that rBoard breaks or GBoard when it comes to fixing the files in /data/data? does this mean you run this fix from time to time to get NGA working?
    That's correct. It does a lot of things actually. You can even make your own custom themes for GBoard as well as enable different flags that aren't enabled by default.

    Here's the XDA link for rBoard linking to the downloads.


    There's been an uprise lately with XDA vs Telegram and whatnot, but based on what I read on the other thread, this doesn't violate the rules since you're not required to join the group to see this post, so...


    This post here will tell you what to do do get rBoard working correctly. Root is required and you have to do this every time you update GBoard since it'll replace what you've done. You can turn off updating so you don't have to do it every time.

    Feel free to PM me(or post here so others can see) and I'll happily guide you through whatever you need help with so that you get the hang of the app. 😎
    1
    Just putting in my thoughts on the whole Pixelify thing, but I said I avoid using that module since it's used to enable Pixel features on non-Pixel devices. Since we already have a Pixel, it changes a lot of settings when everything already works fine. 😅

    Other have claimed the other Pixelify(app) doesn't work for them, but maybe you guys can try it as well. Don't know if you guys were apart of the other thread or not, but open it, select Pixel XL, click force stop(grant root), then open Google Photos and back up something. After that, check the description of it at the very very bottom for this tag in the screenshot below.

    As for Assistant Voice Typing, you'll have to use rBoard to manually enable it. I've linked it in my other post above with the fix to get it working.
    what is this other Pixelify app that you have in the screenshot?? didn't know there was a frontend for it...