Question GCam for Exynos

Search This thread

andreasarxon

Senior Member
Mar 5, 2011
163
35
I ask some post before about the same problem but nobody gave any solution . I search almost all settings but couldnt manage to find a solution . Now i am back to shamim version and try to play with the settings . At least i dont have this rainbow effect .
Is there a way to get rid of the blue circles in AGC? There're especially evident in low light scenes.
 

krishnandb

Senior Member
Aug 20, 2010
55
19
My xml for exynos . More true to life colors for my taste. Left gcam right stock. Shahim v20
Hey Andreas, I tried a few options from the thread and only shamim v20 samsung apk and your configuration works well for me. Thanks for that!

I have a few minor issues though:
1. HDR+ works really nice for all lenses except 10x. There's quite some noise in 10x.
2. HDR+ enhanced introduces rainbow clipping (blue circles) in low light scenes.
3. Night sight takes > 5 seconds and doesn't seem to work that well since normal shot HDR+ images seem better than this.

Have you found a solution for these issues with shamim v20? If you're using some other apk and config that works well for now, do you mind sharing? 🙂
 

andreasarxon

Senior Member
Mar 5, 2011
163
35
Hey Andreas, I tried a few options from the thread and only shamim v20 samsung apk and your configuration works well for me. Thanks for that!

I have a few minor issues though:
1. HDR+ works really nice for all lenses except 10x. There's quite some noise in 10x.
2. HDR+ enhanced introduces rainbow clipping (blue circles) in low light scenes.
3. Night sight takes > 5 seconds and doesn't seem to work that well since normal shot HDR+ images seem better than this.

Have you found a solution for these issues with shamim v20? If you're using some other apk and config that works well for now, do you mind sharing? 🙂
In shamim version i couldnt find a solution about the rainbow clipping so i move to lmc v12 . The problem is with colour . All the versions of gcam, in order to work with our device , must be enable the "leica" mode or else the picture is corrupted. The leica mode put something like yellowish and soft vignette filter on top of the picture that cannot be disabled. I try to experiment with the colour settings to get better colours (for me at least). You can try and experiment with my xml . I think it has good balance between low noise and detail . But im still no pleased with the colours .

*try both xml, i think the second is better
 

Attachments

  • Lmcv12.s22uexynos.arxon.xml
    120.9 KB · Views: 28
  • Lmcv12.s22uexynos.arxon2.xml
    121.1 KB · Views: 58
Last edited:

doum89

Senior Member
Feb 15, 2013
57
3
Is there a gcam/config that makes work astromode?
I Follow. I installed the GCam just to use astrophotography. I came from a OnePlus 7 Pro and GCam worked flawlessly there.
I notice that in my s22 ultra the shutter lag doesn't last more than 2 seconds and of course all the pictures are dark and no stars at all. Any advice?
 

LinardsL

Member
Sep 2, 2022
11
1
I Follow. I installed the GCam just to use astrophotography. I came from a OnePlus 7 Pro and GCam worked flawlessly there.
I notice that in my s22 ultra the shutter lag doesn't last more than 2 seconds and of course all the pictures are dark and no stars at all. Any advice?
In latest Shamim versions i found setting "HDR frames settings" under "Additional". There you can adjust frame count for night mode also. 12 frames gives me 4 sec expo time, 10 - 3 sec.
 

doum89

Senior Member
Feb 15, 2013
57
3
In latest Shamim versions i found setting "HDR frames settings" under "Additional". There you can adjust frame count for night mode also. 12 frames gives me 4 sec expo time, 10 - 3 sec.
Hello, thank you for your answer. I confirm I got Shamim version and put 500 HDR frames on night photos. It takes about 54 seconds to take a picture (an average time that I was used to have on OnePlus 7 Pro) but after 4/5 seconds it stops to acquire the picture. I even remember that besides the shutter lag, during the shot, the camera said It was capturing more light and balancing everything. I this this kind of warns are not present here. Hope the final result will be the same
 

ekin_strops

Senior Member
Apr 29, 2016
1,388
631
Munich
OnePlus 9 Pro
Hello, thank you for your answer. I confirm I got Shamim version and put 500 HDR frames on night photos. It takes about 54 seconds to take a picture (an average time that I was used to have on OnePlus 7 Pro) but after 4/5 seconds it stops to acquire the picture. I even remember that besides the shutter lag, during the shot, the camera said It was capturing more light and balancing everything. I this this kind of warns are not present here. Hope the final result will be the same
This thing with Astro fails exactly the same on multiple different builds/configs.

After 4 seconds, it crashes.

What I figured out is on BGS, If I set the Shutter speed to max 3 seconds, it's fine, but If I set it to 4S or even more, it just never ends doing the photo, it sits in the end at 0:00 seconds and still "capturing", but nothing changes even 10 minutes later. And I'm trying to run the lowest ISO possible, so sometimes 3s of exposure is not enough. Pictures on long exposure are already very noisy, raising the ISO makes it even worse.
 

doum89

Senior Member
Feb 15, 2013
57
3
This thing with Astro fails exactly the same on multiple different builds/configs.

After 4 seconds, it crashes.

What I figured out is on BGS, If I set the Shutter speed to max 3 seconds, it's fine, but If I set it to 4S or even more, it just never ends doing the photo, it sits in the end at 0:00 seconds and still "capturing", but nothing changes even 10 minutes later. And I'm trying to run the lowest ISO possible, so sometimes 3s of exposure is not enough. Pictures on long exposure are already very noisy, raising the ISO makes it even worse.
I'm not a programmer but I hope someone will show up with a solution. Taking those incredibile pictures with just one click is really awesome. Samsung camera is very powerful but not everyone is a pro
 

BoneXDA

Senior Member
Oct 9, 2012
1,720
1,229
Any apk and xml for S22/S22+ Exynos with properly working 3 back lenses and photoshpere?

The one I use installed in May a 8.1.101 version of whatever source with some settings made so main and ultrawide takes perfect photos during that day. Night can be problematic, photosphere doesn't work nor 3x cam sincs its not an S22 optimized version.
 

CiR!X

Member
Nov 25, 2017
5
1
Any apk and xml for S22/S22+ Exynos with properly working 3 back lenses and photoshpere?

The one I use installed in May a 8.1.101 version of whatever source with some settings made so main and ultrawide takes perfect photos during that day. Night can be problematic, photosphere doesn't work nor 3x cam sincs its not an S22 optimized version.
I tried the guide from the Pixel Experience rom and i think its working https://forum.xda-developers.com/t/12-rom-sgsi-exynos2200-pixel-experience-plus.4478655/

Front lense is still not working. How come Shamim's GCam Go work, but not the regular Shamim GCam? Had anyone got the front lense working?
 
  • Like
Reactions: BoneXDA

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    After some searching I found a reliable version of GCam for Exynos.
    It was posted over here https://www.sammyfans.com/2022/05/22/download-gcam-mod-for-samsung-phones/
    I tried Shamim versions before but I had problems where the phone froze after importing settings files.
    I did freeze after switching from camera to video, portrait, ...
    The version in the link above is v13, when I import the accompanying xml file everything keeps working and I can see images on all zoom positions for camera and video.
    But I still get 2X ad 4X zoom instead off 3X and 10X. Does anybody know what to change in the settings to get those zoom values.
    The config also works with V21 of shamim but then I do not have an image for all zoom positions on camera and video.
    So if somebody has a working config for V21 on an Exynos, please post it.
    3
    After some experimenting I have the 3x and 10x telephoto working.
    I can also takes pictures at 3x and 10x telephoto because the display show what I'm abut to photograph but the quality of the picture is not OK.
    First of all the 3x and 10x telephoto.
    This is just a matter of labels as the 3x and 10x work.
    Go to settings - Additional settings - Auxiliary Cameras - Name for camera modules
    enable names for aux lenses
    set telephoto lens to 3x and ID4 lens to 10x
    Second, show display at camera 1x, 3x and 10x
    Go to settings - Advanced - Model Interface
    For all the camera set the Pixel 3 (blueline) instead of Pixel 2 XL (taimen)
    These settings may be saved in the profile files I found but then they are not loaded when importing. It's also possible they are not saved when saving the settings. But this is the way to overcoe this for these settings.
    Now the quality, video is ok, no banding but pictures are not, see included example, i tried a lot of settings but I do not get it right.
    The pictures keep on having banding, if somebody can help me with that?
    [ALLEGARE=completo]5623977[/ALLEGARE]

    LDR disabilitato e SHADE abilitato o LDR e SHADE abilitati insieme e l'effetto arcobaleno scompare.

    Grazie per il link.
    l'opzione sfera non funziona.

    Mod translation via GT:
    LDR disabled and SHADE enabled or LDR and SHADE enabled together and the rainbow effect disappears.

    Thank you for the link.
    the sphere option does not work.
    2

    Ah, I think I know what you were missing. You moved the config file to the folder but you didn't import it in the app, right? Yeah you gotta import it in the LMC app.

    Open LMC, double tap on the empty black space next to the shutter button and choose the LMC-R12-ExyS22U.xml config and tap on import. Do it twice in case it doesn't work the first time, sometimes the importing of config files can bug out.

    short vid here so you can see what it's supposed to look like:

    2
    Does the hdr + work?

    In LMC, both HDR+ and HDR+ Enhanced work.
    In AGC, only HDR+ works. HDR+ Enh will crash
    2
    Please tell me where exactly the config files are placed after installing the apk file?

    For LMC builds, you need to go to the root of your storage, then you will find a folder named "LMC8.4". That's where .xml files go.