GCam for Poco X3

just Nob

Member
Feb 4, 2014
48
9
38
Lägerdorf
I'm sure I'm missing something, but when I take a photo with NGCam_7.4.104-v2.0 in nightmode (maybe in others too) it's only displayed in preview in the lower right for a second and then vanishes. It's also not in gallery. But it's in the DCIM/Camera folder and looks like every other photo. After a few minutes it's also visible in gallery.
I'm having a similar behaviour here, running NGCam 7.14 v.2.0 on ArrowOS.
But it fails to show any picture (located in the DICM/Camera folder) by using the GCam's integrated viewer anyway.
Nevertheless, taking pictures is still OK, and the thumbnail feature (i.e. showing the small preview at the soft button in the GCam's lower right corner) works fine as well.
When trying to open the image viewer by tapping on that button, the image is shown for a part of a second, than NGCam shows a black screen with the camera's elements above, just as if the lenses were covered. To get back the photo preview on the screen, I have to change the lense currently used.

As far as I remember, I had the same (or maybe just a similar) behaviour testing the trCam afew days ago - which isn't surprising due to the fact that trCam is based on NGCam (as mentioned above).
 

sebastianos80

Member
Mar 2, 2011
25
0
21
Płock
[QUOTE = "po prostu Nob, post: 84276899, członek: 5706212"]
Czy ktoś może potwierdzić takie zachowanie?
A może ktoś wie, jak rozwiązać ten problem?
[/ ZACYTOWAĆ]
aplikacja musi być zainstalowana: zdjęcia google.
 

rudix78

Senior Member
Sep 21, 2015
199
67
48
Kwidzyn
I'm having a similar behaviour here, running NGCam 7.14 v.2.0 on ArrowOS.
But it fails to show any picture (located in the DICM/Camera folder) by using the GCam's integrated viewer anyway.
Nevertheless, taking pictures is still OK, and the thumbnail feature (i.e. showing the small preview at the soft button in the GCam's lower right corner) works fine as well.
When trying to open the image viewer by tapping on that button, the image is shown for a part of a second, than NGCam shows a black screen with the camera's elements above, just as if the lenses were covered. To get back the photo preview on the screen, I have to change the lense currently used.

As far as I remember, I had the same (or maybe just a similar) behaviour testing the trCam afew days ago - which isn't surprising due to the fact that trCam is based on NGCam (as mentioned above).
I made few tests. It happened to me only once that after taking picture it was seen in the preview window/circle but I couldn't access it. I cannot replicate this bug. Tonight I took four pictures in night mode and astro (three different options). All pictures were accessable through preview window just while after processing (blue dot went off). All four tonights pictures kept ISO-500 limit whereas my weekend night foto was spoiled because of pumped up ISO-7600 number. Also weekend night photo is too bright, it's almost as picture was taken during daylight.
 

Attachments

Last edited:
  • Like
Reactions: pnin and just Nob

uhhb

Member
May 20, 2019
9
1
3
Update xml for Trcam:

Adjusted denoise.
Optimized time of shot and elaboration.
(equilibrate for nice details and colors)
Hello, I am new here. I have my Poco x3 nfc running on Resurrection Remix. Works great - except for the camera.
So I downloaded your trcam apk. But I don't know how to install or where to download the xml file.
Can you please help me with this?
Thank you
 

just Nob

Member
Feb 4, 2014
48
9
38
Lägerdorf
So I downloaded your trcam apk. But I don't know how to install or where to download the xml file.
Can you please help me with this?
Thank you
Just save them to:
Code:
/storage/emulated/0/trCamera/XMLConfigs
This is the place where XML files are stored when configuration is saved.

To load an XML file, just double-tap somewhere in the black area near the camera's shutter release button.
 

surferbyter

Senior Member
Jul 11, 2007
299
161
73
Hello, I am new here. I have my Poco x3 nfc running on Resurrection Remix. Works great - except for the camera.
So I downloaded your trcam apk. But I don't know how to install or where to download the xml file.
Can you please help me with this?
Thank you
Just install the apk file as if it were a normal application.

Download:

Open the new Camera app that you will find in the drawer.
Accept all initial permissions and the camera already works.

To load the xml just copy the file you downloaded, reattach my in this post, in the path:
/storage/emulated/0/trCamera/XMLConfigs

As soon as done, go back to the Camera application and double tap on the black space between the shutter button and the switch button between the main and front camera, the one with the rotation symbol on the left, a window opens where you can select the xml, if you have copied more than one in the folder you can choose the one you want to try, if you have copied only one, only that will be displayed.
To load it, step on the restore button in the lower right window.
 

Attachments

Last edited:

surferbyter

Senior Member
Jul 11, 2007
299
161
73
I'm having a similar behaviour here, running NGCam 7.14 v.2.0 on ArrowOS.
But it fails to show any picture (located in the DICM/Camera folder) by using the GCam's integrated viewer anyway.
Nevertheless, taking pictures is still OK, and the thumbnail feature (i.e. showing the small preview at the soft button in the GCam's lower right corner) works fine as well.
When trying to open the image viewer by tapping on that button, the image is shown for a part of a second, than NGCam shows a black screen with the camera's elements above, just as if the lenses were covered. To get back the photo preview on the screen, I have to change the lense currently used.

As far as I remember, I had the same (or maybe just a similar) behaviour testing the trCam afew days ago - which isn't surprising due to the fact that trCam is based on NGCam (as mentioned above).
If you are using my xml, both on the ngcam and on the trcam, the option to use an alternative gallery is probably activated. I use two galleries, Gallery Go as a viewer linked to the gcam, the one opens when I click on the preview button of the photo just taken, because it is much faster and lighter than both the stock gallery and Google Photos. I use Google photos anyway, with the synchronization disabled, but it's my choice and you can also keep it active, because when I need to detect more information about the photos it is more complete.
 

Attachments

  • Like
Reactions: just Nob

just Nob

Member
Feb 4, 2014
48
9
38
Lägerdorf
If you are using my xml, both on the ngcam and on the trcam, the option to use an alternative gallery is probably activated.
Thx a lot - that was the decisive hint!

I wasn't aware of that option. But it was the other way around: "use a third party gallery" was disabled, so the standard gallery was set to Google Photos. Due to the fact that I'm running a custom ROM without GApps, I have no Google Photos installed (and I even don't want to!), so the vector for calling the gallery presumably pointed to digital Nirvana...
I switched on that option, et voilà...!

This also explains why I hadn't any problems during the short period I was running stock MIUI ROM on my Poco X3.
 
  • Like
Reactions: temporarium

rudix78

Senior Member
Sep 21, 2015
199
67
48
Kwidzyn
Thx a lot - that was the decisive hint!

I wasn't aware of that option. But it was the other way around: "use a third party gallery" was disabled, so the standard gallery was set to Google Photos. Due to the fact that I'm running a custom ROM without GApps, I have no Google Photos installed (and I even don't want to!), so the vector for calling the gallery presumably pointed to digital Nirvana...
I switched on that option, et voilà...!

This also explains why I hadn't any problems during the short period I was running stock MIUI ROM on my Poco X3.
Ha, ha that's common problem among new gcam 8. There is no such button to activate third party gallery.
 

laspa

Member
Sep 21, 2018
8
1
3
I use trСаm on rom arrow, unfortunately I have a problem with saving photos - a large number of photos are not saved in the dcim folder, did anyone have a similar problem and know the solution? Write permission granted.
 

just Nob

Member
Feb 4, 2014
48
9
38
Lägerdorf
I use trСаm on rom arrow, unfortunately I have a problem with saving photos - a large number of photos are not saved in the dcim folder, did anyone have a similar problem and know the solution? Write permission granted.
I'm also on ArrowOS (Vanilla + microG), but haven't recognized such an error so far.
 

galih_elins

New member
Jan 16, 2021
1
0
11
Thanks for sharing. As for still images I prefer Ngcam as it produces higher resolution pictures in 18/9 ratio and has more options to play with. So I was more interested in it's video recording performance.

Although I couldn't get 4K vidos (despite toggling ultra-high resolution video) EIS works in 1080P. I compared it with latest Arnova's build and I see much better stabilisation (to be honest in my opinion stabilisation doesn't work at all in newest Arnova gcam despite cropping videos in both Video EIS and Video EIS modes). So big + for Urnyx regarding video stablilisation in 1080P. FYI I run custom ROM (and my phone may not have all camera optimisations stock ROM has and this may be the reason stabilisation does not work for me on Arnova's gcam 8).

PS. I think something is messed up and 4K video works on wide angle camera solely.
I'm using Nikita 2.0. Still Image works fine, but EIS video stabilization is not working. I'll try Urnyx..