Gear Fit Manager Patched for Lollipop

Search This thread

soleymani

New member
Oct 22, 2015
2
0
android 5.1.1

Hello
I rooted phone (Samsung galaxy mega 5.8) to Android 5.1.1 Cyanogen I just have a problem, I'll get this error in gear fit manager and don’t set to my gear fit watch please help me to resolve my problem.
I’m tested all gear fit manager programs in this forum and not Result
:( :confused: :(
 

Xochicoatzin

New member
Oct 27, 2015
2
0
Sony Xperia Z2 5.1.1

Hello. Ive tried all the APKs here and I can get it connected by bluetooth but I can´t get any notifications, anyone can help me?
 

soleymani

New member
Oct 22, 2015
2
0
gear fit manager for cm12-1 Cyanogen Mod

Try to use OpenFit app
Thank you, I've used open fit And working properly But The possibilities range
Please Introduce gear fit manager that is compatible with my phone,
Specifications:
Phone: Samsung mega 5.8
Software: cm12-1 Cyanogen Mod (android 5.1.1)
Gear fit software version: R350XX0BOA2
 

intoinside

New member
Jun 11, 2014
2
0
Hi,

finally I managed it to get the Gear Fit working with my brand new Z5 Compact.
Here are the details:

Device: Sony Xperia Z5 Compact with Android 5.1.1.
Gear Fit Firmware: R350XXUOBOA2

Setup of Apps:
- GearFitInstaller.apk v.3.9 (source: APK extracted from Galaxy S6 with Stock ROM 5.1.1.) - attached to this post - installed at first
- Gear Fit Manager 1.1117.03.06 (source: gearmanager_lollipop51_test_2_signed - thanks to zwegnet koalala)
- Samsung sHealth v 4.5.1.0011 (source: Google Play Store)

Order of Installation:
  1. GearFitInstaller
  2. GearFitManager
  3. sHealth

my findings:
Works:
- Change config on Gear Fit Manager
- Find my device
- Media control
- Sync of missed calls
- Workout-Tracking

Don't work:
- Any notification (appointment , incoming calls, Whats app, Threema)
- Sync with Samung sHealth
○ SHealth is telling that synced, but no data is shown there

Any suggestions to get notifications and sync with sHealth running!?

Thanks,
dpoole

Same situation for me. Google Nexus 4 with Purity ROM (5.1.1)
Same feature works and also Notification (yeeeeahh!!!). To get it work, i enabled GearFitManager in system settings.
Same feature don't works (also for me SHealth is telling that synced, but no data is shown).

Anyone was able to get sleep monitoring data? Smart alarm?
 

Note 4 user

New member
Dec 9, 2015
2
0
Hi,
Could Someone attach the latest working gearfit manager for samsung note 4. The one im using does not work peoperly. Cant receive calls and messages. Thanks.
 

CPT Crunch

Member
Jun 17, 2014
11
5
Knoxville Tennessee
Dude, you are SO my hero!! I couldn't get my Gear Fit to work with my new Note5, and I tried everything!! This worked perfectly the first time... the first time!! I don't have to throw my Gear fit away after all. Yay!
 

protonspark

Member
Sep 5, 2013
6
0
I got everything working but
1- the weather update comes default in Fahrenheit, any way I can make it Celsius ?....
2-Time sync doesn't happen automatically, you have to disable and enable 12HR check box to sync..........
3-Most app notifications don't go to watch after adding from +menu........
4-There should be an option to automatically connect, user has to connect manually every time.........
5-Is there anyway to use apps like watch styler to set clock themes through openfit without need for gearfit manager?........

I love the app. Great work.


Sent from my D5833 using XDA Free mobile app
 
Last edited:

coldkyle1

New member
Dec 13, 2015
1
0
LG G4 & Gear Fit works Great!! with the package on post 1

just got my lg G4 in the mail and the package on post 1 instantly worked for my gear fit identically to the samsung note 3 i was previously using. Yay! Thank You so much.:)
 

CNemo7539

Senior Member
Feb 3, 2008
178
6
Is anyone able to sync pedometer with standard VZ rom 5.1.1 and rebuild.apk version.
Everything appears to be working except step count syncking
 

Gator696

New member
Jan 5, 2016
2
0
I have a BLU studio c 5 + 5, i am so far unable to find a gear fit manager application that will allow me pair with my gear fit. my phone currently runs android 5.0. I just bought the gear fit over Christmas, please help!
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 39
    Hi there guys,

    Since Samsung are just idiot and his app isn't working with Android Lollipop i had to modify 'Gear Fit Manager' to get it working on my Motorola Moto X with Lollipop, so download and use it with your Android Lollipop without weird crashes!.

    Greetings XDA!
    7
    Can gear fit be synced with HTC ONE M8 with android v 5.0.1 ??

    I tried installing all apk files given here in XDA but wen i try connecting it is failing.

    Please help

    I don't know if anyone has it working with the M8 or not with Lollipop, but here is what works for me on the Nexus 5:

    1. Make sure the Gear Fit device is on this firmware version: R350XXU0BNG2
      If you need to change the firmware, read the following:
      How to get into download mode: LINK
      Directions to flash the new firmware to the Fit: LINK
      Direct link to the R350XXU0BNG2 firmware: LINK
      In Odin, put that TAR file in the CSC box and flash (with Fit in download mode)
    2. On your phone, Uninstall and clean up ANY remnants of Samsung or Gear software. Open App info, force stop the program clear cache, clear data, uninstall for all of those apps.
    3. In bluetooth settings, forget/unpair the Gear Fit for now
    4. Unzip and install GearFitManager.5.apk LINK
    5. Unzip and install gearfitmanager_no_crash.apk LINK
    6. Open Gear Fit Manager, pair, accept all their Rules and your should be set. Beware that SHealth won't sync.
    I didn't need any build.prop edits, so first try with your normal build.prop file.

    EDIT: Here are the links to the posts where the APK files were originally posted.
    post for GearFitManager.5.apk (Thanks inportb)
    post for gearfitmanager_no_crash.apk (thanks windelwilli)
    5
    Patched last!

    Hi again!

    I see people doesn't like version 1.48, so i patched the latest one.

    Now Music Player works, and some things have been modified to be working at 100% on Lollipop. (They were using ****ing weird APIs for MultiSim use on Gear Fit that crashes on Lollipop... ****in' idiots...)

    I think Samsung should pay me for this, or something. I work more than his engineers.
    4
    Well I installed the apk linked from the OP and it's showing 1.70 on my device.

    That is only your fault that you can't use search, not mine.
    3
    So use this file Please and write report for other users please....
    https://www.dropbox.com/s/3warm904lknu52y/gearfitmanager_no_crash.apk?dl=0

    Hope it's usefull now