Gear Watch Designer problem

Search This thread

g0tch

Senior Member
Dec 29, 2009
152
13
Somerset
Smart Watches
Recently I had updated Java and since then,I’ve not been able to open GWD. It appears that it can’t find the necessary javaw.exe file.

I have uninstalled and reinstalled both Java and GWD to no avail. Anyone come across this problem or anyone has an idea how to fix it please?

Kind regards,
 

Attachments

  • GWD.PNG
    GWD.PNG
    14.3 KB · Views: 406

StStefan

Member
Nov 10, 2017
28
12
You can try to install JDK (if you have only JRE) and also to define the java home in your windows variables.
 

StStefan

Member
Nov 10, 2017
28
12
I don't know what OS you have but I would try to:
- first, restart the computer (I assume you already did that)
- disable the firewall, antivirus;
- stop other processes similar to Apache, database servers or other programs that could use java (eclipse etc.)

Try to launch GWD. If it's not working take a look at the task manager and see if it's running. If it's there, stop it and start it again.

Also, I would add in Environment Variables -> System Variables:
Variable name: JAVA_HOME
Variable value: C:\Program Files\Java\jdk1.8.0_45 (your location to JDK)

After you add the variable, in the same place edit Path variable and add: ;%JAVA_HOME%\bin
Note that it should be ; between paths

No other ideas at this point. Good luck!

---------- Post added at 14:38 ---------- Previous post was at 13:52 ----------

Sorry, I missed your image when I posted. The good news is that you can apply everything from above.

I would try first with the JAVA_HOME. It seems that GWD cannot find your java path.
 

g0tch

Senior Member
Dec 29, 2009
152
13
Somerset
Smart Watches
I don't know what OS you have but I would try to:
- first, restart the computer (I assume you already did that)
- disable the firewall, antivirus;
- stop other processes similar to Apache, database servers or other programs that could use java (eclipse etc.)

Try to launch GWD. If it's not working take a look at the task manager and see if it's running. If it's there, stop it and start it again.

Also, I would add in Environment Variables -> System Variables:
Variable name: JAVA_HOME
Variable value: C:\Program Files\Java\jdk1.8.0_45 (your location to JDK)

After you add the variable, in the same place edit Path variable and add: ;%JAVA_HOME%\bin
Note that it should be ; between paths

No other ideas at this point. Good luck!

---------- Post added at 14:38 ---------- Previous post was at 13:52 ----------

Sorry, I missed your image when I posted. The good news is that you can apply everything from above.

I would try first with the JAVA_HOME. It seems that GWD cannot find your java path.

Thanks, you must be the one helping me on the GWD forum. I've just posted rely there with image. Hope it can be sorted.
Thanks again.
 

g0tch

Senior Member
Dec 29, 2009
152
13
Somerset
Smart Watches
Solved

After days of trying and doing all suggestions to no avail, I now have a working GWD.
The simple solution was to go to my Java folder and copy the jre1.80_151 folder into GWD.
I then renamed it to just jre and it started to work.
Many thanks to you all trying to help.
Best regards,
 
  • Like
Reactions: tonycfc

macshade

Member
Jun 20, 2006
20
5
Thank you now it works.......

After days of trying and doing all suggestions to no avail, I now have a working GWD.
The simple solution was to go to my Java folder and copy the jre1.80_151 folder into GWD.
I then renamed it to just jre and it started to work.
Many thanks to you all trying to help.
Best regards,

Perfect!
 

techlogik

Senior Member
Aug 23, 2006
1,853
305
Yeah, latest Beta dated November keeps locking up. Maybe it launches and works after a few minutes. Says not responding. Once it does work, this happens on two different computers, if I Build, then push to the watch, it works 1 times. Then do some tweaks, rebuild and push again, just locks up the program and says not responding. Have to force stop, relaunch, wait like 2-3 minutes for it to start up...ridiculous.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Solved

    After days of trying and doing all suggestions to no avail, I now have a working GWD.
    The simple solution was to go to my Java folder and copy the jre1.80_151 folder into GWD.
    I then renamed it to just jre and it started to work.
    Many thanks to you all trying to help.
    Best regards,