[General Discussion] QF001 (ROCO K706) Head Units with UIS 7862s (not FYT based) [read first post first]

Search This thread

Meteordust

Senior Member
Feb 3, 2014
286
119
Zurich
8888/2 worked for me. Big thanks for that!

I will check the speaker assignment on the device. I will report. If need be I will install an amplifier for the loudspeakers.

In any case, thanks so far for the help.

I have one last question. How can I reactivate the weather app?

What I know about that....instruction where to connect to wifi and push the weather symbol on the screen...also that you needed to rename your wifi hotspot, but I managed to activate it without that renaming.

This was the instruction:

After you update everything, we also need to enable the Weather APK, please connect your cell phone wifi hotspot name as FYQP5QRG and YOU connect the player wifi to your cell phone hotspot, and then it will die Weather - Activate APK. If you are using an iPhone, please don't connect your iPhone to our player via Bluetooth before you enable Weather APK. This is very important. After enabling the Weather APK, you can connect your iPhone normally via Bluetooth.

Another thing, on first page on this thread you have a link to the firmware, you find information there....or the newly found webste https://autofather.com/
Here you can also find handfull information.
 
Last edited:

buggme

Member
Feb 17, 2012
38
0
I have been following this forum for a couple of weeks now.

My unit has 4G LTE (or is listed as).

It see my Sim card and even shows AT&T. I tested with different APN, reboot, factory reset after messing around in Factory 4455.. and I still have no cell service bars.

It only shows Emergency calls only.

I have even updated the firmware and MCC. Went to the AT&T store and swapped out the Sim cards for the newer one. Drove over close to an tower. Tried 3 different Sim cards. All work in my tablets/phone. With no luck.

Any special settings I'm missing.

On a different note. I'm using the stock Launcher. But my GPS speeds are in km/h. Dose anyone know how to change it to us/Mph. Or have stock Launcher with mph.
 

simetra1

Member
Mar 9, 2023
15
2
Hello friends. My computer does not see the device. I will operate with adb commands. My computer is win11. How can i solve the problem.
 

miroslaw.wiertel

Senior Member
Mar 26, 2023
69
19
Hello. I have hizpo s8. When I engage reverse gear the sound goes off. Does anyone know how to make the sound turn on when I turn on reverse?
 

Elrathias

Senior Member
Mar 16, 2023
90
28
I have been following this forum for a couple of weeks now.

My unit has 4G LTE (or is listed as).

It see my Sim card and even shows AT&T. I tested with different APN, reboot, factory reset after messing around in Factory 4455.. and I still have no cell service bars.

It only shows Emergency calls only.

I have even updated the firmware and MCC. Went to the AT&T store and swapped out the Sim cards for the newer one. Drove over close to an tower. Tried 3 different Sim cards. All work in my tablets/phone. With no luck.

Any special settings I'm missing.

On a different note. I'm using the stock Launcher. But my GPS speeds are in km/h. Dose anyone know how to change it to us/Mph. Or have stock Launcher with mph.
Did you connect the right antenna to the 4g nub?
 

Elrathias

Senior Member
Mar 16, 2023
90
28

Attachments

  • 7440062.jpg
    7440062.jpg
    129.4 KB · Views: 49

Meteordust

Senior Member
Feb 3, 2014
286
119
Zurich
@Dekdek1 @Clandaries @Clyde72 @Aaantonn

Received my DAB+ dongle, works totally fine with DAB Z, reception good, maximum green bars, classified as best reception, and all the channels from my area/ country and some of neighbour countries, around 100+ channels, not living close to my country border to have even more.

Now the two USB ports are used, recording front cam and DAB+ and no voltage problems notable, I'm using almost the maximum capabilities of this HU, including can bus and all buttons on steering wheel working, headlight works automatically in my car, it dims screen and put lights on of the buttons of this HU, in my picked colour.

DAB Z works like the FM radio, it keeps running in background when using other app like navigation, have it integrated in my Agama launcher.
Best thing, can cold start unit to home screen, my Agama launcher, and DAB Z starts in background and playing, this was the most annoying with FM radio or missed the setting for that, it always went to the screen of the FM app when I didn't close the in the background running FM radio app before taking car key out of the ignition switch.

Must say I also fitted a shark fin antenna, combined GPS, DAB+ and 12V amplified FM, GPS fix in 15 seconds and Agama shows 20 tot 25 satellites, accuracy 2 meters in GPS test app.

So really don't understand why @Clandaries had all this problems he wrote in several replies on this thread, this unit rocks, never had in 4 months a crash of the firmware, CPU temperatures depends on how cold/warm my car is, but stable between 35 to 50 degrees.

More then happy, all I wanted is achieved with this HU, I'm going to take a rest now and enjoy it :cool::ROFLMAO:
 
Last edited:
  • Like
Reactions: Clyde72

Clyde72

Senior Member
Dec 3, 2022
542
181
Samsung Galaxy A70
Lenovo P11
@Dekdek1 @Clandaries @Clyde72

Received my DAB+ dongle, works totally fine with DAB Z, reception good, maximum green bars, classified as best reception, and all the channels from my area/ country and some of neighbour countries, around 100+ channels, not living close to my country border to have even more.

Now the two USB ports are used, front cam and DAB+ and no voltage problems notable.

DAB Z works like the FM radio, it keeps running in background when using other app like navigation, have it integrated in my Agama launcher.
Best thing, can cold start unit to home screen, my Agama launcher, and DAB Z starts in background, this was the most annoying with FM radio or missed the setting for that.

Must say I have a shark fin antenna, GPS, DAB+ and FM, GPS fix in 15 seconds and Agama shows 20 tot 25 satellites, accuracy 2 meters in GPS test app.

So really don't understand why @Clandaries had all this problems he wrote in several items, this unit rocks.

More then happy now, all I wanted is achieved.
Thx for the update, will still measure the ports though... Enjoy the music!
 
  • Like
Reactions: Meteordust

Meteordust

Senior Member
Feb 3, 2014
286
119
Zurich
I have resettet the head unit and will test if it just was a failure.

Thanks for the update.
And my experience, only install one DAB+ app, like DAB Z, for instance when you install two DAB apps and one is active and other one is running in the background is not the way, it gave me a conflict.
These DAB apps auto start/ running in the background, at least the ones I had installed.
 
Last edited:

Aaantonn

Senior Member
Feb 5, 2023
149
50
У меня есть наш (Ossuret S7) и я на правильном форуме, и этим я ответил на ваше утверждение, что тоже Teyes такие же, как и у большинства производителей. Как видите (фото добавлено), они также делают больше за большие деньги.
Я рад, что у вас есть охлаждение, но у Тиаса в том же корпусе, что и у меня и у большинства других людей нет того, что вы положили на фото, у него такой же корпус 1-1, не надо людям сказки рассказывать.
@Dekdek1 @Clandaries @Clyde72 @Aaantonn

Received my DAB+ dongle, works totally fine with DAB Z, reception good, maximum green bars, classified as best reception, and all the channels from my area/ country and some of neighbour countries, around 100+ channels, not living close to my country border to have even more.

Now the two USB ports are used, recording front cam and DAB+ and no voltage problems notable, I'm using almost the maximum capabilities of this HU, including can bus and all buttons on steering wheel working, headlight works automatically in my car, it dims screen and put lights on of the buttons of this HU, in my picked colour.

DAB Z works like the FM radio, it keeps running in background when using other app like navigation, have it integrated in my Agama launcher.
Best thing, can cold start unit to home screen, my Agama launcher, and DAB Z starts in background and playing, this was the most annoying with FM radio or missed the setting for that, it always went to the screen of the FM app when I didn't close the in the background running FM radio app before taking car key out of the ignition switch.

Must say I also fitted a shark fin antenna, combined GPS, DAB+ and 12V amplified FM, GPS fix in 15 seconds and Agama shows 20 tot 25 satellites, accuracy 2 meters in GPS test app.

So really don't understand why @Clandaries had all this problems he wrote in several replies on this thread, this unit rocks, never had in 4 months a crash of the firmware, CPU temperatures depends on how cold/warm my car is, but stable between 35 to 50 degrees.

More then happy, all I wanted is achieved with this HU, I'm going to take a rest now and enjoy it :cool::ROFLMAO:
Can I have the name of what you bought or a link? I wonder what kind of antenna and adapter.
 

Meteordust

Senior Member
Feb 3, 2014
286
119
Zurich
Can I have the name of what you bought or a link? I wonder what kind of antenna and adapter.
Of course,

Bought on Ali******

Antenna, Superbat Car Roof Top Shark Fin Antenna, this antenna is very well build, not like the cheaper ones you can buy on Ali******, be sure your roof is flat, so not curverd where you fit the anttenna.

Screenshot_20230402_044850_AliExpress.jpg


DAB+ Dongle, SNRG DAB UDB Adapter, type DAB+ 009S.

Screenshot_20230402_044611_AliExpress.jpg


DAB+ app that comes with this Dongle is limited in the settings, didn't installed that, I'm using DAB Z.

Sorry,my ali***** app can't copy the links or webpages somehow, so you need to search them.
 
Last edited:
  • Like
Reactions: Aaantonn

Clyde72

Senior Member
Dec 3, 2022
542
181
Samsung Galaxy A70
Lenovo P11
Of course,

Bought on Ali******

Antenna, Superbat Car Roof Top Shark Fin Antenna, this antenna is very well build, not like the cheaper ones you can buy on Ali******, be sure your roof is flat, so not curverd where you fit the anttenna.

View attachment 5878417

DAB+ Dongle, SNRG DAB UDB Adapter, type DAB+ 009S.

View attachment 5878419

DAB+ app that comes with this Dongle is limited in the settings, didn't installed that, I'm using DAB Z.

Sorry,my ali***** app can't copy the links or webpages somehow, so you need to search them.
Quite some extra installation but must be way better reception than a front window antenna thingie...
 

Top Liked Posts

  • 2
    yesterday i disconnected the LTE antenna (HU oem), and... the reception didn't change. Even without antenna i can connect to the net via LTE (wifi was off). Then i connected with OEM VW fin antenna, with no change in reception. Weird for me. Now i want to test it in road conditions.

    Next change i made. I have glovebox with wentilation (if the ac is working then i have cool air in there) so i connected air tubes and guide one to the back of HU, near the fan. Also i change a air direction, to fan blow inside HU. First tests look good obviously. Before this change, the HU fan blowed constantly and normal thing was 55-65 degree in CPU (condiotions: radio and google maps was on, nothing else, outside temp 22-23 C, AC off, car fan on, on the lowest speed, inside temp was set to 20C). Now there is ca. 42-46 C in the same conditions.
    1
    You can update firmware to 0508 ( MCU you already have last available) read post back to find download links.

    AC climatic control:
    brand car\model?
    You are already lucky if you can handle this with your car, via HU canbus.
    In most cases nothing works for AC control (German car branding doesn't work...surely with BMW).
    1
    The weird thing is that it works (show the good information) until i close Climate control and turn it back on , after that it just stop showing information and if i go to cliamte control app on the head unit it show like the Climate control stayed off.

    Car : Volkswagen Golf 6 1.6 TDI 2011

    I'll try the udapte and see if it fix the issue, btw there's no OTA update on this unit ?
    It's already anomalous that ssomething with AC works randomly for you, lucky... :)

    I still think that AC control with these units has MANY bugs in its management via canbus, the Chinese still haven't figured out how to deal with canbus strings for this, in particular for DE brand cars (with BMW nothing really works for AC).

    OTA: no users (I think) have ever had OTA updates on these HU.
    1
    Hi,
    probably my zip is corrupted...
    Since the bootanimation factory sw when I converted .mp4 to .gif altered the resolution of the frames too much, I had used the BootAnimator.exe sw instead (a user of the site had created this).
    It was convenient to use that as it allows you to resize final frames images to the desired size...but maybe it creates corrupted final zip.

    You are very kind...if I don't bother you too much can you fix my animated boot and then I try it on HD?

    Download here: https://www.mediafire.com/file/er2erjm4pmil8v6/bootanimation.zip/file

    Thank you so much! (y)
    This should work, dimensions, numbers looks okay.

    My create file is a bigger zip file so assume it was wrongly compressed.
    1
    Has anyone successfully used CarLetter and wireless Android auto?
  • 9
    Guys another good news:
    Today I've got the radio audio output from NavRadio+ working.
    So the most problematic parts of the porting are solved.
    Now it's just a matter of time to add the seek and autoscan functions and to fine tune everything.
    I'm pretty happy for the progresses:)
    6
    Hi guys,
    I just wanted to let you know that the porting of NavRadio+ on this units is going better than expected.
    I already can change frequency, receive RDS data etc.. i can't control the audio focus right now but I'll figure it out sooner or later.
    I'd like to ask you some questions:

    1. Have you ever seen, on the original app, the RDS text broadcasted by radio stations with song name or other infos? Not the name of the station.
    2. How do you set LOC or DX in the original app?
    3. Do you think the AF and TA function work well on the original app?
    Thank's to anyone who reply ;)
    5
    The flash was successful. Only the HU indicates that I have 6GB and that should be 8, so no idea why, but think it has always been 6. If you open the HU, you can also see that there is a sticker on it with the data of the device, there you also see 6 + 128GB, so the same story as android 10 (fake12) Direct update to 20230414 did not work (again a checksum error, but was able to do a full reset) so I updated the HU in steps with the *major" updates with auto update, that went well. Recovery procedure was easier than I thought, with some more extensive explanation from Vėžys, so thank you @Vėžys 🙂 Glad I have a well-functioning HU to update it again, thanks to the people on this forum 👍😊
    3
    Hi Everyone,

    Now that I got the steering wheel controls setup (Camry 2012 LE) my last thing to install is the backup camera. There is a wire provided with two blue wires and a RCA video. I assume I connect to that? The reason I ask is because there is a CVBS-IN and some videos say to use that. Also I am not sure which wire I need to activate the camera. There is a purple wire but it doesn't have any English writing on it.

    I assume I still need to tap into the positive and negative wires for the reverse light in the trunk of the car? Also any good recommendations on Amazon?

    Thanks

    View attachment 5920055View attachment 5920057View attachment 5920059View attachment 5920061
    If it's like for my car, and in yours it works via canbus:
    Power the rear cam via the +12v positive input taken from the reverse lamp, and connect the video signal from the rear cam to the SPECIFIC yellow RCA connector of the radio (the one that also has the 2 short blue wires, which are the antennas for BT and Wifi).

    If you have canbus, automatically when you engage reverse gear, the radio switches to the video signal coming from the rear cam and you see on the monitor what is seen behind.

    NOTE:
    the radio supports both low resolution and high resolution rear cam (AHD) I recommend you to buy AHD rear cam.
    You have to set the right AHD resolution in the radio settings afterwards.
    3
    Yes me Too… px5 px6 with dsp Amazing Sound also cheap Chinese Radio but These one male nothing what has anything to do with dsp
    Do you even know what a DSP is? It's just digital processing and not analog and that's it! Take apart your radio and see what you have there, maybe after that don't talk nonsense. You all had 10 different radio tape recorders, but for some reason you are such specialists who bought this one. What kind of android did you have with aliexpress for $ 1000, it's interesting to see.)) I myself disassembled this radio tape recorder, like many here on the forum, and I can say that one of the top UIS 7862S processors is here. Chat with your friend over a cup of coffee, and don't spit out your negativity here.
    I'll even attach a photo for you two idiots!
    I apologize to the rest of the participants for my statement, but the endless messages are already boring. The branch was not created in order to write what a bad radio.
  • 17
    Hello all,

    it seems that there are some QF001 owners out there but not much informations. So i will try to collect everything and put it at one place.

    The original manufactor is shenzhen jitu technology co. ltd.

    These units are sold from Ossuret, Hizpo and other brands. This are the sellers specs:
    specs.JPG


    The Android 12 is fake which is Android 10 in reality.

    I have the 8/128GB Version myself:
    Screenshot_20221129-085346.png


    Codes for the factory settings menu:

    Different firmware versions are inside this thread. Take care of the right MCU file and beware that clear user data is enabled by default on update. There is also a dedicated firmware thread: https://forum.xda-developers.com/t/...s-with-uis-7862a-7862s-not-fyt-based.4541261/

    Dedicated thread for gaining recovery access: https://forum.xda-developers.com/t/...uret-s4-s8-uis-7862-headunits-no-fyt.4538107/

    Beside the faked Android 12 Version the head unit seems to be a good bang for the buck. I´ve paid around 230 Euros including VAT and shipping. The unit runs stable and powerful so far. Everything works as expected. The Android is a bit downcutted by the manufactor. There are no text notifications in the statusbar e.g. But i can compensate that with widgets.

    Against the description android auto works wireless with my Xiaomi Mi10t pro. So that's also nice to have.

    Tweaks, mods and others:
    - my wire harness was labeled wrong. Key 2 and Key GND were swapped. So better check the cables before connecting. For me the correct wire names/functions were in the printed manual.

    - replacement fan that fits my model: Sunon MF35101V21000UA99

    - there's a sleep whitelist in the factory settings menu that prevents apps from being killed in standby mode (ignition off). That's very useful. I've whitelisted Google maps e.g. and don't lose my programmed route anymore if i turn off the engine for a short stop.

    - tasker trigger for warm boot: detect any USB device connected. (You have to plug in something into the usb port, dashcam or pendrive e.g.)

    - the status bar only shows a few symbols and no text notifications. Therefore I use a notification widget in combination with nova launcher. This way I can see all notifications in a widget which would be at the status bar originally.

    - wireless ADB is enabled by default with root user. 🎉 The port is 9876. ( I've found that inside the build.prop)

    - if you want to have a look inside the firmware you can use a rom kitchen tool like CBR

    - how to change the boot logo:
    1. If your player is 1280*720 screen, you need to rotate the picture 90 degree, and cut it into 720*1280 size, transform the picture to .BMP format.
    2. If your player is 1024*600 screen, you need to cut the picture to 1024*600 size, transform the picture to .BMP format.
    3. copy the picture into your Udisk root path, and then connect Udisk to the player. follow the steps settings-factory-8888-Logo set-then you can see your picture and select it- click update logo.
    - how to change boot animation: https://forum.xda-developers.com/t/...uis-7862s-not-fyt-based.4525675/post-88086835

    - enhance the microphone and call quality by using the external microphone and disable the internal microphone by masking two pins of a ribbon cable. It's explained inside this thread (link to post will follow)

    - GPS tweak: https://forum.xda-developers.com/t/...uis-7862s-not-fyt-based.4525675/post-88112693

    Known issues:
    - "hey Google" (activate the assistant by hotword) doesn't work
    - no car speed dependent volume control (manufacturer says it would be implemented later)
    - the firmware is a debug release which is a serious security risk (every app or malware can get root access through ADB shell). On the upside you can also get root access through ADB and do everything you want

    To be continued...

    Cheers
    blue_one
    9
    And now a few more!

    1122 / 2211 - both popup a bubble with chinese text. I thought they were the same at first but they have different characters. (They both have the word “log” in it)

    6655 - opens up a screen that appears to be the same as 555666 but these are also in Chinese so I don’t know if there are differences. Notably when you enter this menu with either code it will record a snippet of audio from the mic and play it back.

    4455 - engineer mode (lots of stuff in here to explore, includes adb shell)

    5544 - gps stuff

    1212 - notification that says “slog copied to unkown”

    2121 - seems to just take you home

    45645600 - download mcu file
    9
    How did you discover the codes?
    Just by trying a bunch of different codes and looking for patterns. Starting by looking at the codes we already knew I discovered they are all a repeating sequence of digits that are adjacent to each other on the keypad. Once you find a pattern there’s usually another code that uses the same pattern somewhere else on the keypad. If you actually type in the codes and look at the physical pattern they make you’ll see what I mean. For example 114477 is just the digits in the left column of the keypad going down. 336699 is the same pattern in the right column. And then some codes are just variations on top of that, like doing a code in reverse (which we already knew) as well as adding 00 to the end of some. This is how I discovered all the codes. Once I’d find one code Id try that same pattern in all places and variations. Simple as that! I’m sure there’s more patterns yet to be discovered so try different ideas out and see what you can find. With many people using these strategies I’m sure we can discover more! I may have even missed a few using the patterns of ones I found.
    9
    Guys another good news:
    Today I've got the radio audio output from NavRadio+ working.
    So the most problematic parts of the porting are solved.
    Now it's just a matter of time to add the seek and autoscan functions and to fine tune everything.
    I'm pretty happy for the progresses:)
    8
    For whom that's interested and is annoyed that display time is out of sync with atomic network clock time.

    Myself don't use 4G network, but WIFI hotspot from phone.

    Each time when I opened the GPS test app, time changed and was out of sync by 2 to 4 minutes, also when I forgot to put hotspot on my phone on, after that it was taken the GPS time sync by default after startup,
    So first taken my right hotspot network time and changed 30 seconds later to the out of sync GPS time, it was also out of sync with my OEM Opel board computer display.
    With some hassle I could changed that back but needed to be sure that hotspot was always on before starting the car.

    Think I found a solution.

    Note, I don't use sleep mode, always have a fresh cold start, unit starts up with firmware date and time, 09-01-2023, 12:05:54.

    After going in the factory 5544 GPS setting, changed on first tab screen "agps" the server SUPL host to supl.google.com, changed port to 7276 (seems secure port), but you also can leave it on 7275, then tab screen "information", on the bottom page changed the satellites to GPS, Glonass, Galileo, my problem disappeared.

    My unit correctly shows the time now, after a start-up it is in sync within 1 second compared to atomic clock, with or without hotspot, mean also without network connection it syncs with GPS satellites the time correct.
    The AGPS SUPL was using the Chinese host (supl.qxwz.com) and preferred what it looks some Chinese satellites for Glonass and Galileo and somehow the Chinese GPS time is inaccurate.

    Rather Google then the Chinese that follows me ;)