• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question Google Pixel 6 Pro and the Starbucks App Not Working?

Search This thread

t3hbutt3rs

New member
Dec 12, 2010
2
0
Got my 6 Pro yesterday, and after trying to log into the Starbucks app, the only error I get is "A system error has occurred. Please try again later" I can even type in random characters and numbers into the username and password field too, and still results in the same error. App version 6.13.1 Tried on cellular (Verizon) and wi-fi. Uninstalled, reinstalled, etc. Opened a ticket with Starbucks. Is anyone else experiencing this issue?
 
Got my 6 Pro yesterday, and after trying to log into the Starbucks app, the only error I get is "A system error has occurred. Please try again later" I can even type in random characters and numbers into the username and password field too, and still results in the same error. App version 6.13.1 Tried on cellular (Verizon) and wi-fi. Uninstalled, reinstalled, etc. Opened a ticket with Starbucks. Is anyone else experiencing this issue?
I had the same issue. Just thought starbucks was having a problem. Apparently not. Just tried it again and can't log in. Via T-Mobile and Wifi as well.
 
Got my 6 Pro yesterday, and after trying to log into the Starbucks app, the only error I get is "A system error has occurred. Please try again later" I can even type in random characters and numbers into the username and password field too, and still results in the same error. App version 6.13.1 Tried on cellular (Verizon) and wi-fi. Uninstalled, reinstalled, etc. Opened a ticket with Starbucks. Is anyone else experiencing this issue?
So if you log into the mobile web site, go to menu - account - card management, you can pay from there or add money to your card.

It's a workaround anyway. You can also install the PWA app from the chrome menu at that point as well. That will create an icon in your launcher which will open up to the right page/screen to pay from.
 
  • Like
Reactions: t3hbutt3rs

JessRevolvingHearts

New member
Oct 28, 2021
1
1
Just chiming in to say that the same thing is occurring on my Pixel 6 (not pro). Tried reinstalling the app, clearing cache/storage, changing my password to only have one special character (multiple reports of this being an issue on iOS at least), and rebooting.

EDIT: Also tried on normal home Wi-Fi, T-Mobile, and Starbucks Wi-Fi.

Currently running version 6.13.1 apparently. I see multiple reviews on the Play Store also with the exact same problem. I've left my own feedback there to hopefully get their attention.

I also used the web app as a workaround this morning.
 
  • Like
Reactions: t3hbutt3rs

Josh.haveman1

Member
Oct 28, 2021
6
1
Not working on my 6 Pro either. I don't think it's an issue with android 12, the app works fine on my pixel 4xl on Android 12. Maybe it has to do with tensor?
 

plasticarmyman

Senior Member
Apr 13, 2011
627
172
Long Beach
<insert comment here about supporting your local coffee shops>

all jokes aside sounds like an Android 12 issue, reach out to the developer email from the Play Store page and also I have found leaving a review on the Play Store explaining the issue sometimes gets some attention to the issue as well.
 
  • Like
Reactions: t3hbutt3rs

Josh.haveman1

Member
Oct 28, 2021
6
1
<insert comment here about supporting your local coffee shops>

all jokes aside sounds like an Android 12 issue, reach out to the developer email from the Play Store page and also I have found leaving a review on the Play Store explaining the issue sometimes gets some attention to the issue as well.
I don't thinks it's an Android 12 thing. The app works perfectly normally on my Pixel 4XL, and that's on Android 12. The app never stopped working even when that phone was first added to the Android 12 beta. It seems like a specific pixel 6 problem to me
 
  • Like
Reactions: plasticarmyman

Shinseiki21

New member
Oct 28, 2021
1
0
I have the same problem, I cannot log in on my Pixel 3 and Pixel 6 Pro, Pixel 5 is working fine. I logged out and log in again on my Pixel 5 but not on the other Pixels. Pixel 5 and 6 Pro have Android 12 installed and Pixel 3 Android 11
 

Cares

Senior Member
Dec 2, 2010
1,517
272
Google Pixel 4 XL
Google Pixel 4a
I had the same problem all day yesterday but I was able to login this morning.

The difference between today and yesterday is that now I have Magisk rooted whereas yesterday it was just unlocked bootloader. I'm not sure if that was the cause.
 

Josh.haveman1

Member
Oct 28, 2021
6
1
I had the same problem all day yesterday but I was able to login this morning.

The difference between today and yesterday is that now I have Magisk rooted whereas yesterday it was just unlocked bootloader. I'm not sure if that was the cause.
I don't think the issue has to do with the bootloader because mine is locked on my 6 Pro and 4XL. App works on the 4xl but not the 6 pro. The app is working for you on pixel 6?
 

t3hbutt3rs

New member
Dec 12, 2010
2
0
I was just able to log in. The Starbucks app didn't update, but there was a system update for the phone earlier. Decided to try and login for fun and it worked. Hopefully it's working for everyone now. Thanks for your assistance to all who helped. Cheers!
 

jimmiekain

Senior Member
Oct 21, 2007
241
45
Rancho Cucamonga
www.twitter.com
I had the same problem originally. I forgot about it until I started reading this thread. I just tried it now when it worked for me perfectly fine. Maybe the update that came out fixed whatever was causing that.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Got my 6 Pro yesterday, and after trying to log into the Starbucks app, the only error I get is "A system error has occurred. Please try again later" I can even type in random characters and numbers into the username and password field too, and still results in the same error. App version 6.13.1 Tried on cellular (Verizon) and wi-fi. Uninstalled, reinstalled, etc. Opened a ticket with Starbucks. Is anyone else experiencing this issue?
    So if you log into the mobile web site, go to menu - account - card management, you can pay from there or add money to your card.

    It's a workaround anyway. You can also install the PWA app from the chrome menu at that point as well. That will create an icon in your launcher which will open up to the right page/screen to pay from.
    1
    Is it working on other phones with Android 12? I would bet they have an issue with that.
    1
    Just chiming in to say that the same thing is occurring on my Pixel 6 (not pro). Tried reinstalling the app, clearing cache/storage, changing my password to only have one special character (multiple reports of this being an issue on iOS at least), and rebooting.

    EDIT: Also tried on normal home Wi-Fi, T-Mobile, and Starbucks Wi-Fi.

    Currently running version 6.13.1 apparently. I see multiple reviews on the Play Store also with the exact same problem. I've left my own feedback there to hopefully get their attention.

    I also used the web app as a workaround this morning.
    1
    <insert comment here about supporting your local coffee shops>

    all jokes aside sounds like an Android 12 issue, reach out to the developer email from the Play Store page and also I have found leaving a review on the Play Store explaining the issue sometimes gets some attention to the issue as well.
    1
    <insert comment here about supporting your local coffee shops>

    all jokes aside sounds like an Android 12 issue, reach out to the developer email from the Play Store page and also I have found leaving a review on the Play Store explaining the issue sometimes gets some attention to the issue as well.
    I don't thinks it's an Android 12 thing. The app works perfectly normally on my Pixel 4XL, and that's on Android 12. The app never stopped working even when that phone was first added to the Android 12 beta. It seems like a specific pixel 6 problem to me