• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Google Play Services draining my battery since I updated to Lollipop

Search This thread

timmy.andro

Member
Feb 9, 2015
8
2
Hi Guys,
since I updated to Lollipop I noticed a dramatic battery use by "Google Play Services". If until know cell standby, or Screen were the main battery drainers, nowadays more than half of my battery is taken by Google Play Services. I am aware there is a "GPS bug" in lollipop and if I reboot my phone with Wi-Fi on I have no problem with Google Play Services, however if I turn off wifi or get out of the house it starts draining my battery again. I don't use smart lock. I don't use GSP (I set it to battery saving mode - even though it's off). I have my wifi always on, I have disabled every feature of Google Now. I only synchronize contacts and Keep on my gmail account. I disabled most of motorola's apps (assist, alert, etc) I disabled google+ and most of the stuff I never use. I only sync an email account (yahoo), use whatsapp, facebook (location off, notifications off, sync off), and the browser. My phone has a locked bootloader and I don't intend to root it.

Does anyone have any ideas on how I could stop google play services from draining so much of my battery?? (For example my battery is now at 65% and google play services drained 15% from the total of 35%).

Until posting here I did a factory reset, I updated to the latest version of Google Play Services and I used GServiceFix, but nothing worked.
 
Last edited:
  • Like
Reactions: magicblack7

timmy.andro

Member
Feb 9, 2015
8
2
Turn off Location Reporting and Location History in Settings -> Location -> Google Location Reporting

thank you for the suggestion, but it was already off. I turned off everything I linked to the locations - from motorola assist to facebook. I don't know what other app could possibly require my location - except google maps, but I don't use it at the moment (only when going on trips). Since my phone isn't rooted I can't disable the permissions for google play services to "keep awake" and "wake up" the GPS when the phone is in standby.

I don't know what else do to. If you are using your phone 4-5 hours a day you probably don't notice the drain. But if you are like me and want a good autonomy (I got 3-4 days on kitkat) this bug is annoying.
 

frisky_bg

Senior Member
Dec 15, 2010
139
42
Sofia
I believe this is related to Play services keeping the mobile antena active. If you check, you'll see it being displayed as active for hours. Worse thing is that I had this problem with my Nexus 4 on 5.0.0 and 5.0.1 so most probably its a Trollipop problem and not Moto specific.

Sent from my XT1068 using XDA Free mobile app
 

timmy.andro

Member
Feb 9, 2015
8
2
I believe this is related to Play services keeping the mobile antena active. If you check, you'll see it being displayed as active for hours. Worse thing is that I had this problem with my Nexus 4 on 5.0.0 and 5.0.1 so most probably its a Trollipop problem and not Moto specific.

Sent from my XT1068 using XDA Free mobile app

Yes, it does keep the radio on. Prior to this charge it has done this for 4h40minutes :(
 

timmy.andro

Member
Feb 9, 2015
8
2
Hi, did you solved turning off backgrounda data for Google Play Services?


After disabling the background data for google play services from "Data Usage" it seems that they don't consume that much of the battery. I don't know if it's a general solution to the problem but it did the trick for me (if I turn the background data on, battery usage increases - so there is definitely a connection).
 
  • Like
Reactions: HuskerDad3

Dan1234567890

Senior Member
Dec 27, 2012
435
228
After disabling the background data for google play services from "Data Usage" it seems that they don't consume that much of the battery. I don't know if it's a general solution to the problem but it did the trick for me (if I turn the background data on, battery usage increases - so there is definitely a connection).
Yeah, I don't have battery drain after disabling background data for Google play services. And that is just great, but I experience delay in receiving WhatsApp and gmail messages....? Anyone else or this is something specifirfor me and maybe not connected to disabling background data for GPServices....?

Sent from my Nexus 4 using Tapatalk
 

bblzd

Senior Member
Nov 6, 2013
2,291
567
Toronto
After disabling the background data for google play services from "Data Usage" it seems that they don't consume that much of the battery. I don't know if it's a general solution to the problem but it did the trick for me (if I turn the background data on, battery usage increases - so there is definitely a connection).
That setting only works for a data connection and does nothing for WiFi, though Google services tend to drain much more on a data connection.

There's one thing that has always solved this issue for me which i read on a google twitter account specifisly for this issue. Go to Settings > Storage > cached data and then reboot. The caches will rebuild as you launch your apps and u won't lose any personal data.
 

magicblack7

Member
Aug 10, 2013
30
2
Hi Guys,
since I updated to Lollipop I noticed a dramatic battery use by "Google Play Services". If until know cell standby, or Screen were the main battery drainers, nowadays more than half of my battery is taken by Google Play Services. I am aware there is a "GPS bug" in lollipop and if I reboot my phone with Wi-Fi on I have no problem with Google Play Services, however if I turn off wifi or get out of the house it starts draining my battery again. I don't use smart lock. I don't use GSP (I set it to battery saving mode - even though it's off). I have my wifi always on, I have disabled every feature of Google Now. I only synchronize contacts and Keep on my gmail account. I disabled most of motorola's apps (assist, alert, etc) I disabled google+ and most of the stuff I never use. I only sync an email account (yahoo), use whatsapp, facebook (location off, notifications off, sync off), and the browser. My phone has a locked bootloader and I don't intend to root it.

Does anyone have any ideas on how I could stop google play services from draining so much of my battery?? (For example my battery is now at 65% and google play services drained 15% from the total of 35%).

Until posting here I did a factory reset, I updated to the latest version of Google Play Services and I used GServiceFix, but nothing worked.
Same problem here. I did a factory reset buth nothing, Google Play Service drains and Screen is the 3rth-4rth voice in Battery stats after Google Play Service and Facebook. I have already turned off GPS and I haven't installaed Google Now. Disabling the background data for Google Play Service works for you?
 
  • Like
Reactions: ptambo91

Dan1234567890

Senior Member
Dec 27, 2012
435
228
Are all of you guys having an IMAP account being synchronized?

Sent from my XT1068 using XDA Free mobile app
Nope. I wrote few posts above, that I have delay in email and WhatsApp messages (big delay, in 7-8 hours) when I have background data disabled for GPServices.
But it is not for all the messages, just some, other messages are getting through just on time...

Sent from my Nexus 4 using Tapatalk
 

bav2912

Member
May 20, 2012
9
2
Turn off Google Location, google backup under backup & reset and disable automatic sync while going in accounts and disabling it manually for calender, contacts,app data etc..
this might help..

Sent from my XT1068 using XDA Free mobile app
 
  • Like
Reactions: JohnScan

magicblack7

Member
Aug 10, 2013
30
2
My stats today:

347jhif.jpg

xpym2x.jpg

2njevq0.jpg

2gtytf4.jpg

ve16c5.jpg
 

manoj.d2910

New member
Oct 14, 2012
3
2
Hyderabad
Hi you can try this

Go to Privacy Guard in settings -> privacy. Then click on show built-in app and also on advanced. You will get a new populated list. Now under location click on google play servives. Under that you can turn off wake up, keep awake and auto start. It worked for me. Hope this might help you.


Hi Guys,
since I updated to Lollipop I noticed a dramatic battery use by "Google Play Services". If until know cell standby, or Screen were the main battery drainers, nowadays more than half of my battery is taken by Google Play Services. I am aware there is a "GPS bug" in lollipop and if I reboot my phone with Wi-Fi on I have no problem with Google Play Services, however if I turn off wifi or get out of the house it starts draining my battery again. I don't use smart lock. I don't use GSP (I set it to battery saving mode - even though it's off). I have my wifi always on, I have disabled every feature of Google Now. I only synchronize contacts and Keep on my gmail account.
 
  • Like
Reactions: reeeju

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    Turn off Location Reporting and Location History in Settings -> Location -> Google Location Reporting
    2
    After disabling the background data for google play services from "Data Usage" it seems that they don't consume that much of the battery. I don't know if it's a general solution to the problem but it did the trick for me (if I turn the background data on, battery usage increases - so there is definitely a connection).
    That setting only works for a data connection and does nothing for WiFi, though Google services tend to drain much more on a data connection.

    There's one thing that has always solved this issue for me which i read on a google twitter account specifisly for this issue. Go to Settings > Storage > cached data and then reboot. The caches will rebuild as you launch your apps and u won't lose any personal data.
    2
    I've been noticing wakelock's on my oneplus one for some time now, both with kitkat & lollipop. With the default build of CM on the oneplus one, using PrivacyGuard, I was able to reduce usage by disabling a wakelock option for Google Services & Google Play Services. However, eventually, Android OS started doing it.

    Yesterday, I upgraded the oneplus to oxygenOS, kept it rooted, installed SuperSU and wakelock detector. Checking after a few hours, I've seen that it's "SystemUpdateService" triggering the wakelocks, for 98% of the last 2 hours (see attached). If i can figure out a way in oxygenOS to disable the apps wake locks, I'll see how it does.

    * quick update (+5min)
    I found "DisableService", and went in to it's settings and disabled the SystemUpdateService. Will keep an eye on it to see if it resolves the wakelocks.

    dwight

    Well, In addition to that; what worked for me was installing ''servicely'' by Francisco Franco.

    https://play.google.com/store/apps/details?id=com.franco.servicely


    It is a mix of greenify, and amplify. Terminates the selected apps and hibernates it, and gives the apps a brief amount of time to wake up and check for updates.

    The ''systemupdateservice'' wakelock was driving me nuts to oblivion, installing servicely allowed my phone to have its deep sleep back

    ---------- Post added at 10:16 PM ---------- Previous post was at 10:14 PM ----------

    Do you have Xposed installed? I don´t have, just got the donation version of Greenify,enabled hibernate systemapps but google frameworks and google services doesn´t appear in the list.
    Anything more to do?

    Enable ''experimental features'' from options, then select ''greenify system apps''
    1
    Hi Guys,
    since I updated to Lollipop I noticed a dramatic battery use by "Google Play Services". If until know cell standby, or Screen were the main battery drainers, nowadays more than half of my battery is taken by Google Play Services. I am aware there is a "GPS bug" in lollipop and if I reboot my phone with Wi-Fi on I have no problem with Google Play Services, however if I turn off wifi or get out of the house it starts draining my battery again. I don't use smart lock. I don't use GSP (I set it to battery saving mode - even though it's off). I have my wifi always on, I have disabled every feature of Google Now. I only synchronize contacts and Keep on my gmail account. I disabled most of motorola's apps (assist, alert, etc) I disabled google+ and most of the stuff I never use. I only sync an email account (yahoo), use whatsapp, facebook (location off, notifications off, sync off), and the browser. My phone has a locked bootloader and I don't intend to root it.

    Does anyone have any ideas on how I could stop google play services from draining so much of my battery?? (For example my battery is now at 65% and google play services drained 15% from the total of 35%).

    Until posting here I did a factory reset, I updated to the latest version of Google Play Services and I used GServiceFix, but nothing worked.
    1
    That setting only works for a data connection and does nothing for WiFi, though Google services tend to drain much more on a data connection.

    There's one thing that has always solved this issue for me which i read on a google twitter account specifisly for this issue. Go to Settings > Storage > cached data and then reboot. The caches will rebuild as you launch your apps and u won't lose any personal data.

    Just wanted to let you know that clearing the cache worked for me. After almost 24 hours after clearing the cache, com.google.android.gms is no longer hogging my battery. I'm running Omega ROM v25.1 on Galaxy Note 3.