Google Play VR Services CRASH the Do Not Disturb function - HUAWEI P9 LITE (2017)

Search This thread


New member
Oct 7, 2017
Hi All,

I have installed the Google VR Services on my device for development of Games (VR) with Unity 3D.

I have been asked for permissions to enable Do Not Disturb while using VR games, so when I tried switching it off by navigating to settings and clicking on the Do Not Disturb section, it takes me back to the homescreen... which is obviously a bug.

In addition I tried to disable it from the slider (where torch, mobile data etc are located), and it didn't take any affect.

On the other hand, to solve this I have uninstalled Google VR Services, and the function of Do Not Disturb works again.

Now my issue is that with Unity 3D, I have created just 2 objects just to test the VR, and it seems that it is lagging when I build and run.
I wish to know if it is either from the Phone (Software wise), or perhaps Unity (optimization, but again I only have 2 objects).

Are there any developers who encountered problems with lag, while using HUAWEI P9 Lite (2017) here?


Top Liked Posts