• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Google Wallet is not available on your device or your carrier

Search This thread

leebo

Senior Member
Apr 4, 2007
547
48
After the latest update of Google Wallet, I get that error on both my EVO LTE and my Nexus 7.

Both are rooted, but Wallet ran, at least on my EVO LTE, before the update.

I have tried uninstalling, but I get the same error. I've tried temporarily un-rooting, but I get the same error. I've tried re-installing the update. I've cleared both cache and data.

I've even tried using search in this xda app, but it doesn't even find the word Wallet.

Two days ago Wallet decided to run on my Nexus, but today it says "no".

As I am having this same error on both devices, I can infer it has nothing to do with Sprint. Since Wallet ran previously on my rooted device, I can assume it has nothing to do with that either.

Also, since my Nexus and EVO LTE are not related, there must be others having this issue.

Has anyone heard about this?

Sent from my Nexus 7 using xda app-developers app
 

leebo

Senior Member
Apr 4, 2007
547
48
In Root Explorer, what are the permissions on the wallet APK in the system directory?

Sent From My S-OFFed, R00ted, 100% Tricked-Out HTC Evo 4G LTE via XDA Premium!

On Nexus 7
Owner: read write checked.
Group: read checked
Other: read checked.

Everything else un-checked.

On the EVO LTE:

The apk is called "walletnfcrel-1.1-R57-v5-prod-20120405-relkeys.apk.

Permissions show rw-r-r-

Owner is listed as root.

Btw, back at home, Wallet opens on the Nexus again. Wtf? When I started this thread, I was at Starbucks, someplace where I could have actually had a use for Wallet.

Still no go on the EVO though.

Sent from my Nexus 7 using xda app-developers app
 
Last edited:

TonyTurboII

Senior Member
Jan 17, 2008
784
279
Saint Charles, MO
I finally got tired of it. I really wanted wallet to work, and since switching to MeanROM ICS it's worked perfectly. Did you try editing the build prop file to the model number of another device?

Sent from my EVO using xda premium
 

Rxpert

Senior Member
Sep 12, 2011
1,714
687
With the newest software from the OTA wallet is fixed guys.

If your rooted, don't take the OTA, flash a rom with it baked in

Sent from my EVO using Tapatalk 2
 

leebo

Senior Member
Apr 4, 2007
547
48
So no way to get it working on the EVO LTE other than flashing a different Rom? Great.

I'm sure this Wallet thing will really take off if the typical consumer has to do that. I hate Apple, but I can't see this ever happening on that platform.

I tried editing my build.prop to:


I edited my build.prop file to:
I changed my ro.product.model=GT-I9300
ro.product.device=GT-I9300

Still won't even run, much less log into my account.

Sent from my Nexus 7 using xda app-developers app
 

leebo

Senior Member
Apr 4, 2007
547
48
I see.

So even though Wallet ran on my rooted EVO LTE with stock room before, I now have to either un root and update, change to a different Rom, or simply forget about Wallet.

So weird. Thanks though.

Sent from my Nexus 7 using xda app-developers app
 

cruise350

Senior Member
Dec 11, 2007
1,962
625
Memphis, TN
I see.

So even though Wallet ran on my rooted EVO LTE with stock room before, I now have to either un root and update, change to a different Rom, or simply forget about Wallet.

So weird. Thanks though.

Sent from my Nexus 7 using xda app-developers app

You need to fix your build.prop. You obviously did a gameloft mod or something similar. You need to restore your build.prop backup or get the proper settings installed. The problem you are describing is caused by the wrong phone in the build.prop.

Sent from my A500 using Tapatalk

---------- Post added at 06:56 PM ---------- Previous post was at 06:54 PM ----------

So no way to get it working on the EVO LTE other than flashing a different Rom? Great.

I'm sure this Wallet thing will really take off if the typical consumer has to do that. I hate Apple, but I can't see this ever happening on that platform.

I tried editing my build.prop to:


I edited my build.prop file to:
I changed my ro.product.model=GT-I9300
ro.product.device=GT-I9300

Still won't even run, much less log into my account.

Sent from my Nexus 7 using xda app-developers app

Those aren't the correct settings.

Sent from my A500 using Tapatalk
 

leebo

Senior Member
Apr 4, 2007
547
48
I'm a little dense.

Obviously those aren't the correct settings.
The correct settings didn't work in the first place (ro.product.model=EVO, ro.product.device=htc_jewel). That's why I edited it.

I got that from another long thread thread.

I thought the point was to trick Wallet into thinking it was a different device?

I did not do any other mods besides root the phone. It's not even unlocked.

I'm so lost!



Sent from my Nexus 7 using xda app-developers app
 
Last edited: