Google wallet - re-adding your card after reset

Search This thread

jdiddy_ub

Senior Member
Sep 20, 2010
1,108
204
Queens Village, NY
to avoid being locked out of the secure element i reset my info in the google wallet app before i wiped my phone

i redownloaded the app and went through the initial set up...this time it gives me an error when i am trying to link my citi card to it...the same card worked earlier so i know it works

is there a waiting period or something between resetting the info and re-adding the card? i reset the app like an hour ago...wiped and re-flashed...maybe i have to wait?

can anyone who has done this please chime in...thanks
 

msedek

Senior Member
Apr 3, 2012
2,068
635
Santiago de chile
Have you already updated the app?... Seems like theres a new update for it could be the reason.. And as far as i know your info should be there as your card its linked to your account and thats in the cloud not in the phone

Galaxy Nexus AOKP m5 Franco kernel m3
 

jdiddy_ub

Senior Member
Sep 20, 2010
1,108
204
Queens Village, NY
Have you already updated the app?... Seems like theres a new update for it could be the reason.. And as far as i know your info should be there as your card its linked to your account and thats in the cloud not in the phone

Galaxy Nexus AOKP m5 Franco kernel m3

when i logged in with my google account the info wasnt just there...i had to re-do the entire set up...

also to note...when i selected my gmail account it attempted to log in and it said the password was wrong...i had to manually type the password to get it to log in...i dont think that happened the first time i did it (when the credit card link was successful)...idk if that makes a difference
 
Last edited:

msedek

Senior Member
Apr 3, 2012
2,068
635
Santiago de chile
when i logged in with my google account the info wasnt just there...i had to re-do the entire set up...

also to note...when i selected my gmail account it attempted to log in and it said the password was wrong...i had to manually type the password to get it to log in...i dont think that happened the first time i did it (when the credit card link was successful)...idk if that makes a difference

I see, well try updating the app

Galaxy Nexus AOKP m5 Franco kernel m3
 

msedek

Senior Member
Apr 3, 2012
2,068
635
Santiago de chile
No, i cant add cards since im outside usa but i got cards registered in the website wallet to be able to buy apps in the store.. So no matter if I wipe my phone the cards are always there, same as your contacts, pictures, everything should be restored.. Try a. Factory reset, backup your stuff and try again

Galaxy Nexus AOKP m5 Franco kernel m3
 

jdiddy_ub

Senior Member
Sep 20, 2010
1,108
204
Queens Village, NY
No, i cant add cards since im outside usa but i got cards registered in the website wallet to be able to buy apps in the store.. So no matter if I wipe my phone the cards are always there, same as your contacts, pictures, everything should be restored.. Try a. Factory reset, backup your stuff and try again

Galaxy Nexus AOKP m5 Franco kernel m3

yeah...i have my citi card linked to my gmail account because ive bought apps from the playstore...funny how there isnt a correlation....the app acts separately...when i log in to my gmail there is no card attached in the app but when i log on to google wallet from my browser my citi card is there

i called citi and they put a ticket in and told me to wait 24 hours and try to add the card again...they said that they saw that the first time i ever linked it it was successful and they arent sure why i can't add it again...after 24 hours, if it still doesnt work they want me to call back
 
Last edited:

skyheli

Senior Member
May 31, 2007
95
9
I have a ticket open with Citi Bank for the same reasons. I will not let me add the card again. I have wiped the app before and never had a problem. The person I talked with at CitiBank said there was a problem on their end and would not be fixed till Sunday night. They took my info and would call me back. It apparently thinks the card is still active in the system and will not reauthorize it. They have to go in and delete it but it cant happen till Sunday..... I hope so anyways.
 

jdiddy_ub

Senior Member
Sep 20, 2010
1,108
204
Queens Village, NY
I have a ticket open with Citi Bank for the same reasons. I will not let me add the card again. I have wiped the app before and never had a problem. The person I talked with at CitiBank said there was a problem on their end and would not be fixed till Sunday night. They took my info and would call me back. It apparently thinks the card is still active in the system and will not reauthorize it. They have to go in and delete it but it cant happen till Sunday..... I hope so anyways.

ahh ok...it makes sense that the issue is on their end...its not a secure element issue because i reset it before i flashed anything...not that im glad to that you also have the same problem, but im happy to see that my issue isnt isolated

also...you said that you've reset the app before right? in the past after you reset it, you were able to just simply re-add it again? my first link was successful and very quick...just wondering if its a simple process to reset and add

i guess ill have to just wait out the weekend and try it again

if you happen to get it to work please post it here...i will as well
 
Last edited:

bluestar23

Member
Nov 18, 2009
21
2
Actually, they told me same thing last Friday (the system will be back until last Sunday)... and the issue was not revolved until now...

ahh ok...it makes sense that the issue is on their end...its not a secure element issue because i reset it before i flashed anything...not that im glad to that you also have the same problem, but im happy to see that my issue isnt isolated

also...you said that you've reset the app before right? in the past after you reset it, you were able to just simply re-add it again? my first link was successful and very quick...just wondering if its a simple process to reset and add

i guess ill have to just wait out the weekend and try it again

if you happen to get it to work please post it here...i will as well
 

lswartzevo

Member
Jul 7, 2011
7
1
not sure if it has anything to do with it, but when I moved to a different ROM i used mybackup pro to restore the apk and data of google wallet. I had all kinds of problems and could not get it to work correctly. I assumed it was due to me restoring the data with the apk.

I uninstalled the app, re-installed just the APK and went through the setup again and have not had any issues....
 

jdiddy_ub

Senior Member
Sep 20, 2010
1,108
204
Queens Village, NY
not sure if it has anything to do with it, but when I moved to a different ROM i used mybackup pro to restore the apk and data of google wallet. I had all kinds of problems and could not get it to work correctly. I assumed it was due to me restoring the data with the apk.

I uninstalled the app, re-installed just the APK and went through the setup again and have not had any issues....

i have already uninstalled and reinstalled the app...im really hoping its just a server error on their end...im gonna wait a couple more days and call back if its still not working
 

bigknowz

Senior Member
Jan 9, 2012
929
491
NYC
Verizon - Can't add cards

Wallet just started working today for the first time in months. I upgraded to 4.0.4 manually on May 25th, but for some reason on reboot today, Wallet initialized. I cannot add a prepaid or a Citibank MC - phone gives me an error. Any thoughts?
 

jumpmanjay

Member
May 31, 2012
29
5
i totally forgot to wipe the wallet data before rooting/unlocking/flashing/etc and when i loaded a new rom, wallet still worked perfect! it seems sometimes there is no rhyme or reason to wallets behavior.
 

kisrita

Senior Member
May 15, 2008
446
101
This is still not working for me. It's been about a month now. I called Citibank twice, first time they told me to call back after the weekend. I called about two weeks later as I didn't have time earlier. That time they claimed the problem is new and they've only known about it for a week, and they're working on it!?! After some clarification they claimed that adding a citibank card was a new problem, not re-adding after a factory reset.

I had a yakjuxw 4.0.2 Gnex, everything worked including google wallet, but changed the rom to takju 4.0.4 when I got pogo pin docks. I am not rooted and have not been rooted. Google wallet asks for Citibank to be added, and it seems to be going through the same process as originally, but at the end it gets stuck, then tells me "unable to add the Citi Card card, please contact your issuing bank or try again Citibank, N.A. contact number 1-800-842-6596".

Well after the calls to Citibank, this is obviously not getting me anywhere, so I'm not sure what to do. I have the backup of my yakjuxw 4.0.2 rom, would putting that back on the phone help? Or is this a google issue and should I be opening a google ticket?

Sorry, I'm totally lost. I didn't even know about the secure element possibly getting blown by a factory reset until after I couldn't add the card back in, and it turned up in some searches. Could that be the problem? Any way to fix that?

Thanks to anyone that can offer any advice.
 

Neipas09

Senior Member
Jul 20, 2010
256
55
Overland Park, KS
to avoid being locked out of the secure element i reset my info in the google wallet app before i wiped my phone

i redownloaded the app and went through the initial set up...this time it gives me an error when i am trying to link my citi card to it...the same card worked earlier so i know it works

is there a waiting period or something between resetting the info and re-adding the card? i reset the app like an hour ago...wiped and re-flashed...maybe i have to wait?

can anyone who has done this please chime in...thanks

Since nobody gave you a fix for this here's mine.

I just experienced the same thing after doing a RESET GOOGLE WALLET from the SETTINGS option inside Google Wallet.

I called Citi and they told me that they have to put in a request to have my card unlinked from my (i'm guessing) Google Wallet account.
She said that it will take 24hrs and i should be able to add it back after that.
 

InTheRough

Senior Member
Oct 1, 2008
184
107
Since nobody gave you a fix for this here's mine.

I just experienced the same thing after doing a RESET GOOGLE WALLET from the SETTINGS option inside Google Wallet.

I called Citi and they told me that they have to put in a request to have my card unlinked from my (i'm guessing) Google Wallet account.
She said that it will take 24hrs and i should be able to add it back after that.


Were you able to add it back? I am having the same issue after resetting Wallet.