• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Googlefier - Install GMS on Huawei/Honor

Search This thread


Senior Member
Sep 23, 2007
Huawei P40 Pro


Senior Member
Feb 21, 2020
Also, you can try ( I don't know if it works) the same method but copy (download using Wi-fi) the dload folder to the internal storage of the phone.
Source: https://www.tecnoofone.com/2020/04/flash-huawei-firmware-all-method.html
This will not work for him. The userland part of the internal memory is encrypted, and also the recovery flasher is not tuned to flash from user space. And above all: he might have installed the wrong firmware.

The only reliable option for him is to buy a Huawei NanoMemory Card, and put the dload folder onto that. I have tested this, that a NanoMemory Card connected to the NanoMemory slot is recognized even in this screwed up scenerio and is able to initiate an update.

However make sure to ONLY go to first, then if needed you can do this method again with EMUI, while still on Do not skip versions especially when switching from EMUI 10 to 11.


Senior Member
Feb 21, 2020
Few guys said that the OTG can work. In this case use a dload firmware.
This is a LIE! OTG does NOT work in this scenerio because you do not have a usable data connection.
What does work instead> a NanoMemory Card connected to the NanoMemory Slot. THAT is recognized and the "few guys" probably meant this, however the NanoMemory bus is an internal peripheral and is nowehere close to OTG or USB at all. It has a direct connection to the SoC.


New member
Oct 13, 2014
Hi guys, this tread is awesome! It was working just fine, until I accidentally deleted the device from my google account and now neighter from google apps works. So now I am asking is there any "easy" way to make GMS work again, without starting from scratch?

Thank you in advance.
Last edited:


Feb 6, 2011
Huawei P40 Pro
If like me you have for some reasons Gmail notification appearing (sometimes only) or Facebook & What's app working but not Twitter, your GPS also works but YourPhone assistant app from microsoft or some banking apps aren't working then you have a good GMS installation so you should do this :

1) Put your phone in Plane mode.
2) Go to Settings > Apps > Show system process > search for Google
3) Then kill Google Framework > delete cache & data
4) Reboot the phone.
5) Wait for a new framework ID to be created (use devide ID app).
6) Turn off plane mode and try to send a push notification (use push notification API app). You should probably have notifications appearing even before your test them.
7) Start Play store, try to download and so on...

The full notifications and all apps are working (except Google Pay but it's Google that didn't certify the P40 pro..)
If you have the "License error" notification then you probably triggered something from an app :
Do 1 to 7 again.
If you can find the faulty app it could be good to reinstall or kill it's data.
You can now receive instant gmail or twitter or whatever your app is notifying. Even the security push notifications or NFC payments...

Important note :
Only remove data from the framework, do not uninstall it or uninstall anything else.

If you messed up your GMS at some point, you can fix it with the Googlefier fix button.
Remember to download your current Google play services version beforehand.
You most likely to have the PlayStore not working until the end of the fix procedure but it's fine.
Once the fix procedure is done, just uninstall the Google Play services and reinstall the one you had before you started to fix.
Once you fix your GMS, you'll have to do 1 > 7 again.
Before that, use the apps you previewsly installed that relied on GMS to work to trigger a few things. (Pokemon GO or whatever you know that needs GMS).
I did the Fix button on EMUI 11 just so you know. So as long as you installed the GMS correctly from the EMUI 10 it's fine.

You also can trigger some Gmail notifications using AutoSync Account Activator app.

Optional : Keep all functionnalities but loose instant notifications
There is a last step that you can do in order to avoid any error in the future or for those that do not want to bother doing those steps in the future. This fix may last very long for some but only 24h for others.
Once you finished 1 > 7, be sure to install and use your apps that require push notifications (banking or gps or else), use them so it triggers the push messages.
Once it's done and you still do not have any licence error then :
8) Uninstall the Google Play Services.
9) Reinstall the Google Play Services (the one you downloaded earlier).
10) Reboot your phone.
You will loose the instant notifications but you will keep your ability to use the Play Store, NFC pay, GPS and so on without any licence notifications in the future...
I recommand you to not delete those apps that you couldn't use before or delete their datas.

Last edited:


Senior Member
Oct 4, 2015
Hi I have a problem:
When I downgraded my p40 pro i installed version. Lzplay doesn't work so I can't install GMS.
Now, obviously my USB don't work and I don't receive OTA updates. I try with app "my Huawei" but it don't find updates. I try with ercovery method but I have "get package info failed" error. I've been trying for four days but I don't know what to do anymore. Are there other ways to upgrade it?
you can use type c to type c card reader. Put the suitable emui version ( in the card reader. Then downgrade yor version to that Emui Until now, Emui still be the emui version for P40 Pro where GMS still working.


Senior Member
Oct 4, 2015
Guys, if you Huawei P40 Pro User and plan to downgrade your emui 11 to emui 10, please consider the following points :

1. Downgrade from emui 11 (latest) will make your device lost USB Connection. Mine and some users reported they lost OTA Update capability. Also fast charging capability. Huawei seems try to block all downgrade. Maybe the next time, it will getting worst and worst. So, do it all with your OWN RISK.

2. Based on point number 1, MAKE SURE you choose the suitable Emui 10 Version before downgrade. My experience, for Huawei P40 Pro, the best Emui 10 version that still support Googlefier/LZPlay is Emui So please, choose that version when you downgrade your Emui using Hisuite Proxy.

3. If you choose another Emui 10 version, like Emui and then lost OTA Update, USB Connection, and have no idea what to do, don't afraid. Last time, when i also in the same situation, USB Type C to Type C still working for me and make my device still can connect to HiSuite.

4. Installing GMS on your Huawei P40 Pro not always succeed on first try. Some users told be they need even 10 times until GMS installed. So, when you failed for the first tray (Google Play Service Notification appear again-again), try to install it again.

5. After finished installing GMS, you can update to Emui 11 to make all problem i mention on number 1 back to normal. GMS also can still working on Emui 11.

  • Like
Reactions: badmania98


Jun 15, 2012
Hi guys, I was able to downgrade my MatePad T10s(AGR-L09) down to (this is the oldest firmware available). Still no luck opening LZplay, it gives me the device not supported message. Any help?


Senior Member
Oct 4, 2015
Unfortunately I am experiencing the problem mentioned above. Downgraded from 11 to 10.1 and lost USB connection and Supercharge. OTA is not giving me any updates to fix this issue by updating back to 11, don't know if OTA is functioning or not.

Should I wait a few days while OTA becomes available or I'm stuck with this beyond repair?
Me also got same problem. But, i found that you have to choose the right CUST and PRELOAD version for your device (based on region). On the previous downgrade, i choose it randomly. It was succeed to downgrade but missing OTA update.


Senior Member
Jul 16, 2015
Me also got same problem. But, i found that you have to choose the right CUST and PRELOAD version for your device (based on region). On the previous downgrade, i choose it randomly. It was succeed to downgrade but missing OTA update.
I had the same issue. My OTA stopped working. I managed to flash another 10.1 version using Dload method and after that OTA works...i just updated to the latest Emui 11 after that and everything works


Senior Member
Oct 4, 2015
FIXED : Any solution for super charging on P40 Pro after downgrade? the charging stil slow even we update to latest Emui version. Mine now at Emui

(2nd day after upgrade, super charging back to normal). Don't know why. Lol
Last edited:
This is true in the way that these apps still retain their special API access privileges (can run as system apps) which is great. It is safe to apply system updates and even update most of the google apps.

the question was about updating one app specifically, Google Play Services. Well, that is a big NO in my opinion. Technicially it is possible but upon experimenting with it repeatedly, it seems to immediate break the Play Store and EVERYTHING related to GMS by tripping Google Play Protect... Everything would be spammed by Play protect certificate errors...

My advice: DO NOT UPDATE Google play services. If it means you cannot use ChromeCast, then you shouldn't.

if for any reason you really need to do this, then consider freezing Google Service Framework with Icebox to stop this Play Protect error madness. It could work in that case. But it will also break the play store and google enhanced location service... could possibly also break chromecast operations but I'm not sure on that as I cannot test it at the moment

On my case, I updated mine with play protect running pretty flawless, just slightly a bit waiting for new downloads.

My main concern, are there any possibilities of network issues like slowing down data connection after updating the service.


Feb 23, 2021
hello everyone. I am on and hisuite does not connect with my p40 pro. message on phone reads this version is incompatible and asks me to uninstall hisuite from phone. on the same phone in the past i have managed to install GMS using version when i could downgrade it using hisuite but then had to reset to base huawei stuff.
ive tried putting dload folder on my nm card root and tried to hold power & volume up but it comes up with an error with installation package.
i would like to put GMS on my phone, any advice will be much appreciated.


New member
Sep 16, 2021
Hello! I'm new and would like to ask for some help please. I can't get LZplay to work even if I think I have the correct firmware?

I have a new mediapad T10 that I just got (Sep 2021). It comes with the following:
C636E2RP41 (C636 = Asia Pacific)

152 is too high, so I used a combination of https://www.firmfinder.ml/ , hisuite proxy, and HiSuite to downgrade my firmware to No problem with that.


I tried to use googlefier, but got stuck somewhere in step 1. LZplay installs, but when I try open it this error appears: "sorry, the device is currently not supported" then just shuts down.


The instructions say I should open this LZplay app to allow permissions, but I couldn't do that. I researched and saw that this error appears when my firmware is too high, but for a Matepad 10 should be low enough right? the one on the first page is even .

What could I be doing wrong? Or is there something about my model that makes it incompatible with LZPlay even if it's a low firmware?
Last edited:


May 30, 2019
Device: Matepad Pro MRX-W09 C432E3R1P6 EMUI:

So I had everything working originally and then updated to emui 11 and now on latest version. Because of another sort of unrelated problem I tried to clean googlefier to troubleshoot the other problem.

Long story short I lost my google play and now I cant seem to downgrade to get it back.

I've tried hisuite normal downgrade (dont get offered a downgrade)
i've tried hisuite proxy +9 hi suite (lots of different versions) (Again just says i'm on the latest version and wont downgrade)
I've tried downloading firmware and using usb(says version incompatible) (tried mrx-w09a- MRX-W09_10.1.0.151(C432E135R1P135)

All to no avail it just wont budge from the latest software.

Anyone any advice?


New member
Sep 18, 2021
Hi guys!

Device: Honor 10 lite (HRY-AL00a)

I'm bought this phone in about November - December 2019 and successfully install google services with Chinese G app (lzplay).
But a week ago I decided to uninstall huawei system scrap app from adb, and google services begin work so worst (work or no, if work - it was slow).

So I download Googlefier and did all steps excluding run the Chinese G app (lzplay), because it says not compatible. And nothing change google services begin work so worst (work or no, if work - it was slow).

So I try to downgrade my firmware into EMUI 9 via hisuite proxy. And nothing, chinesse G (lzplay) app doesn't work(((
I tried next version: - lzplay does not work - lzplay does not work - lzplay does not work - lzplay does not work - lzplay does not work - lzplay does not work - lzplay does not work

Maybe anyone knew what a firmware version need Honor 10 lite (HRY-AL00a) for chinesse G app (lzplay)?

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hey all , my lad got a Chromebook for Christmas and it wanted me to sign into a parent account , doing so has done something to my Google account on my googlified p40 pro. I've now got a googlified device but have removed my gmail account . Is this a quick fix ?
    No. 2 here.
    Is there a tldr? the language and video quality make following step 2 problematic! Ha
    what tldr means? You dont need sound. Download the files from description and start from min 05:30.
    Hi badmania98,
    I was just reporting a problem encountered with Googlefier for the third time in a week, with a common version of P40 pro in my case.
    If anyone find a working tutorial on youtube, please let me know :)
    You can start reading my thread here.. You will find many info there.
    Hi Bender, first I'd like to thank you for your contribution in the community.
    Secondly, I ran into an issue that doesn't exist in troubleshoot section.
    My phone is P40Lite
    Model: JNY-LX1
    This is the earliest version I can rollback to with official Huawei software.

    After I followed the initial backup / restore process, LZPlay was successfully installed (谷歌助手服务). Then I ran the LZPlay app, and switched back to Googlefier, then new buttons showed up with 01, 02 and 03 respectively.
    When I pressed 01 button, there's no response. I could see the faint shadow of the button on the screen as I pressed it, so it's definitely not the screen's problem.

    I have tried at least twice on each of the following methods to resolve it:
    1. Reinstall Googlefier and LZPlay app.
    2. Disabling/Enabling all the permissions for both Googlefier and LZPlay app.
    3. Reset all the settings of the phone.
    4. Reset the phone completely.

    Nothing works so far. My guess is that either there's an update on Googlefier that I didn't get (downloaded the APK via mirror link), or my phone with that build number is just no go :(

    Thank you very much again for the awesome work so far. Any guidance is highly appreciated :)

    Hi all,

    First, let me thank you all for your awesome work, very helpful!

    I have the same problem as Stein1290 and Mentalchaoz just above.

    "After I followed the initial backup / restore process, LZPlay was successfully installed (谷歌助手服务). Then I ran the LZPlay app, and switched back to Googlefier, then new buttons showed up with 01, 02 and 03 respectively.
    When I pressed 01 button, there's no response. I could see the faint shadow of the button on the screen as I pressed it, so it's definitely not the screen's problem."

    I have a Huawei P40 pro ELS-NX9 build that was downgraded following instructions with HiSuite proxy.

    Do you have any idea on what to do? It seems it is a new problem as we are 3 having this problem in the same week.

    Thanks in advance!

    The problem has been solved. Googlefier cannot work on ...2022. You have to set the phone date to 2021 and googlefier will work.
    More details: here.
  • 41
    Wecome to Googlefier,

    After a successful tool for LG G2 and LG G3 owners (AutoRec), but after a long pause, here is something new and I hope useful

    Googlefier is a simple tool, designed to help you install GMS on your Huawei/Honor device


    Video & Article - please take time to watch the video, answers some open questions

    Check stats for your device here


    Please read the Q/A on POST #2 < click

    Downgrade help is on POST #3 < click

    Firmware Downloads (c432 global only) are on POST #4 < click

    Troubleshooting is on POST #5 < click

    Before asking any questions please read posts 2-5, check if your question has already been answered, in order to keep the thread clean.

    Also - try to ask questions in some sense they are understandable

    A simple: "IT doesn't work - will be ignored and possibly deleted, because it doesn't add to thread quality", instead you should describe the steps properly, and you will get an answer.

    I also encourage all of the members to keep the "alternative downgrade methods" to some other threads, which I will for sure link later. Also please don't spam with firmware links, rather PM me and I will add it to POST #4, let's try to keep the thread clean. As time goes by, I'll try to add more firmware and cover more of the Q/A and Troubleshooting POST/Section so everyone can help himself / herself by simple power of reading

    As always, any donation is highly appreciated and welcome, since a lot of time has been invested into this tool and in research

    click ----> DOWNLOAD - click here to download <- Someone ddosed the server, which means the server is gone, thx a lot :), I mean I don't have anything out of the downloads, I guess the person who ddosed the server had some incomes coming either from googlefier (since some sell it for 4-5 dollars) or it did hurt him in other way..thx a lot, good job!

    Alternative DOWNLOAD from APKMIRROR <----

    click ----> Donate - for support and future projects

    P.S. Please DON'T reupload without permission

    27.10.2020 - Added contact fix (if you are installing it fresh you don't have to do anything to apply it) (if you already have running services - press the FIX button and then press FIX contact sync (it will ONLY fix the contact sync, nothing else))


    microG - microg
    EloYGomeZTv - microG fork + login
    Firmware Downloads

    I'm confused, what do I download?

    -Check your emui version, the important data is:

    1. device name
    -example ANA-NX9

    2. version
    -example C432 or C185 - just download the one for your device

    P40 Lite


    P40 Lite


    P40 Lite


    P40 5G


    P40 5G


    P40 5G


    P40 5G


    P40 5G


    P40 Lite E


    P40 PRO+

    P40 PRO


    P40 PRO


    P40 PRO


    P40 PRO






    Matepad 10.4


    MatePad Pro

    download - Thx to TMc19

    HUAWEI P40 lite 5G


    Honor V30 pro 5G


    Removed firmware requests, I don't have the bandwidth on easy-firmware, nor the time to constantly download-upload stuff, sorry

    click ----> Donate - for support and future projects
    ---this post will change, be sure to visit it for some more firmware

    Alternative link with all of the downloads: click here

    Downgrade Help

    Downgrade via usb/sd

    You NEED USB-OTG -> see the picture



    1. Check your firmware version(emui)
    2. Check the stats about the max supported version for Googlefier/Lzplay
    3. Download the firmware which is supported
    4. Make backup…

    Where can I find the firmware?
    -All of the firmware version that are in the download post I’ve downloaded from easy-firmware, yes I’ve paid 17$ to be able to download firmware for people, but you are welcome to get your firmware from a source which you prefer, please don’t pollute the thread with the firmware download links, there should be a separate thread for that


    Method 1

    0. Make backup..seriously, this will wipe your partitions and reflash them(your files will be gone)
    1. Download your firmware
    2. In case it’s from my uploads you just extract the “dload” folder to your usb/sd
    3. Turn off your phone
    4. Hold volume up and power, until you see the recovery (or. https://www.youtube.com/watch?v=ztobeBHh4Fk if your phone doesn’t have volume keys)
    5. Select upgrade "Memory card / OTG update mode" and that’s it, it will first verify the firmware and flash

    Note: If method 1 doesn't work, try method 2.

    For troubleshooting – see the troubleshooting section

    Method 2

    you need HiSuite (find it and download, install it)
    1. -Open your dialer inside android
    -type *#*#2846579#*#*
    -tap on 2. "Veneer Informations"
    -tap on 1. "Version Info"
    -scroll down to "Base Software Version"
    -You will see something like "JNY-LGRP2-OVS"
    -Just ignore everything after LGRP2, means you need the "JNY-LGRP2" only
    -Type "JNY-LGRP2" or any string you find in that info - into textbox from step 1(in the hisuite proxy) and press step 1

    2. Find a suitable firmware, check that it's "FullOTA-MF" and not just OTA-MF, copy the url link next to the date, paste it into the "package url" inside the hisuite proxy
    3. Copy the text which is next to the date, on the webpage - paste it to the "firmware version" inside the hisuite proxy
    4. Press "Start proxy", connect the phone, authorize with HDB (you should know how to do that)
    5. press update in HiSuite - It will download the older firmware and install it

    Here is the image of how the procedure looks like: CLICK

    DOWNLOAD Hisuite Proxy Modified


    IF method 1 doesn't work for you (stuck at 5%), try finding the firmware somewhere else, or do what I do

    1. find some service where you can download firmware (I use easy-firmware)
    2. pay 17$
    3. find your firmware, download it, extract using that weird ef extractor
    <- this is exactly what I do all the day when you ask me to upload you firmware

    What to check?
    1. device name
    -example ANA-NX9

    2. version
    -example C432 or C185 - just download the one for your device

    OR - try method 2 with hisuite

    Note 2

    You might be able to download the firmware using the free service here ,
    but this is something for the "method 2" for now. I will work on it to try to use the very same firmware you can download from there so you can use it with your SD or USB.
    Not promising anything, but I think it's doable - I just don't have a device ATM and I don't want to bother anyone risking a device

    click ----> Donate - for support and future projects
    ---this post will change, be sure to visit it for alternative/different downgrade methods
    Hi, at first thanks for this very clear process, but I realized, this is not working with matepad 10.4 (BAH3-W09).
    I downgraded successful to 10.0.118, but lzplay is not initialized.
    After I read 20 pages of this thread, it looks like the (C432) version of matepad is not googlefiered with this method. Please, update the original post about this device to help others not spend much time with that.

    1. What devices are supported?
    - Currently Huawei / Honor devices running Android 10 and Emui10. There are limitations based on firmware versions.

    2. Does it use LZplay(Chinese app)?
    -Yes it does. You can uninstall it after the installation is done.

    3. How do I know if it work on my device?
    -You don’t. You need to try it. IF lzplay runs on the device then it will 99% work. However there is a list where you can see some firmware versions on which it’s reported to be working.

    4. I don’t have LZplay and it still worked, how?
    -At some point, on previous firmware version – your phone had LZplay running and/or someone tried the GMS installation method. (yes, even after resetting..yes weird..)

    5. Do firebase push notifications work?
    -No they don’t, some apps will have their notifications pushed through, most of them wont.

    6. I'm getting notifications, a lot of them, what do I do?
    -Hit the fix button and follow the instructions.

    7. I've hit the FIX button, but it doesn't fix a thing. Why do you lie to us? :D
    -The fix button is there to assist you in fixing your own errors :), you didn't follow the procedure.
    -After you hit "fix", just read the instructions.
    -After EVERY single services install do this:
    *Open playstore, browse it, close playstore and all running apps from the recents menu
    *Open sync settings, uncheck-and re-check the sync on/off settings
    *Open playstore - install 2-3 apps, games...close playstore and all running apps from the recents menu
    *Proceed with button 3, just like the message box instructs (until it says everything is done)
    *still getting errors? Repeat..

    8. Does APP {insert name here} which depends on google location services/play services/games work?
    -Most probably it does, even apps like tapatalk work with the google sign in

    9. Is factory reset mandatory?
    -No, there is a button to make sure your previous experimenting is deleted

    10. Will this damage/delete my data?
    -No, this doesn’t touch your data. Although a factory reset is recommended if you want to do it right. Some people use different google replacements, aurora store, microg…etc..they mostly don’t play nicely together, there is just no guarantee it will work. A clean device will set a baseline for the installation.

    11. Some advice on the procedure?
    -always read the message boxes – they are NOT just for your amusement there, it’s very easy to miss something
    -before doing anything – do a backup
    -don’t give up on the first try
    -don’t assume the next step – there are message boxes (already told that, but..)
    -always first read the questions, then the troubleshooting – before asking a question

    12. Ok, so I successfully installed the GMS, everything works. Can I update the Apps, upgrade the system, delete Googlefier, delete LZplay, delete Google Account Manager?
    -Of course, the answer to all is YES. After the successful installation you can report the success-or a failure, just tap on “?”, it will lead you to the “YES it works”, “NO it doesn’t work” chooser. And of course, there is the donate button, which is appreciated and welcome, since a lot..lot of time is invested into this, and still being invested through the support and further investigation.
    I personally have used this services to update

    13. Will this work on my device, version 154? or Will this work on my device, version XXX ?
    -Yes and No. There are multiple factors. Depends if lzplay was at some time installed on this device - no matter what version it was on. If it was installed at for example version 106 and you made a FR, then YES you can still install even if on 154 or more recent. There is however a list of the devices that works by default and some that users report it works on.

    14. Can I run it on my XXXX on my YYYY version?
    -See this:

    15. It doesn't work...
    -Ok, let's try fixing it. I see some Honor users just hit the "doesn't work" button. There is still downgrade, let's look up the firmware and test it. If I could spend 2-2.5 months investigating this and then again downloading all the firmware files, extracting them, repacking and uploading them, I guess 1-2 minutes of your time isn't too much to ask?

    click ----> Donate - for support and future projects
    ---this post will change, be sure to visit it for more information