• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Googlefier - Install GMS on Huawei/Honor

Search This thread

misterbebel62

New member
Nov 2, 2021
1
0
C'est absolument FAUX. Les mises à jour du système ne cassent pas GMS, pas même le patch d'octobre.
Vous êtes prêt à mettre à jour.

La seule chose que vous ne devriez pas mettre à jour, ce sont les services GOogle Play. Si vous mettez à jour cette application, cela déclenchera des avertissements de protection contre le jeu et brisera votre Google Play Store et diverses autres applications car cela invalidera votre certificat de jeu.



Si vous avez mis à jour les services Google Play et que Google Play Store ne fonctionne plus, vous pouvez résoudre ce problème en désinstallant l'application des services Google Play. Alors téléchargez ce pack :
et installez Fix.apk certifié 7-GSM Play Protect
ce fichier. Ensuite, redémarrez et ce sera corrigé.


Hello,

Following the concern of updating the services which blocked the google apps, I reset my phone.
However, I cannot reinstall all of the apps. I used your link to download the package. I installed googlefier, add the googles accounts then the apk installed. During step 3, where you have to launch the playstore, it does not work: impossible to open the playstore ... I tried to install the zip apks (6 and 7) but it does not change anything: unable to open the playstore (or contacts)? An idea of the problem ?
 

[email protected]_

Senior Member
May 1, 2007
191
8
35
Sofia
Hi,
I have a question (could be answered, but can't find it). I have GMS running for some time, however, I had to change my Google account's password. Now every app, that uses my Google account stopped working. How can I fix this. Do I have to install everything from scratch?
Thanks in advance.
 

[.::MDT::.]

Senior Member
May 20, 2012
358
45
Huawei P40
Hello,
I tried to install google apps on my Huawei P40 Lite but I am stuck after many unsuccessful attemps.

I followed this video but I get stuck here:
I get error DF-DFERH-01 when open Google Play Store instead of having it working correctly, as shown in the video.

Details:
HUAWEI P40 lite
MODEL JNY-LX1
Build number 10.0.1.136 (C432E2R2P1) -> downgraded via
EMUI version 10.0.1


Any help?
I tried the Googlefier procedure many many times, factory reset the phone, tried again and again and again... no luck! :(

Thank you very much.


I somehow managed to get Google Apps running now, by fixing the "This Device Isn't Play Protect Certified" error following https://forum.xda-developers.com/t/...scussion-support.4346741/page-3#post-85793741 and then redoing the Googlefier procedure to fix and redo the last steps a few times... but Contacts won't sync yet!

I tried the "fix contacts sync" procedure in Googlefier but it doesn't work.
Any suggestions?

Thanks!
 

RioPetru

New member
Nov 4, 2021
1
0
Hello today I was able to downgrade my Huawei P40 lite via OTG with your firmware thank you from my heart. Is there a minimum fee to make a donation?
 

healer666

Member
Dec 30, 2009
13
2
I'm running the latest play store and GMS 21.21.16. Just turn off the Play Protect and auto update. Maybe turn off data so that you can make sure it's off before it updates... It should be fine.
Hi mate,
Searched for play services 21.21.16 but found a lot of versions.
Can you help on what should be the correct one for p40 pro?
Thanks in advance.
 

healer666

Member
Dec 30, 2009
13
2
21.24.15 (120400-381273646)
Hi,
This fixed my problem of contacts not synching.
Now, only things not synching are keep notes and Google News.
Google duo can't setup... When trying to send sms to validate phone number says that cannot sent request, check connection and try again.
Anyone got around this?
Also seems that some notifications are not appearing.
I googlefied my p40 pro lots of times and this was the most functioning GSM I got until now.
Thanks
 
  • Like
Reactions: RedSkyRoad

healer666

Member
Dec 30, 2009
13
2
Seems that many apps not firing notifications, they appear only when I open the app.
How can I solve this, googlify again? 😢
Does anyone know any workaround?
Thanks,
 

badmania98

Senior Member
Sep 23, 2007
1,443
531
51
ROMANIA
Huawei P40 Pro
Seems that many apps not firing notifications, they appear only when I open the app.
How can I solve this, googlify again? 😢
Does anyone know any workaround?
Thanks,
No re-googlefier needed.

See this post on my thread:
 

healer666

Member
Dec 30, 2009
13
2
Thanks for the help.
Tried your solution, now I don't have play store, error on opening, seems no. That no notifications yet..
Device ID says no Google play services Installed.
But i see that it can be solved after some hours, I'll wait to see if anything changesand try again the final steps of the procedure.
Thanks.
 
Hi! I have used Googlefier on a Mate 30 pro and I'm happy with it. However I've some problems, maybe someone could help me:
- I need to upgrade gps to use contact tracing app but when I upgrade them from play store I have the problem the the phone is not play protect certified. I downgraded the GPS and the apps worked again. How can I solve?
- I installed YouTube Vanced but I can't login, is it normal?
- Hey Google is not working, are there any trick to solve?

Thanks a lot!!
 

Leon200318

Member
Nov 19, 2019
12
0
I did all Steps with my Huawei p40 lite and google is running fine.
Only thing i have is that google pay shows a gray screen for like 0.5 seconds when i try to setup nfc payment and then goes back to the normal app start screen.
Is there anything i missed or did wrong?
 

Leon200318

Member
Nov 19, 2019
12
0
I think you know what GPay is. GPay can't be used to pay in shops, with NFC.
Other bank apps can be used to pay. Not GPay. In GPay case, doesn't matter if you have GMS installed or not.
Idk what you mean Google pay can surely be used to pay in shops via NFC
My brother uses Google pay everyday for it
There's also an option in Google pay for. It
But when I click the option there just comes gray for a second and goes back
 

Thetega

Member
Jul 4, 2015
39
2
Hello Everyone!
I just bought a Huawei Matepad T10 (not the T10s) and I'm trying to install Google Play for 3 days now, but I always fail.
The LZPlay always says the device is not supported (and the backup app what the Googlefier tries to install, always fails to install, because of something about inconsistency, but the preinstalled does the job anyway). I can login to my Google account with the MicroG, but when I need to remove that as per instructed by the Googlefier, the logged in account disappears from the account list.
When I do everything with the Goglefier, the Play Store just opens and closes immediately.
I managed to install the apk-s what the Googlefier installs separately as experimentation, but the Play Store always says I need to log in, but nothing happens when I press the button.

Is anyone out there who ever succeeded to install the Play Store on this device?

When I bought it, the firmware version was already 10.1.0.191 and I can't find any other firmware for it online.

I would really appreciate any help to guide me to the right direction. :)
Hello everyone, i have this same problem.

Any fix please
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hey all , my lad got a Chromebook for Christmas and it wanted me to sign into a parent account , doing so has done something to my Google account on my googlified p40 pro. I've now got a googlified device but have removed my gmail account . Is this a quick fix ?
    No. 2 here.
    1
    Is there a tldr? the language and video quality make following step 2 problematic! Ha
    what tldr means? You dont need sound. Download the files from description and start from min 05:30.
    1
    Hi badmania98,
    I was just reporting a problem encountered with Googlefier for the third time in a week, with a common version of P40 pro in my case.
    If anyone find a working tutorial on youtube, please let me know :)
    You can start reading my thread here.. You will find many info there.
    1
    Hi Bender, first I'd like to thank you for your contribution in the community.
    Secondly, I ran into an issue that doesn't exist in troubleshoot section.
    My phone is P40Lite
    Model: JNY-LX1
    Build: 10.0.1.167(C316E4R2P1)
    This is the earliest version I can rollback to with official Huawei software.

    After I followed the initial backup / restore process, LZPlay was successfully installed (谷歌助手服务). Then I ran the LZPlay app, and switched back to Googlefier, then new buttons showed up with 01, 02 and 03 respectively.
    When I pressed 01 button, there's no response. I could see the faint shadow of the button on the screen as I pressed it, so it's definitely not the screen's problem.

    I have tried at least twice on each of the following methods to resolve it:
    1. Reinstall Googlefier and LZPlay app.
    2. Disabling/Enabling all the permissions for both Googlefier and LZPlay app.
    3. Reset all the settings of the phone.
    4. Reset the phone completely.

    Nothing works so far. My guess is that either there's an update on Googlefier that I didn't get (downloaded the APK via mirror link), or my phone with that build number is just no go :(


    Thank you very much again for the awesome work so far. Any guidance is highly appreciated :)

    Hi all,

    First, let me thank you all for your awesome work, very helpful!

    I have the same problem as Stein1290 and Mentalchaoz just above.

    "After I followed the initial backup / restore process, LZPlay was successfully installed (谷歌助手服务). Then I ran the LZPlay app, and switched back to Googlefier, then new buttons showed up with 01, 02 and 03 respectively.
    When I pressed 01 button, there's no response. I could see the faint shadow of the button on the screen as I pressed it, so it's definitely not the screen's problem."

    I have a Huawei P40 pro ELS-NX9 build 10.1.0.121 that was downgraded following instructions with HiSuite proxy.

    Do you have any idea on what to do? It seems it is a new problem as we are 3 having this problem in the same week.

    Thanks in advance!


    The problem has been solved. Googlefier cannot work on ...2022. You have to set the phone date to 2021 and googlefier will work.
    More details: here.
  • 41
    Wecome to Googlefier,

    After a successful tool for LG G2 and LG G3 owners (AutoRec), but after a long pause, here is something new and I hope useful

    Googlefier is a simple tool, designed to help you install GMS on your Huawei/Honor device


    gf.PNG



    Video & Article - please take time to watch the video, answers some open questions



    Check stats for your device here

    statsi.png


    Please read the Q/A on POST #2 < click

    Downgrade help is on POST #3 < click

    Firmware Downloads (c432 global only) are on POST #4 < click

    Troubleshooting is on POST #5 < click


    Before asking any questions please read posts 2-5, check if your question has already been answered, in order to keep the thread clean.

    Also - try to ask questions in some sense they are understandable

    A simple: "IT doesn't work - will be ignored and possibly deleted, because it doesn't add to thread quality", instead you should describe the steps properly, and you will get an answer.

    I also encourage all of the members to keep the "alternative downgrade methods" to some other threads, which I will for sure link later. Also please don't spam with firmware links, rather PM me and I will add it to POST #4, let's try to keep the thread clean. As time goes by, I'll try to add more firmware and cover more of the Q/A and Troubleshooting POST/Section so everyone can help himself / herself by simple power of reading



    As always, any donation is highly appreciated and welcome, since a lot of time has been invested into this tool and in research




    click ----> DOWNLOAD - click here to download <- Someone ddosed the server, which means the server is gone, thx a lot :), I mean I don't have anything out of the downloads, I guess the person who ddosed the server had some incomes coming either from googlefier (since some sell it for 4-5 dollars) or it did hurt him in other way..thx a lot, good job!

    Alternative DOWNLOAD from APKMIRROR <----

    click ----> Donate - for support and future projects




    P.S. Please DON'T reupload without permission


    changelog:
    27.10.2020 - Added contact fix (if you are installing it fresh you don't have to do anything to apply it) (if you already have running services - press the FIX button and then press FIX contact sync (it will ONLY fix the contact sync, nothing else))


    popravak.png



    credits:
    microG - microg
    EloYGomeZTv - microG fork + login
    9
    Firmware Downloads





    I'm confused, what do I download?

    -Check your emui version, the important data is:

    1. device name
    -example ANA-NX9

    2. version
    -example C432 or C185 - just download the one for your device


    P40 Lite
    JNY-LX1
    10.0.1.111(C432*****)


    download


    P40 Lite
    JNY-LX1
    10.0.1.136(C432E2R2P1)


    download

    P40 Lite
    JNY-LX1
    10.0.1.111(C185E2R2P1)


    download

    P40 5G
    ANA-NX9
    (C432E6R5P2)


    download

    P40 5G
    ANA-NX9
    (C432E5R4P1)


    download

    P40 5G
    ANA-NX9
    EMUI*109(C432E5R4P1)


    download

    P40 5G
    ANA-NX9
    10.1.0.131(c432)


    download

    P40 5G
    ANA-NX9
    10.1.0.121(C185)


    download
    mirror

    P40 Lite E
    ART-L29
    C432*****


    download


    P40 PRO+
    ELS-N39
    C432****


    download
    P40 PRO
    ELS-NX9
    (C432E8R5P2)


    download

    P40 PRO
    ELS-NX9
    (C432E7R4P1)


    download

    P40 PRO
    ELS-NX9
    10.1.0.114(C185E9R3P1)


    download

    P40 PRO
    ELS-NX9
    10.1.0.114(C636E8R4P1)


    download

    Y5P
    DRA-LX9
    (C432E3R1P2)


    download

    Y7P
    ART-L28
    10.1.0.106(C636E2R2P1)


    download

    Matepad 10.4
    BAH3-W09
    10.1.0.118(C432E4R1P3)


    download

    MatePad Pro
    MRX-W09
    10.1.0.120(C432E135R1P135)


    download - Thx to TMc19


    HUAWEI P40 lite 5G
    CDY-NX9A
    10.1.1.131(C432)


    download


    Honor V30 pro 5G
    OXF-AN10
    3.0.1.152(C00)


    download





    Removed firmware requests, I don't have the bandwidth on easy-firmware, nor the time to constantly download-upload stuff, sorry

    click ----> Donate - for support and future projects
    ---this post will change, be sure to visit it for some more firmware


    Alternative link with all of the downloads: click here

    8
    Downgrade Help






    Downgrade via usb/sd


    You NEED USB-OTG -> see the picture

    usbotg.jpg




    Prerequisites

    1. Check your firmware version(emui)
    2. Check the stats about the max supported version for Googlefier/Lzplay
    3. Download the firmware which is supported
    4. Make backup…

    Where can I find the firmware?
    -All of the firmware version that are in the download post I’ve downloaded from easy-firmware, yes I’ve paid 17$ to be able to download firmware for people, but you are welcome to get your firmware from a source which you prefer, please don’t pollute the thread with the firmware download links, there should be a separate thread for that

    transfer.png


    Method 1

    0. Make backup..seriously, this will wipe your partitions and reflash them(your files will be gone)
    1. Download your firmware
    2. In case it’s from my uploads you just extract the “dload” folder to your usb/sd
    3. Turn off your phone
    4. Hold volume up and power, until you see the recovery (or. https://www.youtube.com/watch?v=ztobeBHh4Fk if your phone doesn’t have volume keys)
    5. Select upgrade "Memory card / OTG update mode" and that’s it, it will first verify the firmware and flash






    Note: If method 1 doesn't work, try method 2.

    For troubleshooting – see the troubleshooting section

    Method 2

    you need HiSuite 10.0.0.510 (find it and download, install it)
    1. -Open your dialer inside android
    -type *#*#2846579#*#*
    -tap on 2. "Veneer Informations"
    -tap on 1. "Version Info"
    -scroll down to "Base Software Version"
    -You will see something like "JNY-LGRP2-OVS 10.0.1.108"
    -Just ignore everything after LGRP2, means you need the "JNY-LGRP2" only
    -Type "JNY-LGRP2" or any string you find in that info - into textbox from step 1(in the hisuite proxy) and press step 1

    2. Find a suitable firmware, check that it's "FullOTA-MF" and not just OTA-MF, copy the url link next to the date, paste it into the "package url" inside the hisuite proxy
    3. Copy the text which is next to the date, on the webpage - paste it to the "firmware version" inside the hisuite proxy
    4. Press "Start proxy", connect the phone, authorize with HDB (you should know how to do that)
    5. press update in HiSuite - It will download the older firmware and install it

    Here is the image of how the procedure looks like: CLICK

    DOWNLOAD Hisuite Proxy Modified

    Note:

    IF method 1 doesn't work for you (stuck at 5%), try finding the firmware somewhere else, or do what I do

    1. find some service where you can download firmware (I use easy-firmware)
    2. pay 17$
    3. find your firmware, download it, extract using that weird ef extractor
    <- this is exactly what I do all the day when you ask me to upload you firmware

    What to check?
    1. device name
    -example ANA-NX9

    2. version
    -example C432 or C185 - just download the one for your device

    OR - try method 2 with hisuite

    Note 2

    You might be able to download the firmware using the free service here ,
    but this is something for the "method 2" for now. I will work on it to try to use the very same firmware you can download from there so you can use it with your SD or USB.
    Not promising anything, but I think it's doable - I just don't have a device ATM and I don't want to bother anyone risking a device


    click ----> Donate - for support and future projects
    ---this post will change, be sure to visit it for alternative/different downgrade methods
    8
    Hi, at first thanks for this very clear process, but I realized, this is not working with matepad 10.4 (BAH3-W09).
    I downgraded successful to 10.0.118, but lzplay is not initialized.
    After I read 20 pages of this thread, it looks like the (C432) version of matepad is not googlefiered with this method. Please, update the original post about this device to help others not spend much time with that.
    7
    Q/A



    1. What devices are supported?
    - Currently Huawei / Honor devices running Android 10 and Emui10. There are limitations based on firmware versions.

    2. Does it use LZplay(Chinese app)?
    -Yes it does. You can uninstall it after the installation is done.

    3. How do I know if it work on my device?
    -You don’t. You need to try it. IF lzplay runs on the device then it will 99% work. However there is a list where you can see some firmware versions on which it’s reported to be working.

    4. I don’t have LZplay and it still worked, how?
    -At some point, on previous firmware version – your phone had LZplay running and/or someone tried the GMS installation method. (yes, even after resetting..yes weird..)

    5. Do firebase push notifications work?
    -No they don’t, some apps will have their notifications pushed through, most of them wont.

    6. I'm getting notifications, a lot of them, what do I do?
    -Hit the fix button and follow the instructions.

    7. I've hit the FIX button, but it doesn't fix a thing. Why do you lie to us? :D
    -The fix button is there to assist you in fixing your own errors :), you didn't follow the procedure.
    -After you hit "fix", just read the instructions.
    -After EVERY single services install do this:
    *Open playstore, browse it, close playstore and all running apps from the recents menu
    *Open sync settings, uncheck-and re-check the sync on/off settings
    *Open playstore - install 2-3 apps, games...close playstore and all running apps from the recents menu
    *Proceed with button 3, just like the message box instructs (until it says everything is done)
    *still getting errors? Repeat..

    8. Does APP {insert name here} which depends on google location services/play services/games work?
    -Most probably it does, even apps like tapatalk work with the google sign in

    9. Is factory reset mandatory?
    -No, there is a button to make sure your previous experimenting is deleted

    10. Will this damage/delete my data?
    -No, this doesn’t touch your data. Although a factory reset is recommended if you want to do it right. Some people use different google replacements, aurora store, microg…etc..they mostly don’t play nicely together, there is just no guarantee it will work. A clean device will set a baseline for the installation.

    11. Some advice on the procedure?
    -always read the message boxes – they are NOT just for your amusement there, it’s very easy to miss something
    -before doing anything – do a backup
    -don’t give up on the first try
    -don’t assume the next step – there are message boxes (already told that, but..)
    -always first read the questions, then the troubleshooting – before asking a question

    12. Ok, so I successfully installed the GMS, everything works. Can I update the Apps, upgrade the system, delete Googlefier, delete LZplay, delete Google Account Manager?
    -Of course, the answer to all is YES. After the successful installation you can report the success-or a failure, just tap on “?”, it will lead you to the “YES it works”, “NO it doesn’t work” chooser. And of course, there is the donate button, which is appreciated and welcome, since a lot..lot of time is invested into this, and still being invested through the support and further investigation.
    I personally have used this services to update

    13. Will this work on my device, version 154? or Will this work on my device, version XXX ?
    -Yes and No. There are multiple factors. Depends if lzplay was at some time installed on this device - no matter what version it was on. If it was installed at for example version 106 and you made a FR, then YES you can still install even if on 154 or more recent. There is however a list of the devices that works by default and some that users report it works on.
    workingversions.PNG

    14. Can I run it on my XXXX on my YYYY version?
    -See this:
    canitrun.png


    15. It doesn't work...
    -Ok, let's try fixing it. I see some Honor users just hit the "doesn't work" button. There is still downgrade, let's look up the firmware and test it. If I could spend 2-2.5 months investigating this and then again downloading all the firmware files, extracting them, repacking and uploading them, I guess 1-2 minutes of your time isn't too much to ask?

    click ----> Donate - for support and future projects
    ---this post will change, be sure to visit it for more information