Googlefier - Install GMS on Huawei/Honor

Canna77

Member
Jun 3, 2016
29
0
1
I managed to use gspace to access the play store in the t10s, but the problem is that I am using an account made by the school and it asks me for "action required on the account" and no app appears to me except Chrome, while if I use my account find me all apps
 
Last edited:

Emilehitere

New member
Dec 31, 2020
3
0
1
Thanks to bender007 and to bajangg for their explanations in the forum, I succeded in downgrading my EMUI.

The most difficult was to downgrade, because I usually use a Mac, or a proxy connection... When I succeeded in downloading HiSuite 11 and 10, I was out of trouble. Just had to be patient.

Huawei P40 Pro
Model ELS-NX9
Build 11.0.0.151 (C432E3R5P3)

1/ with HiSuite 11 from EMUI 11 to EMUI 10.0.1.176

2/ with HiSuite 10 from EMUI 10.0.1.176 to .131

3/ Googlefier didn't work... In fact it worked but I kept having the annoying notification asking for Play protect....
After 10 attemps to fix the problem, I tried somthing else.

4/ I downgraded form 10.0.1.131 to 10.0.1.109 with HiSuite, then started again with Googlefier.
After 3 or 4 attemps it worked.
Now I have everything running good, Playstore, GMS, G Maps, etc...
I updated everything and now I run EMUI 11.0.0.168 with Play store ok.


I'mposting this RETEX on the forum for everybody to understand that's just a question of following the method and not waiting for it to work the first time.

Thank you very much Bender007 or Bajangg for the time you spent for all of us.

Please take some time to read everything they wrote, and to watch to the videos (specially the one bajangg posted about downgrading).
And take a minute to donate...
 

x4ce

Member
Jul 15, 2013
25
2
23
I'm having weird results when installing googlefier

tried on my Mate 30 Pro 5G LIO-N29 on both 10.1.0.234 and 10.0.0.179

all the process goes smooth apart for the fact that when opening google play it opens, flashes whit and closes.

Any suggestion?
 

Emilehitere

New member
Dec 31, 2020
3
0
1
I'm having weird results when installing googlefier

tried on my Mate 30 Pro 5G LIO-N29 on both 10.1.0.234 and 10.0.0.179

all the process goes smooth apart for the fact that when opening google play it opens, flashes whit and closes.

Any suggestion?
I think your answer is here...

Troubleshooting

[...]

5. Google Play Store just crashes, what happened? I've done the login procedure
-Downgrade your firmware.

[...]

click ----> Donate - for support and future projects
---this post will change, be sure to read it if something is off
 

apac

New member
Jul 21, 2009
3
0
21
Hi!

Someone could describe how I can conjure GMS for P40 5G. I’m past the videos already, none of them succeed.
My current software version:

84388_img_20210122_162157.thumb.jpg

I was already confused as to what kind of firmware to put on it.

Thanks in advance for the answers,
 

PingMan4000+

New member
Jan 22, 2021
1
0
11
Hey guys! I saw problem like that, but there were no straight answer for that. I did downgrade with HiSuite 11 on my P40 Pro. Then I downgraded it with HiProxy. Everything works fine - I had to problem to install Googlefier. BUT I'm having issues to upgrade it to Emui 11. OTM updates doesn't works. I can only upgrade it manually with HiProxy. I tried to update it manually few times and I was hoping it will move it on. Right now I'm on 10.1.0.161 and still no updates. Any suggestions?
 

SiRIus[X]

Senior Member
May 23, 2009
344
5
48
recent check with phone stats showed

MODEL = CDY-NX9B
EMUI = 10.1.1.210
TOTAL = 1

WORKS
SUCCESS RATE
= 100%


but i can't seem to make it pass LZPlay. can any masters in here enlighten me just for a bit?
 

GurkhaUK

Member
Jun 17, 2012
32
5
28
So a week on from my Downgrade update to my P40 Pro.
Here is what I have found

What doesn't work -
Google Pay - Can't add a card it can see my details but it just times out when I start the process.
Wear OS - Similar sort of error just basically won't add my account to the watch from the phone.

Other than those two I have had no issues at all I even added my Barclays app which really surprised me because that app won't install on Lineage OS for example.

I'm a huge Google user basically everything is in someway intertwined with the company. I do think going back deeper than .131 helped my install and then cloning from a pixel once I was logged in and updated.

I think the big key for this to work is patience don't try and be smart just follow the process. It took me 4 hours in total from out of the box to in my pocket.

As for the phone Im Impressed, I had a Mate 20 Pro and its on par with that. Battery is averaging 6 hours SOT with juice still left at the end of the day. Camera is awesome and Photos as synced well.

I hope it just ticks along now definitely glad I bit the bullet....oh and Stadia works too so that's another bonus.
 

Glegionar

Member
Oct 24, 2013
6
0
21
Hello everyone! I just used Googlefier on a P40Lite E. It took some hour but now works perfectly (I have a suggestion to all of you: read everything the app says to you. Every step, read carefully. It took me some hour to make it work because I didn't read everything. A little hint: the button number 3 must be pressed a lot of times! xD so, again, read everything!). I also updated the Emui to the latest available for this phone and deleted Googlefier&co. and the Play Store works still perfectly.

Now, I'm making this question just because I couldn't find any answer on internet nor here on this thread (there are 85 pages, I simply cannot scroll through every message, so sorry in case this question has been already made in the past) and I wish to understand why some feature is not available.
Now, Youtube: why for youtube is available only the 720p60 option and not the higher one?
Bonus question: Netflix, why is not available on Play Store? I managed to install it via apkpure, but if I look for it on the Play Store it simply doesn't show up.

Thank you in advance for the answers ^^
 

winjie_89

New member
Jan 24, 2021
1
0
11
Mine is Nova 7 5g( JEF-NX9)
I have installed all the available versions(10.1.1.161., 198, 199, 201) and tried GMS installation. But every time the LZ app showing a blue warning and not opening. Anyone can help? The lowest security patch update available with 161 is dated 30 June 2020, and even I searched a lot I cant find a lower version.
Any luck for Nova 7 5g( JEF-NX9) yet?
 

Hadol93

New member
Jun 19, 2014
3
0
21
Hello, I did downgrade to 10.0.1.108 on my p40 lite. Google services work fine but I have a problem because I am not getting system updates neither on the phone nor in hisuite. I did it over a month ago.
He writes that the software version is up to date.
How to solve this problem?
 

mumse1

Senior Member
Jan 10, 2013
66
15
28
Tibro
I have successfully installed GMS on my phone thanks to @bender_007 and his great work (also watching YouTube videos as a guide)
I have also frozen GSF to get push notifications to work.

But one thing i can't get my head around is why it's so hard to get a fully working Google installation on this devices..
I mean, I have owned a bunch of small China brand mobile devices thru the years (elephone, umidigi, bluboo, Blackview, etc.) all with working GMS installed.
Before I bought my P40 pro I had a Asus max M2 pro as a daily driver and have for the last year flashed it with custom roms (Lineage OS 16 & 17, Pixel Experience 10 & 11) and all of the roms have fully working GMS installations.
Maybe the answer is simple but can someone please explain to me why Huawei devices seems to be impossible to get to work 100% ( without having to ex. choose between notifications or play store + location services)
 

Playtime7

New member
Jan 24, 2021
1
0
1
Hello bender I did everything as described only when I start the LZ play app after I have set the date back to automatic though a blue bar comes directly but I can't allow a correction as in the screenshot this picture comes directly when I open the LZ play app I own the Huawei Y5P I just reset it please to help here the screenshot
Also the Google play store app opened briefly in white where I still tried everything to complete so all steps


I still have to say the first time where I had given it up because I had not understood it correctly my phone after the data backup still reinstalled the software of you properly like a new mobile phone but this time I don't know what's going on

Greeting



Screenshot_20210124_220756_com.lzplay.helper.jpg
 
Last edited:

Glegionar

Member
Oct 24, 2013
6
0
21
Hello bender I did everything as described only when I start the LZ play app after I have set the date back to automatic though a blue bar comes directly but I can't allow a correction as in the screenshot this picture comes directly when I open the LZ play app I own the Huawei Y5P I just reset it please to help here the screenshot
Also the Google play store app opened briefly in white where I still tried everything to complete so all steps


I still have to say the first time where I had given it up because I had not understood it correctly my phone after the data backup still reinstalled the software of you properly like a new mobile phone but this time I don't know what's going on

Greeting



View attachment 5197997
This screen shows up when your firmware is too updated for lzplay. You should downgrade your firmware first, then proceed with Googlefier.
 

03jeff09

Member
Jan 2, 2021
8
0
11
Hi Guy, I had asking few time, but no ppl reply mine question.

My current Matepad Pro is MRX-W29 10.1.0.183 C636, i try to downgrade the firnware as mention on 1st page, but is different version.

I also using the proxy solution but cant find any firmware.

May I ask is that anyone success to downgrade the Matepad Pro is MRX-W29 10.1.0.183 C636 and install the GMS.

Thx everyone