• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question Google's Messages stuck on "trying to verify" in chat features activation menu

Search This thread

dkcats3

Senior Member
Sep 13, 2013
240
108
OnePlus 9 Pro
I'm still having this issue but instead of coming from an old phone, it was working on my OP9P but then after a factory reset and installing a custom rom it wont verify now. Even restoring back to Oxygen, it still wont verify
 

dkcats3

Senior Member
Sep 13, 2013
240
108
OnePlus 9 Pro
After trying every thing on every site, the last idea I'm trying is from some random blog post. They claim it takes 7-10 days for Jibe to deactivate and unregister your device from their system, and you have to leave chat features disabled or the timer resets. After that I will hopefully be able to activate it again.
 

dkcats3

Senior Member
Sep 13, 2013
240
108
OnePlus 9 Pro
same as you !
i even tried on my old phoneS, still unable to connect to RCS.
i'm doing the cold turkey for 10 days too. haha
So I talked to google Fi support (since I transfered from Fi to Verizon without disabling chat first, and I think that is the root of the issue), and Fi confirmed to me that if I disable it for at least 8 days and then turn it on on or after the 9th day, it should be completely deregistered by then and will activate like new.
 
  • Like
Reactions: netnerd

GM90765

New member
Jul 25, 2021
1
2
Hello All. I have great news. My RCS is finally working. Here is how I did it, please read this very carefully. Read my original post in Recommemded Answer green color above link.
You must disable chat on all previous devices by going here and (on bottom of this site) follow directions: https://messages.google.com/disable-chat
Then you must TURN RCS CHAT FEATURES OFF in GM and wait exactly 10 days.
If you turn RCS ON before 10 days are gone, the clock starts all over again for 10 days.
You literally have to be patient and wait 10 days with the RCS OFF for 10 days.
After 10 days, turn RCS ON and you will see CONNECTED !!!!

I repeat to you again, STEP 1 is: You must deactivate all prior devices' GM phone number associations by following the bottom instructions on this site: https://messages.google.com/disable-chat and if you get error message like: contact your carrier or you requested code too many times, disregard it.
Then STEP 2, TURN RCS OFF FOR 10 DAYS in GM and wait 10 days. If you potz around and turn on RCS in GM BEFORE 10 days are gone, you must start 10-days clock all over again! Just be patgient for 10 days.
STEP 3: On day #10, Clear Cache in GM and turn on RCS and you will see that you are GREEN LIGHT in RCS as CONNECTED. The best thing to do for this step 3 is to: completely uninstall Google messages and completely uninstall Carrier Services and then reinstall Google messages and reinstall Carrier Services. If you do this in this step, your cash and Data will be cleared.

I am an expert in this now as I have triued everything: Contacted carrier, contacted device manufacturer, uninstalled Carrier Services and Reinstalled Carrier services. This has nothing with the carrier nor device manufacturer nor Samsung nor Motorola nor OnePlus. This RCS trying to verify.... occurs because when you switched your device, or when you switched SIM, or when u ported a number, or when you activated Google account email on another device, you DID NOT turn OFF RCS in GM or did not turn OFF RCS in the native Messages App, and now Google's RCS sees that you have RCS active in multiple devices/accounts/phone numbers, in which RCS remained TURNED ON, and Google RCS Server gets confused. What you need to do is STEP 1, STEP 2 and Step 3. Step 1 will deactivate ALL the shmootz you created and Step 1 will DEACTIVATE ALL devices' and all phone numbers' and all accounts' RCS GM once and for all. Step 2 does the "reset with google". Step 2 takes you OFF of "blacklist" at google. I see some people waited 8 days-not good. You absolutely must wait 10 days (not business days) - 10 CALENDAR DAYS and the day you do step 1, and step 2 is day #1.

And by the way: Please make sure you have CARRIER SERVICES INSTALLED AND UPDATED from Google Play Store as well as latest updates of GM, and please update your device firmware by checking for update in SOftware Update in Settings. Basically please update your device firmware and all device apps in Google Play Store all aroung before proceeding with Steps 1,2,3.

Let me know, but dont tell me that it doesnt work because you did not wait 10 full days. You must wait 10 days and then reply here and let me know.

If you are unable to send or receive messages on Google messages app, this post does not apply to you. What I recommend you do is to: completely uninstall Google messages and completely uninstall Carrier Services. Then reinstall Google messages and reinstall Carrier Services. Then contact your cell phone carrier and ask them to refresh your connection and make sure that your messages and data features are turned on on the carrier side and make sure that Short Code Programming is also turned on, on the carrier side. So make sure messaging, data and short code programming is also turned on, on the carrier side. And meanwhile do not touch the toggle for full 10 days. In 10 days toggle ON and u will be set.

I wrote 3 steps: make sure you read this twice to fully understand and follow my directions.

From now on, you need to understand the concept, to make sure that this RCS feature not turning on again never happens to you again, you FIRST must make sure that before you change your devices, or change SIM cards in devices, or change Google accounts in devices, you absolutely must make sure that the first thing you do is: TOGGLE RCS CHAT OFF in GM FIRST before changing devices, sims or accnts! Otherwise, the Google server will be very confused and will Blacklist Your account, your device and your phone number by yourhaving too many RCS features toggled on in GM everywhere. To get UNblacklisted and turning RCS back to ON, you must read the steps 1,2 and 3.
When i say 10 days, i mean 10 calendar days, not 10 business days. Day #1 starts the moment you toggle OFF rcs and keep it OFFfor 10 calendar days.

You absolutely must respect the 10-DAY TOGGLE OFF, as i explained to you in Step 2. This step 2 is the only step that will UN-blacklist your phone number, you GM, and your GM account from the Google server. Please respect the 10day toggle off. If you potz around with toggle, you will not have RCS, and your 10day clock will start all over again with every time u potz around with Toggle.

ALSO: ON DAY # 10, WHEN YOU TOGGLE THE RCS ON, IN THE GOOGLE MESSAGES APP, THE GOOGLE MESSAGES WILL ASK YOU TO RE-TYPE YOUR CELL PHONE NUMBER TO VERIFY IT WITH GOOGLE (THAT SAME DAY 10), PLEASE RETYPE THE PHONE NUMBER VERY SLOWLY AND CORRECTLY-BECAUSE: IF YOU TYPE YOUR NUMBER INCORRECTLY, EVEN BY 1 DIDIGT, YOUR STEPS 1,2 AND 3 (WITH 10-DAYS TOGGLE OFF) MAY START AGAIN. PLEASE SLOW DOWN AND BE VERY CAREFUL WHEN YOU RE-TYPE YOUR CELL NUMBER INTO GM APP WHEN IT RE-ASKS YOU TO VERIFY YOUR CELL NUMBER ON THAT DAY #10. PLEASE SLOW DOWN AND BREATH SLOWLY WHEN TYPING YOUR CELL ON DAY 10 (AFTER YOU TOGGLE RCS on ON SAME DAY #10.)
 
  • Like
Reactions: rodken and netnerd

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Hello All. I have great news. My RCS is finally working. Here is how I did it, please read this very carefully. Read my original post in Recommemded Answer green color above link.
    You must disable chat on all previous devices by going here and (on bottom of this site) follow directions: https://messages.google.com/disable-chat
    Then you must TURN RCS CHAT FEATURES OFF in GM and wait exactly 10 days.
    If you turn RCS ON before 10 days are gone, the clock starts all over again for 10 days.
    You literally have to be patient and wait 10 days with the RCS OFF for 10 days.
    After 10 days, turn RCS ON and you will see CONNECTED !!!!

    I repeat to you again, STEP 1 is: You must deactivate all prior devices' GM phone number associations by following the bottom instructions on this site: https://messages.google.com/disable-chat and if you get error message like: contact your carrier or you requested code too many times, disregard it.
    Then STEP 2, TURN RCS OFF FOR 10 DAYS in GM and wait 10 days. If you potz around and turn on RCS in GM BEFORE 10 days are gone, you must start 10-days clock all over again! Just be patgient for 10 days.
    STEP 3: On day #10, Clear Cache in GM and turn on RCS and you will see that you are GREEN LIGHT in RCS as CONNECTED. The best thing to do for this step 3 is to: completely uninstall Google messages and completely uninstall Carrier Services and then reinstall Google messages and reinstall Carrier Services. If you do this in this step, your cash and Data will be cleared.

    I am an expert in this now as I have triued everything: Contacted carrier, contacted device manufacturer, uninstalled Carrier Services and Reinstalled Carrier services. This has nothing with the carrier nor device manufacturer nor Samsung nor Motorola nor OnePlus. This RCS trying to verify.... occurs because when you switched your device, or when you switched SIM, or when u ported a number, or when you activated Google account email on another device, you DID NOT turn OFF RCS in GM or did not turn OFF RCS in the native Messages App, and now Google's RCS sees that you have RCS active in multiple devices/accounts/phone numbers, in which RCS remained TURNED ON, and Google RCS Server gets confused. What you need to do is STEP 1, STEP 2 and Step 3. Step 1 will deactivate ALL the shmootz you created and Step 1 will DEACTIVATE ALL devices' and all phone numbers' and all accounts' RCS GM once and for all. Step 2 does the "reset with google". Step 2 takes you OFF of "blacklist" at google. I see some people waited 8 days-not good. You absolutely must wait 10 days (not business days) - 10 CALENDAR DAYS and the day you do step 1, and step 2 is day #1.

    And by the way: Please make sure you have CARRIER SERVICES INSTALLED AND UPDATED from Google Play Store as well as latest updates of GM, and please update your device firmware by checking for update in SOftware Update in Settings. Basically please update your device firmware and all device apps in Google Play Store all aroung before proceeding with Steps 1,2,3.

    Let me know, but dont tell me that it doesnt work because you did not wait 10 full days. You must wait 10 days and then reply here and let me know.

    If you are unable to send or receive messages on Google messages app, this post does not apply to you. What I recommend you do is to: completely uninstall Google messages and completely uninstall Carrier Services. Then reinstall Google messages and reinstall Carrier Services. Then contact your cell phone carrier and ask them to refresh your connection and make sure that your messages and data features are turned on on the carrier side and make sure that Short Code Programming is also turned on, on the carrier side. So make sure messaging, data and short code programming is also turned on, on the carrier side. And meanwhile do not touch the toggle for full 10 days. In 10 days toggle ON and u will be set.

    I wrote 3 steps: make sure you read this twice to fully understand and follow my directions.

    From now on, you need to understand the concept, to make sure that this RCS feature not turning on again never happens to you again, you FIRST must make sure that before you change your devices, or change SIM cards in devices, or change Google accounts in devices, you absolutely must make sure that the first thing you do is: TOGGLE RCS CHAT OFF in GM FIRST before changing devices, sims or accnts! Otherwise, the Google server will be very confused and will Blacklist Your account, your device and your phone number by yourhaving too many RCS features toggled on in GM everywhere. To get UNblacklisted and turning RCS back to ON, you must read the steps 1,2 and 3.
    When i say 10 days, i mean 10 calendar days, not 10 business days. Day #1 starts the moment you toggle OFF rcs and keep it OFFfor 10 calendar days.

    You absolutely must respect the 10-DAY TOGGLE OFF, as i explained to you in Step 2. This step 2 is the only step that will UN-blacklist your phone number, you GM, and your GM account from the Google server. Please respect the 10day toggle off. If you potz around with toggle, you will not have RCS, and your 10day clock will start all over again with every time u potz around with Toggle.

    ALSO: ON DAY # 10, WHEN YOU TOGGLE THE RCS ON, IN THE GOOGLE MESSAGES APP, THE GOOGLE MESSAGES WILL ASK YOU TO RE-TYPE YOUR CELL PHONE NUMBER TO VERIFY IT WITH GOOGLE (THAT SAME DAY 10), PLEASE RETYPE THE PHONE NUMBER VERY SLOWLY AND CORRECTLY-BECAUSE: IF YOU TYPE YOUR NUMBER INCORRECTLY, EVEN BY 1 DIDIGT, YOUR STEPS 1,2 AND 3 (WITH 10-DAYS TOGGLE OFF) MAY START AGAIN. PLEASE SLOW DOWN AND BE VERY CAREFUL WHEN YOU RE-TYPE YOUR CELL NUMBER INTO GM APP WHEN IT RE-ASKS YOU TO VERIFY YOUR CELL NUMBER ON THAT DAY #10. PLEASE SLOW DOWN AND BREATH SLOWLY WHEN TYPING YOUR CELL ON DAY 10 (AFTER YOU TOGGLE RCS on ON SAME DAY #10.)
    1
    Never had an issue with this app doing this before, but here we are. I've made sure my number was correct, and even added the Messages app to MagiskHide (which I've never had to do before). It still is stuck. Eventually it gives up trying to verify, but tapping the button just repeats the same issue again. Any ideas?
    It's really annoying I've had this before. What I did I'd clear data cache in the messages app restart phone then do same again delete data cache then open messages app and try again. If that fails then you have to turn chat off for 7 days don't try turning chat on within the 7 days otherwise it resets to 7 days again. It's a right pain in the but.
    1
    I've had multiple issues with apps not sending OTP codes or being able to log in completely, and I even think I've had the same issue you are having when I had "dns.adguard.com" set as my private dns setting. Also, if you use AdAway, that could cause the issue. For some reason I have to disable AdAway to use the Amazon app. Weird.

    Oh yep, in fact I had another thread about that. Turns out the new AdAway seems to inadvertently block a lot of things. Try adding "*amazon*" (without quotation marks) to the whitelist. PayPal was another I needed to add to the whitelist. I also added Google to see if it'd work for this, but nah... No such luck.

    If you have some sort of vpn running, try disabling it and activating chat features. For me it won't work until I turn my vpn off.

    No VPN in my case, that I'm aware of.

    is Google carrier services app is up to date on your phone?

    Yes. I did find it disabled, oddly, so it's enabled and up to date now. Matter of fact, I even installed the latest from APKmirror.
    1
    same as you !
    i even tried on my old phoneS, still unable to connect to RCS.
    i'm doing the cold turkey for 10 days too. haha
    So I talked to google Fi support (since I transfered from Fi to Verizon without disabling chat first, and I think that is the root of the issue), and Fi confirmed to me that if I disable it for at least 8 days and then turn it on on or after the 9th day, it should be completely deregistered by then and will activate like new.