Got Ad-hoc wifi working on my Xoom! (binaries inside)

Search This thread

kelvie

Member
Apr 12, 2011
42
47
Vancouver, BC
I've managed to build a version of wpa_supplicant that has ad-hoc enabled, by forward porting the patch in this thread:

http://forum.xda-developers.com/showthread.php?t=754961

After building and a couple of tests, it works.

To install, you need a rooted Xoom, of course, and just push the file to system/bin/wpa_supplicant.

Because zipfiles don't store permission, you have to make it executable as well.

Code:
adb remount
adb push system/bin/wpa_supplicant /system/bin/wpa_supplicant
adb shell chmod 755 /system/bin/wpa_supplicant

I also had to change the permissions on /data/misc/wifi/wpa_supplicant.conf for some reason:
Code:
adb shell chown system.wifi /data/misc/wifi/wpa_supplicant.conf

Then reboot, and try it!

It works with my Nokia N8 with JoikuSpot; I can't tether it any other way as the N8 doesn't support the PAN Bluetooth profile, and Android doesn't support DUN.

Don't forget to backup your files, and I am not liable, etc, etc.

The code I used is here:
https://github.com/kelvie/android-wpa_supplicant
 

Attachments

  • wpa_supplicant_xoom_wifi_adhoc.zip
    161.1 KB · Views: 13,975
Last edited:

SaintFarris`

Member
Apr 13, 2011
5
0
Ok heres what happened to me..

I was able to push the first file and when I input the adb shell code it said the device was not connected I am rooted and had no problems rooting or access shell before

So I got a little cocky and thought that the port 5037 that adb communicates with was blocked so I typed adb tcpip 5036 to see if I could get shell access on that port well now when I type adb remount it immediately tells me error: device not found....help!

Got myself stuck without wifi (error)
 

Ehsan Mahmood

Senior Member
Feb 19, 2011
101
13
Islamabad
Thanks for developing such a great app. If i m not wrong i think its working with all 3G carriers.

You can also turn your Motorola Xoom tablets to WiFi hotspot without rooting by enabling setting which are given here http://goo.gl/mgwdn
 

SaintFarris`

Member
Apr 13, 2011
5
0
Also my xoom has been in debug mode and now all of a sudden I noticed that its not entering debug mode when connected there used to a little icon come up and not anymore it acts like nothing yet i can access it on my computer by going my computer and I see Xoom
 

SaintFarris`

Member
Apr 13, 2011
5
0
Ok I got debugging mode back and xoom is plugged in now my problem is when the daemon server starts in adb shell it starts on port 5038

So when I try to copy "adb shell chmod +x /system/bin/wpa_supplicant" it still says device not found and thats if I copy and paste it exactly if I type adb shell it gives me the # Symbol then i put it "chmod +x /system/bin/wpa_supplicant" and it says bad mode

One good thing is I can now type /remount again so what I am doing wrong still stuck without wifi ;\
 

SaintFarris`

Member
Apr 13, 2011
5
0
Ok I've tried everything except reflash my devices I've literally only been able to do step 1 which leaves me with no wifi because i cannot execute the shell commands so please a little help it's been a long night messing with this appreciate your time and I'd love to get this working!
 

Fusius

Member
Mar 22, 2007
21
6
Washington, DC
I've managed to build a version of wpa_supplicant that has ad-hoc enabled, by forward porting the patch in this thread:

http://forum.xda-developers.com/showthread.php?t=754961

After building and a couple of tests, it works.

To install, you need a rooted Xoom, of course, and just push the file to system/bin/wpa_supplicant.

Because zipfiles don't store permission, you have to make it executable as well.

Code:
adb remount
adb push system/bin/wpa_supplicant /system/bin/wpa_supplicant
adb shell chmod +x /system/bin/wpa_supplicant

I also had to change the permissions on /data/misc/wifi/wpa_supplicant.conf for some reason:
Code:
adb shell chown system.wifi /data/misc/wifi/wpa_supplicant.conf

Then reboot, and try it!

It works with my Nokia N8 with JoikuSpot; I can't tether it any other way as the N8 doesn't support the PAN Bluetooth profile, and Android doesn't support DUN.

Don't forget to backup your files, and I am not liable, etc, etc.

The code I used is here:
https://github.com/kelvie/android-wpa_supplicant



Ok...I tried this and got the same "bad mode" error at the
"adb shell chmod +x /system/bin/wpa_supplicant" stage.

So, I instead did "adb shell chmod 700 /system/bin/wpa_supplicant" and that was successful, so I finished the steps listed and can see my cell on my Xoom. I have a Windows Mobile 6.5 cell and my Xoom can NOW see my ad-hoc network. Thanks a lot Kelvie.
 

PengLord

Senior Member
Oct 24, 2007
135
27
If not for the SDCard update from BRD, I think this thread would be getting alot more attention.

Not to be too mistrusting, but I am hesitant about loading this on my Xoom when it is posted by a new user with only one post.
 

SaintFarris`

Member
Apr 13, 2011
5
0
Ok...I tried this and got the same "bad mode" error at the
"adb shell chmod +x /system/bin/wpa_supplicant" stage.

So, I instead did "adb shell chmod 700 /system/bin/wpa_supplicant" and that was successful, so I finished the steps listed and can see my cell on my Xoom. I have a Windows Mobile 6.5 cell and my Xoom can NOW see my ad-hoc network. Thanks a lot Kelvie.

Hey that worked instantly love you!
 

kelvie

Member
Apr 12, 2011
42
47
Vancouver, BC
If not for the SDCard update from BRD, I think this thread would be getting alot more attention.

Not to be too mistrusting, but I am hesitant about loading this on my Xoom when it is posted by a new user with only one post.

I completely understand where you're coming from; but check my github repo, and google for me, I do leave a small internet trail...

I (mostly used to, don't do much anymore but answer the odd email) maintain an open source project (Basket for KDE), and try to participate in open source communities as much as I can.

I just did this to tether my Xoom Wifi to my phone, as I had no other way to get internet on the go.
 

sangreal06

Senior Member
Sep 9, 2010
273
111
Nice work. I tried to do this myself last week but ran into trouble just getting wpa_supplicant from the Android git to compile (with or without the changes)
 

mr_wrong_0

Senior Member
Dec 8, 2008
297
62
Colorado
First off, wow man thank you so much. I've been playing with this for a while and I've tried a number of different wpa supplicant files but they failed to initiate a scan of wireless networks. I just tried this one and it works great. I wanted to explain a different way to install it however for the people having ADB issues.

First you want to turn off your wifi. I have used the ADB method a couple of times but I find it easier to use Root explorer. Save the file to your Xoom, Copy it using root explorer, navigate to the system/bin folder and click mount R/W then paste the file into the folder replacing the original (make sure to make a backup!) then long hold on the file and view permissions, check all the boxes in the first two columns and the first 2 in the last column. (chmod 775) You can then restart your wifi and enjoy ad-hoc networks (no reboot needed.)

I've done this a couple of times and it works great. Thanks again.
 
Last edited:

Elementix

Senior Member
Mar 27, 2010
171
18
First off, thanks a ton to the OP for getting this working!


Also, thanks to mr_wrong_0 for the root explorer directions. Not that I'm incapable of using the command prompt, it was just easier to do it this way. :)

First off, wow man thank you so much. I've been playing with this for a while and I've tried a number of different wpa supplicant files but they failed to initiate a scan of wireless networks. I just tried this one and it works great. I wanted to explain a different way to install it however for the people having ADB issues.

First you want to turn off your wifi. I have used the ADB method a couple of times but I find it easier to use Root explorer. Save the file to your Xoom, Copy it using root explorer, navigate to the system/bin folder and click mount R/W then paste the file into the folder replacing the original (make sure to make a backup!) then long hold on the file and view permissions, check all the boxes in the first two columns and the first 2 in the last column. (chmod 775) You can then restart your wifi and enjoy ad-hoc networks (no reboot needed.)

I've done this a couple of times and it works great. Thanks again.
 

Vanman1979

Member
Mar 29, 2011
6
0
Great, thanks for your hard word.

I do have a question for those how have done this hack. I currently have an old iPhone 3g with tetherme installed and use Bluetooth tethering to give my Xoom (wifi only) internet access. This works great for me.

Is there are speed/battery life advantage to using wifi tethering instead?

Cheers
 

mr_wrong_0

Senior Member
Dec 8, 2008
297
62
Colorado
I don't know for sure. From what I understand wifi is potentially faster than bluetooth, but it can vary from device to device. I have noticed that my Epic seems to stay cooler and use less battery when broadcasting an Ad-hoc network vs broadcasting in infrastructure mode (using wifi tether 3.0.) But I've never been able to get my phone to tether with bluetooth so I don't know about battery life. One advantage of connecting over wifi is file sharing via apps like wifi file explorer. I have used that a lot to transfer files between my Xoom and my phone as well as the computer.
 

the5threvolution

New member
Aug 22, 2010
4
0
Noob question

Hello all,

Thank you very much for the patch.
I would like to try it out, but before that, I need to make sure of one thing;

If I root my Xoom, will I still be getting future updates from Motorola for the device if there is one? Or once I root it, is it impossible for me to update them from the manufacturer?

Thank you!
 

gizhola

Senior Member
Apr 10, 2007
51
1
Thanks so much to the OP! I've been waiting for a reason to root my wifi Xoom. SDCard access was tempting, but I think this is the thing that pushes me over the edge!!

Thanks!!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 25
    I've managed to build a version of wpa_supplicant that has ad-hoc enabled, by forward porting the patch in this thread:

    http://forum.xda-developers.com/showthread.php?t=754961

    After building and a couple of tests, it works.

    To install, you need a rooted Xoom, of course, and just push the file to system/bin/wpa_supplicant.

    Because zipfiles don't store permission, you have to make it executable as well.

    Code:
    adb remount
    adb push system/bin/wpa_supplicant /system/bin/wpa_supplicant
    adb shell chmod 755 /system/bin/wpa_supplicant

    I also had to change the permissions on /data/misc/wifi/wpa_supplicant.conf for some reason:
    Code:
    adb shell chown system.wifi /data/misc/wifi/wpa_supplicant.conf

    Then reboot, and try it!

    It works with my Nokia N8 with JoikuSpot; I can't tether it any other way as the N8 doesn't support the PAN Bluetooth profile, and Android doesn't support DUN.

    Don't forget to backup your files, and I am not liable, etc, etc.

    The code I used is here:
    https://github.com/kelvie/android-wpa_supplicant
    5
    First off, wow man thank you so much. I've been playing with this for a while and I've tried a number of different wpa supplicant files but they failed to initiate a scan of wireless networks. I just tried this one and it works great. I wanted to explain a different way to install it however for the people having ADB issues.

    First you want to turn off your wifi. I have used the ADB method a couple of times but I find it easier to use Root explorer. Save the file to your Xoom, Copy it using root explorer, navigate to the system/bin folder and click mount R/W then paste the file into the folder replacing the original (make sure to make a backup!) then long hold on the file and view permissions, check all the boxes in the first two columns and the first 2 in the last column. (chmod 775) You can then restart your wifi and enjoy ad-hoc networks (no reboot needed.)

    I've done this a couple of times and it works great. Thanks again.
    3
    If I get some time this weekend, I can see if I can change the new wpa_supplicant in ICS to get ad-hoc wifi working for that.
    2
    IMHO no-go

    If I get some time this weekend, I can see if I can change the new wpa_supplicant in ICS to get ad-hoc wifi working for that.

    Team EOS nightlies have already done that. In fact they already reverted to the original 'wpa_supplicant' since the patch had no effect. Here are the reverted changes - https://review.teameos.org/#patch,sidebyside,271,1,wpa_supplicant/ctrl_iface.c. Builds prior to 'Eos-wingray-48' have the patched 'wpa_supplicant'. You can try and extract it from one of their builds and - if you have root - replace the original one in '\system\bin' on stock. IMHO it's a no-go :(

    I even went further to extract the patched 'wpa_supplicant' from 'Eos-wingray-38' and include it in the Unofficial CM9 ROM - nothing.

    With the patched 'wpa_supplicant' you can 'see' the adhoc AP, but trying to connect just leads to a connection with an empty name appearing in the connection list. Nothing happens though.

    The problem seems to go deeper. There's a bug on the Team EOS Bugzilla site - https://bugs.teameos.org/show_bug.cgi?id=30. Any suggestions are appreciated.

    The patched 'wpa_supplicant' v8 from the Team EOS nightlies build 38 is attached below. You can try and experiment with it.
    1
    Can you tell me exactly how you did this as I dont appear to have an option for enabling wifi tether on my xoom

    Thanks

    Follow the steps in the first post to get the Xoom to see adhoc networks, download and install barnacle on your phone, run barnacle, connect your Xoom to the access point created by barnacle. Pretty easy really.

    I got the xoom not knowing honeycomb couldn't natively see ad-hoc networks. I knew the atrix could see and connect to ad-hoc networks and I could do it with my x10, so I assumed the xoom would be able to as well. This has made my wifi version of the xoom well worth the purchase. I knew it had something to do with the wpa_supplicant file when I opened in in visual studio and found the part where it excluded the ad-hoc from network scanning, but I couldn't really do anything more than just see that.

    Thanks for all the work put into making this happen. Couldn't have been an easier process to get it working either. I actually couldn't get it copied to the system/bin folder using RE since for some reason it wouldn't remount as r/w, so I just used adb.

    It's working great too.