• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

GPS Lock Takes FOREVER

Search This thread

sidbaxter

Member
Jun 23, 2008
16
1
104
After reboot, gps lock takes 10-15 minutes. Outdoors, clear sky, good cell signal, etc. My location on Maps jumps around all over a 1-2 mile radius, and navigation is impossible, until the phone finally achieves a lock. I've cleared and updated AGPS using GPS Test multiple times, calibrated compass, tried with Wi-fi and bluetooth scanning both off and on, etc., and still the issue persists. Attached is a gif screenshot of GPS Test -- click it and it will show that it finds a lock for a brief moment, then it loses all satellites. Rinse and repeat.

I saw on the Samsung forums that someone had success by using a new SIM card, but I haven't tried that yet.

With a rooted device, it was possible to edit gps.conf, but no can do with this device. Until some wizard dev cracks the bootloader lock, that is!!!

This is an unlocked device running on Verizon.

Anyone else having this issue?
 

sublimaze

Senior Member
Oct 13, 2010
2,626
985
Many people are having GPS problems. I thought it was an Exynos issue, but since you are on Verizon, I assume you have the Snapdragon model. I would first try a new sim card. If that doesn't help, then do a factory reset. If neither of those help, then contact Samsung and inquire about a warranty claim. You shouldn't have to settle with broken GPS on a brand new $1200 phone.