• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[GSI][11] LineageOS 18.x GSI (all archs)

Should I build *B with EXT4 share duplicate blocks?

  • Yes - my /system is small, I need every bit of space saving to make it fit

    Votes: 14 51.9%
  • No - I'm not short on space, and/or I prefer mountable /system

    Votes: 13 48.1%

  • Total voters
    27
  • Poll closed .
Search This thread

Creeper Azul

New member
Oct 10, 2021
2
0
Hola me pueden mandar la rom de J2Core edicion go
Es
"Solo A -Arm32 pero dice que utilisa binder de 64 -no soporta root - treble y VNDK 27.0"X fa ayuda
 

RoDo84

New member
Oct 10, 2021
2
0
Hi Guys
I have a redmi 5 plus with Resurrection Remix version 8.6.2 and I used to check it in app Treble Info and here is the info:
This device support Project Treble.
Architecture is ARM64.
System as root: Supported, A/B operating system
Required image is: system-arm64-ab-vndklite.img.xz so this is correct image:
lineage-18.1-20210914-UNOFFICIAL-treble_arm64_bvS-vndklite.img.xz ?
Thx
 
Last edited:

hooutoo

Senior Member
Apr 17, 2009
399
44
Ft. Lauderdale
Installed Android 12 GSI RC on Sprint v50. Very slow booting up but once you get there it's pretty smooth. This just made this phone worth having. LG is dead, long live LG.
 

Creeper Azul

New member
Oct 10, 2021
2
0
Hello, can you send me the rom of J2Core edition go It is "Only A -Arm32 but says it uses 64 binder -no root support - treble and VNDK 27.0" X fa help
 

AndyYan

Recognized Contributor
Jan 30, 2012
4,337
3,645
Beijing
Updated all variants with October security patches. Note that there's no impactful change in v313. [Insert obligatory backup-and-test warning here]

As with last year, I'll continue to build 18.x until some time later when disk space becomes an issue, likely a month or two before Android T.

PHH is making steady progress on S, but no ETAs.
 
Nov 10, 2018
8
0
AOSP Android 12 source has dropped just now, and unlike previous years, this time I'm joining the day-1 fun in my way.
I've already (re-)done most of my frameworks_base personal mods and, as a demo, applied them on top of an aosp_arm64 build, which you can download here. It's also RW-enabled so you can poke around it further. The modifications themselves are open-sourced here, some of which could be of use to custom ROM makers.
Note that, booting- and feature-wise, this would be no different from Google's aosp_arm64 build, so if you're looking for a daily driver, this isn't it.

EDIT: Emphasize that this build is merely an appetizer/demo - it won't get support or updates.
Hi,

Is it working for Essential Ph-1 ? if someone did it, please share tour experience
Thanks in advance
 

Gomeman

Senior Member
Aug 31, 2020
52
16
I like to add (nano open) GApps to the rom and also prefer Magisk over phh-su, so I was looking for a way to make the system image writeable again. Some posts above a guide from PHH was given to unshare duplicate blocks directly on the phone once the image has been flashed, but I wanted to perform these steps before flashing the image.

I came up with the following method to unshare duplicate blocks on a linux machine. Note that you need "simg2img" and "img2simg" to convert from and to sparse image file. Those tools should be available on most current linux distributions (i.e. on debian/ubuntu you can install them with a simple "sudo apt-get install simg2img img2simg").

Here's are the commands to unshare duplicate blocks. Replace ##FILENAME## in the first line with the actual name of the downloaded .xz-image file:
xz -d -k -c ##FILENAME## > ROM.img simg2img ROM.img ROM_RAW.img e2fsck -y -f ROM_RAW.img resize2fs ROM_RAW.img 3500M e2fsck -E unshare_blocks -y -f ROM_RAW.img e2fsck -f -y ROM_RAW.img resize2fs -M ROM_RAW.img img2simg ROM_RAW.img Lineage_RW.img

If you want, like me, to remove phh-su in the process, use the following commands just after the "e2fsck -E unshare_blocks..." command:
mkdir tmpdir mount -o loop,rw ROM_RAW.img tmpdir rm tmpdir/system/bin/phh-su rm tmpdir/system/etc/init/su.rc umount tmpdir

The final image is then stored as Lineage_RW.img which can be flashed to the phone instead of the originally downloaded image.
Hi. . Taking for example this gsi.
Just want to say no need to simg2ing ROM.img ROM_RAW. it will give you errors.
Its a RAW all ready
And when you mount tmpdir, there is no system folder, but there is a bin file where you can remove phh-su.
Works with MAGISK- PHH-v23. and pico gapps in my case.
Bootloader was anoying , so i changed it :)
thanks by the way.
 
Last edited:

JUAN139

Member
Oct 3, 2021
26
6
Hi, unfortunately I wasn't able to boot after install. I tried a few times and even by using the TWRP option reboot to system.

Samsung A20e.
maybe you can try with orange fox with samsung is most better option you need wipe data(format data) after install, although if you want to try with twrp first.

-its the most common trouble

-other it´s the no compatibility try to instal treble info(playstore)
 
Aug 25, 2021
5
0
Only 32 mb is left after flashing image, can't resize system partition... Failed to mount system_root (invalid arguments)
 

Geanny_Martin

New member
Oct 11, 2021
2
0
Screenshot_20211011-143256_Treble Info.jpg
My device is Samsung A6+
Where can find android 12 ?
 

AndyYan

Recognized Contributor
Jan 30, 2012
4,337
3,645
Beijing
As ready as PHH's TG betas...
(read: not ready for public)
 

Attachments

  • photo_2021-10-19_23-52-59.jpg
    photo_2021-10-19_23-52-59.jpg
    64.8 KB · Views: 128
  • photo_2021-10-19_23-52-59 (2).jpg
    photo_2021-10-19_23-52-59 (2).jpg
    27.4 KB · Views: 122
  • photo_2021-10-19_23-53-00.jpg
    photo_2021-10-19_23-53-00.jpg
    40.5 KB · Views: 127

Top Liked Posts

  • 1
    clicking on securize does nothing
    You didn't install PHH-SU.
  • 4
    Updated all variants with November security patches. [Insert obligatory backup-and-test warning here]

    Added a patch related to BT calls on Samsung, which I somehow missed from earlier.
    2
    Can you explain in noon friendly language ?
    I am using arm64 an vndklite .
    Appreciate your work buddy.
    Settings - PHH - Misc - Securize (towards the bottom). It should ask for SU privilege and then reboot.
    ARM64 AB VNDKLite is /system read-writable, go for it.
    1
    Doesn't LineageOS' kernel support MTP for GSI ?
    GSIs don't contain a kernel. S21 doesn't seem to have any device-specific LOS, so you're on your stock kernel, an it's a known issue for all Samsung devices. TWRP usually has its own kernel.
    1
    clicking on securize does nothing
    You didn't install PHH-SU.
  • 42
    640px-Lineage_OS_Logo.png


    Background:
    This is a natural continuation/extension of the LineageOS 17.x GSIs I've been making since November 2019.
    LineageOS is a free, community built, aftermarket firmware distribution of Android, which is designed to increase performance and reliability over stock Android for your device.
    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.
    All the source code for LineageOS is available in the LineageOS GitHub repo. And if you would like to contribute to LineageOS, please visit Gerrit Code Review.

    Disclaimer:
    This is still mostly a LineageOS team / PHH @phhusson effort, credits to them and all associated for making all this possible.
    No flashing instructions will be offered. If you're here in this forum, you should know what you're doing.
    No guarantees that everything would work. This is a GSI, bugs are bound to happen.

    Download:
    https://sourceforge.net/projects/andyyan-gsi/files/
    Compressed as .xz archives - extract first.
    Vanilla except for these changes:
    • Modifications needed to make it build/boot/feature-complete
    • Revived navbar layout tuning via sysui_nav_bar tunable
    • Disabled "vendor mismatch" warning on boot
    • Signature spoofing support from MicroG
    • Default stretch-to-fullscreen (force apps to render in longer than 16:9)

    Stuff on GitHub (builders-only):
    Since builders' stuff aren't really interesting to end users, I decided not to separately document the modifications needed in this post; instead just check out the scripts/patches, where most things should be self-explanatory: lineage_build_unified, lineage_patches_unified (where patches_treble_phh contains PHH's treble_patches adjusted for LOS). Not the cleanest code, but should help if you need some clues.

    Donate?
    https://paypal.me/AndyCGYan
    18
    Reserved

    Couple of things to note:
    • I now have a rather taxing day job, and can't devote nearly as much time/effort into this as I did as a student.
    • As always, you are strongly advised to try PHH's AOSP first and identify/report issues there, before moving onto other GSIs that are based on his work. Please report bugs here only if it's specific to this GSI.
    • Thanks to patches from @eremitein , Magisk compatibility is partially restored. For devices that still don't play well with it (e.g. kernel restrictions implemented by OEM), use PHH-SU instead. Install the app and you'll get root for apps.
    • A-only and VNDKLite targets are now generated from AB images instead of built from source, see sas-creator. Kinda hacky and might be buggy. Move on to an AB device if you can.
    • To mount /system RW on AB devices, refer to this.
    • exfat SD cards still don't seem to work. Any help related to this would be appreciated.
    9
    Initial builds are based on PHH v300.j and December security patches.
    Building-related bits have been published, but only for AB targets - I'm not sure if I want to integrate sas-creator yet.
    9
    March patch is ready, but due to lack of time, I'll have to postpone this month's update for a while. I worked on it yesterday but couldn't figure out a core problem in time.
    9
    Updated all variants with March security patches and in sync with PHH v302. [Insert obligatory backup-and-test warning here]

    Two years of GSIs. Life is trying to rob me of this "hobby" - I'll keep this going as long as I can handle it.