[GSI][11] LineageOS 18.x GSI (all archs)

Sanket Kalore

Member
Jan 2, 2016
20
3
23
Hoo, I didn't pick dynamic SU for now (more cuz I'm lazy), guess I made the right call?



I did hear that it takes more than just simply flashing to get Magisk to work (e.g. here), maybe that'd help?
Sir safety net fails and even hotspot not working in the latest build...and can u please make a BvN version also please...rest all is good as always...sir please help super su also not working...i installed phh su apkbut no root so securize won't help
 
Last edited:

AyHenry

Member
Apr 7, 2020
13
4
3
it can messed only if you enabled SuperUser. if you want using Magisk just don't use superuser
(also you can call module's commands like /data/adb/modules/MagiskHidePropsConf/system/xbin/props)
That only worked for magiskhide props. Didn't work for other modules like app systemizer. And as regards superuser, I did disable it, even securized, still didn't work.
 

eltanque9

Member
Mar 22, 2020
26
8
13
On arm64 ab vndklite last release it's not possible to use firewall (afwall). With SU it's everything OK (I've granted root access to other apps) but it's not possible to enable afwall. In other GSIs there isn't this problem. Someone have experienced the same issue?
 

jr313

Senior Member
Jan 18, 2010
788
277
93
Detroit, MI
Quick question everyone any help is greatly appreciated. So i have a note 20 ultra snapdragon that i am planning to get the bootloader unlocked if i would be able to flash a this ROM or an android 11 AOSP based ROM? I know the bootloader has to be unlocked and TWRP installed but i keep reading it isnt possible unless its the exynos or chinese snapdragon version?
 
Last edited:

birdibird

Senior Member
Apr 9, 2005
343
8
38
20210111 a64_bvS version is working great here on my KingKong Mini.

And I managed to install Magisk.
Here is howto:

-> make sure you patch your boot.img with Magisk 21.2 or newer: change update channel to beta (or canary) in Magisk Manager
(I used SPFlashtool to flash the magisk_patched .img, because with my device flashing the zip in TWRP didn't work. You can also choose to flash the magisk_patched .img in TWRP or use fastboot)

1) boot the GSI and connect the phone to the pc. Make sure in developer options usb debugging and rooted debugging are switched on
2) adb root and adb shell
3) type echo $PATH, and copy output to a text file on your pc
4) reboot into recovery
5) in TWRP mount /system
6) adb root (probably still active)
7) adb pull /system/init.environ.rc
8) edit on the pc the init.environ.rc file and add an extra line under 'on early-init':
Code:
export PATH /sbin:(the $PATH output which you copied into a text file goes here without these parentheses)
9) adb push ./init.environ.rc /system
10) still in TWRP go in file manager to /system/system/xbin
11) delete su

done.

reboot into a LineageOS 18.1 with a working Magisk

ps
-hotspot is working fine here
-afwall+ too (with Magisk and EdXposed)

pps
See post 31 I told a method
The PATH in your post #31 gave me really weird red fonts, but it pointed me in the right direction. Thanks.
 
Last edited:
  • Like
Reactions: kkm6761 and Reznor7

AndyYan

Recognized Contributor
Jan 30, 2012
4,228
3,387
253
Beijing
Sir safety net fails and even hotspot not working in the latest build...
Is hotspot a regression? And as usual, how about on PHH's AOSP equivalent (v300.l)?

Is there a way to install it My phone has Treble support
I already told you? Rest is research, I can't go into details for a device I don't own.

i keep reading it isnt possible unless its the exynos or chinese snapdragon version?
This addresses the bootloader unlocking problem. Once that hurdle is past, GSI should work on par with the CN/HK variant (that is, I'm not sure how well it works there).
 
  • Like
Reactions: jr313

jr313

Senior Member
Jan 18, 2010
788
277
93
Detroit, MI
This addresses the bootloader unlocking problem. Once that hurdle is past, GSI should work on par with the CN/HK variant (that is, I'm not sure how well it works there).
[/QUOTE]
Thank you very much for the information, I appreciate you
 

ilyanc

New member
Jan 16, 2021
1
0
1
When I try to change the Select USB Configuration to other than charging, it will always remain on Charing only, not able to select any other options. Honor V10.
 

JuanTamqd21

Member
Jun 30, 2020
44
11
8
16
20210111 a64_bvS version is working great here on my KingKong Mini.

And I managed to install Magisk.
Here is howto:

-> make sure you patch your boot.img with Magisk 21.2 or newer: change update channel to beta (or canary) in Magisk Manager
(I used SPFlashtool to flash the magisk_patched .img, because with my device flashing the zip in TWRP didn't work. You can also choose to flash the magisk_patched .img in TWRP or use fastboot)

1) boot the GSI and connect the phone to the pc. Make sure in developer options usb debugging and rooted debugging are switched on
2) adb root and adb shell
3) type echo $PATH, and copy output to a text file on your pc
4) reboot into recovery
5) in TWRP mount /system
6) adb root (probably still active)
7) adb pull /system/init.environ.rc
8) edit on the pc the init.environ.rc file and add an extra line under 'on early-init':
Code:
export PATH /sbin:(the $PATH output which you copied into a text file goes here without these parentheses)
9) adb push ./init.environ.rc /system
10) still in TWRP go in file manager to /system/system/xbin
11) delete su

done.

reboot into a LineageOS 18.1 with a working Magisk

ps
-hotspot is working fine here
-afwall+ too (with Magisk and EdXposed)

pps

The PATH in your post #31 gave me really weird red fonts, but it pointed me in the right direction. Thanks.
PS C:\platform-tools_r30.0.4-windows\platform-tools> adb pull /system/init.environ.rc
remote object '/system/init.environ.rc' does not exist

how do i fix this?
 

Kurt Krummbein

Senior Member
Jul 19, 2011
510
387
98
PS C:\platform-tools_r30.0.4-windows\platform-tools> adb pull /system/init.environ.rc
remote object '/system/init.environ.rc' does not exist

how do i fix this?
So, you want to add /sbin to $PATH? I also wanted to do this before i installed Magisk 21.3 on my gauguin with 18.1-GSI-20210111 ... one of the first steps in the steps to do is looking in a shell, what the current setting of $PATH is and than putting that into init.environ.rc like "export PATH=/sbin;<what was in your $PATH>" right ?
Well, when i did this first step, i already found /sbin in in the $PATH, so i just renamed /system/xbin/su and Magisk-SU worked.

Greets
Kurt
 

JuanTamqd21

Member
Jun 30, 2020
44
11
8
16
So, you want to add /sbin to $PATH? I also wanted to do this before i installed Magisk 21.3 on my gauguin with 18.1-GSI-20210111 ... one of the first steps in the steps to do is looking in a shell, what the current setting of $PATH is and than putting that into init.environ.rc like "export PATH=/sbin;<what was in your $PATH>" right ?
Well, when i did this first step, i already found /sbin in in the $PATH, so i just renamed /system/xbin/su and Magisk-SU worked.

Greets
Kurt
I'll try this next weekend because I don't want this to interfere with my online schooling
i hope it works for me.
 

alvinprimo

Senior Member
May 30, 2010
161
12
48
Sir safety net fails and even hotspot not working in the latest build...and can u please make a BvN version also please...rest all is good as always...sir please help super su also not working...i installed phh su apkbut no root so securize won't help
Safety net works for me after securize and wipe data but security patch show my old vendor date