[GSI][12] LineageOS 19.x GSI (A64B/64B)

What's your status on GAPPS and SafetyNet?

  • I use GAPPS and passed SafetyNet with Magisk, etc.

    Votes: 10 20.0%
  • I use GAPPS and can't pass SafetyNet - I probably need a VNDKLite or "secure" build

    Votes: 12 24.0%
  • I use GAPPS as-is and don't care about SafetyNet

    Votes: 7 14.0%
  • I don't use GAPPS at all

    Votes: 21 42.0%

  • Total voters
    50
  • Poll closed .
Search This thread

nuxlight

Member
Mar 1, 2017
15
4
Thanks for your wonderful jobs, perfect for samsung a21s ;)
For Gapps i had just to use resize2fs to add space to install BitGapps.

Just only one thing, i had to add somes lineage apps manually like Email (not included in this rom)
Big thanks :D
 

Incomtus

Senior Member
Apr 30, 2016
303
50
soundcloud.com
You have to wait at least 10 minutes after entering the ID, and then about an hour after rebooting!
In my case after waiting , I don't have the Google play protect notification anymore it s ok, but playstore keep saying not certified 🤔

Edit : finally playstore is working loool it took 4 DAYS after registration
 
Last edited:

kookoo004

New member
Jan 21, 2022
3
0
Thank you Works well with Lenovo Xiaoxini Pad 11. I'm new to gsi this rom
Want to question... L1 on drm info app but L3 on neflix app. This seems to be a problem with most of the gsi roms. Any solution?
 

hooutoo

Senior Member
Apr 17, 2009
465
62
Ft. Lauderdale
fastboot erase system_b
fastboot flash system_b lineage-19.0-20220114-UNOFFICIAL-treble_arm64_bvS-vndklite.img
fastboot -w
fastboot erase userdata ----for good measure!
fastboot --set-active=b
fastboot reboot

Everything successfully complete!

I then get a kernel panic attack. Any ideas?????

I'm running a LG v60.

Ps. Never mind. Just had to flash both slots and she booted right up.
 
Last edited:

mister-13x

Senior Member
Mar 4, 2015
108
19
I tried the firmware today, the firmware is loading, even almost everything works, problems only occur during a reboot or when trying to reboot into TWRP, then the device just reboots, and the desktop cannot boot normally, it loads and disappears,
in order for everything to work properly, you just have to turn it off and turn it on again, then everything works, in order to get into the recovery, just turn off the device and enter using the power keys and the volume minus (that is, as usual). I installed the firmware without gapps, my applications all work, even what did not work for 9 without gapps worked.
Due to the lack of gapps or for some other reason, I haven’t figured out yet whether the lock with a graphic key, password, naturally a fingerprint scanner does not work, there are problems even during a call if a headset and a smart watch are connected, the sound does not go either way, but when choosing a speaker works fine. Installed Magisk and it works. Xperia X Compact.
 

AndyYan

Recognized Contributor
Jan 30, 2012
4,442
3,784
Beijing
Right now there isn't a VNDKLite GAPPS variant, for which I've got a few queries, so here's a new poll regarding GAPPS/SafetyNet.
It should be quite obvious by now that I'd like to keep variants few; VNDKLite GAPPS builds will also be quite a bit larger, keeping it out of slightly older devices.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    Updated all variants with May security patches and in sync with PHH v413. [Insert obligatory backup-and-test warning here]

    This is the first release after LOS 19.1 upstream went official - another important occasion to alarm you that you really should backup and brace for wipe. Don't say I didn't warn ya...

    Cherry-picked 2 SafetyNet workarounds, not sure if they'll help.
    1
    Hello! Thanks for your work. Is this build RW?
    Personal builds are always built RW (not because of sas-creator/VNDKLite postprocessing).
    1
    updated from within the PHH settings, went fine, lost magisk but no big deal, thanks for implementing this feature as I've loads of problems with TWRP on the TAB A 500 previously, also seems that usb connections are borked to PCs?
    usb to PC will work but you have to enable it from developer otpions and then choose DEFAULT USB CONFIGURATION and enable it and choose what you want it to do. then you can plug in the phone and the usb connection to computer or whatever you choose works. Only problem is after every reboot you have to enable it again.
    1
    Andy, were there any updates besides security patches?
    I typically don't track changes, unless it's something I deliberately changed on my side or picked from upstream (e.g. the SN workarounds in this release).
    1
    Any way to remove green location icon?, its phone services that access the location all the time.
    developer settings -scrollto bottom
  • 20
    640px-Lineage_OS_Logo.png


    Background:
    This is a natural continuation/extension of the LineageOS 18.x GSIs I've been making since 2020.
    LineageOS is a free, community built, aftermarket firmware distribution of Android, which is designed to increase performance and reliability over stock Android for your device.
    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.
    All the source code for LineageOS is available in the LineageOS GitHub repo. And if you would like to contribute to LineageOS, please visit Gerrit Code Review.

    Disclaimer:
    This is still mostly a LineageOS team / PHH @phhusson effort, credits to them and all associated for making all this possible.
    No flashing instructions will be offered. If you're here in this forum, you should know what you're doing.
    No guarantees that everything would work. This is a GSI, bugs are bound to happen.

    Must-read:
    You are STRONGLY ADVISED to try PHH's AOSP of equivalent version FIRST and identify/report issues there, before moving onto other GSIs that are based on his work, including this one.
    If you do find bugs on this GSI and want to report, then you MUST try reproducing on AOSP, and ONLY proceed to report here when it's specific to this GSI. This filters out bugs common to all PHH-based GSIs, which you should let PHH know, not me. I might silently ignore your report if you skip this.


    Download:
    https://sourceforge.net/projects/andyyan-gsi/files/
    Compressed as .xz archives - extract first.

    Stuff on GitHub (builders-only):
    Since builders' stuff aren't really interesting to end users, I decided not to separately document the modifications needed in this post; instead just check out these repos, where most things should be self-explanatory. Not the cleanest code, but should help if you need some clues.
    Donate?
    https://paypal.me/AndyCGYan
    9
    Reserved

    Notes:
    • I now have a rather taxing day job, and can't devote nearly as much time/effort into this as I did as a student.
    • Naturally, LOS19 is pretty early at this point, and many features are absent or don't work. Heck, I hacked in Gallery and LiveDisplay before LOS people even attempted, just because they're important to me.
    • GAPPS builds are offered as-is without guarantees. Read #10 for more.
    • /system is RO on regular builds and RW on VNDKLite builds. VNDKLite builds can be used on most non-VNDKLite devices as well.
    • Signature spoofing (MicroG) is supported, but only for priv-apps. This is a security consideration from PHH.
    • Magisk support should be on par with A11 (thanks @eremitein). The "abnormal state / unsupported SU" warning can be ignored. For devices that still don't play well with Magisk (e.g. kernel restrictions implemented by OEM), use PHH-SU instead. Install the app and you'll get root for apps.
    • I've picked a few commits from ProtonAOSP to fix global theming (thanks @kdrag0n), and also moved a few useful patches out from my personal build to public. I'm willing to deviate a bit from vanilla LOS to bring them to everyone. For even more personalized mods, check out this sample personal build side-by-side with the patches repo.
    • exfat SD cards still don't seem to work. Any help related to this would be appreciated.
    8
    Updated all variants with March security patches and in sync with PHH v410. [Insert obligatory backup-and-test warning here]

    Lots to say about this build...
    • Backup: We're entering Android 12L / LineageOS 19.1, and you should be alarmed to any major updates like this. Especially if you're a maniac like me who uses this daily, BACKUP EVERYTHING and BRACE FOR WIPE! Out of the 10 devices I flashed 19.x on, 2 of them was unable to update through a dirty flash, prompting me to wipe data. I was lucky that neither were critical, and my daily driver updated smoothly, but don't test your luck.
    • Change of variant names: see 18.1 post.
    • Broken stuff: 12L broke quite a bunch of my changes, as evident by how much I delayed this build to correct them, but even now there might still be ones lingering. Known is statusbar height might be f'd up for devices that have an overlay (Google inverted the definition, I already informed PHH of it), and SearchLauncher on GAPPS variants might be half-working.
    • OTA: This is also the first release to contain PHH's homemade OTA mechanism, implementation info here. Enter the Updater either from PHH Settings, or from Settings - System. However, some known caveats:
      • SourceForge could be stupidly slow when accessed through the Updater
      • No error detection or A/B fallback in case of failure
      • Magisk will NOT work anymore after you take such an OTA
      • Any data wipe will take you back to when you haven't taken any
    ...thus I strongly recommend you stick to the current flow and have a PC by you for updates.​
    6
    Initial builds are based on PHH v400.c and November security patches.
    Sigh, I don't really want to make a thread this early...

    BTW, 32-bit and A-only users, you should really move on.
    6
    Updated all variants with December security patches and in sync with PHH v400.d. [Insert obligatory backup-and-test warning here]

    This can be called the "I take back my words" release:
    - LOS merged r18 much quicker than I expected, invalidating the post above.
    - After too many queries regarding GAPPS through various channels, I've given up resisting and will build some. However, as already stated in #10, these are offered entirely at your request, as-is, without guarantees, and you'll have to help each other out on GAPPS-related/-induced issues.

    One more thing - PHH introduced yet another variant called "secure", which is the same as clicking "Securize" after booting, however it's effective on first boot and therefore avoids certain data breakage. This variant is generated with sas-creator, and as long as you have a Linux PC, it's trivial work (doesn't require building environment), so for the few that might need it, do it yourself.

    OP has been updated with some of the above info as necessary; SF has also been updated with a readme that better explains the naming rules of variants.