[GSI][13] LineageOS 20 TrebleDroid-based

Search This thread


Senior Member
May 30, 2023
OnePlus Nord N10 5G
Set up IMS/VoLTE properly in Treble settings.

This sounds like something crashing hard in the background repeatedly - a logcat would perhaps be useful.

Neither - right now it's a known issue that Moto/Lenovo QCOM S vendor devices have spotty or no SMS reception, and this can easily break daily driving. I've even bought a device just to look into this, but so far I don't know how to solve it within a GSI environment (device-specific ROMs have more room to work with).

Just because this is a generic image doesn't mean there's a generic enough way of flashing it everywhere. I've handled dozens of devices for GSI purposes so far, and many have curious traits that one would never know until a hands-on. You can blame me for being lazy and not summarizing findings on my devices on PHH's wiki, but I won't take blame for not offering an all-encompassing guide that "just works".
Hello, AndyYan.
I tried to flash the GSI on my device, unfortunately though, it went in a complete bootloop.
I'll be reflashing stock on it, but yeah, that's what happened..

But anyways, thanks for making GSIs so that other people can use them! Its GSIs like these that keep some phones without feature updates or even security updates without much of a choice in custom roms from becoming completely unusable!

Good luck! 😁
Last edited:


Apr 16, 2023
Thanks - I ended up getting MicroG going - but it can't restore my purchases on the real Play Store - so I've abandoned that idea.

I did a full reinstall of `lineage-20.0-20230507-UNOFFICIAL-arm64_bvS-vndklite.img` and then formatted userdata and started again.

I booted once, rebooted back into TWRP, and then installed the MTG zip. Rebooted again, and once I allowed Play Store access to the network, everything just started to work.

It looks like there are no problems with app permissions this time. Google Drive works fine now.

I'm still getting everything set up again, but it even seems like it responds better too. Not sure why - or if its just user bias :D :D :D
Do you use zygisk, because that happens in some devices for some reason


New member
Oct 22, 2019
I just wanted to report that I've installed LOS20 TD GSI (arm64-bgN 20230507) on my Moto G22 and with some settings tweaking, as far as I can tell, it works flawlessly. No issues noticed so far.

Great work! Keep it up!


Senior Member
May 30, 2023
OnePlus Nord N10 5G
Hi @AndyYan.
I came back to give the logcat that might give an idea behind why my phone's (OnePlus Nord N10 5G) buggin' out.

The Image for the provided logcat is "lineage-20.0-20230507-UNOFFICIAL-arm64_bvN.img"

VNDKLITE version absolutely failed to boot and kept bootlooping.

Here's the log file.


  • OnePlusNordN10Logcat.zip
    1 MB · Views: 8
Last edited:


Apr 16, 2023
I had exactly the same issue, it is not a problem with this GSI, neither the GApps, install and modify the boot.img from the latest canary version available on github, there they have fixed certain problems with zygisk that result in apps crashing, or google apps not detecting your accounts for sync


Senior Member
Oct 29, 2007
Lenovo Tablet TB-X606F. Your GSI Rom works very well with this device. There are almost no crashes or errors. It is far more stable than Pixel Experience with the same data. Your version of Lineage is amazing

Same device as me.... Did you also get rid of the boot delay and the 'orange' status?

If not, here:

On mine, I just did the "Removing 5 seconds boot delay time" part - and that got rid of the text spam as well.


Jun 18, 2017
I installed Magisk GAPPS in BVN instead of the built-in GAPPS of BGN.
Google Calendar still can't install from the Play Store.
Chrome sync works sporadically and sporadically fails.
So, the conclusion is that the built-in GAPPS of the BGN version is not the reason with those glitches.
Aug 15, 2022
any idea about this?

01-06 11:51:09.392 952 1078 W AidlConversion: legacy2aidl_audio_channel_mask_t_AudioChannelLayout: no AudioChannelLayout found for legacy input / voice audio_channel_mask_t value 0x3
01-06 11:51:09.392 952 1078 E AidlConversion: legacy2aidl_audio_channel_mask_t_bits_AudioChannelLayout_layout: legacy input audio_channel_mask_t 0x3 contains unrecognized bits 0x3
01-06 11:51:09.393 1238 1558 W AudioManager: updateAudioPortCache: listAudioPorts failed

audio seems to be fine though, but it is being spammed thousands of times (on aosp gsi as well...)
Yeah i am getting the same thing, and my audio randomly starts routing from my bluetooth headphones to the phone speaker but yet it still says my headphones are connected. the sound just starts playing through the phone speakers.


Senior Member
Oct 6, 2020
Two steps to install. 1. Install EXTRACTED system image file to system partition using TWRP. 2. Install or re-install Magisk 26.1 using TWRP.

I used latest lineage 20 with bgn option. lineage-20.0-20230507-UNOFFICIAL-arm64_bgN.img
Well actually I am following step 1. I copied latest lineage 20 bgn on SD card. Then I selected wipe, advanced and select partitions to wipe: dalvik, system, vendor, cache and data. I then swiped to wipe. I then went on format data and typed yes. Finally I tried to install via SD card the ROM on system partition, but I got the error message you can see on the photo mate... What am I doing wrong? I don't use magisk is it required?


  • 16863404555345886161243387412454.jpg
    4.7 MB · Views: 24


Senior Member
Dec 2, 2020
Lenovo Thinkpad Tablet
Moto E6
No, no, no. You don't wipe any partitions. You need the Lenovo firmware vendor partition to be there. I don't even wipe the data partition, and have had no problem. Treble firmware only works if every partition, except for system, is stock. I suggest you restore all of the Lenovo firmware via TWRP and reboot to make certain it still works. Then you can reboot to TWRP and follow my suggested steps.

Magisk is not required, but I use it.
  • Like
Reactions: vassiliszacharis


Senior Member
Oct 6, 2020
No, no, no. You don't wipe any partitions. You need the Lenovo firmware vendor partition to be there. I don't even wipe the data partition, and have had no problem. Treble firmware only works if every partition, except for system, is stock. I suggest you restore all of the Lenovo firmware via TWRP and reboot to make certain it still works. Then you can reboot to TWRP and follow my suggested steps.

Magisk is not required, but I use it.
Cheers mate. I see that was my bloody mistake 😕 how can I install stock ROM via twrp? I only did that with the help of Lenovo official software, can't remember it's name. Where I could find the stock image and install it?

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    thanks but I do need GSI anymore because i will lose instant fingerprint feature.
    Yes i may have corrupted TWRP
    I can't answer that for you, it's your decision. Fingerprint has lately been working fine for me on gsis. But every gsi is different, every device is different. The installed underlying firmware can play a big role too. So there are no guarantees. If stock is working better for you overall, i'd say go back to it. My gsi experiences have been mostly good, but it won't be so rosy for everyone else.
    Evening all, I have the latest BVN A64 Andy Yan image installed on my SM-T510 after initially following MagenDanz' guide including his version of TWRP but am still having issues with powering the device off? Also I am unable to install magisk

    I get an error stating " Failed to mount system_root, I have flashed multi disabler previously in TWRP

    Thanks in advance

    Issues powering off from where? TWRP? Android?

    If the partitions in your super partition don't have shared_blocks, you should be able to mount it this way from TWRP terminal:

    mount -o rw,remount /
    mount -o rw,remount /system_root

    This of course assumes you have a super partition.

    As for Magisk, just patch your stock boot.img, flash with Odin from download mode.
    Apologies, from the system, I hold power button, select power off and it just sits there until I have to hold down both volumes and power button
    Never seen this behavior on any gsi that I've ran on both of my Samsung devices.
    According to other posts its a common fault on the SM-T510? I suppose ill just have to never turn it off ha, usb file transfer works fine along with everything else I've tested and its much snappier without all the bloatware

    Thanks for replies
    Try another gsi. Probably same behavior on others though, most gsis share a lot of source code. If a bug exists in one, it's probably also in others released around the same date. But some bugs/issues are device-specific. Not much you can do except file a bug report and wait.

    The best place to file a bug report is here, it's where most gsis derive their code from:

    I've decided that I'm skipping this month's update to LOS20 Light/TD. Please read #290 in Light for details.

    If I enable the spoofing option the apps still don't work.
    At least tell what the apps are? Although in #2 I did state that I can't help with GAPPS/SN, I might still try... when I have time.
    I just wanted to suggest the use of torrents as a means of distributing your GSI images.
    SF provides statistics; I doubt torrents would allow me to accumulate accurate statistics?
    There also isn't a compelling reason on my side. I need faster and more convenient uploads, and SF offers SFTP which runs at a good rate over VPN.
    I've already verified that the issue also exists on all of @phhusson's AOSP builds after that date.
    I've diffed patches before/after the dates you mentioned, there are BT-related patches, but are either dormant (only activates on command) or applies to specific vendors.
    If you've pinpointed dates on TD AOSP, please tell me the dates (these are more precise than my monthly updates, you now). If you're fed up with my incompetence/inactivity, try contacting PHH too (the TG group might get you more attention).
  • 33

    LineageOS is a free, community built, aftermarket firmware distribution of Android, which is designed to increase performance and reliability over stock Android for your device.
    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.
    All the source code for LineageOS is available in the LineageOS GitHub repo. And if you would like to contribute to LineageOS, please visit Gerrit Code Review.

    MUST-READ BACKGROUND - Android 13 and the two approaches:
    As some of you already know, due to various reasons, @phhusson , who kickstarted the GSI trend and committed to it over the years, is backing out from future development
    - there won't be any AOSP 13+ builds or patches directly from him. He did most of the heavylifting for fixing bugs and implementing features, and selflessly supported more than his AOSP GSIs and more than devices he own. For the situation of GSIs today, we owe him a big thank-you.
    Earlier, inspired by @PeterCxy , I took the "light" approach, which starts over from AOSP's generic gsi_* target and adds the minimum amount of fixes needed for my own devices, intentionally leaving many legacy devices behind. For more details about it, visit its own thread.
    Meanwhile, a number of existing builders incl. myself have formed the TrebleDroid organization, with PHH himself helping us in technical issues. TD will forward-port PHH's final patches (v415) onto Android 13 and attempt to fix new issues. This is still a new and ongoing process, but if done right, will have compatibility and feature-completion on par with past PHH-based GSIs. This thread contains LOS builds based on TrebleDroid's collective work, which supposedly suits legacy devices, Samsung, etc. better than "light".

    No flashing instructions will be offered. If you're here in this forum, you should know what you're doing.
    No guarantees that everything would work. This is a GSI, bugs are bound to happen.

    MUST-READ - reporting bugs:
    If you want to report a bug, then you MUST try reproducing on an AOSP reference build of around the same date from TrebleDroid, and ONLY proceed to report here when it's specific to this GSI. This filters out bugs common to all TD-based GSIs, which you should still let me know, but it might not be mine to fix. I might silently ignore your report if you skip this.

    Scroll down for the naming rules of variants.
    Compressed as .xz archives - extract first.

    Stuff on GitHub (builders-only):
    Most things should be self-explanatory. Not the cleanest code, but should help if you need some clues.
    Thanks to:
    • The LineageOS team
    • @phhusson - shaped the treble community, and still takes care of TrebleDroid at a higher level
    • @PeterCxy - coded critical fixes such as sysbta
    • The TrebleDroid builders
    • ...and more
    • I now have a rather taxing day job, and can't devote nearly as much time/effort into this as I did as a student, or even a year ago.
    • I now daily-drive "light", so I can't test TD-based builds as extensively as before. For the same reason, I likely won't build/upload any TD-based "personal" build either.
    • While most >=A13 GSIs out there are going to be TD-based, some perform better than others - some devs have their own patches that haven't been merged into TD yet. I myself will stay close to TD's raw patchset as much as possible, without picking patches from others left and right. If you find another GSI working better, don't just complain - try to narrow down which ones, and the intersection of them might be an unmerged patch that, if approved, would be merged into TD and benefit all.
    • GAPPS builds are offered as-is without guarantees. As a Chinese I can't/won't help with GAPPS/SN issues - please help each other out.
    • ADB is intentionally insecure, even on first boot (turned on by default and no authentication needed). GSIs are more fragile compared to device-specific custom ROMs, both on first boot (no-boot issues) and on subsequent boots (after tuning certain Treble settings), and I insist that no-auth ADB is a must-have for debugging and general fail-safe.
    • Signature spoofing (MicroG) is supported, but only for priv-apps. This is a security consideration from PHH.
    • On *S variants, install PHH-SU and you'll get basic root for apps, good for devices that don't play well with Magisk or when you don't need modules.
    • Refer to this post for explanation/workaround of an MediaTek-specific kernel bug that causes no internet.
    Updated all variants with April security patches and in sync with TD 20230417. [Insert obligatory backup-and-test warning here]

    All modern Xiaomi/Redmi devices should be able to see high refresh rates now (if supported), without having to spoof properties globally.
    Updated all variants with July security patches. [Insert obligatory backup-and-test warning here]

    I just realized that I haven't included PHH-SU app in *S (while I did over at Light) - this has been corrected.

    @Jonny - although I still very much doubt that the uname change is related to the alarm, adding it back is trivial, so now it's back.
    Updated all variants with Android 13 QPR2 and March security patches. [Insert obligatory backup-and-test warning here]

    As usual with "feature drops", things can change or break majorly.

    Fixed in-call audio on Snapdragon 8 Gen 2 (SM8550), tested on OnePlus 11, should pave the way for future QCOM SoCs as well. Users of other SM8550 devices like Xiaomi 13 and RedMagic 8 Pro/+ might want to try this out too. Also pushed to TD upstream, so in case you don't like LOS, it's still coming to your favorite TD/-based GSI later.

    Imported some SN fixes from HentaiOS - GAPPS users should now get CTS profile match as well.

    Fixed videos sometimes getting stuck after pausing and resuming, thanks @Cozzmy13 for working it.

    Fixed two-pane layout in Settings for tablets - set an appropriate density then force stop Settings for it to take effect.

    And finally for builders, starting this month LOS has moved to Git LFS for hosting their Chromium webviews. Please re-init the repo with "--git-lfs" flag BEFORE syncing again or you will hit errors. If you already have a bad sync, clear the residue and re-init:
    rm -rf external/chromium-webview/prebuilt/*
    rm -rf .repo/projects/external/chromium-webview/prebuilt/*
    rm -rf .repo/project-objects/LineageOS/android_external_chromium-webview_prebuilt_*