• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

GSI for the Galaxy A20 (Android 10)

Search This thread

Tn. Ferry

Member
Jan 18, 2021
16
4
guys, why can't the a20 device install the gsi rom android 11 ?? when it has been running for about a minute, the device auto reboots. kernel or vendor problems ??
 
Jan 11, 2021
8
1
Hello 🙋‍♂️

Thank you for all the informations you share.
My phone is a Samsung SM-A202F/DS

I followed your instructions from post #2 Part "B. Android 10 (Q) "
The GSI I tried to install is crDroid (because I read on this thread it was working) I downloaded it from your post #1 https://sourceforge.net/projects/am...200104--v6.1-arm64-ab-vanilla.img.xz/download

I stopped at Step " 1. Installation ", I did not installed the Gapps etc.
My phone is booting a first time (Samsung Logo) and rebooting.
Again I got the Samsung Logo and then, the crDroid boot animation. I let my phone for more than 10 hours and still got this animation on the screen.

What would you suggest ?

Thank you very much !
 

physwizz

Senior Member
Sep 16, 2013
3,168
687
Sydney
Hello 🙋‍♂️

Thank you for all the informations you share.
My phone is a Samsung SM-A202F/DS

I followed your instructions from post #2 Part "B. Android 10 (Q) "
The GSI I tried to install is crDroid (because I read on this thread it was working) I downloaded it from your post #1 https://sourceforge.net/projects/amber-gsi/files/crDroid v6.1/crDroidAndroid-10.0-20200104--v6.1-arm64-ab-vanilla.img.xz/download

I stopped at Step " 1. Installation ", I did not installed the Gapps etc.
My phone is booting a first time (Samsung Logo) and rebooting.
Again I got the Samsung Logo and then, the crDroid boot animation. I let my phone for more than 10 hours and still got this animation on the screen.

What would you suggest ?

Thank you very much !
I know that some people have got GSIs to work on the a202 but I have a a205
I also know that some have got Zrom 5 working with my kernel 1.56
 
Jan 11, 2021
8
1
Thank you for your answer.
I am not sure of how to install the rom and the kernel.

I tried to flash the kernel (1.56) zip file using TWRP -> got a message: "couldn't find ramdisk" or something like that.

So I did it the other way, I flashed the ROM (ZRom5) (got a message saying "couldn't mount vendor...")
And I continued with flashing the Kernel, this time no message about ramdisk but still a message about the vendor.
I reboot my phone and got a bootloop with Samsung Logo.

Any ideas ?

Thank you !
 

physwizz

Senior Member
Sep 16, 2013
3,168
687
Sydney
Thank you for your answer.
I am not sure of how to install the rom and the kernel.

I tried to flash the kernel (1.56) zip file using TWRP -> got a message: "couldn't find ramdisk" or something like that.

So I did it the other way, I flashed the ROM (ZRom5) (got a message saying "couldn't mount vendor...")
And I continued with flashing the Kernel, this time no message about ramdisk but still a message about the vendor.
I reboot my phone and got a bootloop with Samsung Logo.

Any ideas ?

Thank you !
Flash Magisk before the kernel
Restore vendor from your backup or flash stock vendor.img
 

Tn. Ferry

Member
Jan 18, 2021
16
4
Hello 🙋‍♂️

Thank you for all the informations you share.
My phone is a Samsung SM-A202F/DS

I followed your instructions from post #2 Part "B. Android 10 (Q) "
The GSI I tried to install is crDroid (because I read on this thread it was working) I downloaded it from your post #1 https://sourceforge.net/projects/amber-gsi/files/crDroid v6.1/crDroidAndroid-10.0-20200104--v6.1-arm64-ab-vanilla.img.xz/download

I stopped at Step " 1. Installation ", I did not installed the Gapps etc.
My phone is booting a first time (Samsung Logo) and rebooting.
Again I got the Samsung Logo and then, the crDroid boot animation. I let my phone for more than 10 hours and still got this animation on the screen.

What would you suggest ?

Thank you very much !
watch this bro ,crDroid 6.14 With AOD - Android 10 On Galaxy A20
 
Jan 11, 2021
8
1
Thank you for your suggestion ;)
I tried it, but I get this error:

simg2img '/external_sd/A20e/arm64_bvN.img' '/dev/blockmmcblk0p25' process ended with error: 255

I had this error with TWRP 3.5, I flashed TWRP 3.4 like in the video, but still the same error.
Any ideas ?
 
Jan 11, 2021
8
1
The image was corrupt. I flashed the image but got stuck on Samsung logo.
And in the video the guy has Eureka R5 A205 gsi permissive. Which i don't have.
And I think I would need an A202 version since I got a SM-A202F...
 

physwizz

Senior Member
Sep 16, 2013
3,168
687
Sydney
The image was corrupt. I flashed the image but got stuck on Samsung logo.
And in the video the guy has Eureka R5 A205 gsi permissive. Which i don't have.
And I think I would need an A202 version since I got a SM-A202F...
The only custom kernel available for the a202 is mine for OneUI.
A20e Root,Kernel and TWRP
 
Jan 11, 2021
8
1
Thank you for this information.
But at what step from your post #2 " B. Android 10 (Q) " should I flash the kernel (or what step should be replaced by flashing your kernel) ?
Or when you suggest me to use the Zrom5, what are the steps (using your kernel) to follow.
Excuse me but I don't understant everything like you do as I'm not often dealing with phones ROMs or kernels.

Thank's for your help.
 

physwizz

Senior Member
Sep 16, 2013
3,168
687
Sydney
Thank you for this information.
But at what step from your post #2 " B. Android 10 (Q) " should I flash the kernel (or what step should be replaced by flashing your kernel) ?
Or when you suggest me to use the Zrom5, what are the steps (using your kernel) to follow.
Excuse me but I don't understant everything like you do as I'm not often dealing with phones ROMs or kernels.

Thank's for your help.
Fir GSI you must choose a GSI kernel,
flash it after the GSI
 

munesh20200001

New member
Feb 26, 2021
2
0
Hi so I flashed evolution x android 10gsi on my a20 then flashed the magisk then fix DM verity then the permissive v5 and rebooted into system but when the device rebooted past the android logo it gave a blank screen and just turned off. I tried pressing all 3 keys then volume up to get into twrp recovery but got the same black screen I also tried to get into download mode with Odin but got the same black screen.
 
Last edited:

munesh20200001

New member
Feb 26, 2021
2
0
Yea I pressed all 3 keys then plugged my phone into the laptop with Odin till it rebooted 2 times with the black screen then pressed the volume up and down for a while and it boot into download mode and Odin recognized it :) I did the power and volume down then power up when it restarted and got into twrp I've charged and left it there as the original firmware is taking a while to download. I'll flash the original with Odin and see what happens. Thanks tho
 

pa1n._.

Member
Mar 2, 2021
14
1
are some a20 treble a? bcuz i have an a205g and i downloaded evo x android 10 ab img for my device, flashed it, got stuck on evo x boot animation i tried everything, custom kernel, permissive, magisk,fix boot and none worked, then i tried havoc os ab img android 9 tried everything still wouldnt even show the boot animation so i had to download back the original firmware and flashed it with odin. it worked and i decided to just op for one ui kernel instead and it worked then i checked the treble app (i thought all the a20s were ab before and didnt check) and it said that the device is not ab that it is a. this is an a205g btw


i'll try flashing an a img later and see tho
 
  • Like
Reactions: munesh20200001

physwizz

Senior Member
Sep 16, 2013
3,168
687
Sydney
are some a20 treble a? bcuz i have an a205g and i downloaded evo x android 10 ab img for my device, flashed it, got stuck on evo x boot animation i tried everything, custom kernel, permissive, magisk,fix boot and none worked, then i tried havoc os ab img android 9 tried everything still wouldnt even show the boot animation so i had to download back the original firmware and flashed it with odin. it worked and i decided to just op for one ui kernel instead and it worked then i checked the treble app (i thought all the a20s were ab before and didnt check) and it said that the device is not ab that it is a. this is an a205g btw


i'll try flashing an a img later and see tho
Use Arm64 ab
Some GSIs are difficult
 

Top Liked Posts