Development GSIs status + boot dump

Search This thread


Senior Member
Apr 26, 2014
St. Veit an der Glan


I need help with me it has not worked as I should it
I tried to follow the instructions did not work.
I still have the stock rom on it plus magisk. now I have the problem that I have no wifi and bt more.
how can i undo all this ?

full wip did not work wifi and bt still does not work
undo? you cant, i warned.... flash the vendor as in the instructions... be sure it shows (OK) in CMD.
undo? you cant, i warned.... flash the vendor as in the instructions... be sure it shows (OK) in CMD.
I know is my own fault. No problem I will send it to OnePlus and get it fixed.
I forgot to restore the original image before closing the bootloader. Stupid run 😅


  • IMG_20210908_203133_315.jpg
    35.5 KB · Views: 74
OMG... this horrible went wrong 😔 but the text says flash boot? did you try to boot into bootloader again? (vol down and power)
Yes I did I can no longer get into the bootloader since I shot the bootloader again .
I only get into the recovery , but that does not bring me much since nothing more is on it . Everything deleted.
if the device is recognized

hmmm what did you do to achieve this? did you delete the boot partition?
I deleted magisk and reset the stock rom to factory defaults.
and then I closed the bootloader again and restarted and then came this message :
The current image(boot/recovery)have been destroyed and can not boot......
how did you do this from bootloader?
what do you mean exactly how i closed the bootloader ?

because the main instructions did not work .

i tried to follow your instructions
with your instructions I only got as far as vendor and at the end there was error

so I wanted to reset everything
which of course then came out that the original image was missing
Last edited:


Senior Member
Apr 26, 2014
St. Veit an der Glan
what do you mean exactly how i closed the bootloader ?

i tried to follow your instructions

because the main instructions did not work .
why did you need the bootloader for deleting magisk and factory reset? it was working before expect wifi/bt.... what did you exactly then?


Sep 1, 2021
I can confirm that the Doogee S88 Pro does not work with any treble GSI's I've tried. I've tried the latest Android 11 aosp, right down to android 9 aosp.

1. Factory reset, enable OEM unlocking and usb debug
2. ADB reboot bootloader
3. Fastboot flashing unlock
4. Fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img (one downloaded from Google.)
5. Fastboot reboot fastboot
6. Fastboot erase system
7. Fastboot flash system system.img
8. Fastboot reboot

Boots into recovery saying that I need to factory reset the device, doing so results in it booting right back into this menu.

My conclusion so far unless I'm missing something is the doogee s88 pro is unflashable.


Sep 28, 2021
I switched back to stock rom from the GSI using TWRP backup. But now my play store certification is gone. Also, I am not able to register device password/fingerprint. Please help.


Nov 27, 2013
OnePlus Nord 2 5G
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 16

    Here is the status as of few days ago. So most of Phh-based GSI should have the same status, just pick whichever you want.

    What works:
    - Backlight control works (requires "Force alternative backlight scale" in Treble Settings => Misc)
    - 5G
    - Bluetooth
    - A2DP/Bluetooth media (requires "Force disable A2DP offload" in Treble Settings => Misc)
    - USB-C headset
    - Speaker
    - 90Hz screen (Recommend "Force FPS" to 90Hz in Treble Settings => Misc)
    - BSG GCam
    - SELinux enforcing
    - Encrypted userdata
    - 65W Dash charge

    What doesn't work:
    - Under-display fingerprint
    - Others?

    Fixed in my AOSP GSI v311 (2021-08-07):
    - Access to auxiliary cameras (Expose Aux cameras in Treble Settings => Misc)

    Fixed in future AOSP GSI release:
    - VoLTE (needs to click all 4 options in Treble Settings => IMS Settings)
    - Alert slider

    List to other GSIs -- I recommend to try out LeOS, CAOS, or AndyYan's LineageOS

    Flash procedure:
    - Unlock bootloader
    - Reboot into bootloader
    - Download
    - `fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img`
    - `fastboot reboot fastboot`
    - `fastboot flash system system-roar-arm64-ab-gapps.img`
    - On the phone itself, do a full factory reset

    As a small bonus, I attach the boot.img that I got on my device. It could be useful for people wanting to root with magisk, since currently the stock ROM isn't available. In exchange, I'd really like a dump of system partiton :)
    @onken @maximusxD1998

    install this module in magisk to pass safetynet (magisk hide enabled for sure)
    Cool waiting for a more detailed how to 😅
    Yes best is to wait until we have full stock rom.
    do i have to flash vbmeta as well?
    Hum yeah, it's likely that if you modify boot.img you need to disable boot.img verification through vbmeta
    Booted and using latest android 12