• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[GT-i9500] CWM 6.0.3.1 RECOVERY & ROOT (Big Update on NEW VERSION! )

Status
Not open for further replies.
Search This thread

GSeeker

Senior Member
Aug 12, 2008
366
103
Guangzhou
update 3-5-2013: the developer Cofface himself is now in XDA and posted a new verison of recovery HERE!

* All credit goes to Chinese developer Cofface *

GOOD NEWS!

This should be the easiest way to root the i9500 (yes, the so called 8-core one) by now.

Tested on FW I9500ZCUAMDG and should be working on others.

Recovery Feature:

1. Based on CWM 6.0.3.1 (Thanks CM Team!)
2. ROOT your phone

Just download the recovery and unzip it, flash the cofface_I9500_cwm_recovery_en_new.tar as PDA in Odin.

Then turn off the phone and enter recovery by pressing Vol Up+Home+Power keys, and select ROOT YOUR PHONE, reboot, DONE.

Download: Hotfile Dropbox

update: Some Russian FW users reported this will not work, i've inform the developer Cofface and will update later if he fixed this. And here is a way to root Russian FW.

update2: I've talked to Cofface and he is on vacation now but if you need further helps, feel free to contact with him via Gtalk: [email protected]

update3: Here is a video tutorial by ashwin123, thanks!

https://www.youtube.com/watch?v=SajfKZBjvuQ
 
Last edited:

fsw23

Member
Jul 21, 2008
47
4
Hi !!!

Good news...

But i tried, and it doesn't work.
After reboot, i see that SuperSU is installed, but it is not working. Impossible to update the binaries, and no "root applications" working.

Was a good try ;)
 
  • Like
Reactions: twisted_mind

Tutsumi

Senior Member
Nov 17, 2011
123
22
Nassau
Hi !!!

Good news...

But i tried, and it doesn't work.
After reboot, i see that SuperSU is installed, but it is not working. Impossible to update the binaries, and no "root applications" working.

Was a good try ;)

You, good sir, probably did something wrong. Mine's working just fine with Titanium Backup Pro, rooted.
 

twisted_mind

Senior Member
Apr 27, 2005
632
133
Mumbai, India
Hi !!!

Good news...

But i tried, and it doesn't work.
After reboot, i see that SuperSU is installed, but it is not working. Impossible to update the binaries, and no "root applications" working.

Was a good try ;)

Thanks bro for clarifying this. Hope chainfire gets his magic working on the I9500 soon.

---------- Post added at 09:34 AM ---------- Previous post was at 09:32 AM ----------

You, good sir, probably did something wrong. Mine's working just fine with Titanium Backup Pro, rooted.


Ah cool. Sweet. Thanks mate for clearing it out.

Gotta try it now. Will post back the results. :)
 

fsw23

Member
Jul 21, 2008
47
4
You, good sir, probably did something wrong. Mine's working just fine with Titanium Backup Pro, rooted.

Thanks bro for clarifying this. Hope chainfire gets his magic working on the I9500 soon.

---------- Post added at 09:34 AM ---------- Previous post was at 09:32 AM ----------




Ah cool. Sweet. Thanks mate for clearing it out.

Gotta try it now. Will post back the results. :)


About mine, i pushed CWM with odin, then did a reboot, clicked the "root" option, and did a reboot.That's it :)

BUT, my i9500 has the russian firmware, wich is : Russia - 2013 April - 4.2.2 - I9500XXUAMDK - I9500SERAMDK

It may be the "problem"..!?
 

twisted_mind

Senior Member
Apr 27, 2005
632
133
Mumbai, India
Yeah just did the process..... Unable to get my root apps to work... i have a feeling it has to do with the firmware. Mine is also the russian fw.... Gotta flash the chinese one and then see..
 

Tutsumi

Senior Member
Nov 17, 2011
123
22
Nassau
About mine, i pushed CWM with odin, then did a reboot, clicked the "root" option, and did a reboot.That's it :)

BUT, my i9500 has the russian firmware, wich is : Russia - 2013 April - 4.2.2 - I9500XXUAMDK - I9500SERAMDK

It may be the "problem"..!?

Perhaps? Perhaps give it another shot using Odin which is in the ZIP, be USB debugged, and set not as a camera?
 

fsw23

Member
Jul 21, 2008
47
4
try flash again? We've tested this in China on say 7 i9500s, and it all worked.:laugh:

Thanks Gseeker... I'm in China, and bought mine here too, but i flashed the russian firmware to get the european languages (the chinese firmware has got only chinese, english, and corean languages).
And unfortunately, i didn't get your CWM method working on it...
 

Tutsumi

Senior Member
Nov 17, 2011
123
22
Nassau
Baseband Version: I9500UBUAMDE
Build Number: JDQ39.I9500UBUAMDE
Mine worked.

Bought it from in the Bahamas, uploading the system dump (non-root) as we speak.
 
Status
Not open for further replies.

Top Liked Posts