GT-P5210 stuck on boot screen after trying to root

Search This thread

Joey79100

Member
Feb 12, 2016
8
1
EDIT March 11, 2016: Finally found a solution and no data was lost!
See post #5.

(is there no way to indicate on the thread that this is solved? I don't know exactly how it works on this forum...)

---------------------------------------------------------------

Hi!
So I've posted my problem on another forum but didn't get any reply, and I just realized I might have more chances to get faster replies on here.

Well, to make it short, I've tried to root my mothers' Galaxy Tab 3 (GT P5210), and as I've already rooted several devices (including another Galaxy Tab) without any problem, I didn't bother saving all the data on it... I'm afraid this was a big error.

I decided to root because it was getting stuck sometimes because of too many things running at a time in the background, and it made the tablet unusable until I reboot it. I wanted to install Greenify and make it work alone so my mother doesn't have anything to worry about but play without the tablet getting stuck. But I needed to root to use Greenify at its best...

As I've rooted several phones before, I know rooting doesn't wipe any data, unlike flashing seems to do. So I wasn't afraid of doing it.
I've followed this tutorial after installing the drivers.

Everything seemed to work correctly, Odin did what it had to do and it succeeded.

Though, now I can't turn on the tablet anymore: if it's turned on and that I press and hold the Power button, the "Samsung Galaxy Tab 3" screen shows up. But it doesn't move, it just stays here and does nothing.
I can turn it off, and try again, but the result is the same.

On the Internet I've read that charging it to 100% could solve the problem, but it doesn't seem to do anything as it was plugged all night and it's the same.
Now I've tried all combinations of buttons, because it was said that a second solution was to wipe the cache partition. But the only combination that works is Volume Down + Power, which brings the Download mode I had to get through in order to run Odin.
I've found this tutorial on here, but I don't even know if the correct word for my situation is "brick". And like many things I've found on the net, the tutorials for unlocking the tablet are for the tablets that have been flashed. But this is not what I wanted to do and I hope this is not what I did. And it doesn't inform if I'll lose data or not... which I'm afraid of. :(

I made the error of not making any backup before starting the process... I seriously hope nothing is lost.
Is there a way I can restart the tablet correctly again, even if I have to unroot, without losing anything?
Thanks by advance!
 
Last edited:

OKAstro

Senior Member
Mar 5, 2011
653
172
Edmond, OK
(sorry for the double-post)
No one?
Please, at least give me a clue on what I should do, or if there's hope to get back the data from it.

I don't know if you've lost data or if this method will wipe data, but it's what I used to root stock kitkat

Method

Also - I seem to remember that you should uncheck auto reboot, and after flashing is finished power off and back on

Good luck
 

Joey79100

Member
Feb 12, 2016
8
1
Thank you for your answer.

The thing is that I've already gone through some steps of the tutorial I linked in the OP (until step 10 / step 11), and when the tablet was meant to reboot, it got stuck on the "Samsung Galaxy Tab 3" screen. I can turn it off and on, but it won't go further than this screen.

I can still bring up the Download Mode (by pressing Volume Down + Power), but there's no way to bring up anything else. Even the debug menu with Volume Up + Power (though I don't know if it was even available this way before trying to root). It will just load the boot screen and nothing more.

I'd try something with the Download Mode only if I can be sure that no data will be lost. If it may erase data, I prefer not doing it and to find a way to get it back before anything else.
Do you know if there's some way to access the memory?
 

Joey79100

Member
Feb 12, 2016
8
1
Okay okay... I've struggled a long time with this problem, brought the tabled to a local repair shop but didn't find anything that couldn't risk any data loss... And finally I've found something, so I'll post my solution in case other people have the same problem.

Remember, I could only boot the tablet in Download mode. Every other button combination led me to the boot screen.
The problem was indeed the cache, that I needed to wipe, but without being able to access the Recovery mode there was no way to do it.

-------------------------------------
Solution:

First, I downloaded Odin 3.07 from somewhere else than from the link given in the tutorial (quick search on Google), because I had to untick Auto-reboot. Actually I'm not sure this is needed, but it worked for me with it unticked (while the version of Odin given in the tutorial doesn't let you untick it).

Then, download TWRP for P5210 (a quick search through Google led me to this ). Take out the .tar file from the .zip, but DON'T try to extract anything from the .tar file.
(basically, we'll "install" it onto the tablet using the same method as described in the tutorial)

Boot the tablet in Download Mode (Volume- and Power), choose Continue (Volume+ IF I remember correctly, but it's written anyway), then plug the tablet to your computer.
Run Odin, untick Auto-Reboot (as said before, not sure it's needed, but oh well, it worked...). Then click PDA, select the file you've downloaded (for me it was twrp-2.8.6.0-p5210.tar).
Then press Start, and wait (I waited approx. 2 minutes) until Odin displays "PASS!".

Now unplug the tablet, and turn it off.
Turn it on with Volume+ and Power, this time it will bring you to the TWRP menu (it asks to stay in Read-Only mode or not... choose no). Go to Wipe > Advanced Wipe, and tick Cache ONLY. "Swipe" to start the operation, wait, wait... then, once it's completed, press back until you go back to the main menu, press Reboot > System (then Swipe).
Now the tablet will boot normally. It won't be rooted, but at least it will work again, and fortunately, without any data loss.
 

Donovan178

New member
Oct 3, 2016
4
0
I have the same issue, my Tab 3 is stuck on the Samsung logo.
And the Odin is stuck on the file mentioned above.
Can someone please help?
Knipsel2.PNG