[Guide] Activate Native Video Calling (over LTE), RCS & other features

warriorvibhu

Inactive Recognized Developer
Aug 28, 2007
1,329
252
113
Somewhere Amazing
This is the kind of stuff that makes me regret buying a Samsung.
Any luck yet with the shield x replacement?
According to their discord, SAMSUNG issued them a new license, but haven't cleared their old one.
That being said, all code to disable apps is being removed because THAT is what breaks the knox TOS.
OK good news is, it (Alliance Shield X) just got updated on my phone and their Knox license is back and I can confirm that I was able to switch the IMS setting to On.
@hayabusa1300cc it works now. Try.
 

warriorvibhu

Inactive Recognized Developer
Aug 28, 2007
1,329
252
113
Somewhere Amazing
Funny, waited all that time, and when now that I'm finally able to change the settings chat features still don't show up in samsung messages..
I can confirm i have it, Its called Chat Settings. Sometimes you need to go to google messages and switch of the RCS there (Chat Features) for Samsung Messages Chat settings to work. Try that may be.
 
  • Like
Reactions: Fatmonk8

Fatmonk8

Senior Member
Dec 16, 2010
178
52
58
28
Holmes
I can confirm i have it, Its called Chat Settings. Sometimes you need to go to google messages and switch of the RCS there (Chat Features) for Samsung Messages Chat settings to work. Try that may be.
Yup, turned off chat features in Google messages, went thru the steps to turn everything on in ims settings, and nothing. No option for chat settings anywhere.
 

warriorvibhu

Inactive Recognized Developer
Aug 28, 2007
1,329
252
113
Somewhere Amazing
I only get unable to start activity. Unlocked on T-Mobile. On Sprint I had native RCS.
Did you toggle the knox switch? Make sure your settling page of Alliance shield app looks like my screen shot and then when you open the IMS settings it will look like my other screen shot.. Then you have to go to activities tab and select the first from the list and pick open and now you will see the IMS settings.. Just toggle the RCs switches like instructed in first post.
 

Attachments

Last edited:
  • Like
Reactions: hayabusa1300cc

hayabusa1300cc

Senior Member
Jun 8, 2007
2,496
753
193
HOUSTON TEXAS
www.facebook.com
Did you toggle the knox switch? Make sure your settling page of Alliance shield app looks like my screen shot and then when you open the IMS settings it will look like my other screen shot.. Then you have to go to activities tab and select the first from the list and pick open and now you will see the IMS settings.. Just toggle the RCs switches like instructed in first post.
Did you toggle the knox switch? Make sure your settling page of Alliance shield app looks like my screen shot and then when you open the IMS settings it will look like my other screen shot.. Then you have to go to activities tab and select the first from the list and pick open and now you will see the IMS settings.. Just toggle the RCs switches like instructed in first post.
That worked! Thank you
 

nprev420

Senior Member
Jan 7, 2013
420
636
133
Can't get this to work on Verizon using samsung messenger but does with google messenger. Has anyone got it working on Verizon with samsung messenger?
 

Fatmonk8

Senior Member
Dec 16, 2010
178
52
58
28
Holmes
Can't get this to work on Verizon using samsung messenger but does with google messenger. Has anyone got it working on Verizon with samsung messenger?
I'm on Verizon too and I have the same problem, I think it's Verizon that is c**k blocking us this time. Pretty sure it's because they want you to use their messaging app instead. Why they block it on unlocked models tho is beyond me.
 

pieces of cake

Senior Member
Mar 10, 2012
1,122
280
103
I give up. Following the steps in this thread resulted in the total loss of RCS features in both Google Messages and the stock messaging app. I suppose a hard reset is in my near future.
I think it's only fair that I return here to mention that just now, seemingly out of nowhere, my RCS/Chat features suddenly started working within Google Messages. No idea how or why, but it's back. Not messing with the native Samsung Messages app again.
 

pieces of cake

Senior Member
Mar 10, 2012
1,122
280
103
I'm on Verizon too and I have the same problem, I think it's Verizon that is c**k blocking us this time. Pretty sure it's because they want you to use their messaging app instead. Why they block it on unlocked models tho is beyond me.
Maybe because they can. Verizon is the most overrated carrier by far and they have the least amount of respect for their customers. Their pricing and plans tell most of the story.
 
  • Like
Reactions: Fatmonk8