[Guide] activate Volte on Android 11 (root)

Search This thread

rimsv77

Senior Member
Dec 19, 2016
56
4
Screenshot_20210508-192539888.jpg
 

rimsv77

Senior Member
Dec 19, 2016
56
4
So I created it to the end without error. restarted. dial under the code * # * # 4636 # * # * runs. but I don't have an icon on the status bar
 

rimsv77

Senior Member
Dec 19, 2016
56
4
efs is writing me a mistake. I have no idea how to get rid of her. I've done all the steps from the beginning and I can't get through.
 

rimsv77

Senior Member
Dec 19, 2016
56
4
So I did everything without you. I had to download efs again. then it was no problem. but unfortunately even that mbn from nokie 8 doesn't work.
 
  • Like
Reactions: Seosam

Seosam

Senior Member
Jul 13, 2016
147
56
Germany
ASUS ZenFone 7/7 Pro
So I did everything without you. I had to download efs again. then it was no problem. but unfortunately even that mbn from nokie 8 doesn't work.
You just can try new mbn.
Here is a zip where you can extract.
 

rimsv77

Senior Member
Dec 19, 2016
56
4
it is so. wants it mbn for O2 Cz from supported phones. For fun, I tried the vodafone sim and I downloaded the pixel 4a mbn cz vodafone and choose frci. But the main sim is for me O2 so I need mbn from the supported phones for 02 cz which are on the list. what I sent.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    it's the same mbn as from you. it did not help. voLTE still KO. Asus changed something in the firmware and now it doesn't work. If you figure it out, it will be great ;-)
  • 5
    Finally I got it working on ww_30.40.30.96 on German carrier O2. I used most of the Guide from @HomerSp : https://forum.xda-developers.com/t/guide-enabling-volte-vowifi-v2.4028073/

    requirements:
    adb for PC
    QPST
    latest EFS Tools from JohnBel: https://github.com/JohnBel/EfsTools/releases/tag/v.0.14
    Qualcomm-Driver
    mbn file for your carrier- I used Google Pixel 4a from @swangjang : https://github.com/swangjang/Pixel-...pss/readonly/vendor/mbn/mcfg_sw/generic/Pixel

    1. settings props (I don`t know if we need this):​

    adb shell​
    setprop persist.vendor.dbg.ims_volte_enable 1​
    setprop persist.vendor.dbg.volte_avail_ovr 1​
    setprop persist.vendor.dbg.vt_avail_ovr 1​
    setprop persist.vendor.dbg.wfc_avail_ovr 1​

    2. go into diag mode for X55 modem:​

    adb shell​
    su​
    setprop sys.usb.config diag,diag_mdm,qdss,qdss_mdm,serial_cdev,dpl,rmnet,adb​
    Make sure to install the drivers for it manually, especially the Diag Drivers.

    3. find the correct com port​

    go to QPST configuration and find the X55 Modem com port in active phones. After it stop the QPST server.

    4. EfsTools​

    Go to the EFSTools folder and find the EfsTools.dll config file. Open and change from autoport:
    efstool port="yourcomport" (e.g. efstool port="com8")​

    5. Flash the mbn file​

    Now its' the same procedure like in the guide from Homersp. So I copy it from there:

    You can test the connection by running this in the cmd window:
    Code:
    EfsTools.exe efsInfo
    This should report back some info if everything is working. If not, try rebooting the device and redo the bits from the DIAG guide.

    Step 3 - disabling mcfg
    Extract efs.zip from above to the same directory as EfsTools.exe, and make sure the mcfg_autoselect_by_uim file is there. Now simply run this in the cmd window, one line at a time:
    Code:
    EfsTools.exe writeFile -i mcfg_autoselect_by_uim -o /nv/item_files/mcfg/mcfg_autoselect_by_uim
    EfsTools.exe writeFile -i mcfg_autoselect_by_uim -o /nv/item_files/mcfg/mcfg_autoselect_by_uim -s 1
    If everything worked you should see no error messages.

    Step 4 - writing mbn
    If you are using the Xiaomi Mi 9T mbns zip from above, move it to the EfsTools directory and extract it. Now we simply need to find the mbn for your carrier.
    The mbn directory structure is generally laid out like this: <region>/<carrier>/commerci/<country>/mcfg_sw.mbn. For example, the one for my carrier is eu/h3g/commerci/se/mcfg_sw.mbn. Copy the mcfg_sw.mbn file to the same directory as the EfsTools.exe, then go to the cmd window you opened and type this:
    Code:
    EfsTools.exe uploadDirectory -i mcfg_sw.mbn -o / -v
    To get it working on the second SIM slot you will also have to run this:
    Code:
    EfsTools.exe uploadDirectory -i mcfg_sw.mbn -o / -s 1

    If it has worked you should see a bunch of output, but no errors. Try rebooting now, and hopefully after it has booted you will have fully functional VoLTE and VoWiFi.
    2
    My wife is far too busy and has no time for my nerdy ways! :LOL: Even though she is gonna miss it (shoot I am too) she is gonna return the phone. She gets way too many business calls and it keeps dropping service sporadically due to being on T-Mobile. Thank you and I hope your tutorial is helpful to others! (y)
    I figured out how to enable volte on tmobile pretty easily if you still have the phone to try it out on! 💖 My guide on how to do it is posted in this thread.
    2
    For some U.S. carriers may it work so. I have read in ROG 2 or 3 forum about it. Maybe because Asus has build in these carriers but not activated. For other you need whole procedure....
    Tip: you can check your setptop status with getprop e.g. getprop persist.vendor.dbg.ims.volte If you get a "1" back it's activatetd.

    Hey there, thank you for the response. I'm glad I didn't have to do anything else because I'm woefully underskilled at understanding the rest of the procedures though with enough time could have figured it out of course.

    My image attached below shows what I got when I wrote in getprop to the terminal emulator.

    When I wrote the command you gave me specifically it didn't return anything, though there are 1s returning for all the other setprop commands previously entered which is the same thing yes?
    2
    I Got Volte VoWifi working on Tmobile in the US for the zenfone 7 pro! Read on below for easy instructions that worked for me.

    Ok guys I was obsessing over all this, (as someone who doesn't program at all), how to get volte working on tmobile for the zenfone 7 pro on android 11, version (30.40.30.96), that I have in the U.S. And I ended up giving up on it late last night accepting I don't know what I'm doing in my life in general lol. Then randomly, I restarted my phone today for an unrelated reason and then I saw the volte letters at the top of my phone! I was like WTF!

    So I THINK it's fully working now. Though I'm open to someone here helping me verify if I'm truly right or wrong about that. In fact I welcome it because I did it kind of on accident in an easier way than this guide or other guides have taught how to do it.

    For more potential proof that I fully got it working:

    The settings to enable volte, ("4G calling" as it's called in the menu) off and on are now present in the 'Settings>Network & Internet>Mobile Network' page, which seemingly indicates volte as an option to turn on and off has been enabled on the phone. Also Wifi Voice Calling as an option to enable is also there as well if you click the "Advanced" Menu Option on that same page under 4G calling and 5G Network Options.

    BUT, when I check Settings>System>About Phone>Status>Sim Status it still doesn't say Volte or LTE under data or voice, it still says 4G which one might think would be an indicator against volte being truly enabled. Though I think it just means that officially my carrier tmobile doesn't have it activated on my sim even though it is activated on my phone? Could someone correct me on if I have this right?

    BUT if i dial *#*#4636#*#* in the phone dialer and click phone information to be taken to secret phone information settings it shows LTE under Both data network type and VOICE NETWORK TYPE, which IS an indicator that I got volte working.

    I also downloaded two volte status checker apps from the play store and they both said it is connected so I suppose at this point I am sold unless someone here tells me how wrong I am.

    Also when I called my voicemail, aka placed a phone call, it said "HD voice" on my phone and it kept 4G data enabled instead of downshifting to 3G or H+ which is another strong indicator I got it working.

    Ok So here's how I think I got it working easily for those who may get it to work doing the same method that's the easiest way I have found.

    So I wasn't able to do any of the complicated stuff, (to me it's complicated), in any of the guides above because I just couldn't get my phone to connect right with qspt or anything else for whatever reason. Nor could I get a shell on my computer to even recognize the setprop commands. I didn't even get to the later steps because I couldn't complete the first ones.

    What I did was manually entered all of these setprop commands below, on the terminal emulator app that I downloaded from the play store. First I typed in su in the app and pressed enter. Don't know if that matters but it said it granted superuser rights to the terminal emulator app, which I suppose could be important. I'm rooted with magisk and twrp don't know if that matters either.

    setprop persist.vendor.dbg.ims_volte_enable 1
    setprop persist.vendor.dbg.volte_avail_ovr 1
    setprop persist.vendor.dbg.vt_avail_ovr 1
    setprop persist.vendor.dbg.wfc_avail_ovr 1

    Then I guess I reset the phone a couple times maybe turned the data on and off and then today it was all working and said volte at the top of the phone!

    It seems like instead of having to use qspt and all that other stuff to enter the commands through a computer that then connect to a phone I just entered them on the phone itself through the terminal emulator app and it worked?

    Other than that I'm not sure how else I got it working because when I tried to enter those setprop commands from my computer to the phone I couldn't even get it to work and the computer kept telling me setprop wasn't a recognized command, whereas when I entered those commands into the terminal emulator app on the phone itself, it DID recognize setprop as a valid command, even though when I entered the block of setprop commands through manual typing it didn't say anything once I entered them to verify that they did anything.

    But I think the results say that they in fact DID do something.

    I know my explanation is long but it seems I got it working a lot simpler than anyone else has just using the terminal emulator app on the phone itself after having it rooted on android 11 so wanted to share in case someone else can get it to work this way as well because man was it a pain in my ass to figure it out lol.

    And please if someone is more knowledgeable let me know if I got it wrong or if there was something else I did to make it work that I'm not aware of at the moment or if I haven't FULLY got it enabled or it's only saying I did or something. But there seems to be a lot more evidence it is working that evidence that it isn't. Called my mom and she said my voice was clearer and richer as well so I think I got it.

    I'm looking forward to using this phone in the U.S. and seeing if this radically improves my call quality and connection dependability! Cuz this phone's hardware is awesome it's just the software that is whack and incomplete because Asus cheaped out on the licensing this time. They did it for the bluetooth audio quality also. But Viper for android has solved that as well. 😎
    1
    Trying this but I can never get my wife's phone to show up in QPST and notice connecting her phone vs my G8 behaves differently in Device Manager. My G8 I'm able to see my Com Port number via Device Manager. The Zenfore only shows up as ASUS Android Composite ADB Interface and under Portable Devices. Weird.
    That's strange. What happens in the "normal" diag mode: setprop sys.usb.config rndis,diag,adb ?
    Which firmware your wife's has?