• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Guide]Activate VoLTE/VoWiFi OOS 11(OB1&OB2)

Was this topic usefull?


  • Total voters
    48
Search This thread

Galloway

Senior Member
Sep 14, 2010
132
14
Calgary, Alberta
OnePlus 7 Pro
Still confused why VoWifi was working fine before latest OOS update. Same MBN being used as before... Is there possibly a newer MBN required? Does anyone have access to some newer Pixel MBN files?

Was so excited to have this working again, only to have it quit due to an OOS update 😢
 

stan79

Senior Member
Dec 21, 2005
99
4
Nvidia Shield Tablet
OnePlus 5
Still confused why VoWifi was working fine before latest OOS update. Same MBN being used as before... Is there possibly a newer MBN required? Does anyone have access to some newer Pixel MBN files?

Was so excited to have this working again, only to have it quit due to an OOS update 😢
U have to use the OP7 Pro MBNs to get it work on the latest 11.0.2.1. Pixel and Mi9 MBNs aren't working for me too

Refer to post #15 to download the stock old Oneplus 7 Pro MBNs.
 

stan79

Senior Member
Dec 21, 2005
99
4
Nvidia Shield Tablet
OnePlus 5
Well that sucks because OP7P does not have the proper mbn for my carrier. Will try the original OP7P again with commercial overseas and telefonica UK I guess to see.
Yes got to use back the old ones in the past that works to have both VoLTE and VoWifi.

Anyway I did try the Mi9 and Pixel ones when on 11.0.1.1 but after few days, I will lose VoLTE, VoWifi and even 4G till a reboot or turn flight mode on and off. I'm wondering why too.

But this old OP7 Pro MBNs seems to work fine after few days...
 

Galloway

Senior Member
Sep 14, 2010
132
14
Calgary, Alberta
OnePlus 7 Pro
Mine also had one error but i ignore it. Reboot and volte and vowifi will be back.
No love, going back to Overseas Commercial with error gave me no VoLTE or VoWif. Going to try a few other mbn's and then go back to the na\freedom one. At least VoLTE worked fine on that one. Was really hoping to get VoWifi working again due to low signal in some areas I'm in.
 

Galloway

Senior Member
Sep 14, 2010
132
14
Calgary, Alberta
OnePlus 7 Pro
Ok, weirdest S**t ever... after flashing several different mbn's, said screw it and went back to the Freedom mbn that was working before the OOS update a few days ago... VoWifi is working again... WTF?

No idea how the hell to explain that one. Guess something there needed to be overwritten that didn't happen until several wrong ones were tried. Went from whatever the one was that came with OOS during the update to Freedom, to Overseas Commercial to Telus to TMobile to Overseas Commercial and then back to Freedom and it is now functional again.

Weird but cool I guess. lol. Not much help to those having issues other than maybe try a bunch of different ones before going to the one you think should work?
 
Last edited:

rogosteve

Senior Member
Dec 17, 2010
56
6
Toronto
Ok, weirdest S**t ever... after flashing several different mbn's, said screw it and went back to the Freedom mbn that was working before the OOS update a few days ago... VoWifi is working again... WTF?

No idea how the hell to explain that one. Guess something there needed to be overwritten that didn't happen until several wrong ones were tried. Went from whatever the one was that came with OOS during the update to Freedom, to Overseas Commercial to Telus to TMobile to Overseas Commercial and then back to Freedom and it is now functional again.

Weird but cool I guess. lol. Not much help to those having issues other than maybe try a bunch of different ones before going to the one you think should

Are you using the Freedom mbn on Telus or did you actually cancel your Telus line and switch to Freedom? Thanks.
 

Hasitha92

Member
Jul 29, 2018
6
0
I enabled engineering mode toggle and installed usb drivers but this error appears. How to fix this? Oneplus 6 Android 11 oxygen OS 11
Capture.JPG
2.JPG
 

alvinma

Senior Member
Jan 24, 2012
134
25
I got both vowifi and volte working on freedom mobile, OP7pro, runing latest OOS 11.
I had to flash Telefonika_UK_Commercial mbn from OP7pro mbn first, then flash the freedom mbn from pixel mbn.
 

xyzyx22

New member
Nov 23, 2018
2
0
on the latest 11.0.2.1 update, *#801# and check Engineer Mode Toggle did not work for me, instead Full-port switch ON worked. Kinda weird I had to try the EfsTools.exe efsInfo command a few times, but it worked and I entered all the rest of the commands into cmd and rebooted, Voila. OP7T Pro on Singapore's M1 MBN (circles.life) network.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    *****UPDATE*****

    So played around again today with the port selection after reading up more about the error.
    Going from others with higher versions of Android 11 on the OnePlus 8 and 9 phones, it appears you have to select:

    Rndis,diag Switch instead.

    I have tried it tonight and can say, it successfully worked!!
    Got VoLTE and VoWIFI working again on a OnePlus 7T Pro with 11.0.3.1.HD01AA August 2021 patch.

    Using Telstra AU network.
    2
    Updated to 11.0.3.1GM21AA on model GM1917 on Freedom/Shaw Mobile using Freedom mbn from Pixel 4. Lost VoLTE and VoWIFI after update which was expected. Was able to use original steps in PowerShell with no issue.

    Confirmed VoLTE and VoWIFI working on Freedom/Shaw mobile again post updates.
  • 11
    Hi everyone.


    Code:
    /*
    * Your warranty is void. Or vaild, probably?
    *
    * I am not responsible for bricked devices, dead SD cards, Ebolation X,
    * thermonuclear war, or the current economic crisis caused by you following
    * these directions. YOU are choosing to make these modificiations, and if
    * you point your finger at me for messing up your device, I will LMAO at you.
    */


    First you will need that apps:

    EFS Modded 1.2
    EFS
    mbns-mi9t.zip can use this or can use this Pixel mbns
    OEMLogKit_1.0-1.apk
    EngineeringMode.apk

    NOTE: ON custom ROM OEM and Enginer mode does not work. See step 5.1 for custom ROM.
    1. Enter * # 800 # in the stock dialer, and then click oneplus Logkit - next - Function Switch - next - activate VoLTE switch, VoWifi switch and VT switch.
    2. Reboot device.
    3. Install Qualcomm QPST Diag port x64 / QPST 2.7.474 software on your computer
    4. Unzip EfsTools from above, open up a cmd window and cd to the directory where you extracted it. Depending on how you connect to diag you will need to modify EfsTools.exe.config - if you're connecting via USB you most likely won't have to do anything as it will find the port automatically, unless you have more than one port, in which case you can simply change port from Auto to the COM port of the phone (for example COM13).
    5. With your phone connected via USB enter *#801# and check Engineer Mode Toggle switch to ON.
    5.1. If you are on custom ROM you activate the enginer mode by entering in adb shell and run the next command:
    setprop sys.usb.config diag,serial_cdev,rmnet,adb
    5.2. Also if you are on custom rom you can use this method or the PDC one, also not using OEM and engineer, just run command from 5.1 and you should see your phone in PDC.
    6. You can test the connection by running this in the cmd window:

    Code:
    EfsTools.exe efsInfo

    Should return something like this:
    efsInfo.PNG



    This should report back some info if everything is working.

    7. Extract efs.zip from above to the same directory as EfsTools.exe, and make sure the mcfg_autoselect_by_uim file is there. Now simply run this in the cmd window, one line at a time:

    Code:
    EfsTools.exe writeFile -i mcfg_autoselect_by_uim -o /nv/item_files/mcfg/mcfg_autoselect_by_uim
    EfsTools.exe writeFile -i mcfg_autoselect_by_uim -o /nv/item_files/mcfg/mcfg_autoselect_by_uim -s 1


    If everything worked you should see no error messages.

    The mbn directory structure is generally laid out like this: <region>/<carrier>/commerci/<country>/mcfg_sw.mbn. For example, the one for my carrier is eu/h3g/commerci/se/mcfg_sw.mbn. Copy the mcfg_sw.mbn file to the same directory as the EfsTools.exe, then go to the cmd window you opened and type this:


    Code:
    EfsTools.exe uploadDirectory -i mcfg_sw.mbn -o / -v
    
    EfsTools.exe uploadDirectory -i mcfg_sw.mbn -o / -s 1

    8. If it has worked you should see a bunch of output, but no errors. Try rebooting now, and hopefully after it has booted you will have fully functional VoLTE and VoWiFi.


    Credits to:

    HomerSp
    jimmy123322

    If you manage to activate VoLTE/VoWiFi using this guide please let us know your Country--Carrier--MBNS that you used.

    Proof:
    3
    I have extracted the MBNs from OP7 Pro. Hope this will help someone.
    2
    Same method worked fine for me, though I got the information and files from different sources, as I have been looking for some days for a solution. Also, it's possible to set the engineer mode using adb, rather then installing the Engineer apk, by writing in adb shell setprop sys.usb.config diag,adb
    I used the Telefonika_UK_Commercial mbn from Pixel 4, so far it seems a lot more stable than the one from OOS (on OOS10 it was continuously switching between VoWiFi/VoLTE every few minutes).

    Romania - Digi.Mobil - Pixel's 4 EU\Telefonica\Commercial\UK, if it makes any difference.
    2
    Updated to 11.0.3.1GM21AA on model GM1917 on Freedom/Shaw Mobile using Freedom mbn from Pixel 4. Lost VoLTE and VoWIFI after update which was expected. Was able to use original steps in PowerShell with no issue.

    Confirmed VoLTE and VoWIFI working on Freedom/Shaw mobile again post updates.
    2
    Working like a charm with OnePlus 7T (HD1900 with Oxygen 11 stable) I used Telia Sweden profile for the Mexican carrier Altan with the MVNO Diri. I think should works with the rest of the Altan's MVNO as well.