[GUIDE] Activate VoWiFi / WLAN Call

Search This thread

HelmutK.

Senior Member
Jan 30, 2018
76
8
Hi there
I got some problems to install the Qualcomm driver. I already installed the driver and windows goes in testmode. But the device manager shows the smartphone still just as a usb device. I look which driver is using and it's still the windows driver. When I try manually to choose the Qualcomm driver there is no .inf file in the Qualcoom folder.
 

robert1968

Senior Member
Mar 23, 2011
357
99
DIGI.HU VoWifi works on Poco F2 Pro

Hi,

VoWifi is now working on Poco F2 Pro / K30 Pro with DIGI.HU (a small Hungarian GSM/LTE provider)

The most current XIAOMI.EU Stable 12.2.1.0 van (Android 11-es) has SmartFren_VoWifi_Comercial profile works nicely with VoWifi with this provider.

I followed #1 guide, but because DT_Greece is not in my ROM, i chose SmartFren_VoWifi_Comercial profile.

attachment.php


attachment.php
 

Attachments

  • InkedInkedIMS_digi_voWifi_2020-11-29-21-51-46-753_com.android.phone_LI2.jpg
    InkedInkedIMS_digi_voWifi_2020-11-29-21-51-46-753_com.android.phone_LI2.jpg
    139 KB · Views: 1,172

KubeNsx

Member
Aug 21, 2017
13
0
I am experiencing a weird behavior, mainly, when someone calls and I have Volte or vowifi enabled, in the dialer app it shows long phone number which contains callers phone number and mine. It looks something like this, let's say my phone number is 788 233 145 and callers is 822 441 521, when he calls me, I see +48788233145822441521. This way, even if i have them in contacts I can't make out who's really calling me.. :/ It's a rare case probably, but i'd appreciate any kind of help at this point. I don't want to give up on VoLte or VoWifi.
 

SPLESHER

Member
Jun 23, 2017
44
8
Hey, did anyone try with Orange Poland carrier?
When i try to make call via WiFi, it always tells me to disable airplane mode or to connect to WiFi even tho im all the time connected to it, do you know which carrier is working with my carrier?
 

holymoz

Senior Member
Oct 25, 2013
868
263
Ragusa
works for me changing the carrier with vodafone romania, but after reboot volte not working anymore despite vodafone romania is still active in pdc. seems like it reversed to default carrier even if I deleted it.
 

razenxd

Senior Member
Oct 22, 2015
53
5
Hello, I have tested maaany profiles and only with DT_Greece I am able to have working VoWiFi on Mi 8 and Vodafone Greece operator.
Thing is that any incomning call on VoWiFi will display Unknown Caller.
Does anybody perhaps knows a fix?
A post in here was saying to edit ovverideconfig on efs, that made no difference.
Thanks
 
  • Like
Reactions: duttyend

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hello, I have tested maaany profiles and only with DT_Greece I am able to have working VoWiFi on Mi 8 and Vodafone Greece operator.
    Thing is that any incomning call on VoWiFi will display Unknown Caller.
    Does anybody perhaps knows a fix?
    A post in here was saying to edit ovverideconfig on efs, that made no difference.
    Thanks
  • 25
    First of all a BIG thanks to ed-gonzo
    He made this possible :)

    This is the instruction to activate VoWiFi / WLAN Call on the Poco F1
    Its tested and verfied to work with EU ROM (Oreo , Pie and Q based) and german provider o2 (Telefonica)

    Before you read on i want to make clear that I am not responsible for bricked devices !

    Basic requirements are root rights to do this mod
    Maybe latest 2020 Qualcomm Diag QD-Loader Windows 10 Drivers signed are needed for this to work.

    !!! Before doing this Mod you should backup EFS-partition !!!

    - download QPST tool and install
    - enable USB debugging in Developer settings
    - now either go to terminal app and type:
    Code:
       su
       setprop sys.usb.config diag,serial_cdev,rmnet,adb
    or
    adb from PC
    Code:
      adb shell
      su
      setprop sys.usb.config diag,serial_cdev,rmnet,adb
    - connect Poco F1 with original USB cable to PC
    - start PDC (from QPST tool) on PC
    - Poco F1 should be recognized by PDC (if not install Qualcomm driver and check Device Manager)
    - activate corresponding profile (in case of german o2 its DT_Greece)
    - install VoLTE & VoWiFi Enabler Magisk module (optional) or activate setting with dialer code *#*#869434#*#*
    - restart Poco F1
    - Voila
    5
    ok this works, just needed a bit more work for WoWiFi in my case
    after a reboot it kept returning to my default carrier config (VoLTE working just fine anyway)
    so what I did was to remove my carrier config from within PDC Tool, just that by doing that it defaulted to a non-VoLTE config
    well, removed that also and this time it kept DT_Greece config on both subs
    VoLTE works and VoWiFi also :) (carrier Orange Romania)

    ps. don't restart phone if you want to test new configs
    just click on activate and enter airplane mode then exit (keeps testing faster)
    4
    FAQ:
    Q: What are the requirements for VoWiFi
    A: A provider resp. plan which includes VoWiFi

    Q: How to know if VoWiFi is working ?
    A: Put phone in airplane mode and reactivate WiFi only. If you are able to make a call then VoWiFi is working.

    Q: Does this only work with MIUI ROM ?
    A: No ... its reported to work also on Custom ROMs like LOS, crDroid ...
    2
    Does this work with custom ROM (LOS)?
    in german forum there is a user who has it running.... but it seems that LOS has no icon for VoWiFi
    But nlow ...

    in case of german o2 its DT_Greece? are you sure? german carrier and greece? ;)
    yes indeed DT-Greece for german o2 :)
    I have it up and running ...
    2
    I'm using 8.11.27 global beta and I modified the DT_greece section. Set sub0 and sub1 to active.
    Opened dialer and dialed *#*#vowifi#*#*
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone